KanewilliamKanewilliam MemberComments: 4 Received thanks: 0 Member since: August 2018 edited August 2018

I have install the shopware after completed the insatllation frontend show the below error. Please help how to fix the issue.

 

Oops! An error has occurred!

The following notes should help you.

An exception occurred while executing 'SELECT page.id, page.description, page.link, page.target, page.parentID, groups.key as `group`, mapping.key as mapping FROM s_cms_static page LEFT JOIN s_cms_static_groups groups ON groups.active = 1 LEFT JOIN s_cms_static_groups mapping ON groups.mapping_id = mapping.id LEFT JOIN s_core_shop_pages shops ON groups.id = shops.group_id AND shops.shop_id = ? WHERE (groups.active = 1) AND (page.active = 1) AND (CONCAT('|', page.grouping, '|') LIKE CONCAT('%|', groups.key, '|%')) AND ((mapping.id IS NULL OR shops.shop_id IS NOT NULL)) AND ((mapping.id IS NULL OR mapping.active=1)) AND ((page.shop_ids IS NULL OR page.shop_ids LIKE ?)) ORDER BY parentID ASC, mapping.key ASC, page.position ASC, page.description ASC' with params [1, "%|1|%"]: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'groups ON groups.active = 1 LEFT JOIN s_cms_static_groups mapping ON groups.mapp' at line 1 in vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php on line 131

1 Answer

  • ShyimShyim MemberComments: 672 Received thanks: 280 Member since: May 2015

    It seems so that you have MySQL 8. Shopware will support MySQL 8 with Shopware 5.5

    Quote
    Accepted Answer
    Thanked by 1Kanewilliam
  • Accepted Answer

Answers

  • vanwittlaervanwittlaer MemberComments: 329 Received thanks: 80 Member since: September 2015

    A broken installation. Check your server meets all prerequisites as stated on Shopware's web site. Retry a fresh install.

    Good luck!

    Geert

  • ShyimShyim MemberComments: 672 Received thanks: 280 Member since: May 2015

    It seems so that you have MySQL 8. Shopware will support MySQL 8 with Shopware 5.5

    Quote
    Accepted Answer
    Thanked by 1Kanewilliam
Sign In or Register to comment.