# Zugang zur Datenbank vom Client zur VM

**URL:** <https://forum.shopware.com/t/zugang-zur-datenbank-vom-client-zur-vm/68255>\
**Category:** Administration\
**Created:** [9. Juli 2020 um 17:32 UTC](https://forum.shopware.com/t/zugang-zur-datenbank-vom-client-zur-vm/68255 "2020-07-09T17:32:45Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![rammi22](https://avatars.discourse-cdn.com/v4/letter/r/258eb7/32.png) [@rammi22](https://forum.shopware.com/u/rammi22)\
**Post date:** [9. Juli 2020 um 17:32 UTC](https://forum.shopware.com/t/zugang-zur-datenbank-vom-client-zur-vm/68255/1 "2020-07-09T17:32:45Z")

</div>

Hallo,

ich versuche mich über HeidiSql bzw. MysqlWorkbench mit der Datenbank meiner Shopware-Installation zu verbinden.

Zunächst finde ich die Zugangsdaten nicht und ich bekomme es nicht getestet.  
In der .env steht ja nur der Zugang ohne Passwort oder User:

```
...
DATABASE_URL=mysql://app:app@localhost:3306/shopware
...

```

Ich nehme mal an, das es dieselben Zugangsdaten sind, wie bei dem Zugang zum Adminbereich, also:  
User: admin  
Passwort: shopware

Ich versuche nun eine Verbindung mit dem MySqlServer mit TCP/IP herzustellen mit folgenden Daten:

- IP: 192.168.33.10
- Port: 3306
- User: admin
- Passwort: shopware

Das erzeúgt eine Fehler mit folgender Meldung:  
&nbsp;

```
Failed to Connectz to MySQL at 192.168.33.10:3306 with user admin

Can't connect to MySQL server on '192.168.33.10' (10061)

```

Fragen:

Sind die Zugangsdaten korrekt?

Wo in der Doku fiinde ich die entsprechenden Konfigurationsanweiseungen?

Gruß

---

<div class="post-metadata">

**Author:** ![rammi22](https://avatars.discourse-cdn.com/v4/letter/r/258eb7/32.png) [@rammi22](https://forum.shopware.com/u/rammi22)\
**Post date:** [11. Juli 2020 um 06:50 UTC](https://forum.shopware.com/t/zugang-zur-datenbank-vom-client-zur-vm/68255/2 "2020-07-11T06:50:52Z")

</div>

Moin,

niemand eine Idee? ![Undecided](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/8ae622c50104e84c5003fedfcc22572813a67b41.png "Undecided")

Ich habe versucht, mich direkt auf der VM auf die DB zuzugreifen mit folgenden Fehler:

```
vagrant@dev:~$ mysql
ERROR 1045 (28000): Access denied for user 'vagrant'@'localhost' (using password: NO)

```

Das treibt mich zum Versuch als Superuser mich anzumelden (Password: shopware):

```
vagrant@dev:~$ su
Password:
su: Authentication failure

```

Wie lauten denn hier die Zugangsdaten?

Wie schon geschrieben, Links zu den entsprechenden Stellen in der Doku sind herzlich willkommen…

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [11. Juli 2020 um 09:08 UTC](https://forum.shopware.com/t/zugang-zur-datenbank-vom-client-zur-vm/68255/3 "2020-07-11T09:08:21Z")

</div>

Also zunächst müsstest du schauen ob die Ports der VM auf Ports des Hosts gemappt&nbsp;sind. Und dann solltest du dich verbinden können mit User app und Passwort app.

Bei Virtualbox geht das so:&nbsp;[https://docs.shopware.com/en/shopware-6-en/tutorials-and-faq/virtual-box-setup#creating-a-virtual-box-image](https://docs.shopware.com/en/shopware-6-en/tutorials-and-faq/virtual-box-setup#creating-a-virtual-box-image)

Mit Vagrant kenne ich mich leider nicht aus.

---

<div class="post-metadata">

**Author:** ![rammi22](https://avatars.discourse-cdn.com/v4/letter/r/258eb7/32.png) [@rammi22](https://forum.shopware.com/u/rammi22)\
**Post date:** [11. Juli 2020 um 09:33 UTC](https://forum.shopware.com/t/zugang-zur-datenbank-vom-client-zur-vm/68255/4 "2020-07-11T09:33:21Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> Also zunächst müsstest du schauen ob die Ports der VM auf Ports des Hosts gemappt&nbsp;sind. Und dann solltest du dich verbinden können mit User app und Passwort app.
> 
> …

Klappt leider nicht wie gedacht:

- VM eingstellt  
 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/e/ef8f3a86d5782ee4694cdb15b63911b6e320e4a3.png)
- MySQL-Server Connection mit Workbench  
 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/d/d11a039244180ee876e77c0399e1166722b20c94.png)

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/2/2dc6fea79cfee58d1e10b9691b8725ebce09b4b3.png)

Was kann ich noch tun?

---

<div class="post-metadata">

**Author:** ![rammi22](https://avatars.discourse-cdn.com/v4/letter/r/258eb7/32.png) [@rammi22](https://forum.shopware.com/u/rammi22)\
**Post date:** [11. Juli 2020 um 10:25 UTC](https://forum.shopware.com/t/zugang-zur-datenbank-vom-client-zur-vm/68255/5 "2020-07-11T10:25:07Z")

</div>

> [@rammi22 schrieb:](https://forum.shopware.com/profile/33796/rammi22 "rammi22")
> 
> …
> 
> Was kann ich noch tun?

Mit diesem [Beitrag auf forum.ubuntuusers.de](https://forum.ubuntuusers.de/topic/zugriff-auf-datenbank-in-einer-vm/#post-9171790) hab ich das erstmal hinbekommen:  
&nbsp;

```
$ cat /etc/ssh/sshd_config

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes

```

&nbsp;
