# Zu 1452 - Cannot add or update a child row

**URL:** <https://forum.shopware.com/t/zu-1452-cannot-add-or-update-a-child-row/47318>\
**Category:** Allgemein\
**Created:** [4. August 2017 um 11:59 UTC](https://forum.shopware.com/t/zu-1452-cannot-add-or-update-a-child-row/47318 "2017-08-04T11:59:40Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)\
**Post date:** [4. August 2017 um 11:59 UTC](https://forum.shopware.com/t/zu-1452-cannot-add-or-update-a-child-row/47318/1 "2017-08-04T11:59:40Z")

</div>

Nachdem ich mich jetzt einen halben Tag in einer Test-VM mit dem Fehler „1452 - Cannot add or update a child row“ rumgeschlagen habe:  
[http://community.shopware.com/Foreign-Keys-reparieren\_detail\_954.html](http://community.shopware.com/Foreign-Keys-reparieren_detail_954.html)  
Den letzten Absatz&nbsp;…CONSTRAINED FAILED… FOREIGN KEY (‚articleID‘)… kann man auch noch um einen Fix auf die **s\_article\_details** erweitern.  
Verwaiste Einträge in dieser Tabelle dort führen zum gleichen Fehler, nur das ganz oben im Error-Log&nbsp;klein&nbsp;articledetailsID steht.  
Wird ein Import mit einer ordenumber durchgeführt, die mit einem verwaisten Eintrag in **s\_articles\_details** &nbsp;identisch ist, wird ein Fehler mit „Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`bitnami_shopware`.` **s\_articles\_attributes** `, CONSTRAINT ` **s\_articles\_attributes\_ibfk\_1** ` FOREIGN KEY (`articleID`) REFERENCES `s\_articles` (`id`) ON DELETE CASCADE ON UPDATE NO ACTION)“ geworfen. Da kann man 100 Mal die foreign keys für **s\_articles\_attributes** &nbsp;reparieren - man muss nur den SQL-Befehl auf&nbsp; **s\_articles\_details** &nbsp;anwenden - und schon läuft der Import wieder. ![Wink](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/wink.png "Wink")

Vielleicht könnte man die Reparatur-Anleitung noch ergänzen .

---

<div class="post-metadata">

**Author:** ![Forscher](https://avatars.discourse-cdn.com/v4/letter/f/f04885/32.png) [@Forscher](https://forum.shopware.com/u/Forscher)\
**Post date:** [14. Februar 2018 um 12:16 UTC](https://forum.shopware.com/t/zu-1452-cannot-add-or-update-a-child-row/47318/2 "2018-02-14T12:16:26Z")

</div>

Danke, hat mein Problem gefixt. Sollte wirklich mal jemand von Shopware dort ergänzen.&nbsp;

---

<div class="post-metadata">

**Author:** ![KingJah](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/kingjah/32/15438_2.png) [@KingJah](https://forum.shopware.com/u/KingJah)\
**Post date:** [28. Juli 2018 um 16:36 UTC](https://forum.shopware.com/t/zu-1452-cannot-add-or-update-a-child-row/47318/3 "2018-07-28T16:36:55Z")

</div>

Bei mir kam die Meldlung leider ohne verwaiste Datensätze. Die Ursache hab ich nicht ermitteln können aber die Lösung war den Contraint zu löschen und identisch wieder herzustellem.

ALTER TABLE `s_user_attributes` DROP FOREIGN KEY `s_user_attributes_ibfk_1`;

ALTER TABLE `s_user_attributes` ADD CONSTRAINT `s_user_attributes_ibfk_1` FOREIGN KEY (`userID`) REFERENCES `shopware`.`s_user`(`id`) ON DELETE CASCADE ON UPDATE NO ACTION;

Drei weitere s\_user Tabellen hatten das selbe Problem.

---

<div class="post-metadata">

**Author:** ![stefan.sl](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/stefan.sl/32/8923_2.png) [@stefan.sl](https://forum.shopware.com/u/stefan.sl)\
**Post date:** [8. Januar 2020 um 13:37 UTC](https://forum.shopware.com/t/zu-1452-cannot-add-or-update-a-child-row/47318/4 "2020-01-08T13:37:29Z")

</div>

```
DELETE ca -- SELECT ca.*
FROM `s_order_attributes` ca 
LEFT JOIN s_order c
ON c.id = ca.orderId 
WHERE c.id IS NULL;

DELETE ca -- SELECT ca.*
FROM `s_order_details` ca 
LEFT JOIN s_order c
ON c.id = ca.orderId 
WHERE c.id IS NULL;

```

Ich hatte den gleichen Fehler mit s\_order bei einem Update einer 5.5 auf die letzte 5.6. Folgendes hat geholfen:

&nbsp;
