# \[WSL Debian\] Slim Application Error - Could not resolve host after last step of installation

**URL:** <https://forum.shopware.com/t/wsl-debian-slim-application-error-could-not-resolve-host-after-last-step-of-installation/67762>\
**Category:** Installation / Getting Started (EN)\
**Created:** [18. Juni 2020 um 11:02 UTC](https://forum.shopware.com/t/wsl-debian-slim-application-error-could-not-resolve-host-after-last-step-of-installation/67762 "2020-06-18T11:02:53Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Niyabi](https://avatars.discourse-cdn.com/v4/letter/n/85f322/32.png) [@Niyabi](https://forum.shopware.com/u/Niyabi)\
**Post date:** [18. Juni 2020 um 11:02 UTC](https://forum.shopware.com/t/wsl-debian-slim-application-error-could-not-resolve-host-after-last-step-of-installation/67762/1 "2020-06-18T11:02:53Z")

</div>

Hi, I’m using WSL Debian as local web server and it works for Wordpress and Shopware 5 however after last step of Shopware 6 installation (shop configuration) I get this message:

```
Slim Application Error
The application could not run because of the following error:

Details
Type: Shopware\Recovery\Common\HttpClient\ClientException
Code: 6
Message: Could not resolve host: shop6.local
File: /var/www/shop6/vendor/shopware/recovery/Common/src/HttpClient/CurlClient.php
Line: 97
Trace
#0 /var/www/shop6/vendor/shopware/recovery/Common/src/HttpClient/CurlClient.php(35): Shopware\Recovery\Common\HttpClient\CurlClient->call('http://shop6.lo...', 'POST', Array, '{"grant_type":"...')
#1 /var/www/shop6/vendor/shopware/recovery/Install/src/app.php(513): Shopware\Recovery\Common\HttpClient\CurlClient->post('http://shop6.lo...', '{"grant_type":"...', Array)
#2 [internal function]: Closure->{closure}(Object(Slim\Http\Request), Object(Slim\Http\Response), Array)
#3 /var/www/shop6/vendor/shopware/recovery/Common/vendor/slim/slim/Slim/Handlers/Strategies/RequestResponse.php(40): call_user_func(Object(Closure), Object(Slim\Http\Request), Object(Slim\Http\Response), Array)
#4 /var/www/shop6/vendor/shopware/recovery/Common/vendor/slim/slim/Slim/Route.php(281): Slim\Handlers\Strategies\RequestResponse->__invoke(Object(Closure), Object(Slim\Http\Request), Object(Slim\Http\Response), Array)
#5 /var/www/shop6/vendor/shopware/recovery/Common/vendor/slim/slim/Slim/MiddlewareAwareTrait.php(117): Slim\Route->__invoke(Object(Slim\Http\Request), Object(Slim\Http\Response))
#6 /var/www/shop6/vendor/shopware/recovery/Common/vendor/slim/slim/Slim/Route.php(268): Slim\Route->callMiddlewareStack(Object(Slim\Http\Request), Object(Slim\Http\Response))
#7 /var/www/shop6/vendor/shopware/recovery/Common/vendor/slim/slim/Slim/App.php(503): Slim\Route->run(Object(Slim\Http\Request), Object(Slim\Http\Response))
#8 /var/www/shop6/vendor/shopware/recovery/Install/src/app.php(158): Slim\App->__invoke(Object(Slim\Http\Request), Object(Slim\Http\Response))
#9 [internal function]: Closure->{closure}(Object(Slim\Http\Request), Object(Slim\Http\Response), Object(Slim\App))
#10 /var/www/shop6/vendor/shopware/recovery/Common/vendor/slim/slim/Slim/DeferredCallable.php(57): call_user_func_array(Object(Closure), Array)
#11 [internal function]: Slim\DeferredCallable->__invoke(Object(Slim\Http\Request), Object(Slim\Http\Response), Object(Slim\App))
#12 /var/www/shop6/vendor/shopware/recovery/Common/vendor/slim/slim/Slim/MiddlewareAwareTrait.php(70): call_user_func(Object(Slim\DeferredCallable), Object(Slim\Http\Request), Object(Slim\Http\Response), Object(Slim\App))
#13 /var/www/shop6/vendor/shopware/recovery/Common/vendor/slim/slim/Slim/MiddlewareAwareTrait.php(117): Slim\App->Slim\{closure}(Object(Slim\Http\Request), Object(Slim\Http\Response))
#14 /var/www/shop6/vendor/shopware/recovery/Common/vendor/slim/slim/Slim/App.php(392): Slim\App->callMiddlewareStack(Object(Slim\Http\Request), Object(Slim\Http\Response))
#15 /var/www/shop6/vendor/shopware/recovery/Common/vendor/slim/slim/Slim/App.php(297): Slim\App->process(Object(Slim\Http\Request), Object(Slim\Http\Response))
#16 /var/www/shop6/vendor/shopware/recovery/Install/index.php(51): Slim\App->run()
#17 /var/www/shop6/public/recovery/install/index.php(6): require_once('/var/www/shop6/...')
#18 {main}

```

In Apache error log I got “PHP&nbsp;message:&nbsp;PHP&nbsp;Warning:&nbsp;&nbsp;chmod():&nbsp;Operation&nbsp;not&nbsp;permitted” so i changed directory to /var/www/ and set permissions for 777. Chmod error disappeared however I still get the same error after last step of installation.

System:

- WSL Debian
- PHP 7.2.31
- Apache 2.4.38

Do you have any idea what is the cause and how to fix it?

---

<div class="post-metadata">

**Author:** ![PasiB](https://avatars.discourse-cdn.com/v4/letter/p/9de0a6/32.png) [@PasiB](https://forum.shopware.com/u/PasiB)\
**Post date:** [18. Juni 2020 um 11:13 UTC](https://forum.shopware.com/t/wsl-debian-slim-application-error-could-not-resolve-host-after-last-step-of-installation/67762/2 "2020-06-18T11:13:52Z")

</div>

Message: Could not resolve host: shop6.local

&nbsp;

Is your host reachable under [http://shop6.local](http://shop6.local)? Try to use the IP-Adress instead. It could&nbsp;be a problem&nbsp;with ur Network-Config&nbsp;not Shopware.&nbsp;

&nbsp;

&nbsp;

However…&nbsp;Instead of chmod 777 you better&nbsp;should give the Webserver user the ownership of the directory.&nbsp;

For Apache2 with www-data as user:

sudo chown -R www-data:www-data /var/www/

---

<div class="post-metadata">

**Author:** ![Niyabi](https://avatars.discourse-cdn.com/v4/letter/n/85f322/32.png) [@Niyabi](https://forum.shopware.com/u/Niyabi)\
**Post date:** [19. Juni 2020 um 08:03 UTC](https://forum.shopware.com/t/wsl-debian-slim-application-error-could-not-resolve-host-after-last-step-of-installation/67762/3 "2020-06-19T08:03:35Z")

</div>

&nbsp;It’s localhost and multiple vHosts so every vHost is on 127.0.0.1 so I can’t access it by IP alone. Tried changing ownership of directory but it didn’t help.

> [@PasiB schrieb:](https://forum.shopware.com/profile/35453/PasiB "PasiB")
> 
> Message: Could not resolve host: shop6.local
> 
> &nbsp;
> 
> Is your host reachable under [http://shop6.local](http://shop6.local)? Try to use the IP-Adress instead. It could&nbsp;be a problem&nbsp;with ur Network-Config&nbsp;not Shopware.&nbsp;
> 
> &nbsp;
> 
> &nbsp;
> 
> However…&nbsp;Instead of chmod 777 you better&nbsp;should give the Webserver user the ownership of the directory.&nbsp;
> 
> For Apache2 with www-data as user:
> 
> sudo chown -R www-data:www-data /var/www/
