# Wie kann ich Shopware 5 installieren ?

**URL:** <https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937>\
**Category:** Installation/Einstieg\
**Created:** [30. März 2015 um 12:42 UTC](https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937 "2015-03-30T12:42:02Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![farbklecks](https://avatars.discourse-cdn.com/v4/letter/f/5daacb/32.png) [@farbklecks](https://forum.shopware.com/u/farbklecks)\
**Post date:** [30. März 2015 um 12:42 UTC](https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937/1 "2015-03-30T12:42:02Z")

</div>

Hallo, wir nutzen ein Hosting bei 1und1 und würden gerne den 5.0 RC testen. Wie funktioniert denn die Installation ? Finde keine Informationen und bin etwas ratlos. Kann mir jemand helfen ? Gruß Thorsten

---

<div class="post-metadata">

**Author:** ![Neox](https://avatars.discourse-cdn.com/v4/letter/n/b5a626/32.png) [@Neox](https://forum.shopware.com/u/Neox)\
**Post date:** [30. März 2015 um 12:49 UTC](https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937/2 "2015-03-30T12:49:15Z")

</div>

Paket hochladen per ftp. Dann musst du deine Domain öffnen: [http://www.exampel.com/unterverzeichniss/](http://www.exampel.com/unterverzeichniss/) Dann kommt auch schon der Installer. Aber im Prinzip genau so wie bei der Shopware 4.

---

<div class="post-metadata">

**Author:** ![farbklecks](https://avatars.discourse-cdn.com/v4/letter/f/5daacb/32.png) [@farbklecks](https://forum.shopware.com/u/farbklecks)\
**Post date:** [30. März 2015 um 13:32 UTC](https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937/3 "2015-03-30T13:32:19Z")

</div>

Hi, danke bekomme dann aber diese Fehlermeldung: Parse error: syntax error, unexpected T\_STRING, expecting T\_CONSTANT\_ENCAPSED\_STRING or ‚(‘ in /homepages/19/d117176283/htdocs/shopware/shopware.php on line 88

---

<div class="post-metadata">

**Author:** ![Thomas](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/thomas/32/8167_2.png) [@Thomas](https://forum.shopware.com/u/Thomas)\
**Post date:** [30. März 2015 um 14:05 UTC](https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937/4 "2015-03-30T14:05:21Z")

</div>

[quote=„farbklecks“]Hi, danke bekomme dann aber diese Fehlermeldung: Parse error: syntax error, unexpected T\_STRING, expecting T\_CONSTANT\_ENCAPSED\_STRING or ‚(‘ in /homepages/19/d117176283/htdocs/shopware/shopware.php on line 88[/quote] Welche PHP Version hast Du denn im Einsatz? Gruß

---

<div class="post-metadata">

**Author:** ![farbklecks](https://avatars.discourse-cdn.com/v4/letter/f/5daacb/32.png) [@farbklecks](https://forum.shopware.com/u/farbklecks)\
**Post date:** [30. März 2015 um 16:57 UTC](https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937/5 "2015-03-30T16:57:46Z")

</div>

Hallo, aktuell 5.5. Bekomme jetzt diesen Fehler: Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log. Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

---

<div class="post-metadata">

**Author:** ![Liesl](https://avatars.discourse-cdn.com/v4/letter/l/2acd7d/32.png) [@Liesl](https://forum.shopware.com/u/Liesl)\
**Post date:** [2. April 2015 um 18:18 UTC](https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937/6 "2015-04-02T18:18:39Z")

</div>

Hallo zusammen, habe gerade das gleiche Problem wie der TE. Meine Konstellation: Domainfactory Managed Hosting Pro/ MySQL5.6.19/PHP5.5.6 STABLE (alles lt. Empfehlung von SW) (aktuell auf naturversand.biz zum Testen) PS: SW4.3.2 läuft auf anderer Domain bestens auf PHP5.5.3 Gibt’s inzwischen neue Erkenntnisse ? VG Liesl

---

<div class="post-metadata">

**Author:** ![Shopwareianer](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Shopwareianer](https://forum.shopware.com/u/Shopwareianer)\
**Post date:** [2. April 2015 um 18:32 UTC](https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937/7 "2015-04-02T18:32:02Z")

</div>

Schaut einmal ob die .htaccess wirklich mit im Verzeichnis liegt. Ansonsten, was sagt der Server Error Log ?

---

<div class="post-metadata">

**Author:** ![Liesl](https://avatars.discourse-cdn.com/v4/letter/l/2acd7d/32.png) [@Liesl](https://forum.shopware.com/u/Liesl)\
**Post date:** [3. April 2015 um 11:53 UTC](https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937/8 "2015-04-03T11:53:23Z")

</div>

So habe ich es lösen können: `http://meinedomain.de/recovery/install/index.php` aufgerufen (schon komisch, dass die index.php explizit angegeben werden muss, damit der Installer ausgeführt wird). Diese Voraussetzungen für die Installation waren bei mir nicht erfüllt: in Ordner „/engine/shopware/plugins/community/“ Verzeichnis „Core“ zusätzlich angelegt, Rechte auf 740 gesetzt memory\_limit auf 256M (php.ini) allow\_url\_fopen aktiviert (php.ini) upload\_max\_filesize auf 10M (php.ini) In der php.ini ganz am Ende anhängen: `[Extensions] zend\_extension = "/usr/local/lib/php\_modules/5-56STABLE/ioncube\_loader\_lin\_5.6.so"` (Achtung: gilt nur für Domainfactory und bei PHP-Version 5.5.6 Stable) Nach der ganzen Aktion kommt nur noch der Hinweis, dass mod\_rewrite auf dem Indianer nicht aktiv wäre. Laut DF läuft das Modul aber und wird jeweils über die .htaccess aktiviert. Also den Hinweis tapfer ignoriert und den Assistenten weiter ausgeführt. Beim Datenbank-Update nun im ersten Step eine neue Fehlermeldung: `Notice: session\_start(): ps\_files\_cleanup\_dir: opendir(/tmp) failed: Permission denied (13) in /\*\*\*\*\*webspace\*\*\*\*\*\*/shopware5/recovery/install/src/app.php on line 34 \n{\"valid\":false,\"offset\":2106,\"totalCount\":2107,\"success\":true}"` Also schnell dem /tmp Verzeichnis im Webspace Schreibrechte verpasst und das Ganze nochmal von vorn gestartet. Jetzt mit Erfolg 🙂 Frohe Ostern euch allen VG Liesl … jetzt beim :shopware:5-Testen

---

<div class="post-metadata">

**Author:** ![henrik23](https://avatars.discourse-cdn.com/v4/letter/h/ecae2f/32.png) [@henrik23](https://forum.shopware.com/u/henrik23)\
**Post date:** [18. April 2021 um 05:21 UTC](https://forum.shopware.com/t/wie-kann-ich-shopware-5-installieren/25937/9 "2021-04-18T05:21:34Z")

</div>

Wer in seinem Managed Hosting die Schreibrechte für das tmp-Verzeichnis nicht anpassen darf, kann in der PHP.INI zur genutzten Domain unter ‚session.save\_path‘ einen eigenen Pfad zu einem Temp-Ordner angeben. Zum Beispiel:  
_session.save\_path = /kunden/KUNDENNUMMER\_PLZ/webseiten/temp\_folder\_user_
