# Welche Timeouts bei dem Migrationtool anpassen?

**URL:** <https://forum.shopware.com/t/welche-timeouts-bei-dem-migrationtool-anpassen/48069>\
**Category:** Plugins\
**Tags:** offizielle-shopware-\
**Created:** [5. September 2017 um 16:53 UTC](https://forum.shopware.com/t/welche-timeouts-bei-dem-migrationtool-anpassen/48069 "2017-09-05T16:53:41Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![leini](https://avatars.discourse-cdn.com/v4/letter/l/bb73d2/32.png) [@leini](https://forum.shopware.com/u/leini)\
**Post date:** [5. September 2017 um 16:53 UTC](https://forum.shopware.com/t/welche-timeouts-bei-dem-migrationtool-anpassen/48069/1 "2017-09-05T16:53:41Z")

</div>

Hallo zusammen,

wir wollen gerne unseren Shop vom xtc:modified auf Shopware migrieren. Grundsätzlich ist das alles gar kein Problem mit dem Plugin. Allerdings haben wir im alten Shop sehr viele Kategorien und sehr viele Artikel (ca. 73.000). Ich habe zum Testen auch mal die Anzahl der Artikel auf 40.000 reduziert. Leider erhalte ich immer nur timeouts bei den Importen wenn ich Artikel+Kategorien importieren möchte.&nbsp;

In dem Error-Log steht derzeit:

[Tue Sep 05 19:45:16.513513 2017] [proxy\_fcgi:error] [pid 18744] [client xxx] AH01067: Failed to read FastCGI header, referer: [http://www.xxx.com](http://www.xxx.com)  
[Tue Sep 05 19:45:16.513539 2017] [proxy\_fcgi:error] [pid 18744] (104)Connection reset by peer: [client xxx] AH01075: Error dispatching request to : , referer: [http://www.xxx.xom/backend/](http://www.xxx.xom/backend/)

Die Fehlermeldungen ändern sich hier aber, je nachdem welche PHP-Version ich in Plesk einstelle bzw. wenn ich einstelle, wie PHP auszuführen ist (FPM,CGI etc)

Meiner Meinung nach handelt es sich hier immer um Timeouts. Immer nach ca. knapp 4 Minuten bricht der Import ab.

Wenn ich Artikel, Bilder oder Kategorien alleine übertrage, klappt alles ohne Probleme.

Was ich bisher gemacht habe:

PHP-Limits hochgesetzt

> memory\_limit = 10024M  
> max\_execution\_time = 880  
> max\_input\_time = 36000  
> post\_max\_size = 10024M  
> upload\_max\_filesize &nbsp;= 10024M
> 
> FcgidBusyTimeout 3600  
> FcgidIOTimeout &nbsp; 3600

Zusätzlich die Werte für den nginx hinzugefügt:

> &nbsp;&nbsp; &nbsp;FcgidIdleTimeout 3600  
> &nbsp;&nbsp; &nbsp;FcgidBusyTimeout 1800  
> &nbsp;&nbsp; &nbsp;FcgidProcessLifeTime 0
> 
> &nbsp;&nbsp; &nbsp;# Increase the FastCGI max request length for large file uploads (needed for some sites)  
> &nbsp;&nbsp; &nbsp;FcgidMaxRequestLen 1073741824
> 
> &nbsp;&nbsp; &nbsp;FcgidMaxRequestsPerProcess 100000  
> &nbsp;&nbsp; &nbsp;FcgidMaxProcessesPerClass 4  
> &nbsp;&nbsp; &nbsp;FcgidIOTimeout 3600

Könnte mir da vielleicht jemand weiterhelfen? Langsam bin ich da echt schon am verzweifeln.

Danke & Gruß

Thomas

---

<div class="post-metadata">

**Author:** ![vismagine](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/vismagine/32/24302_2.png) [@vismagine](https://forum.shopware.com/u/vismagine)\
**Post date:** [7. September 2018 um 08:25 UTC](https://forum.shopware.com/t/welche-timeouts-bei-dem-migrationtool-anpassen/48069/2 "2018-09-07T08:25:14Z")

</div>

Hallo,

wir erhalten aktuell die gleichen Fehlermeldungen bei ähnlich hohem&nbsp;Artikelbestand. Konnten Sie die Ursache finden?

Danke & Gruß,  
Christian
