# Von Zeit zu Zeit Fehlermeldung im Frontend

**URL:** <https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382>\
**Category:** Shopware 3.5\
**Tags:** administration\
**Created:** [5. April 2011 um 09:40 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382 "2011-04-05T09:40:03Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![handgedruckt](https://avatars.discourse-cdn.com/v4/letter/h/6f9a4e/32.png) [@handgedruckt](https://forum.shopware.com/u/handgedruckt)\
**Post date:** [5. April 2011 um 09:40 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/1 "2011-04-05T09:40:03Z")

</div>

Hallo zusammen. Von Zeit zu Zeit und aus nicht nachvollziehbaren Gründen (meine damit, es ist kein kausaler Zusammenhang zu erkennen) erhalte ich folgende Fehlermeldung im Frontend, mit der ich leider gar nix anfangen kann. Momentan grad mal wieder auf der Startseite und nach einer gewissen Zeit ist sie wieder weg. Das ist natürlich mehr als Benutzerunfreundlich … ☹ Kann mir jemand weiter helfen? [quote]Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘AND a.active=1 AND ( SELECT articleID FROM s\_articles\_avoid\_custo’ at line 51 in Vendor/Zend/library/Zend/Db/Statement/Pdo.php on line 234 Stack trace: #0 Vendor/Zend/library/Zend/Db/Statement.php(300): Zend\_Db\_Statement\_Pdo-\>\_execute(Array) #1 Vendor/Zend/library/Zend/Db/Adapter/Abstract.php(468): Zend\_Db\_Statement-\>execute(Array) #2 Vendor/Zend/library/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend\_Db\_Adapter\_Abstract-\>query(’???SELECT???..’, Array) #3 Vendor/Zend/library/Zend/Db/Adapter/Abstract.php(725): Zend\_Db\_Adapter\_Pdo\_Abstract-\>query(’???SELECT???..’, Array) #4 Enlight/Components/Adodb.php(124): Zend\_Db\_Adapter\_Abstract-\>fetchRow(’???SELECT???..’, Array) #5 Enlight/Components/Adodb.php(198): Enlight\_Components\_Adodb-\>GetRow(’???SELECT???..’, Array) #6 engine/core/class/sArticles.php(3539): Enlight\_Components\_Adodb-\>\_\_call(‘CacheGetRow’, Array) #7 engine/core/class/sArticles.php(3539): Enlight\_Components\_Adodb-\>CacheGetRow(‘86400’, ‘???SELECT???..’) #8 engine/core/class/sArticles.php(3964): sArticles-\>sGetPromotionById(‘new’, 3) #9 Shopware/Controllers/Frontend/Index.php(20): sArticles-\>sGetPromotions(‘3’) #10 Enlight/Controller/Action.php(55): Shopware\_Controllers\_Frontend\_Index-\>indexAction() #11 Enlight/Controller/Dispatcher/DispatcherDefault.php(329): Enlight\_Controller\_Action-\>dispatch(‘indexAction’) #12 Enlight/Controller/Front.php(88): Enlight\_Controller\_Dispatcher\_DispatcherDefault-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #13 Shopware/Bootstrap.php(21): Enlight\_Controller\_Front-\>dispatch() #14 Enlight/Application.php(69): Shopware\_Bootstrap-\>run() #15 shopware.php(6): Enlight\_Application-\>run() #16 {main} [/quote]

---

<div class="post-metadata">

**Author:** ![Moro](https://avatars.discourse-cdn.com/v4/letter/m/b9e5f3/32.png) [@Moro](https://forum.shopware.com/u/Moro)\
**Post date:** [5. April 2011 um 10:03 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/2 "2011-04-05T10:03:24Z")

</div>

hallo wie kann ich hier ein neues thema eröffnen?

---

<div class="post-metadata">

**Author:** ![handgedruckt](https://avatars.discourse-cdn.com/v4/letter/h/6f9a4e/32.png) [@handgedruckt](https://forum.shopware.com/u/handgedruckt)\
**Post date:** [5. April 2011 um 10:23 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/3 "2011-04-05T10:23:03Z")

</div>

… auf [administration-f11/](http://forum.shopware.de/administration-f11/) gehen und oben links auf “Neues Thema erstellen klicken” Jemand eine Idee wegen der Fehlermeldung? Leider immer noch da ☹

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [5. April 2011 um 11:05 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/4 "2011-04-05T11:05:34Z")

</div>

Welche Shopware-Version setzt du ein und welche PHP und MySQL-Version?

---

<div class="post-metadata">

**Author:** ![artep](https://avatars.discourse-cdn.com/v4/letter/a/aca169/32.png) [@artep](https://forum.shopware.com/u/artep)\
**Post date:** [5. April 2011 um 11:13 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/5 "2011-04-05T11:13:00Z")

</div>

Das ist aber nur auf der Startseite. Deine Kategorien etc. kann man anklicken und geht auf!

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [5. April 2011 um 11:14 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/6 "2011-04-05T11:14:19Z")

</div>

Eventuell irgendwelche Plugins aktiv, die das verursachen könnten?

---

<div class="post-metadata">

**Author:** ![handgedruckt](https://avatars.discourse-cdn.com/v4/letter/h/6f9a4e/32.png) [@handgedruckt](https://forum.shopware.com/u/handgedruckt)\
**Post date:** [5. April 2011 um 12:23 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/7 "2011-04-05T12:23:17Z")

</div>

@Stefan Hamann Shopware 3.5.2 mysql 5.0.77 PHP 5.2.17 Plugins diverse, die ich aber gar nicht selber eingestellt hab. Als letztes allerdings SexyBookmarks installiert, mit der Fehlermeldung hatte ich allerdings auch schon vorher Probleme (wobei ich nicht sicher sagen, kann, dass es exakt die selbe Fehlermeldung war). @artep … macht die Sache nicht wirklich besser … ☹

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [5. April 2011 um 12:27 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/8 "2011-04-05T12:27:41Z")

</div>

Ich würde zunächst mal auf 3.5.3 updaten - je nachdem, welche Möglichkeiten du hast, wäre auch ein Update auf MySQL 5.1 sinnvoll. Wahrscheinlich tritt der Fehler immer dann auf, wenn du den Shopcache leerst, oder? Hast du ansonsten eventuell eine defekte Kundengruppe im System? Probiere bitte mal, das Problem reproduzierbar zu machen - dann kann ich mir das gerne selbst mal anschauen!

---

<div class="post-metadata">

**Author:** ![handgedruckt](https://avatars.discourse-cdn.com/v4/letter/h/6f9a4e/32.png) [@handgedruckt](https://forum.shopware.com/u/handgedruckt)\
**Post date:** [5. April 2011 um 12:49 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/9 "2011-04-05T12:49:04Z")

</div>

… ich habe gerade erst für viel Geld auf 3.5.2 updaten lassen OoO und dachte, jetzt ist erst mal alles gut ☹ Glaube nämlich nicht, dass ich das selber hin kriege … Und das mit dem reproduzierbar machen ist genau das Problem. Ich hab bisher noch keine Regelmäßigkeit entdeckt, wann der Fehler auftritt. Zig mal lösche ich den Cache ohne Probleme! Aber ich teste noch mal ein bisschen. Wie finde ich heraus, ob ich eine „defekte Kundengruppe“ im System habe? Danke!

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [5. April 2011 um 12:55 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/10 "2011-04-05T12:55:37Z")

</div>

Das ist nur eine Vermutung - eventuell unter Grundeinstellungen \> Kundengruppen und da ggf. ein „leerer“ Eintrag. Die 3.5.3 gibt es ja schon seit Anfang Dezember, wundert mich daher etwas - da wurden ja doch einige Fehlerchen behoben und das Update macht auf jeden Fall Sinn, ist auch im Endeffekt nicht kompliziert einzuspielen. Das ist ca. eine halbe Stunde Arbeit, viel Kosten darf das also nicht.

---

<div class="post-metadata">

**Author:** ![Sammy123](https://avatars.discourse-cdn.com/v4/letter/s/76d3ee/32.png) [@Sammy123](https://forum.shopware.com/u/Sammy123)\
**Post date:** [5. April 2011 um 14:41 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/11 "2011-04-05T14:41:39Z")

</div>

Ähm? Wer nimmt denn für ein kleines Update so viel Geld? Btt: Ich bekomme den Fehler auch wenn ich z.b. viele neue Artikel anlege oder viele StatusMails hintereinander verschicke. Sobald ich den Cache leere ist er wieder weg!

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [5. April 2011 um 14:51 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/12 "2011-04-05T14:51:20Z")

</div>

@Sammy Genau den gleichen Fehler? Stell davon mal einen Screenshot ein, wenn der wieder auftaucht! Danke!

---

<div class="post-metadata">

**Author:** ![Sammy123](https://avatars.discourse-cdn.com/v4/letter/s/76d3ee/32.png) [@Sammy123](https://forum.shopware.com/u/Sammy123)\
**Post date:** [5. April 2011 um 15:29 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/13 "2011-04-05T15:29:28Z")

</div>

Zu 98% ja! Werd ich machen!

---

<div class="post-metadata">

**Author:** ![handgedruckt](https://avatars.discourse-cdn.com/v4/letter/h/6f9a4e/32.png) [@handgedruckt](https://forum.shopware.com/u/handgedruckt)\
**Post date:** [7. April 2011 um 14:30 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/14 "2011-04-07T14:30:49Z")

</div>

Also nur zur Info, falls es interessiert: Die Fehlermeldung war am nächsten Tag wieder weg. Was zwar ganz schön ist, aber nichts daran ändert, dass der Shop im Grunde einen Tag nicht funktionabel war. :thumbdown:

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [7. April 2011 um 14:36 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/15 "2011-04-07T14:36:08Z")

</div>

Das kann auch durchaus ein temporäres Problem mit der Datenbank gewesen sein oder ein anders geartetes Server-Problem… Wenn das irgendwann nochmal auftritt, melde dich kurz!

---

<div class="post-metadata">

**Author:** ![TSchenk](https://avatars.discourse-cdn.com/v4/letter/t/779978/32.png) [@TSchenk](https://forum.shopware.com/u/TSchenk)\
**Post date:** [7. April 2011 um 15:43 UTC](https://forum.shopware.com/t/von-zeit-zu-zeit-fehlermeldung-im-frontend/2382/16 "2011-04-07T15:43:16Z")

</div>

Hmmm… Kenn ich das Problem… 🙂 Ist schön reproduzierbar, wenn man das Einstelldatum eines neuen Artikels (erscheint zur Zeit auf der Startseite) auf ein älteres setzt, so das dieser dort nicht mehr erscheinen soll. Wenn man den Cache nicht leert, geht das schief… [http://trac.shopware.de/trac/ticket/100323](http://trac.shopware.de/trac/ticket/100323) Viele Grüße Thomas
