# URL-Fehler Bildupload via API

**URL:** <https://forum.shopware.com/t/url-fehler-bildupload-via-api/93384>\
**Category:** Shopware 6 (German)\
**Created:** [11. März 2022 um 12:01 UTC](https://forum.shopware.com/t/url-fehler-bildupload-via-api/93384 "2022-03-11T12:01:49Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![hloettgen](https://avatars.discourse-cdn.com/v4/letter/h/50afbb/32.png) [@hloettgen](https://forum.shopware.com/u/hloettgen)\
**Post date:** [11. März 2022 um 12:01 UTC](https://forum.shopware.com/t/url-fehler-bildupload-via-api/93384/1 "2022-03-11T12:01:49Z")

</div>

Hallo zusammen, ich habe ein seltsames Phänomen bei einem Shop.  
Und zwar gebe ich für die Bildzuordnung die URL des Bildes mit.  
Aber Shopware fügt dann selbständig irgendwie Backslashs in die URL ein :

Mein Call und Payload sieht so aus:

```auto
POST: api/_action/media/04b056d5e6894323bc045dd682156ea3/upload?extension=jpg&fileName=1061
BODY: {"url":"http://www.meinedomain.de/bilder/1061.jpg"}
api/_action/media/04b056d5e6894323bc045dd682156ea3/upload?extension=jpg&fileName=1061

```

Ich erhalte aber das hier als Result:

```auto
{"errors":[{"status":"500","code":"CONTENT__MEDIA_UPLOAD","title":"Internal Server Error","detail":"Could not open source stream from http:\/\/www.meinedomain.de\/bilder\/1061.jpg","meta":{"parameters":{"message":"Could not open source stream from http:\/\/www.meinedomain.de\/bilder\/1061.jpg"}}}]}

```

Hat jemand eine Idee, woher das kommt ?  
Bei anderen Shops habe ich das Problem mit der gleichen Routine nicht.

Beste Grüße  
Holger

---

<div class="post-metadata">

**Author:** ![hloettgen](https://avatars.discourse-cdn.com/v4/letter/h/50afbb/32.png) [@hloettgen](https://forum.shopware.com/u/hloettgen)\
**Post date:** [29. März 2022 um 10:50 UTC](https://forum.shopware.com/t/url-fehler-bildupload-via-api/93384/2 "2022-03-29T10:50:41Z")

</div>

Wirklich niemand mit einem Hinweis, was das Problem sein könnte ???

---

<div class="post-metadata">

**Author:** ![mobilize](https://avatars.discourse-cdn.com/v4/letter/m/7ba0ec/32.png) [@mobilize](https://forum.shopware.com/u/mobilize)\
**Post date:** [13. April 2022 um 14:42 UTC](https://forum.shopware.com/t/url-fehler-bildupload-via-api/93384/3 "2022-04-13T14:42:30Z")

</div>

Habe das gleiche Problem. Hast Du eine Lösung bzw die Ursache gefunden?

---

<div class="post-metadata">

**Author:** ![hloettgen](https://avatars.discourse-cdn.com/v4/letter/h/50afbb/32.png) [@hloettgen](https://forum.shopware.com/u/hloettgen)\
**Post date:** [5. August 2022 um 05:56 UTC](https://forum.shopware.com/t/url-fehler-bildupload-via-api/93384/6 "2022-08-05T05:56:01Z")

</div>

Die Fehlermeldung ist natürlich absoluter Unsinn, denn das Problem ist, dass das Bild schon vorhanden ist und Shopware dann diese Meldung bringt.  
Lösung: die mediaID rausfinden, und dann löschen. Danach kann auch ein Bild wieder aktualisiert werden.
