# Ups-Fehler: SQLSTATE 28000

**URL:** https://forum.shopware.com/t/ups-fehler-sqlstate-28000/1444
**Category:** Shopware 3.5
**Tags:** installation--gettin
**Created:** [18. Januar 2011 um 10:00 UTC](https://forum.shopware.com/t/ups-fehler-sqlstate-28000/1444 "2011-01-18T10:00:33Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![cappu](https://avatars.discourse-cdn.com/v4/letter/c/ecd19e/32.png) [@cappu](https://forum.shopware.com/u/cappu)
#### Post date: [18. Januar 2011 um 10:00 UTC](https://forum.shopware.com/t/ups-fehler-sqlstate-28000/1444/1 "2011-01-18T10:00:33Z")

</div>

Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. SQLSTATE [28000] [1045] Benutzer ‚dbxxxxx\_1‘ @ 'local3 "verweigert (using password: YES) in Hersteller / Zend / library / Zend / Db / Adapter / PDO / Abstract.php auf der Leitung 144 Stack-Trace: # 0 Hersteller / Zend / library / Zend / Db / Adapter / gU / mysql.php (96): Zend\_Db\_Adapter\_Pdo\_Abstract-\> \_connect () # 1 Hersteller / Zend / library / Zend / Db / Adapter / Abstract.php (315): Zend\_Db\_Adapter\_Pdo\_Mysql-\> \_connect () # 2 Shopware / Bootstrap.php (48): Zend\_Db\_Adapter\_Abstract-\> getConnection () # 3 [interne Funktion]: Shopware\_Bootstrap-\> initdb () # 4 Enlight / Bootstrap.php (99): call\_user\_func (Array) # 5 Shopware / Bootstrap.php (12): Enlight\_Bootstrap-\> LoadResource („DB“) # 6 Enlight / application.php (69): Shopware\_Bootstrap-\> run () # 7 shopware.php (6): Enlight\_Application-\> run () # 8 {main}

---

<div class="post-metadata">

### Author: ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)
#### Post date: [18. Januar 2011 um 11:21 UTC](https://forum.shopware.com/t/ups-fehler-sqlstate-28000/1444/2 "2011-01-18T11:21:58Z")

</div>

Das bedeutet, dass deine Datenbank-Zugangsdaten nicht korrekt sind.

---

<div class="post-metadata">

### Author: ![cappu](https://avatars.discourse-cdn.com/v4/letter/c/ecd19e/32.png) [@cappu](https://forum.shopware.com/u/cappu)
#### Post date: [18. Januar 2011 um 11:36 UTC](https://forum.shopware.com/t/ups-fehler-sqlstate-28000/1444/3 "2011-01-18T11:36:08Z")

</div>

sind diese Zugangsdaten nur in der shopware/index.php hinterlegt oder auch noch woanders ?

---

<div class="post-metadata">

### Author: ![sr-1](https://avatars.discourse-cdn.com/v4/letter/s/9dc877/32.png) [@sr-1](https://forum.shopware.com/u/sr-1)
#### Post date: [18. Januar 2011 um 11:39 UTC](https://forum.shopware.com/t/ups-fehler-sqlstate-28000/1444/4 "2011-01-18T11:39:41Z")

</div>

Hi, eigentlich in der config.php^^… Also im Ordner indem du Shopware installiert hast, sprich wo sich die ganze Ordnerstruktur befindet. Gruß P.s. auf Leerzeichen achten!

---

<div class="post-metadata">

### Author: ![cappu](https://avatars.discourse-cdn.com/v4/letter/c/ecd19e/32.png) [@cappu](https://forum.shopware.com/u/cappu)
#### Post date: [18. Januar 2011 um 11:47 UTC](https://forum.shopware.com/t/ups-fehler-sqlstate-28000/1444/5 "2011-01-18T11:47:55Z")

</div>

stimmt… 🙂 jetzt wo du es sagst sehe ich es auch… config.php (mein fehler) das Passwort steht wohl „verschlüsselt“ in der config.php (geöffnet mit notepad++) denn es stimmt nicht mit dem Passwort überein wie ich mich bei phpMyAdmin mit anmelde finde man im phpMyAdmin auch das Passwort ?

---

<div class="post-metadata">

### Author: ![cappu](https://avatars.discourse-cdn.com/v4/letter/c/ecd19e/32.png) [@cappu](https://forum.shopware.com/u/cappu)
#### Post date: [18. Januar 2011 um 11:56 UTC](https://forum.shopware.com/t/ups-fehler-sqlstate-28000/1444/6 "2011-01-18T11:56:17Z")

</div>

Danke… habe den Fehler gefunden… 🙂

---

<div class="post-metadata">

### Author: ![sr-1](https://avatars.discourse-cdn.com/v4/letter/s/9dc877/32.png) [@sr-1](https://forum.shopware.com/u/sr-1)
#### Post date: [18. Januar 2011 um 11:59 UTC](https://forum.shopware.com/t/ups-fehler-sqlstate-28000/1444/7 "2011-01-18T11:59:04Z")

</div>

Hi, lag an dem verschlüsselten PW in der config.php oder? Gruß

---

<div class="post-metadata">

### Author: ![cappu](https://avatars.discourse-cdn.com/v4/letter/c/ecd19e/32.png) [@cappu](https://forum.shopware.com/u/cappu)
#### Post date: [18. Januar 2011 um 12:15 UTC](https://forum.shopware.com/t/ups-fehler-sqlstate-28000/1444/8 "2011-01-18T12:15:22Z")

</div>

Ich habe 2 Datenbanken \* db12345\_1 + db12345\_2 \* und dachte, beide haben das gleiche passwort. Dem war leider nicht so. Dank dem Server-Zugang beim provider bekommt man ja die Paßwörter angezeigt - und siehe da, sie sind unterschiedlich.
