# Updateproblem: Datenbank-Update-Fehlermeldung

**URL:** <https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652>\
**Category:** Installation/Einstieg\
**Created:** [17. August 2017 um 16:07 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652 "2017-08-17T16:07:51Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![solaradmin](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@solaradmin](https://forum.shopware.com/u/solaradmin)\
**Post date:** [17. August 2017 um 16:07 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/1 "2017-08-17T16:07:51Z")

</div>

```
 Update von 5.2.27 auf 5.3.1: {**"valid":false,"errorMsg":"Could not apply migration (Migrations\_Migration907). Error: SQLSTATE[42S01]: Base table or view already exists: 1050 Table 's\_order\_basket\_signatures' already exists "**}

```

Was genau hat das zu bedeuten, bzw. wie kann ich das reparieren?

---

<div class="post-metadata">

**Author:** ![solaradmin](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@solaradmin](https://forum.shopware.com/u/solaradmin)\
**Post date:** [17. August 2017 um 16:10 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/2 "2017-08-17T16:10:39Z")

</div>

Leere Tabelle, soll ich die einfach löschen?

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [17. August 2017 um 16:45 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/3 "2017-08-17T16:45:29Z")

</div>

Das bedeutet, dass schon Tabellen in deinem Shops existieren, die es erst mit 5.3 gibt. Da ist in der Vergangenheit schon mal was schief gelaufen.

Vermutlich nicht das einzige Problem dann.

Du kannst du Tabelle sicher versuchen zu&nbsp;entfernen. Eigentlich müsste man aber im Detail prüfen, warum es die schon gibt und was sonst noch so fehlerhaft ist. Sonst bekommst du später evtl. Folgefehler

Sebastian

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [17. August 2017 um 17:25 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/4 "2017-08-17T17:25:50Z")

</div>

Schau mal hier: [https://forum.shopware.com/discussion/comment/202241/#Comment\_202241](https://forum.shopware.com/discussion/comment/202241/#Comment_202241)

Wahrscheinlich gab es schonmal ein Update und du hast ein Backup eingespielt. Viele Hoster kopieren dann die daten einfach zurück und neu angelegte Tabellen die nicht im Backup enthalten sind, bleiben einfach in der Datenbank. Am besten kannst du Backups immer in eine leere Datenbank einspielen.

---

<div class="post-metadata">

**Author:** ![solaradmin](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@solaradmin](https://forum.shopware.com/u/solaradmin)\
**Post date:** [17. August 2017 um 17:28 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/5 "2017-08-17T17:28:18Z")

</div>

Habe ein Update auf 5.3.1 erfolgreich durchgeführt gehabt, dann aber gesehen, das die mühevoll angelegten Custom Products verschwunden sind;

also wieder die WebSeiten- und Datenbank-Sicherheitskopie von gestern mit 5.2.27 eingespielt. Das System läuft dann (veraltet) normal.&nbsp;

Bloß das Update scheitert seit dem.&nbsp;

Was soll ich machen?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [17. August 2017 um 17:29 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/6 "2017-08-17T17:29:40Z")

</div>

Müsste reichen, wenn du die verlinkten Tabellen löschst.

Aber am besten vorher mal ein Testsystem aufsetzen und updaten.

---

<div class="post-metadata">

**Author:** ![solaradmin](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@solaradmin](https://forum.shopware.com/u/solaradmin)\
**Post date:** [17. August 2017 um 17:43 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/7 "2017-08-17T17:43:58Z")

</div>

OK - danke - Tabelle gelöscht - einen Schritt weiter, jetzt kommt:

&nbsp;

**"Error**

\*\*Received the following error message:  
Could not apply migration (Migrations\_Migration917). Error: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry ‘1’ for key ‘PRIMARY’&nbsp;

Please try to fix this error and restart the update.\*\*

**Response**

```
**{"valid":false,"errorMsg":"Could not apply migration (Migrations\_Migration917). Error: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry '1' for key 'PRIMARY' "}"**
```

---

<div class="post-metadata">

**Author:** ![solaradmin](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@solaradmin](https://forum.shopware.com/u/solaradmin)\
**Post date:** [17. August 2017 um 18:03 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/8 "2017-08-17T18:03:27Z")

</div>

Um welche Tabelle handelt&nbsp;es sich, bzw. auf welche Tabelle bezieht sich die Fehlermeldung?

---

<div class="post-metadata">

**Author:** ![solaradmin](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@solaradmin](https://forum.shopware.com/u/solaradmin)\
**Post date:** [18. August 2017 um 08:09 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/9 "2017-08-18T08:09:01Z")

</div>

Habe den&nbsp;Datenbankinhalt ganz gelöscht und anschließend die Sicherheitskopie reingespielt, jetzt funkt es …

---

<div class="post-metadata">

**Author:** ![mahlzeit](https://avatars.discourse-cdn.com/v4/letter/m/3da27b/32.png) [@mahlzeit](https://forum.shopware.com/u/mahlzeit)\
**Post date:** [18. August 2017 um 08:46 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/10 "2017-08-18T08:46:42Z")

</div>

> [@SebastianKlöpper schrieb:](https://forum.shopware.com/profile/66/SebastianKl%C3%B6pper "SebastianKl%C3%B6pper")
> 
> Das bedeutet, dass schon Tabellen in deinem Shops existieren, die es erst mit 5.3 gibt. Da ist in der Vergangenheit schon mal was schief gelaufen.
> 
> Vermutlich nicht das einzige Problem dann.
> 
> Du kannst du Tabelle sicher versuchen zu&nbsp;entfernen. Eigentlich müsste man aber im Detail prüfen, warum es die schon gibt und was sonst noch so fehlerhaft ist. Sonst bekommst du später evtl. Folgefehler
> 
> Sebastian

&nbsp;

Hallo Sebastian (oder wer anderes von swag),

warum macht Shopware hier keinen Gebrauch von der einfachen Abfrage CREATE TABLE **IF NOT EXISTS** … ?

Damit wären doch die meisten Upgrade-Probleme hier gelöst, oder?

Eine andere Möglichkeit wäre auch über PHP zunächst die Datenbank auf Konsistenz zu prüfen und den USER zu benachrichten, das etwas nicht stimmt, BEVOR man das Upgrade durchführt. Das wäre IMHO besser als den Shop womöglich komplett zu schrotten … ! Ich finde das ehrlich gesagt etwas unprofessionell. Oder gibt es hier einen anderen Hintergrund, den ich (noch) nicht kenne?

LG

(gleich) mahlzeit 🙂

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [18. August 2017 um 09:10 UTC](https://forum.shopware.com/t/updateproblem-datenbank-update-fehlermeldung/47652/11 "2017-08-18T09:10:02Z")

</div>

Hi,

das stellt aber auch nicht wirklich sicher, ob die Datenbankänderung vollständig / sauber durchgeführt wurde. Es gibt ja nicht nur Create, sondern auch komplette Migrationsaufgaben und Änderungsvorgänge usw.  
Shopware speichert / loggt ja genau mit, welche Datenbankänderungen durch Updates gemacht wurden. Daher führt Shopware immer nur die Änderungen aus, die noch nicht vorhanden sind.

Das einzige Problem an dieser ganzen Sache ist ja nur, wenn das Backup nicht richtig zurückgespielt wurde. Nur dann treten Probleme auf. Bei einem Backup muss die aktuelle Datenbank halt vorher geleert werden. Man darf ein Backup niemals über eine bestehende Datenbank drüber kopieren. Beachtet man das, sind 99,9% alle Probleme gar nicht erst existent. So hat man u.U. immer irgendwelche fehlerhaften Stände und auch das kann zu Folgeproblemen führen. Nur der aktuelle Weg kann das praktisch vollständig gewährleisten, vernünftige Datenbank-Strukturen zu haben. Alles andere wäre im Fehlerfall kaum prüfbar.

Sebastian

PS: Dein genannter Weg wird auch i.d.R. bereits genutzt&nbsp;[shopware/926-add-emotion-presets.php at 5.3 · shopware/shopware · GitHub](https://github.com/shopware/shopware/blob/5.3/_sql/migrations/926-add-emotion-presets.php#L57)  
Es gibt aber viele Updates / Änderungen, wo sowas einfach auch nicht geht oder sinnvoll ist.
