# Update auf Shopware 5.5.4: Fehler (Migration1445)

**URL:** https://forum.shopware.com/t/update-auf-shopware-5-5-4-fehler-migration1445/56901
**Category:** Administration
**Created:** [5. Dezember 2018 um 17:35 UTC](https://forum.shopware.com/t/update-auf-shopware-5-5-4-fehler-migration1445/56901 "2018-12-05T17:35:22Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![hagen-deutschland](https://avatars.discourse-cdn.com/v4/letter/h/8e7dd6/32.png) [@hagen-deutschland](https://forum.shopware.com/u/hagen-deutschland)
#### Post date: [5. Dezember 2018 um 17:35 UTC](https://forum.shopware.com/t/update-auf-shopware-5-5-4-fehler-migration1445/56901/1 "2018-12-05T17:35:22Z")

</div>

Bitte seid so nett und gebt uns einen Hinweis, wie folgende Fehlermeldung beim Aktualisieren von Shopware 5.5.3 auf 5.5.4 vermieden werden kann:  
&nbsp;

> Error  
> Received the following error message:  
> Could not apply migration (Migrations\_Migration1445). Error: SQLSTATE[23000]: Integrity constraint violation: 1048 Column ‚resourceID‘ cannot be null
> 
> Please try to fix this error and restart the update.  
> Response
> 
> {„valid“:false,„errorMsg“:"Could not apply migration (Migrations\_Migration1445). Error: SQLSTATE[23000]: Integrity constraint violation: 1048 Column ‚resourceID‘ cannot be null "}

---

<div class="post-metadata">

### Author: ![hagen-deutschland](https://avatars.discourse-cdn.com/v4/letter/h/8e7dd6/32.png) [@hagen-deutschland](https://forum.shopware.com/u/hagen-deutschland)
#### Post date: [7. Januar 2019 um 07:43 UTC](https://forum.shopware.com/t/update-auf-shopware-5-5-4-fehler-migration1445/56901/2 "2019-01-07T07:43:48Z")

</div>

Sicherheitshalber pushen wir die Frage in der Hoffnung, dass vielleicht mittlerweile jemand eine Idee dazu haben möge. Alle Daumen & Glücksbringer sind gedrückt&nbsp; ![Foot-in-Mouth](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/foot-in-mouth.png "Foot-in-Mouth")

---

<div class="post-metadata">

### Author: ![Patrick\_Stahl](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/patrick_stahl/32/7679_2.png) [@Patrick\_Stahl](https://forum.shopware.com/u/Patrick_Stahl)
#### Post date: [7. Januar 2019 um 08:18 UTC](https://forum.shopware.com/t/update-auf-shopware-5-5-4-fehler-migration1445/56901/3 "2019-01-07T08:18:28Z")

</div>

Moin @hagen-deutschland‍,

es scheint mir so, als hättet ihr die ACL Resource mit Namen “order” gelöscht.  
Also:  
Im Backend unter _“Einstellungen” \> “Benutzerverwaltung” \> “Regeln & Berechtigungen editieren”_&nbsp;fehlt bei dir scheinbar “order”.  
Warum das bei euch verschwunden ist, kann ich dir leider auch nicht beantworten. Vermutlich habt ihr das einfach gelöscht.

Das kannst du auch über ein SQL Statement über deine Datenbank testen:

```
SELECT id FROM s_core_acl_resources WHERE name = "order")

```

Hier&nbsp; **muss** &nbsp;bei dir ein Ergebnis kommen - ich schätze aber, dass in eurem System kein Ergebnis auftaucht, und da liegt auch das Problem.  
Die genannte Migration erwartet die ID von dieser Resource, ist vielleicht auch nicht ganz optimal gelöst.

**Also, was kannst du tun?  
Falls ihr die “Order” Rechte bewusst gelöscht habt:**

1. Das Update über das Dateisystem hochladen, **nicht ausführen!** ([klick mich](https://docs.shopware.com/de/shopware-5-de/update-guides/shopware-aktualisieren-updaten#update-per-browser))
2. Die Datei&nbsp;_\_sql/migrations/1445-add-delete-document-right.php_&nbsp;öffnen
3. In der Methode “up” direkt innerhalb der ersten Zeile einen “return” einfügen
4. Anschließend dürfte das Update laufen, es kann aber zu Folgeproblemen kommen (bspw. wird es nicht mehr möglich sein Dokumente zu löschen)

**Falls das eher ein Versehen war:**  
Das folgende SQL Statement sollte die Datensätze wieder herstellen.  
Aber&nbsp; **Vorsicht** : Ggf. sind die ID-Spalten schon anderweitig besetzt - die musst du dann natürlich aus dem SQL Statement entfernen bzw. eben neu setzen:

```
INSERT INTO `s_core_acl_resources` (`id`, `name`, `pluginID`) VALUES
    (14, 'order', NULL);

INSERT INTO `s_core_acl_privileges` (`id`, `resourceID`, `name`) VALUES
    (57, 14, 'create'),
    (58, 14, 'read'),
    (59, 14, 'update'),
    (60, 14, 'delete');

```

Hilft euch das etwas weiter?

Gruß,  
Patrick&nbsp; ![Shopware](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/86c57fbace799dd4eb1f1b8a2d3bdc1733f0aea1.png "Shopware")

---

<div class="post-metadata">

### Author: ![hagen-deutschland](https://avatars.discourse-cdn.com/v4/letter/h/8e7dd6/32.png) [@hagen-deutschland](https://forum.shopware.com/u/hagen-deutschland)
#### Post date: [8. Januar 2019 um 15:11 UTC](https://forum.shopware.com/t/update-auf-shopware-5-5-4-fehler-migration1445/56901/4 "2019-01-08T15:11:11Z")

</div>

Patrick, du bist ein Held!

Es ist fantastisch, es hat geklappt! Vielen herzlichen Dank, juuhuuu! ![Smile](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/smile.png "Smile")
