# Update auf 5.6.6 funktioniert nicht.

**URL:** <https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136>\
**Category:** Administration\
**Created:** [8. April 2020 um 13:43 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136 "2020-04-08T13:43:19Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 13:43 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/1 "2020-04-08T13:43:19Z")

</div>

Hi, ich wollte gerade meinen Shop updaten.

Es hat anfangs alles problemlos geklappt. Beim Aufräumen wurde der Screen dann weiß und es hat nichts mehr funktioniert.

Habe dann die&nbsp;/recovery/update nochmal aufgerufen und erhalte folgende Fehlermeldung:

Error

Received an error message.  
**URL:** &nbsp;unpack?offset=0&total=0  
**Message:** &nbsp;Internal Server Error

Please try to fix this error and restart the update.

Response

```
 &nbsp;

```

Slim Application Error

The application could not run because of the following error:

Details

**Type:** Gaufrette\Exception\FileAlreadyExists

**Message:** The file files/backup/auto\_update/dummy already exists and can not be overwritten.

**File:** /home/.sites/809/site70/web/recovery/common/vendor/knplabs/gaufrette/src/Gaufrette/Filesystem.php

**Line:** 100

Trace

```
 &nbsp;

```

#0 /home/.sites/809/site70/web/recovery/update/src/Steps/UnpackStep.php(86): Gaufrette\Filesystem-\>write(‚files/backup/au…‘, ‚dummyfile‘)

#1 /home/.sites/809/site70/web/recovery/update/src/Controller/BatchController.php(137): Shopware\Recovery\Update\Steps\UnpackStep-\>run(‚0‘, ‚0‘)

#2 /home/.sites/809/site70/web/recovery/update/src/app.php(154): Shopware\Recovery\Update\Controller\BatchController-\>unpack()

#3 [internal function]: {closure}()

#4 /home/.sites/809/site70/web/recovery/common/vendor/slim/slim/Slim/Route.php(468): call\_user\_func\_array(Object(Closure), Array)

#5 /home/.sites/809/site70/web/recovery/common/vendor/slim/slim/Slim/Slim.php(1355): Slim\Route-\>dispatch()

#6 /home/.sites/809/site70/web/recovery/common/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim-\>call()

#7 /home/.sites/809/site70/web/recovery/common/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash-\>call()

#8 /home/.sites/809/site70/web/recovery/common/vendor/slim/slim/Slim/Middleware/PrettyExceptions.php(67): Slim\Middleware\MethodOverride-\>call()

#9 /home/.sites/809/site70/web/recovery/common/vendor/slim/slim/Slim/Slim.php(1300): Slim\Middleware\PrettyExceptions-\>call()

#10 /home/.sites/809/site70/web/recovery/update/index.php(57): Slim\Slim-\>run()

#11 {main}

&nbsp;

Was kann da schief gelaufen sein?

&nbsp;

Beste Grüße Jürgen

---

<div class="post-metadata">

**Author:** ![dogado\_shops](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@dogado\_shops](https://forum.shopware.com/u/dogado_shops)\
**Post date:** [8. April 2020 um 14:17 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/2 "2020-04-08T14:17:36Z")

</div>

Hallo Jürgen,

falls Du PHP 7.3 verwendest, auf PHP 7.2 umstellen, die dummy Datei im vorgenannten Verzeichnis löschen und dann nochmal das Update über /recovery/update versuchen.

Auf PHP 7.3 kannst Du erst nach erfolgtem Update umstellen.

Viele Grüße aus Dortmund

dogado shops (ehemals AIXPRO)

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 14:24 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/3 "2020-04-08T14:24:49Z")

</div>

PHP läuft noch auf der Version 7.2, da wurde auch nichts verändert. Die dummy Datei habe ich bereits gelöscht, das hat aber nicht geholfen.

Ich spiele grad das Backup wieder ein und starte einen neuen Versuch.

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 14:58 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/4 "2020-04-08T14:58:45Z")

</div>

Ich hätte noch eine kurze Frage zum Update.

&nbsp;

Sollte man Plugins die nicht mehr im Store verfügbar sind deaktivieren, oder komplett deinstallieren?

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 15:17 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/5 "2020-04-08T15:17:22Z")

</div>

Das Update endet mit einem weißen Screen (recovery/update/index.php/done)&nbsp;und die Seite befindet sich im Wartungsmodus.

&nbsp;

---

<div class="post-metadata">

**Author:** ![dogado\_shops](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@dogado\_shops](https://forum.shopware.com/u/dogado_shops)\
**Post date:** [8. April 2020 um 15:28 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/6 "2020-04-08T15:28:47Z")

</div>

Hallo,

entsprechende&nbsp;Plugins, bei welchen die Kompatibilität im&nbsp;Update Vorgang nicht geprüft werden kann, solltest Du deaktivieren -und- deinstallieren sowie vollständig entfernen.

Ferner dürfen keine verschlüsselten Plugins mehr aktiv sein - dies gilt auch für den Shopware Lizenz-Manager.

Mit folgendem Plugin kannst Du dies prüfen:

[https://store.shopware.com/frosh49916215277f/ioncube-check.html](https://store.shopware.com/frosh49916215277f/ioncube-check.html)

Alle bemängelten Plugins müssen deaktiviert, deinstalliert und vollständig vor dem Update entfernt werden.

Viele Grüße aus Dortmund

dogado shops (ehemals AIXPRO)

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 15:30 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/7 "2020-04-08T15:30:48Z")

</div>

Hatte es deaktiviert und deinstalliert, aber nicht entfernt. Also wieder über das Backup den nächsten Anlauf starten.

Oder hab ich noch eine andere Möglichkeit?

---

<div class="post-metadata">

**Author:** ![dogado\_shops](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@dogado\_shops](https://forum.shopware.com/u/dogado_shops)\
**Post date:** [8. April 2020 um 15:48 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/8 "2020-04-08T15:48:58Z")

</div>

Hallo,

ich empfehle den Weg über ein erneutes Einspielen des Backups und Vorgehensweise wie beschrieben.

Wenn Du weisst, welches Plugin die Probleme verursacht, kannst Du zwar im Dateisystem unter /engine/Shopware/Plugins das entsprechende Plugin-Verzeichnis löschen und den dazugehörigen Eintrag in der DB Tabelle s\_core\_plugins, läufst aber Gefahr, dass Du Überbleibsel mitschleppst die dann in der Zukunft Probleme verursachen.

Viele Grüße aus Dortmund

dogado shops (ehemals AIXPRO)

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 16:00 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/9 "2020-04-08T16:00:04Z")

</div>

Dann auf ein Neues.

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 16:55 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/10 "2020-04-08T16:55:58Z")

</div>

Leider wieder beim weißen Screnn gelandet.

Wenn ich recovery/update erneut aufrufe kommt dann folgender Screen:

Aufräumen

Die folgenden Dateien gehören zu einer früheren Shopware Version und werden nach diesem Update nicht länger benötigt. Drücken Sie “Weiter” um die Dateien automatisch zu löschen und das Update zu beenden. Wir empfehlen vorher ein Backup anzulegen.&nbsp;  
**Abhänging von der Menge der aufzuräumenden Dateien kann dieser Prozess einige Zeit in Anspruch nehmen.** var/cache/production\_202003031106

Danach lande ich wieder beim weißen Screen.

Was kann da falsch laufen?

&nbsp;

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 17:24 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/11 "2020-04-08T17:24:33Z")

</div>

Ich hab das jetzt nochmal mit Windows versucht.

Im Internet Explorer kann die Seite&nbsp;recovery/update/done nicht angezeigt werden.

Meldung im Internet Explorer:

Die Website kann diese Seite nicht anzeigen

&nbsp;

Der oben genannte Ordner (production\_202003031106) wird auch nie gelöscht.

Auch der Versuch den Ordner manuell zu löschen und das Update erneut anzustoßen brachte keinen Erfolg.

---

<div class="post-metadata">

**Author:** ![dogado\_shops](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@dogado\_shops](https://forum.shopware.com/u/dogado_shops)\
**Post date:** [8. April 2020 um 18:48 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/12 "2020-04-08T18:48:17Z")

</div>

Von welcher auf welche Version versuchst Du zu aktualisieren ?

Viele Grüße aus Dortmund

dogado shops (ehemals AIXPRO)

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 20:02 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/13 "2020-04-08T20:02:03Z")

</div>

Von der Version 5.5.9 auf 5.6.6.

---

<div class="post-metadata">

**Author:** ![dogado\_shops](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@dogado\_shops](https://forum.shopware.com/u/dogado_shops)\
**Post date:** [8. April 2020 um 20:12 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/14 "2020-04-08T20:12:49Z")

</div>

Aktiviere mal das erweiterte Error-Debugging in Deiner config.php, damit Du eine ausführliche Fehlermeldung erhältst:

> **[Shopware 5 - Tutorials & FAQs - Fehlermeldungen in Shopware debuggen](https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/fehlermeldungen-in-shopware-debuggen#erweitertes-error-debugging)**

Viele Grüße aus Dortmund

dogado shops (ehemals AIXPRO)

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 20:40 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/15 "2020-04-08T20:40:56Z")

</div>

Ich hab jetzt erneut das Backup eingespielt und hab die index.php geändert.

Und bekomme jetzt schon folgenden Fehler:

&nbsp;

Parse error: syntax error, unexpected ‚=\>‘ (T\_DOUBLE\_ARROW) in /home/.sites/809/site70/web/config.php on line 11

&nbsp;

Ist das die mögliche Ursache?

Zur Info, das ist noch vor dem Update.

Oder ist das normal und ich soll die index.php erst nach dem Update ändern?

---

<div class="post-metadata">

**Author:** ![dogado\_shops](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@dogado\_shops](https://forum.shopware.com/u/dogado_shops)\
**Post date:** [8. April 2020 um 21:00 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/16 "2020-04-08T21:00:25Z")

</div>

Da hast Du in Zeile 11 Deiner config.php einen Fehler - das hat nichts mit dem Update zu tun - schau Dir nochmal genau die Parameter an.

Viele Grüße aus Dortmund

dogado shops (ehemals AIXPRO)

&nbsp;

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 21:06 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/17 "2020-04-08T21:06:49Z")

</div>

Gefunden, hab den Code&nbsp;in die falsche Zeile kopiert.

Dann starte ich einen neuen Versuch mit dem Update.

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [8. April 2020 um 21:23 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/18 "2020-04-08T21:23:29Z")

</div>

Diese Fehlermeldung kommt:

&nbsp;

Fatal error: Allowed memory size of 118489088 bytes exhausted (tried to allocate 20480 bytes) in /home/.sites/809/site70/web/vendor/symfony/http-kernel/Kernel.php on line 918

&nbsp;

Liegt das am PHP Memory Limit?

---

<div class="post-metadata">

**Author:** ![dogado\_shops](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@dogado\_shops](https://forum.shopware.com/u/dogado_shops)\
**Post date:** [9. April 2020 um 08:05 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/19 "2020-04-09T08:05:14Z")

</div>

Hallo,

ja - das PHP Memory Limit sollte mindestens bei 256MB, besser 384MB liegen.

Viele Grüße aus Dortmund

dogado shops (ehemals AIXPRO)

---

<div class="post-metadata">

**Author:** ![sonnenenergie](https://avatars.discourse-cdn.com/v4/letter/s/ba8739/32.png) [@sonnenenergie](https://forum.shopware.com/u/sonnenenergie)\
**Post date:** [9. April 2020 um 13:03 UTC](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136/20 "2020-04-09T13:03:52Z")

</div>

Danke für die Hilfe, das Memory Limit hat das Problem gelöst.

&nbsp;

&nbsp;

[Nächste Seite](https://forum.shopware.com/t/update-auf-5-6-6-funktioniert-nicht/66136.md?page=2)
