# Update auf 5.3.6 Abbruch mit Fehlermeldung

**URL:** <https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427>\
**Category:** Administration\
**Created:** [13. Januar 2018 um 09:02 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427 "2018-01-13T09:02:57Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![Toric](https://avatars.discourse-cdn.com/v4/letter/t/bbe5ce/32.png) [@Toric](https://forum.shopware.com/u/Toric)\
**Post date:** [13. Januar 2018 um 09:02 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/1 "2018-01-13T09:02:57Z")

</div>

Hallo,

habe gerade das Update durchführen wollen. Es lief durch bis zum Button „Aufräumen“ danach kam folgende Fehlermeldung:

```
Slim Application Error

The application could not run because of the following error:
Details
Type: Symfony\Component\DependencyInjection\Exception\ParameterNotFoundException
Message: The service "shopware_attribute.table_mapping" has a dependency on a non-existent parameter "shopware_attribute.table_entity_mapping".
File: /var/www/vhosts/domain.de/shopname/vendor/symfony/dependency-injection/ParameterBag/ParameterBag.php
Line: 84
Trace

#0 /var/www/vhosts/domain.de/shopname/vendor/symfony/dependency-injection/ParameterBag/ParameterBag.php(200): Symfony\Component\DependencyInjection\ParameterBag\ParameterBag->get('shopware_attrib...')
#1 /var/www/vhosts/domain.de/shopname/vendor/symfony/dependency-injection/ParameterBag/ParameterBag.php(171): Symfony\Component\DependencyInjection\ParameterBag\ParameterBag->resolveString('%shopware_attri...', Array)
#2 /var/www/vhosts/domain.de/shopname/vendor/symfony/dependency-injection/ParameterBag/ParameterBag.php(161): Symfony\Component\DependencyInjection\ParameterBag\ParameterBag->resolveValue('%shopware_attri...', Array)
#3 /var/www/vhosts/domain.de/shopname/vendor/symfony/dependency-injection/Compiler/ResolveParameterPlaceHoldersPass.php(37): Symfony\Component\DependencyInjection\ParameterBag\ParameterBag->resolveValue(Array)
#4 /var/www/vhosts/domain.de/shopname/vendor/symfony/dependency-injection/Compiler/Compiler.php(102): Symfony\Component\DependencyInjection\Compiler\ResolveParameterPlaceHoldersPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#5 /var/www/vhosts/domain.de/shopname/vendor/symfony/dependency-injection/ContainerBuilder.php(583): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#6 /var/www/vhosts/domain.de/shopname/engine/Shopware/Kernel.php(519): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#7 /var/www/vhosts/domain.de/shopname/engine/Shopware/Kernel.php(287): Shopware\Kernel->initializeContainer()
#8 /var/www/vhosts/domain.de/shopname/recovery/update/src/DependencyInjection/Container.php(180): Shopware\Kernel->boot()
#9 /var/www/vhosts/domain.de/shopname/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Update\DependencyInjection\Container->Shopware\Recovery\Update\DependencyInjection\{closure}(Object(Pimple\Container))
#10 /var/www/vhosts/domain.de/shopname/recovery/update/src/DependencyInjection/Container.php(189): Pimple\Container->offsetGet('shopware.contai...')
#11 /var/www/vhosts/domain.de/shopname/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Update\DependencyInjection\Container->Shopware\Recovery\Update\DependencyInjection\{closure}(Object(Pimple\Container))
#12 /var/www/vhosts/domain.de/shopname/recovery/common/src/DependencyInjection/Container.php(80): Pimple\Container->offsetGet('shopware.theme_...')
#13 /var/www/vhosts/domain.de/shopname/recovery/update/src/app.php(169): Shopware\Recovery\Common\DependencyInjection\Container->get('shopware.theme_...')
#14 [internal function]: {closure}()
#15 /var/www/vhosts/domain.de/shopname/recovery/common/vendor/slim/slim/Slim/Route.php(462): call_user_func_array(Object(Closure), Array)
#16 /var/www/vhosts/domain.de/shopname/recovery/common/vendor/slim/slim/Slim/Slim.php(1326): Slim\Route->dispatch()
#17 /var/www/vhosts/domain.de/shopname/recovery/common/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim->call()
#18 /var/www/vhosts/domain.de/shopname/recovery/common/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash->call()
#19 /var/www/vhosts/domain.de/shopname/recovery/common/vendor/slim/slim/Slim/Middleware/PrettyExceptions.php(67): Slim\Middleware\MethodOverride->call()
#20 /var/www/vhosts/domain.de/shopname/recovery/common/vendor/slim/slim/Slim/Slim.php(1271): Slim\Middleware\PrettyExceptions->call()
#21 /var/www/vhosts/domain.de/shopname/recovery/update/index.php(69): Slim\Slim->run()
#22 {main}

```

&nbsp;

&nbsp;

Kann mir das jemand übersetzen? Die wenigen vorhandenen Plugins waren freigegeben.

LG

Nachtrag: Ich hab auf gut Glück mit /recovery/update&nbsp; aufgerufen und es lief bis zum Ende durch. Dennoch wäre natürlich interessant zu wissen, was den Fehler verursacht hat, bevor ich den großen Shop update.

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [13. Januar 2018 um 10:38 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/2 "2018-01-13T10:38:09Z")

</div>

Hast du die Dateien manuell hochgeladen?  
Vielleicht fehlen da Dateien.

---

<div class="post-metadata">

**Author:** ![Toric](https://avatars.discourse-cdn.com/v4/letter/t/bbe5ce/32.png) [@Toric](https://forum.shopware.com/u/Toric)\
**Post date:** [13. Januar 2018 um 10:51 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/3 "2018-01-13T10:51:51Z")

</div>

Ich habe über “?” Softwareaktualisierung gestartet, also komplett im Backend. Sah zunächst auch alles normal aus. Nur eben nach Aufräumen kam die Meldung.

Bei einem früheren Update hatte ich schon mal nen Absturz nach Aufräumen (anderer Shop und andere Fehlermeldung allerdings), damals hat der Hoster mit [Domain.de/recovery/update](http://Domain.de/recovery/update) einen Aufruf gemacht und es lief alles bis Ende durch. Das hab ich jetzt auch so versucht. Hat geklappt.

Ob der Shop jetzt irgendwo unvollständig ist, kann ich nicht erkennen. Auf den ersten Blick sieht es normal aus.

---

<div class="post-metadata">

**Author:** ![lampenstar](https://avatars.discourse-cdn.com/v4/letter/l/e47c2d/32.png) [@lampenstar](https://forum.shopware.com/u/lampenstar)\
**Post date:** [16. Januar 2018 um 06:41 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/4 "2018-01-16T06:41:27Z")

</div>

Hallo zusammen!

Wir haben leider ebenfalls ein Problem beim updaten.

Unser Updatevorgang kommt nicht weiter als “Vorbereiten…”

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/c/c670a44225a29d49cbab1257d03d55955491be24.png)

Woran könnte das liegen?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [16. Januar 2018 um 07:05 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/5 "2018-01-16T07:05:04Z")

</div>

max\_execution\_time vom Server. Shopware prüft in diesem Schritt nochmal alle Schreib/Leserechte der Verzeichnisse. Wird wohl zu lange dauern.

---

<div class="post-metadata">

**Author:** ![lampenstar](https://avatars.discourse-cdn.com/v4/letter/l/e47c2d/32.png) [@lampenstar](https://forum.shopware.com/u/lampenstar)\
**Post date:** [18. Januar 2018 um 16:43 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/6 "2018-01-18T16:43:26Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> max\_execution\_time vom Server. Shopware prüft in diesem Schritt nochmal alle Schreib/Leserechte der Verzeichnisse. Wird wohl zu lange dauern.

Vielen Dank für die Info, dies wird es aber nicht sein.

Habe die Zeit hoch gestellt und jetzt versucht es seit heute Morgen (ca. 10h) und kommt nicht weiter!?&nbsp;

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [18. Januar 2018 um 17:09 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/7 "2018-01-18T17:09:43Z")

</div>

Du musst am besten mal schauen, was entweder in der Konsole passiert oder im Shopware Log steht. Das wird mit Sicherheit direkt im Hintergrund was knallen. Das dauert alles eigentlich sonst weniger als ne Minute&nbsp;

---

<div class="post-metadata">

**Author:** ![Ladenbesitzer](https://avatars.discourse-cdn.com/v4/letter/l/dc4da7/32.png) [@Ladenbesitzer](https://forum.shopware.com/u/Ladenbesitzer)\
**Post date:** [19. Januar 2018 um 17:15 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/8 "2018-01-19T17:15:23Z")

</div>

Habe da genau das gleiche Problem.

Ging bis 5.3.4&nbsp;super, aber zu 5.3.5 oder 5.3.6 gar nicht mehr.

Ich habe bereits /var/cache/ mehrfach gelöscht, jedoch ohne Veränderungen.

Laut „top“ erzeugt der Shop zuerst einmal wie erwartet Last, hört dann aber auf, während sich das Rädchen im Backend&nbsp;weiter und weiter dreht.&nbsp;

---

<div class="post-metadata">

**Author:** ![lampenstar](https://avatars.discourse-cdn.com/v4/letter/l/e47c2d/32.png) [@lampenstar](https://forum.shopware.com/u/lampenstar)\
**Post date:** [19. Januar 2018 um 18:12 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/9 "2018-01-19T18:12:11Z")

</div>

> [@Ladenbesitzer schrieb:](https://forum.shopware.com/profile/23256/Ladenbesitzer "Ladenbesitzer")
> 
> Habe da genau das gleiche Problem.
> 
> Ging bis 5.3.4&nbsp;super, aber zu 5.3.5 oder 5.3.6 gar nicht mehr.
> 
> Ich habe bereits /var/cache/ mehrfach gelöscht, jedoch ohne Veränderungen.
> 
> Laut „top“ erzeugt der Shop zuerst einmal wie erwartet Last, hört dann aber auf, während sich das Rädchen im Backend&nbsp;weiter und weiter dreht.&nbsp;

Ja klingt ähnlich wie bei uns! &nbsp;Wir haben es mit „Update über FTP“ gelöst, anders war es nicht möglich -\>&nbsp;[http://community.shopware.com/Shopware-aktualisieren-updaten\_detail\_1878.html](http://community.shopware.com/Shopware-aktualisieren-updaten_detail_1878.html)

---

<div class="post-metadata">

**Author:** ![Ladenbesitzer](https://avatars.discourse-cdn.com/v4/letter/l/dc4da7/32.png) [@Ladenbesitzer](https://forum.shopware.com/u/Ladenbesitzer)\
**Post date:** [20. Januar 2018 um 09:34 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/10 "2018-01-20T09:34:09Z")

</div>

OK, danke.

Ich werde es dann genau so machen

&nbsp;

PS: die technischen Voraussetzungen sind laut Updater alle erfüllt.

Zusätzlich ist die max upload size auf 16 MB erhöht worden.

---

<div class="post-metadata">

**Author:** ![sschreier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sschreier/32/23296_2.png) [@sschreier](https://forum.shopware.com/u/sschreier)\
**Post date:** [20. Januar 2018 um 09:41 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/11 "2018-01-20T09:41:16Z")

</div>

Hallo,

wie groß ist euer Bildordner (media)?&nbsp;

Grüße

Sebastian

---

<div class="post-metadata">

**Author:** ![lampenstar](https://avatars.discourse-cdn.com/v4/letter/l/e47c2d/32.png) [@lampenstar](https://forum.shopware.com/u/lampenstar)\
**Post date:** [20. Januar 2018 um 13:46 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/12 "2018-01-20T13:46:52Z")

</div>

> [@sschreier schrieb:](https://forum.shopware.com/profile/18157/sschreier "sschreier")
> 
> Hallo,
> 
> wie groß ist euer Bildordner (media)?&nbsp;
> 
> Grüße
> 
> Sebastian

11 GB (!!)&nbsp;

---

<div class="post-metadata">

**Author:** ![sschreier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sschreier/32/23296_2.png) [@sschreier](https://forum.shopware.com/u/sschreier)\
**Post date:** [20. Januar 2018 um 14:26 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/13 "2018-01-20T14:26:09Z")

</div>

Hallo,

ich würde noch folgendes probieren: nenne mal den media - Ordner von “media” in “\_media” um und versuch es dann noch mal mit dem automatischen Update. Wie Moritz schon sagt, überprüft das automatische Update die Schreib- und Leserechte aller Verzeichnisse, als auch der des media - Verzeichnisses. Und das kann bei einer großen Masse an Bildern natürlich solange dauern, dass der Prozess dabei abbricht. Wenn er den media - Ordner aber nicht findet, kann man es so umgehen und es dürfte wieder klappen. Nach dem Update solltest du dann natürlich den Ordner wieder zurück benennen.

Grüße

Sebastian

---

<div class="post-metadata">

**Author:** ![Ladenbesitzer](https://avatars.discourse-cdn.com/v4/letter/l/dc4da7/32.png) [@Ladenbesitzer](https://forum.shopware.com/u/Ladenbesitzer)\
**Post date:** [23. Januar 2018 um 07:08 UTC](https://forum.shopware.com/t/update-auf-5-3-6-abbruch-mit-fehlermeldung/50427/14 "2018-01-23T07:08:54Z")

</div>

media ist bei mir nur 51 MB groß.

Laut top hört die durch das Update verursachte Last nach nur kurzer Zeit auf.

Nur der Kringel im Backend dreht sich weiter als würde noch etwas geschehen.
