# Update auf 4.3 nicht möglich (Strict Standards Fehler)

**URL:** https://forum.shopware.com/t/update-auf-4-3-nicht-moglich-strict-standards-fehler/21085
**Category:** Shopware 3.5
**Tags:** installation--gettin
**Created:** [2. Juli 2014 um 08:32 UTC](https://forum.shopware.com/t/update-auf-4-3-nicht-moglich-strict-standards-fehler/21085 "2014-07-02T08:32:42Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![fuzz](https://avatars.discourse-cdn.com/v4/letter/f/c5a1d2/32.png) [@fuzz](https://forum.shopware.com/u/fuzz)
#### Post date: [2. Juli 2014 um 08:32 UTC](https://forum.shopware.com/t/update-auf-4-3-nicht-moglich-strict-standards-fehler/21085/1 "2014-07-02T08:32:42Z")

</div>

Hallo allerseits, wollte gerade meinen 4.2.3 Demo-Shop auf 4.3 updaten. Das ist aber nicht möglich da der Update ständig Fehler auswirft. Gleich auf der ersten Seite (siehe unten) oder das selbe in Verbindung mit JSON wenn man den Schritt „Datenbank Migration“ ausführen will. `Strict Standards: Redefining already defined constructor for class Slim\Log in [...]/web/recovery/common/vendor/slim/slim/Slim/Log.php on line 304 Strict Standards: Redefining already defined constructor for class Slim\Helper\Set in [...]/web/recovery/common/vendor/slim/slim/Slim/Helper/Set.php on line 72` Habe dann auch mal eine Neuinstallation von 4.3 probiert, mit Erfolg… aber die Demo-Daten (demo.sql) scheinen noch nicht für 4.3 geeignet zu sein (Mysql Fehler: table s\_cms\_content not exist). Hoffe Ihr könnt mir helfen! Danke & Gruß

---

<div class="post-metadata">

### Author: ![farbTopi](https://avatars.discourse-cdn.com/v4/letter/f/a88e4f/32.png) [@farbTopi](https://forum.shopware.com/u/farbTopi)
#### Post date: [2. Juli 2014 um 09:02 UTC](https://forum.shopware.com/t/update-auf-4-3-nicht-moglich-strict-standards-fehler/21085/2 "2014-07-02T09:02:55Z")

</div>

Hi, hab auch noch einige (kleine) Probleme mit 4.3.0 Bei einer frischen Installation läßt sich Paypal und Billsafe nicht aktivieren, da diese beiden Plugins nicht 4.3.0 kompatibel sind. Das sollte ebenfalls schnell gelöst werden.

---

<div class="post-metadata">

### Author: ![Benjamin\_Cremer](https://avatars.discourse-cdn.com/v4/letter/b/a8b319/32.png) [@Benjamin\_Cremer](https://forum.shopware.com/u/Benjamin_Cremer)
#### Post date: [2. Juli 2014 um 10:16 UTC](https://forum.shopware.com/t/update-auf-4-3-nicht-moglich-strict-standards-fehler/21085/3 "2014-07-02T10:16:30Z")

</div>

Hallo fuzz, das sieht mir so aus als wenn dort noch eine alte Version des Slim Framework geladen wird. Kanns du bitte den (jetzt ungenutzen) Order /engine/Library/Slim von deinem Server löschen und das Update dann noch einmal ausführen. Wenn du einen OpCache wie APC installiert hast müsstest du ggf. den Webserver noch neustarten. Viele Grüße, Benjamin Cremer

---

<div class="post-metadata">

### Author: ![fuzz](https://avatars.discourse-cdn.com/v4/letter/f/c5a1d2/32.png) [@fuzz](https://forum.shopware.com/u/fuzz)
#### Post date: [2. Juli 2014 um 10:27 UTC](https://forum.shopware.com/t/update-auf-4-3-nicht-moglich-strict-standards-fehler/21085/4 "2014-07-02T10:27:40Z")

</div>

Hi, leider hilft das nicht. Es kommt weiterhin die Meldung wie oben beschrieben. Hier jetzt auch nochmal die Meldung vom Update wenn man auf „Starten“ (DB Update) klickt (Browser Version): ` Error Received an error message. URL: unpack?offset=0&total=0 Message: SyntaxError: JSON.parse: unexpected character at line 2 column 1 of the JSON data Please try to fix this error and restart the update. Response Strict Standards: Redefining already defined constructor for class Slim\Log in [...]/web/recovery/common/vendor/slim/slim/Slim/Log.php on line 304 Strict Standards: Redefining already defined constructor for class Slim\Helper\Set in [...]/web/recovery/common/vendor/slim/slim/Slim/Helper/Set.php on line 72 {"valid":false,"offset":0,"total":0,"success":true} `

---

<div class="post-metadata">

### Author: ![Benjamin\_Cremer](https://avatars.discourse-cdn.com/v4/letter/b/a8b319/32.png) [@Benjamin\_Cremer](https://forum.shopware.com/u/Benjamin_Cremer)
#### Post date: [2. Juli 2014 um 15:56 UTC](https://forum.shopware.com/t/update-auf-4-3-nicht-moglich-strict-standards-fehler/21085/5 "2014-07-02T15:56:38Z")

</div>

Hallo, ich konnte bisher noch nicht definitiv nachstellen in welchen konstellationen dieser Fehler auftritt. Um das Update durchzuführen sollte Folgende Dateiänderung helfen: [https://github.com/ShopwareAG/shopware- … pp.php#L30](https://github.com/ShopwareAG/shopware-4/blob/master/recovery/update/src/app.php#L30) Datei: recovery/update/src/app.php Zeile: 30 `ini\_set('display\_errors', 1);` durch `ini\_set('display\_errors', 0);` ersetzen. Viele Grüße, Benjamin Cremer :shopware:

---

<div class="post-metadata">

### Author: ![coco](https://avatars.discourse-cdn.com/v4/letter/c/8797f3/32.png) [@coco](https://forum.shopware.com/u/coco)
#### Post date: [2. Juli 2014 um 17:31 UTC](https://forum.shopware.com/t/update-auf-4-3-nicht-moglich-strict-standards-fehler/21085/6 "2014-07-02T17:31:54Z")

</div>

Hallo, hab das gleiche Problem wie beschrieben, durch die beschriebene Änderung läuft jetzt alles fast durch bis zum Aufräumen, dort sollen einige Dateien die man nicht mehr benötigt löschen. Aber leider wird mir der Pfad zu den Dateien nicht angezeigt. z.B. [list] ter.php e/DeveloperGarden e/Ebay e/Flickr e/LiveDocx e/Nirvanix e/Rackspace e/ReCaptcha [/list] usw… möchte es gerne abschließen, kann mir einer vielleicht helfen ?

---

<div class="post-metadata">

### Author: ![fuzz](https://avatars.discourse-cdn.com/v4/letter/f/c5a1d2/32.png) [@fuzz](https://forum.shopware.com/u/fuzz)
#### Post date: [3. Juli 2014 um 07:57 UTC](https://forum.shopware.com/t/update-auf-4-3-nicht-moglich-strict-standards-fehler/21085/7 "2014-07-03T07:57:26Z")

</div>

Mit dem display\_errors = 0 (wie oben beschrieben) hat es geklappt. Danke & Gruß

---

<div class="post-metadata">

### Author: ![ELL](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/ell/32/15661_2.png) [@ELL](https://forum.shopware.com/u/ELL)
#### Post date: [11. April 2018 um 17:11 UTC](https://forum.shopware.com/t/update-auf-4-3-nicht-moglich-strict-standards-fehler/21085/8 "2018-04-11T17:11:43Z")

</div>

> Datei: recovery/update/src/app.php  
> Zeile: 30
> 
> ini\_set(‚display\_errors‘, 1);
> 
> durch
> 
> ini\_set(‚display\_errors‘, 0);
> 
> ersetzen.

Ich hatte den Fehler auch. Der Tipp von Benjamin hat einwandfrei funktioniert. Anschließend lief das Update fehlerfrei durch – DANKE!&nbsp;

&nbsp;
