# Update 5.7.2 - Fatal Error

**URL:** <https://forum.shopware.com/t/update-5-7-2-fatal-error/88780>\
**Category:** Sonstiges\
**Created:** [2. Juli 2021 um 12:35 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780 "2021-07-02T12:35:46Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![distrax](https://avatars.discourse-cdn.com/v4/letter/d/8dc957/32.png) [@distrax](https://forum.shopware.com/u/distrax)\
**Post date:** [2. Juli 2021 um 12:35 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/1 "2021-07-02T12:35:46Z")

</div>

Hallo,

Wir wollten uns mal daran machen, unser 5.6.10er auf die aktuelle 5.7.2 upzudaten.  
Vorher alle Plugins aktualisiert, deaktiviert und manche sogar deinstalliert.  
PHP Version auf 7.4.13 gestellt. (Auch mit 8.0.0 probiert):  
Dann das Update gestartet, klappt auch alles soweit super, bis das Update aufräumt und dann auf der Seite  
_…/recovery/update/done_  
mit einer weißen Seite hängen bleibt.  
Das Log sagt:

- **Fatal error** : Out of memory (allocated 62918656) (tried to allocate 20480 bytes) in **…/vendor/symfony/http-kernel/Kernel.php** on line **838** \*

Speicherprobleme? Laut Hoster und Shopware Systeminfo liegt unser Memory Limit bei 512M.

Woran kann es also nur liegen?

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [2. Juli 2021 um 12:37 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/2 "2021-07-02T12:37:15Z")

</div>

Hallo,

die 512MB reichen offenbar bei Deinem Shop nicht aus.

Viele Grüße

---

<div class="post-metadata">

**Author:** ![distrax](https://avatars.discourse-cdn.com/v4/letter/d/8dc957/32.png) [@distrax](https://forum.shopware.com/u/distrax)\
**Post date:** [2. Juli 2021 um 12:39 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/3 "2021-07-02T12:39:40Z")

</div>

Danke für die fixe Antwort.

Aber kann es wirklich sein dass das Limit von 512M nicht ausreicht? Shopware empfielt 256M. Da müsste doch die doppelte Menge locker langen.

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [2. Juli 2021 um 12:44 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/4 "2021-07-02T12:44:32Z")

</div>

Hallo,

ja durchaus - hängt immer von verwendeten Plugins uvm. ab. 256MB ist die absolute Mindestvoraussetzung.

Viele Grüße

---

<div class="post-metadata">

**Author:** ![Steffffi](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/steffffi/32/13846_2.png) [@Steffffi](https://forum.shopware.com/u/Steffffi)\
**Post date:** [2. Juli 2021 um 19:25 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/5 "2021-07-02T19:25:37Z")

</div>

Interessant, weil für die 5.6’er Version hat wohl der Wert von 512mb gereicht.

Witzig, dass ab 5.7 gar nichts mehr so reicht wie als für die Versionen davor. Zum Glück spare ich mir das Update, ein Gang ins Casino scheint zielführender.

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [2. Juli 2021 um 19:38 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/6 "2021-07-02T19:38:07Z")

</div>

Ich kenne 5.7.2er Shops, die problemlos mit 512MB laufen. Kann durchaus auch an einem Drittanbieter-Plugin liegen …

---

<div class="post-metadata">

**Author:** ![msg20](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/msg20/32/14162_2.png) [@msg20](https://forum.shopware.com/u/msg20)\
**Post date:** [11. Juli 2021 um 06:41 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/7 "2021-07-11T06:41:32Z")

</div>

Hallo Distrax,

konntest du das Problem schon lösen oder eingrenzen?  
Ich habe die gleiche Fehlermeldung mit php 7.4.13 / 512 M beim Updateversuch von 5.6.10 auf 5.7.2

Plugins (außer SW) waren kpl. deaktiviert

Beste Grüße Hans

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [12. Juli 2021 um 05:48 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/8 "2021-07-12T05:48:35Z")

</div>

Das Update ist im „aufräumen“ Schritt ja schon quasi durchgelaufen. Was passiert denn, wenn ihr es nach der Fehlermeldung nochmal startet solange bis die Fehlermeldung weg geht?

Denke er bekommt einfach nur nicht alles in einem Schritt aufgeräumt.

---

<div class="post-metadata">

**Author:** ![msg20](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/msg20/32/14162_2.png) [@msg20](https://forum.shopware.com/u/msg20)\
**Post date:** [13. Juli 2021 um 13:28 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/9 "2021-07-13T13:28:31Z")

</div>

Hallo Moritz,

ich habe das 5.7.2 Update einige Male neu angestoßen, die Fehlermeldung bleibt unverändert.

Vorher Cache gelöscht, Theme kompiliert, alle Plugins im Sicherheitsmodus

**Fatal error** : Out of memory (allocated 62918656) (tried to allocate 20480 bytes) in **/var/httpdocs/TESTSERVER/vendor/symfony/http-kernel/Kernel.php** on line **838**

**Weiter geforscht….**

Einen Schritt zurück SW 5.6.10 mit php 7.3.27 im config.php debug Modus folgende Meldung:

**Fatal error** : Listener „onStartDispatch“ in „OmecoSaveBasketCustomer“ is not callable. in **/var/ /httpdocs/TESTSERVER/engine/Library/Enlight/Event/Handler/Plugin.php** on line **141**

Das Plugin „OmecoSaveBasketCustomer“ - Permanenter Warenkorb von synaigi ist jedoch komplett gelöscht!

Kein Eintrag in der s\_core\_plugins und im Plugin Verzeichnis

_ **Der Shop läuft anstandslos unter php 7.3.27** _ switche ich auf 7.4.13 bekomme ich 500er Fehler und für das Update 5.7.2 den obigen Fehler bzw. in der Detailansicht:

**Details**

**Type:** ErrorException

**Code:** 2

**Message:** include(/var/TESTSERVER/vendor/composer/…/symfony/dependency-injection/Compiler/FactoryReturnTypePass.php): failed to open stream: No such file or directory

**File:** /var/TESTSERVER/recovery/common/vendor/composer/ClassLoader.php

**Line:** 478

Ursache scheint also das „Omeco“ Plugin zu sein, nur wo suche ich danach?

---

<div class="post-metadata">

**Author:** ![distrax](https://avatars.discourse-cdn.com/v4/letter/d/8dc957/32.png) [@distrax](https://forum.shopware.com/u/distrax)\
**Post date:** [20. Juli 2021 um 19:02 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/10 "2021-07-20T19:02:16Z")

</div>

> [@Moritz\_Naczenski](#):
>
> Das Update ist im „aufräumen“ Schritt ja schon quasi durchgelaufen. Was passiert denn, wenn ihr es nach der Fehlermeldung nochmal startet solange bis die Fehlermeldung weg geht?
> 
> Denke er bekommt einfach nur nicht alles in einem Schritt aufgeräumt.

Also wir hatten es probiert mit manuellem Cache löschen und einigen anderen sachen, aber es hat einfach nichts geholfen. Sowohl Front- als auch Backend bleiben unaufrufbar. Inzwischen kamen ja auch seitens Pickware und Shopware einige Updates mit Bezug auf PHP Kompatibilät. Ich werde demnächst noch mal einen Versuch starten.

---

<div class="post-metadata">

**Author:** ![nemoment](https://avatars.discourse-cdn.com/v4/letter/n/ea5d25/32.png) [@nemoment](https://forum.shopware.com/u/nemoment)\
**Post date:** [21. Juli 2021 um 13:19 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/11 "2021-07-21T13:19:47Z")

</div>

Bei mir leider das gleiche Problem. In 3 voneinander unabhängigen Shopware 5 Projekten. Memory Limit in der php.ini habe ich jeweils auf 756MB erhöht. Leider ohne Erfolg. Nach der Datenbankbereinigung sind Front- und Backend nicht erreichbar.

---

<div class="post-metadata">

**Author:** ![msg20](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/msg20/32/14162_2.png) [@msg20](https://forum.shopware.com/u/msg20)\
**Post date:** [23. Juli 2021 um 12:01 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/12 "2021-07-23T12:01:02Z")

</div>

So nun läuft es endlich mit php 7.4.13 …, aber nicht mit php 8.0.0 (Ticket läuft noch)

Antwort vom Provider … „Wir konnten das Problem **Serverseitig** ausfindig machen und Final beheben.“

Was konkret ursächlich war, wurde leider nicht mitgeteilt. Ich hatte zwischendurch auch eine Neuinstallation 5.7.2 auf der Arbeitsdomain versucht, auch die lief nicht. Aber so offenbarte sich der Fehler. Das o.e. Plugin war nicht ursächlich.

---

<div class="post-metadata">

**Author:** ![nemoment](https://avatars.discourse-cdn.com/v4/letter/n/ea5d25/32.png) [@nemoment](https://forum.shopware.com/u/nemoment)\
**Post date:** [10. August 2021 um 08:57 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/13 "2021-08-10T08:57:10Z")

</div>

Hier läuft es leider immer noch nicht. PHP 7.4-latest bei Mittwald gehostet.  
Plugins sind und Theme sind up-to date. Auch das Deaktivieren von Plugins habe ich versucht.  
Nach dem Update sind Front- und Backend weiterhin nicht erreichbar.

---

<div class="post-metadata">

**Author:** ![M.Hanske](https://avatars.discourse-cdn.com/v4/letter/m/5e9695/32.png) [@M.Hanske](https://forum.shopware.com/u/M.Hanske)\
**Post date:** [11. August 2021 um 08:04 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/14 "2021-08-11T08:04:00Z")

</div>

Bei uns haut ein Cronjob ähnliche Fehler. Kann es evtl. auch an der Kombi PP Version → 5.7.2 liegen?#

Processing Amazon Pay Transaktionen Processing Shopmeister Zalando Integration: Auto Reactivate Cronjob Synchronisation Processing Shopmeister Zalando Integration: Price Report Synchronisation Processing Shopmeister Zalando Integration: Order Synchronisation IMPORTED 1 orders  
**Fatal error** : Uncaught Error: Call to undefined method Shopware\Components\Logger::addError() in /var/www/clients/client244/web647/web/custom/plugins/ShopmasterZalandoIntegration/Components/CronJobsHelpers/Orders.php:406 Stack trace: #0 /var/www/clients/client244/web647/web/custom/plugins/ShopmasterZalandoIntegration/Components/CronJobsHelpers/Orders.php(159): ShopmasterZalandoIntegration\Components\CronJobsHelpers\Orders-\>updateZTrackingNumbers() #1 /var/www/clients/client244/web647/web/custom/plugins/ShopmasterZalandoIntegration/Subscriber/Cronjob.php(555): ShopmasterZalandoIntegration\Components\CronJobsHelpers\Orders-\>updateImportedOrders() #2 /var/www/clients/client244/web647/web/engine/Library/Enlight/Event/Handler/Default.php(87): ShopmasterZalandoIntegration\Subscriber\Cronjob-\>onOrderSynchronisation() #3 /var/www/clients/client244/web647/web/engine/Library/Enlight/Event/EventManager.php(251): Enlight\_Event\_Handler\_Default-\>execute() #4 /var/www/clients/client244/web647/web/engine/Library/Enlight/Components/Cron/Ma in **/var/www/clients/client244/web647/web/custom/plugins/ShopmasterZalandoIntegration/Components/CronJobsHelpers/Orders.php** on line **406**

---

<div class="post-metadata">

**Author:** ![Chris.L](https://avatars.discourse-cdn.com/v4/letter/c/5f9b8f/32.png) [@Chris.L](https://forum.shopware.com/u/Chris.L)\
**Post date:** [12. August 2021 um 07:21 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/15 "2021-08-12T07:21:48Z")

</div>

Hallo. Wie ist denn hier der Stand zu der Sache? Ich hab seit Wochen das selbe Problem das nach dem aufräumen das Backend/Frontend nicht mehr erreichbar ist. Alle Plugins aktuell und auch sonst alles grün. Konnte jemand zwischenzeitlich den Grund finden?

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [12. August 2021 um 09:22 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/16 "2021-08-12T09:22:32Z")

</div>

Hallo,

lt. Fehlermeldung gibt es ein Problem mit dem Shopmaster Zalando Plugin - evtl. ist dieses nicht mit Shopware 5.7.2 kompatibel.

Viele Grüße

---

<div class="post-metadata">

**Author:** ![Chris.L](https://avatars.discourse-cdn.com/v4/letter/c/5f9b8f/32.png) [@Chris.L](https://forum.shopware.com/u/Chris.L)\
**Post date:** [12. August 2021 um 09:37 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/17 "2021-08-12T09:37:24Z")

</div>

Das Zalando Plugin nutze ich nicht. Das würde ich also zumindest in meinem Fall ausschließen.

Ich tippe momentan darauf das es irgendwas mit PHP zu tun hat.

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [12. August 2021 um 09:40 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/18 "2021-08-12T09:40:49Z")

</div>

Ich denke auch eher, dass @M.Hanske selbst auf der Fehlersuche ist, da er der Entwickler des Zalando Plugins ist. 😉

---

<div class="post-metadata">

**Author:** ![M.Hanske](https://avatars.discourse-cdn.com/v4/letter/m/5e9695/32.png) [@M.Hanske](https://forum.shopware.com/u/M.Hanske)\
**Post date:** [12. August 2021 um 09:58 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/19 "2021-08-12T09:58:41Z")

</div>

Das stimmt 😉 Ich hatte zuerst die Vermutung, das es auch mit einem größeren PHP Sprung beim  
Hoster zu tun hatte, aber die hat sich schnell verflüchtigt.

Lösung:

- Unsere Logger Integration wahr fehlerhaft/veraltet
- Wir hatten einen Service in der services.xml nicht `public="true"` gestellt

alt:

```auto

// $this->logger = Shopware()->Container()->get('pluginlogger');

```

neu:

```auto
$this->logger = $logger;

```

Vielleicht hilft es ja Jemandem.

---

<div class="post-metadata">

**Author:** ![M.Hanske](https://avatars.discourse-cdn.com/v4/letter/m/5e9695/32.png) [@M.Hanske](https://forum.shopware.com/u/M.Hanske)\
**Post date:** [12. August 2021 um 10:01 UTC](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780/20 "2021-08-12T10:01:06Z")

</div>

> [@msg20](#):
>
> OmecoSaveBasketCustomer

…weist ja auf dein betreffendes Plugin hin.

Ich würde alle Plugins deaktivieren und schauen ob es dann läuft. Ich habe bei manchen Shops eine ganze Reihe Plugins rausnehmen müssen, die so ähnliche Probleme erzeugt haben.

[Nächste Seite](https://forum.shopware.com/t/update-5-7-2-fatal-error/88780.md?page=2)
