# Update 5.5.10 -\> 5.6 MySql Probleme

**URL:** <https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317>\
**Category:** Installation/Einstieg\
**Created:** [26. August 2019 um 10:08 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317 "2019-08-26T10:08:47Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [26. August 2019 um 10:08 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/1 "2019-08-26T10:08:47Z")

</div>

Hallo Leute.

ich bin gerade dabei das angebotene Update/Upgrade auf V5.6 durchzuführen. Provider 1&1 IONOS. Das direkte Update ist voll in die Hose gegangen. Ich habe zuvor alle Plugins geprüft und die 5.5’er Datenbank zur 5.7’er migiert. PHP7.3 läuft problemlos, auch zurzeit mit der V5.5.10.

Was ist passiert. Bei der Migation zu MySql 5.7 habe ich locker den doppelten Datenverbrauch im Vergleich zur 5.5.

db795686861&nbsp; shopware MySql5.5&nbsp; -&nbsp; 37 von 1024 MB verwendet  
dbs151317&nbsp;&nbsp; shopware MySql5.7&nbsp; -&nbsp; 68 von 1000 MB verwendet

Das verstehe ich nicht. Wenn ich nun die V5.6 oder die V5.5 mit der MySql 5.7 laufen lasse, werden die Seiten kpl. zerstört oder sind weiss. Admin Login erscheint, nach dem Login ist Banane. Schalte ich die V5.5 auf die MySql5.5 um dann ist alles okay.

Was muss ich bei der Migration (via 1&1 phpMyAdmin) beachten? Ich habe die Datenbank exportiert und so wieder in eine Neue Importiert. Oder handelt es sich um die neue Shopware V5.6 um einen gnadenlosen Speicherfresser?!

Danke für Tipps und Gruß!

&nbsp;

---

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [29. August 2019 um 10:02 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/2 "2019-08-29T10:02:50Z")

</div>

Hi,

kann mir niemand bei meinem Problem helfen?

&nbsp;

Gruß!

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [29. August 2019 um 11:05 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/3 "2019-08-29T11:05:24Z")

</div>

1&1 ist der schlechteste Ort für einen Shopware Shop - nur meine persönliche Meinung.

Wenn Seiten weiß bleiben, dann liegt in der Regel auch ein Fehler vor. Nun ja, dazu müsstest allerdings Du mal in deine Logs schauen (Shopware Log, Server Log). Diesen Part musst du schon selber machen. Wenn dort Fehler stehen, dann hier im Forum posten (bitte dazu die Code-Funktion benutzen). Dann können wir ggf. auch helfen.

---

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [30. August 2019 um 06:13 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/4 "2019-08-30T06:13:26Z")

</div>

Jo, habe gestern noch einmal geprüft. Fehlermeldungen (gekürzt):

```
An exception occurred while executing 'INSERT IGNORE INTO s_search_index (keywordID, elementID, fieldID) SELECT sk.id as keywordID, 1360 as elementID, 3 as fieldID FROM s_search_keywords sk WHERE 

```

und am Ende:

```
: SQLSTATE[HY000]: General error: 1436 Thread stack overrun: 246144 bytes used of a 262144 byte stack, and 16000 bytes needed. Use 'mysqld --thread_stack=#' to specify a bigger stack. in vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php on line 131

```

Boh, denke das die neue Datenbank zuviel Recourcen verbraucht. Habe gestern 1+1 drauf angesetzt. Die prüfen das. Der Shop läuft ja ohne Probleme mit der 5.5’er Datenbank. Ist doch auch komisch dass die 5.7’er nach dem Import auf das doppelte angewachsen ist. Erschließt sich mir nicht…

&nbsp;

Danke und Gruß!

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [30. August 2019 um 06:22 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/5 "2019-08-30T06:22:07Z")

</div>

Hm, also ich kann dies nicht bestätigen. Muss vermutlich direkt mit 1&1 zusammen hängen. Meine Test-Datenbank war vor dem Update bei ca. 20MB. Nach dem Update auf SW 5.6 aber nicht sonderlich größer geworden. In diesem Falle hätte ich mir die Daband-Tabellen mal näher angeschaut. Entweder berechnet 1&1 falsch oder an den Tabellen stimmt etwas nicht.

---

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [30. August 2019 um 09:22 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/6 "2019-08-30T09:22:34Z")

</div>

Okay… ich will mal abwarten, was die finden. Das sie was machen das kann ich erkennen, die 5.7’er Datenbank ist neu.

Melde mich, Gruß!

---

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [31. August 2019 um 08:29 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/7 "2019-08-31T08:29:49Z")

</div>

So…

die Jungs von 1und1 meinen, dass sie hoster und keine Scripter sind und somit den Fehler nicht beheben können. Ich soll mich an eine Community wenden. Toll!

Gestern hate ich ein paar neue Datenbanken erstellt und die Daten instelliert. Bei der 3. Datenbank lief die Seite bis heute morgen einwandfrei! Ich konnte es nicht glauben, habe die caches gelöscht und viele Anforderungen gemacht. Sie lief.

Heute Morgen das gleiche Problem mit dem Stack. Fehlermeldung wie gehabt.

Was ist das nur für ein Mist? Wer hat da echt Ahnung und kann mir Tipps zur Fehlersuche geben? Ich bin kein Super Profi aber erfahren und kann einiges selbst erarbeiten.

Danke und Gruß!!

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [31. August 2019 um 08:50 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/8 "2019-08-31T08:50:19Z")

</div>

Stell mal den Aufbau des Suchindexes von Live auf Cronjob um im Performance Modul.

---

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [2. September 2019 um 09:48 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/9 "2019-09-02T09:48:35Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> Stell mal den Aufbau des Suchindexes von Live auf Cronjob um im Performance Modul.

Okay, habe ich gemacht. Caches geleert und die config.php umgestellt (Kopie für SQL5.7). Shop läuft. Lasse den noch etwas online, dann prüfe ich nochmal.

Ich habe deinen Tippp hoffentlich kapiert! Habe vor Tagen an dieser Stelle nachgedacht, bin aber irgendwie nicht mit klargekommen.  
Was genau ist NUN der Unterschied? Muss ich das jetzt so verstehen, dass der Indexaufbau, der ja wohl immer abbricht und diese Fehler aufzeigt, Schuld daran ist? Der bei jedem Seitenaufruf (Startseite) ausgelöst wird? Deshalb dann bei der MySql 5.7 der Stack nicht ausreicht?

Jetzt durch die Umstellung ein cronjob dafür zuständig ist? Der dann diese Probleme nicht aufzeigt?

So verstehe ich Deinen Tipp jetzt einfach mal. Danke für die Erklärung, möchte das ja auch verstehen…

Gruß!

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [2. September 2019 um 09:54 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/10 "2019-09-02T09:54:14Z")

</div>

Ob der Cronjob das Problem nicht hat, müsstest du nachschauen. Dafür findest du hier eine Anleitung wie du Cronjobs einrichtest:&nbsp;[Shopware 5 - Einstellungen - System: Cronjobs](https://docs.shopware.com/de/shopware-5-de/einstellungen/system-cronjobs)

Live heißt ja, dass bei jedem Seitenaufruf etwas gemacht wird. Das bedeutet natürlich auch, dass man ggf. andere Scriptlaufzeiten usw. hat. Das ist erstmal eine schnelle Lösung, damit der Seite nichts passiert, heißt aber nicht, dass der Suchindex dadurch automatisch wieder funktioniert.

---

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [2. September 2019 um 10:52 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/11 "2019-09-02T10:52:56Z")

</div>

Hmm…

kein Glück! Ging etwa eine Stunde gut, nun wieder das Gleiche:

```
SQLSTATE[HY000]: General error: 1436 Thread stack overrun: 246144 bytes used of a 262144 byte stack, and 16000 bytes needed. Use 'mysqld --thread_stack=#' to specify a bigger stack. in vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php on line 131

```

Oha!

Danke und Gruß!

---

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [4. September 2019 um 06:18 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/12 "2019-09-04T06:18:05Z")

</div>

Also,

der Support von 1&1 sagt aus, dass es nur noch an den Scripten der Shopware Software liegen kann. Ein- Umstellungen ihrerseits können sie nicht vornehmen, das sonst auch andere Nutzer betroffen wären, bei denen dann andere Probleme auftreten könnten. Kann ich verstehen.

**Mal die grundsätzliche Frage:** Arbeitet Shopware 5.5.10 mit MySQL 5.7? Oder nicht?

Ich traue mich nicht das Update vorzunehmen. Backups hin und her ist via ftp sehr aufwändig.

Danke udn Gruß!

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [4. September 2019 um 06:27 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/13 "2019-09-04T06:27:42Z")

</div>

Schau mal hier:

> **[Ups! Ein Fehler ist aufgetreten!](https://forum.shopware.com/discussion/45842/ups-ein-fehler-ist-aufgetreten)**
>
> Hallo  wir verwenden Shopware 5.2.21 Im Frontend erhalte ich folgende fehlermeldung nachdem ich den Cache geleert habe und im Frontend auf eine Kategorie klicke. Was könnte die fehlermeldug auslösen? Kann mir jemand weiterhelfen?   ...

&nbsp;

---

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [4. September 2019 um 10:56 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/14 "2019-09-04T10:56:50Z")

</div>

Diesen tread habe ich schon am Anfang gefunden und durchgearbeitet… Kein Erfolg.&nbsp; ☹

&nbsp;

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [4. September 2019 um 11:33 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/15 "2019-09-04T11:33:18Z")

</div>

Also wir haben einige SW Shops schon für Kunden umgesetzt und hosten auch selber, aber diese Fehlermeldung ist mir gänzlich unbekannt. Für mich sieht das nach einer mangelhaften Einstellung bei MySQL aus, was in diesem Falle beim Hoster liegt. Wie ich schon erwähnte „1&1 ist der schlechteste Ort für einen Shopware Shop“.

Hierzu muss man ggf. in der Datei /etc/my.cnf den (MySQL Config auf dem Server) den Wert „thread\_stack“ anpassen bzw. eintragen  
=\> z.B. thread\_stack = 256K

Wenn man nur ein normales Webhosting hat, dann ist das für Shopware ggf. nicht geeignet.

---

<div class="post-metadata">

**Author:** ![raymond](https://avatars.discourse-cdn.com/v4/letter/r/c57346/32.png) [@raymond](https://forum.shopware.com/u/raymond)\
**Post date:** [4. Oktober 2019 um 09:23 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/16 "2019-10-04T09:23:09Z")

</div>

Gehe zu einem Shopware Hoster (siehe&nbsp;[https://www.shopware.com/de/partner/list/group/hosting](https://www.shopware.com/de/partner/list/group/hosting)). Da tritt hoffentlich nicht das Problem auf oder der Hoster ist eher an einer Lösung interessiert.

---

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [15. Januar 2020 um 13:07 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/17 "2020-01-15T13:07:51Z")

</div>

Hallo,

mal ein kurzer Zwischenstand. Seit Monaten habe ich heute die alte 5.7’er Datenbank gelöscht und erneuert, ex- und importiert. Das alles nun OHNE FEHLER. Obwohl die Datenbank locker auf das Doppelte Volumen gewachsen ist. Dann habe ich die config.php umgeswitcht und siehe da, läuft schon einige Stunden ohne Sorgen. Ich schaue mal ein paar Tage dann mache ich das Shopware-Upgrade…

Gruß!

---

<div class="post-metadata">

**Author:** ![poi](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@poi](https://forum.shopware.com/u/poi)\
**Post date:** [20. Januar 2020 um 07:12 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/18 "2020-01-20T07:12:28Z")

</div>

Hi,

eine knappe Woche nach dem Upgrade: Läuft!

Also hat 1und1 Sonos da echt Probleme gehabt, es lag da nicht an der Installation. Die Datenbank 5.7 war bei denen wohl fehlkonfiguriert…

Gruß!

---

<div class="post-metadata">

**Author:** ![gthom2020](https://avatars.discourse-cdn.com/v4/letter/g/cab0a1/32.png) [@gthom2020](https://forum.shopware.com/u/gthom2020)\
**Post date:** [14. März 2021 um 17:14 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/19 "2021-03-14T17:14:56Z")

</div>

Hi Poi,  
Wie haben sie das problem gelöst?? wir haben genau die gleiche Probleme, wurde gern weg vom Ionos leider geht zurzeit nicht.

Hilfe!!  
Danke

---

<div class="post-metadata">

**Author:** ![shyim](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/shyim/32/7681_2.png) [@shyim](https://forum.shopware.com/u/shyim)\
**Post date:** [15. März 2021 um 07:35 UTC](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317/20 "2021-03-15T07:35:17Z")

</div>

Das sollte es beheben [Suche verursacht immer SQL Fehler - #4 von shyim](https://forum.shopware.com/t/suche-verursacht-immer-sql-fehler/59806/4)

[Nächste Seite](https://forum.shopware.com/t/update-5-5-10-5-6-mysql-probleme/61317.md?page=2)
