# Update 5.3.7 auf 5.4.3 - Fehler Datenbankmigration

**URL:** https://forum.shopware.com/t/update-5-3-7-auf-5-4-3-fehler-datenbankmigration/53002
**Category:** Administration
**Created:** [18. Mai 2018 um 22:36 UTC](https://forum.shopware.com/t/update-5-3-7-auf-5-4-3-fehler-datenbankmigration/53002 "2018-05-18T22:36:54Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![verpacken24](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/verpacken24/32/16229_2.png) [@verpacken24](https://forum.shopware.com/u/verpacken24)
#### Post date: [18. Mai 2018 um 22:36 UTC](https://forum.shopware.com/t/update-5-3-7-auf-5-4-3-fehler-datenbankmigration/53002/1 "2018-05-18T22:36:54Z")

</div>

Hallo Zusammen,

ich habe jetzt schon mehrmals versucht meinen Shop von der Version 5.3.7 auf die Version 5.4.3 zu updaten.

Bei der Datenbank Migration 2/3 bleibt das Update eine ganze Zeit stehen:

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/1/1c5953f81186e35924e51edded8065a1b89ee821.png)

&nbsp;

Danach kommt dann diese Meldung:

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/6/6c25da52fe35108e6761b1cfdca7a379c9454ac3.png)

&nbsp;

Im error log finde ich einzig dazu folgende Fehlermeldung:

```
FastCGI: incomplete headers (0 byte) received from server "/etc/httpd/fastcgi/php-fcgi-starter", refer https://domain.com/pfad/recovery/update/index.php/dbmigration

```

&nbsp;

Ich kann mir nicht erklären warum es nicht funktioniert. Bin für jede Hilfe dankbar.

&nbsp;

Was mich einzig wundert, das dort [https://domain.com/pfad/recovery/update/index.php/dbmigration](https://domain.com/pfad/recovery/update/index.php/dbmigration)&nbsp; ohne www. auf gerufen wird.

Ich habe im root Verzeichnis eine .htaccess Datei die per RewriteRule immer auf die Domain inkl. www. umleitet. Kann es daran liegen?

Freue mich auf Eure Hilfe.

&nbsp;

Gruß Daniel

---

<div class="post-metadata">

### Author: ![verpacken24](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/verpacken24/32/16229_2.png) [@verpacken24](https://forum.shopware.com/u/verpacken24)
#### Post date: [21. Mai 2018 um 21:49 UTC](https://forum.shopware.com/t/update-5-3-7-auf-5-4-3-fehler-datenbankmigration/53002/2 "2018-05-21T21:49:12Z")

</div>

Ich habe das Update jetzt noch zwei Mal probiert.

Jeweils bei der Datenbank Migration 2/3 bleibt das Update hängen.

Fehler  
URL: applyMigrations?offset=7&total=20

Was kann ich tun? Komme leider nicht weiter!

Viele Grüße

Daniel

---

<div class="post-metadata">

### Author: ![SB1](https://avatars.discourse-cdn.com/v4/letter/s/0ea827/32.png) [@SB1](https://forum.shopware.com/u/SB1)
#### Post date: [21. Mai 2018 um 21:57 UTC](https://forum.shopware.com/t/update-5-3-7-auf-5-4-3-fehler-datenbankmigration/53002/3 "2018-05-21T21:57:13Z")

</div>

na dann schau mal in die logfiles - upgrade nicht in einer testumgebung (so wie empfohlen) getestet ?

---

<div class="post-metadata">

### Author: ![verpacken24](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/verpacken24/32/16229_2.png) [@verpacken24](https://forum.shopware.com/u/verpacken24)
#### Post date: [21. Mai 2018 um 22:08 UTC](https://forum.shopware.com/t/update-5-3-7-auf-5-4-3-fehler-datenbankmigration/53002/4 "2018-05-21T22:08:34Z")

</div>

Update habe ich in einem separatem Unterordner in einer Test-Installation gemacht. So wie immer bisher.

Ich habe jeweils eine neue Test-Installation erstellt, aber bleibt immer bei dem Punkt hängen.

In meinen Logfiles steht lediglich:

```
FastCGI: incomplete headers (0 byte) received from server "/etc/httpd/fastcgi/php-fcgi-starter", refer https://domain.com/pfad/recovery/update/index.php/dbmigration

```

&nbsp;

Gruß Daniel

---

<div class="post-metadata">

### Author: ![SB1](https://avatars.discourse-cdn.com/v4/letter/s/0ea827/32.png) [@SB1](https://forum.shopware.com/u/SB1)
#### Post date: [21. Mai 2018 um 22:11 UTC](https://forum.shopware.com/t/update-5-3-7-auf-5-4-3-fehler-datenbankmigration/53002/5 "2018-05-21T22:11:31Z")

</div>

… dann hast du offenbar einen fehler in deiner datenbank - ursache könnte ein nicht kompatibles plugiin (häufig von drittanbietern) sein. im zweifel backup einspielen, testumgebung einrichten …
