# Up Date Plugin

**URL:** <https://forum.shopware.com/t/up-date-plugin/4550>\
**Category:** Shopware 3.5\
**Tags:** general\
**Created:** [4. Oktober 2011 um 06:34 UTC](https://forum.shopware.com/t/up-date-plugin/4550 "2011-10-04T06:34:25Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Bibeno](https://avatars.discourse-cdn.com/v4/letter/b/13edae/32.png) [@Bibeno](https://forum.shopware.com/u/Bibeno)\
**Post date:** [4. Oktober 2011 um 06:34 UTC](https://forum.shopware.com/t/up-date-plugin/4550/1 "2011-10-04T06:34:25Z")

</div>

Guten morgen, als ich das UpDate Plugin soeben manuell installiert habe und es im Backend aufrufen wollte, sprang mir gleich folgende Fehler ins Gesicht: [quote]Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. simplexml\_load\_file() [function.simplexml-load-file]: URL file-access is disabled in the server configuration simplexml\_load\_file([https://update.shopware.de/version.php? … nahrung.de](https://update.shopware.de/version.php?version=3.5.4&revision=5922&stage=1.3.1&host=www.bibeno-artgerechte-tiernahrung.de)) [function.simplexml-load-file]: failed to open stream: no suitable wrapper could be found simplexml\_load\_file() [function.simplexml-load-file]: I/O warning : failed to load external entity „[https://update.shopware.de/version.php?version=3.5.4&revision=5922&stage=1.3.1&host=www.bibeno-artgerechte-tiernahrung.de](https://update.shopware.de/version.php?version=3.5.4&revision=5922&stage=1.3.1&host=www.bibeno-artgerechte-tiernahrung.de)“ in Vendor/Zend/library/Zend/Config/Xml.php on line 98 Stack trace: #0 Shopware/Plugins/Community/Backend/SwagUpdate/Controllers/Update.php(89): Zend\_Config\_Xml-\>\_\_construct(‚[https://update](https://update)…‘, ‚update‘) #1 Shopware/Plugins/Community/Backend/SwagUpdate/Controllers/Update.php(55): Shopware\_Controllers\_Backend\_Update-\>VersionConfig() #2 Enlight/Controller/Action.php(70): Shopware\_Controllers\_Backend\_Update-\>indexAction() #3 Enlight/Controller/Dispatcher/DispatcherDefault.php(329): Enlight\_Controller\_Action-\>dispatch(‚indexAction‘) #4 Enlight/Controller/Front.php(99): Enlight\_Controller\_Dispatcher\_DispatcherDefault-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #5 Shopware/Bootstrap.php(33): Enlight\_Controller\_Front-\>dispatch() #6 Enlight/Application.php(86): Shopware\_Bootstrap-\>run() #7 shopware.php(7): Enlight\_Application-\>run() #8 {main} [/quote] Ich habe es in Binaermodus hochgeladen und auch den Cache geleert.

---

<div class="post-metadata">

**Author:** ![Bibeno](https://avatars.discourse-cdn.com/v4/letter/b/13edae/32.png) [@Bibeno](https://forum.shopware.com/u/Bibeno)\
**Post date:** [4. Oktober 2011 um 12:46 UTC](https://forum.shopware.com/t/up-date-plugin/4550/2 "2011-10-04T12:46:52Z")

</div>

Ohem :shopware: ich komm da echt nicht weiter, oder ich muss es halt manuell machen und auf den Updater verzichten

---

<div class="post-metadata">

**Author:** ![Bibeno](https://avatars.discourse-cdn.com/v4/letter/b/13edae/32.png) [@Bibeno](https://forum.shopware.com/u/Bibeno)\
**Post date:** [17. Oktober 2011 um 12:30 UTC](https://forum.shopware.com/t/up-date-plugin/4550/3 "2011-10-17T12:30:14Z")

</div>

Oehm, ich warte immer noch auf irgendeine Reaktion, denn der Fehler ist immer noch und ich kann das Plugin nicht nutzen. schade eigentlich

---

<div class="post-metadata">

**Author:** ![avenger](https://avatars.discourse-cdn.com/v4/letter/a/9de0a6/32.png) [@avenger](https://forum.shopware.com/u/avenger)\
**Post date:** [17. Oktober 2011 um 13:29 UTC](https://forum.shopware.com/t/up-date-plugin/4550/4 "2011-10-17T13:29:54Z")

</div>

[quote=“Bibeno”]Guten morgen, als ich das UpDate Plugin soeben manuell installiert habe und es im Backend aufrufen wollte, sprang mir gleich folgende Fehler ins Gesicht: [quote]Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. simplexml\_load\_file() [function.simplexml-load-file]: URL file-access is disabled in the server configuration simplexml\_load\_file([https://update.shopware.de/version.php? … nahrung.de](https://update.shopware.de/version.php?version=3.5.4&revision=5922&stage=1.3.1&host=www.bibeno-artgerechte-tiernahrung.de)) [/quote][/quote] Dein Server ist restriktiv konfiguriert, so dass Zugriffe auf entfernte Serverdaten bei den PHP-Zugriffsfunktionben nicht möglich sind… Das ist ein Problem Deines Providers, der soll das mal freischalten.

---

<div class="post-metadata">

**Author:** ![Bibeno](https://avatars.discourse-cdn.com/v4/letter/b/13edae/32.png) [@Bibeno](https://forum.shopware.com/u/Bibeno)\
**Post date:** [17. Oktober 2011 um 13:32 UTC](https://forum.shopware.com/t/up-date-plugin/4550/5 "2011-10-17T13:32:15Z")

</div>

Danke, das wusste ich nicht. Ich werde da gleich mal nachhacken. Vielen Dank fuer diese Info

---

<div class="post-metadata">

**Author:** ![andreas](https://avatars.discourse-cdn.com/v4/letter/a/ee7513/32.png) [@andreas](https://forum.shopware.com/u/andreas)\
**Post date:** [26. Oktober 2011 um 13:57 UTC](https://forum.shopware.com/t/up-date-plugin/4550/6 "2011-10-26T13:57:18Z")

</div>

Seid gegrüßt. Ich möchte wegen der hoffentlichen Kleinigkeit nicht extra ein neues Thema aufmachen. Das Update Plugin gibt mir am Ende des Updates eine Fehlermeldung „ZIP Erweiterung fehlt“ aus. Ich meine irgendwann schon einmal hier was darüber gelesen zu haben, finde aber nichts. Hat jemand eine Idee, woran diese Fehlermeldung liegt? Danke.

---

<div class="post-metadata">

**Author:** ![Sammy123](https://avatars.discourse-cdn.com/v4/letter/s/76d3ee/32.png) [@Sammy123](https://forum.shopware.com/u/Sammy123)\
**Post date:** [26. Oktober 2011 um 14:24 UTC](https://forum.shopware.com/t/up-date-plugin/4550/7 "2011-10-26T14:24:55Z")

</div>

Ebenfalls den Hoster kontaktieren 🙂

---

<div class="post-metadata">

**Author:** ![andreas](https://avatars.discourse-cdn.com/v4/letter/a/ee7513/32.png) [@andreas](https://forum.shopware.com/u/andreas)\
**Post date:** [26. Oktober 2011 um 14:47 UTC](https://forum.shopware.com/t/up-date-plugin/4550/8 "2011-10-26T14:47:07Z")

</div>

Danke. Es ist Domainfactory. Die sagen zwar, das sollte klappen, aber es will sich wohl jemand alles noch mal genauer anschauen. Ich werde das Ergebnis posten. Gruß Andreas

---

<div class="post-metadata">

**Author:** ![andreas](https://avatars.discourse-cdn.com/v4/letter/a/ee7513/32.png) [@andreas](https://forum.shopware.com/u/andreas)\
**Post date:** [26. Oktober 2011 um 15:32 UTC](https://forum.shopware.com/t/up-date-plugin/4550/9 "2011-10-26T15:32:53Z")

</div>

Das war die Lösung: [quote]Wir haben Ihre php.ini überprüft und konnten feststellen, dass die zip-Funktionalität nicht aktiviert ist. Um die Zip-Funktionalität zu aktivieren ist es erforderlich, in der php.ini für Ihre Domain folgenden Eintrag einzutragen: extension = zip.so Zusätzlich dazu ist es auch notwendig, das extension-Verzeichnis in der Variable “extension\_dir” mit anzugeben, damit die Extension auch gefunden wird. Für die PHP-Version 5.2 STABLE wäre dies folgendes Verzeichnis: /usr/local/lib/php\_modules/5-STABLE Für die STABLE-Version von PHP 5.3 wäre es folgendes Verzeichnis: /usr/local/lib/php\_modules/5-53STABLE/ Wenn Sie diese Einträge entsprechend Ihrer PHP-Version in die php.ini-Datei eingetragen haben wird die Extension für Sie verfügbar sein. Bei Rückfragen stehen wir Ihnen selbstverständlich jederzeit gern zur Verfügung. Freundliche Grüße[/quote] Ich kann nur sagen Danke an Domainfactory, die sehr schnell antworteten und es sogar auf meine Bitte hin einstellten. Andreas
