# Unterseiten öffnen sich nicht....

**URL:** <https://forum.shopware.com/t/unterseiten-offnen-sich-nicht/53837>\
**Category:** Installation/Einstieg\
**Created:** [3. Juli 2018 um 09:33 UTC](https://forum.shopware.com/t/unterseiten-offnen-sich-nicht/53837 "2018-07-03T09:33:21Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![schotschen](https://avatars.discourse-cdn.com/v4/letter/s/85e7bf/32.png) [@schotschen](https://forum.shopware.com/u/schotschen)\
**Post date:** [3. Juli 2018 um 09:33 UTC](https://forum.shopware.com/t/unterseiten-offnen-sich-nicht/53837/1 "2018-07-03T09:33:21Z")

</div>

**Hallo Freunde des online Business.**

**Nun ist es auch bei mir soweit. Ich versuche mich an Shopware.&nbsp;  
Natürlich habe ich gleich das erste Problem. Nach der installation funktioniert die Haupseite des Shops und das Backend.  
Nur leider sobald ich im Frontend einen Link anklicke bekomme ich diese Fehlermeldung:**

Internal Server Error  
The server encountered an internal error or misconfiguration and was unable to complete your request.  
Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.  
More information about this error may be available in the server error log.  
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

**Es scheint mir als hätte ich einen Rewrite Fehler in der .htaccess. Finde diesen allerdings nicht.**

**Gehostet wird bei 1+1 was anscheinen Problematischer sein soll in verbindung mit Shopware.**

&nbsp;

**Ich habe meine Datei mal angehängt:**

RewriteEngine on

# RewriteBase recovery/update/.htaccess

# RewriteBase recovery/install/.htaccess

# Https config for the backend

#RewriteCond %{HTTPS} !=on  
#RewriteRule backend/(.\*) https://%{HTTP\_HOST}%{REQUEST\_URI} [L,R=301]

RewriteRule /shopware.php/shopware.dll shopware.php  
RewriteRule /shopware.php/files/documents/.\* engine [NC,L]  
RewriteRule /shopware.php/backend/media/(.\*) media/$1 [NC,L]

RewriteCond %{REQUEST\_URI} !(/(engine|files|templates|themes|web)/)  
RewriteCond %{REQUEST\_URI} !(/media/(archive|banner|image|music|pdf|unknown|video)/)  
RewriteCond %{REQUEST\_FILENAME} !-f  
RewriteCond %{REQUEST\_FILENAME} !-d  
RewriteRule ^(.\*)$ shopware.php [PT,L,QSA]

# Fix missing authorization-header on fast\_cgi installations

RewriteRule .\* - [E=HTTP\_AUTHORIZATION:%{HTTP:Authorization},L]

# Restrict access to VCS directories  
  
RedirectMatch 404 /\.(svn|git|hg|bzr|cvs)(/|$)

&nbsp; &nbsp; # Restrict access to root folder files  
&nbsp; &nbsp; RedirectMatch 404 /(autoload.php|composer.(json|lock|phar)|README.md|UPGRADE-(.\*).md|CONTRIBUTING.md|eula.\*.txt|.gitignore|.\*.dist|.env.\*)$

&nbsp; &nbsp; # Restrict access to shop configs files  
&nbsp; &nbsp; RedirectMatch 404 /(web/cache/(config\_\d+.json|all.less))$

&nbsp; &nbsp; # Restrict access to theme configurations  
&nbsp; &nbsp; RedirectMatch 404 /themes/(.\*)(.\*.lock|package.json|.gitignore|Gruntfile.js|all.less|node\_modules/.\*)$

# Staging environment

#SetEnvIf Host „staging.test.shopware.in“ SHOPWARE\_ENV=staging

# Development environment

#SetEnvIf Host „dev.shopware.in“ SHOPWARE\_ENV=dev  
#SetEnv SHOPWARE\_ENV dev

DirectoryIndex index.html  
DirectoryIndex index.php  
DirectoryIndex shopware.php

# Disables download of configuration

# Deny all requests from Apache 2.4+.  
  
  
  
Require all denied

&nbsp; &nbsp; # Deny all requests from Apache 2.0-2.2.  
&nbsp; &nbsp;   
  
Deny from all

# Enable gzip compression

AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json application/font-woff application/font-woff2 image/svg+xml

ExpiresActive on  
  
ExpiresDefault „access plus 1 month“

&nbsp; &nbsp;   
  
Header append Cache-Control „public“  
  
Header unset ETag

&nbsp; &nbsp; FileETag None

# Match generated files like:

# 1429684458\_t22\_s1.css

# 1429684458\_t22\_s1.js

Header set Cache-Control „max-age=31536000, public“

&nbsp; &nbsp;   
  
ExpiresActive on  
  
ExpiresDefault „access plus 1 year“

# Disables auto directory index

Options -Indexes

Options -MultiViews

# php\_value memory\_limit 1024M

# php\_value max\_execution\_time 120

# php\_value upload\_max\_filesize 20M

php\_flag phar.readonly off  
  
php\_flag magic\_quotes\_gpc off  
  
php\_flag session.auto\_start off  
  
php\_flag suhosin.session.cryptua off  
  
php\_flag zend.ze1\_compatibility\_mode off  
  
php\_value always\_populate\_raw\_post\_data -1

# &nbsp; AddType x-mapp-php5 .php

# &nbsp; AddHandler x-mapp-php5 .php

Header append X-Frame-Options SAMEORIGIN

&nbsp;

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [3. Juli 2018 um 09:45 UTC](https://forum.shopware.com/t/unterseiten-offnen-sich-nicht/53837/2 "2018-07-03T09:45:27Z")

</div>

Gibt es eine Fehlermeldung im Error-Log der Website? Ein 500er-Fehler sollte dort auftauchen.

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![schotschen](https://avatars.discourse-cdn.com/v4/letter/s/85e7bf/32.png) [@schotschen](https://forum.shopware.com/u/schotschen)\
**Post date:** [3. Juli 2018 um 13:35 UTC](https://forum.shopware.com/t/unterseiten-offnen-sich-nicht/53837/3 "2018-07-03T13:35:51Z")

</div>

**Gelöst!**

**Für alle 1und1 Nutzer die Ähnlich Probleme haben:  
die htacess muss so beginnen:**

RewriteEngine on

&nbsp;RewriteBase /shopware  
&nbsp;RewriteBase /

**Dann klappt es auch bei 1+1!**

**Herzlichen Dank!**

---

<div class="post-metadata">

**Author:** ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)\
**Post date:** [14. Juli 2018 um 11:50 UTC](https://forum.shopware.com/t/unterseiten-offnen-sich-nicht/53837/4 "2018-07-14T11:50:24Z")

</div>

Hallo,

eine der beiden&nbsp;RewriteBase-Anweisungen genügt. Die zweite überschreibt ja die erste. Und nicht blind kopieren, sondern versuchen zu verstehen, was die Anweisung bedeutet. Eingetragen werden muss der relative Pfad zur Shopinstallation im Vergleich zum Domain-Root. Meist also / - aber nicht immer. Wenn der Shop in einem Unterordner&nbsp;installiert ist, muss dieses angegeben werden.
