# Unknown database type enum requested

**URL:** <https://forum.shopware.com/t/unknown-database-type-enum-requested/98651>\
**Category:** Administration\
**Created:** [21. Februar 2023 um 16:11 UTC](https://forum.shopware.com/t/unknown-database-type-enum-requested/98651 "2023-02-21T16:11:27Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![sunflower](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sunflower/32/8100_2.png) [@sunflower](https://forum.shopware.com/u/sunflower)\
**Post date:** [21. Februar 2023 um 16:11 UTC](https://forum.shopware.com/t/unknown-database-type-enum-requested/98651/1 "2023-02-21T16:11:27Z")

</div>

Hallo zusammen,

ich erhalte in einem Shop in der Konsole die Meldung:\_

> 16:03:03 CRITICAL [console] Error thrown while running command „dal:validate“. Message: „Unknown database type enum requested, Doctrine\DBAL\Platforms\MySQL80Platform may not support it.“ [„exception“ =\> Doctrine\DBAL\Exception^ { …},„command“ =\> „dal:validate“,„message“ =\> „Unknown database type enum requested, Doctrine\DBAL\Platforms\MySQL80Platform may not support it.“]
> 
> In AbstractPlatform.php line 454:
> 
> Unknown database type enum requested, Doctrine\DBAL\Platforms\MySQL80Platform may not support it.
> 
> dal:validate

Was sollen mir diese Worte sagen? 🤔

Möchte da ein Plugin einen falschen Datentyp nutzen?

Grüße  
sunflower

---

<div class="post-metadata">

**Author:** ![PatrickHoelscher](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/patrickhoelscher/32/21102_2.png) [@PatrickHoelscher](https://forum.shopware.com/u/PatrickHoelscher)\
**Post date:** [7. März 2023 um 10:32 UTC](https://forum.shopware.com/t/unknown-database-type-enum-requested/98651/2 "2023-03-07T10:32:57Z")

</div>

Hey @sunflower,

hab hierzu gerade ein ähnliches Support-ticket gehabt und die Ursache hierbei war die Pickware ERP Starter Erweiterung.  
Problem ist hierbei allerdings, dass der Fehler durch den Typen „enum“ ausgelöst wird. Heißt die Erweiterung muss komplett entfernt werden um den Fehler zu beheben, da sonst die Spalten weiterhin in der Datenbank sind.  
Muss in diesem Fall aber auch nicht Pickware ERP Starter sein. Am besten kannst du einmal schauen, welche Spalten den Typ „enum“ haben.  
Folgender SQL Befehl gibt dir diese Spalten aus:

```plaintext
select col.table_schema as database_name,
       col.table_name,
       col.ordinal_position as column_id,
       col.column_name,
       col.data_type,
       trim(leading 'enum' from col.column_type) as enum_values
from information_schema.columns col
join information_schema.tables tab on tab.table_schema = col.table_schema
                                   and tab.table_name = col.table_name
                                   and tab.table_type = 'BASE TABLE'
where col.data_type in ('enum')
      and col.table_schema not in ('information_schema', 'sys',
                                   'performance_schema', 'mysql')
     --and col.table_schema = 'database_name' -- put your database name here
order by col.table_schema,
         col.table_name,
         col.ordinal_position;

```

MfG  
Patrick

---

<div class="post-metadata">

**Author:** ![sunflower](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sunflower/32/8100_2.png) [@sunflower](https://forum.shopware.com/u/sunflower)\
**Post date:** [7. März 2023 um 15:05 UTC](https://forum.shopware.com/t/unknown-database-type-enum-requested/98651/3 "2023-03-07T15:05:08Z")

</div>

Hallo Patrick,

prima, danke für die Info.

Wer denkt sich denn so eine SQL-Anweisung aus? 😲

Grüße  
sunflower

---

<div class="post-metadata">

**Author:** ![great2gether](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/great2gether/32/12887_2.png) [@great2gether](https://forum.shopware.com/u/great2gether)\
**Post date:** [1. Juli 2025 um 00:13 UTC](https://forum.shopware.com/t/unknown-database-type-enum-requested/98651/4 "2025-07-01T00:13:11Z")

</div>

Danke für den Tipp!

Ich hatte nach Ausführung von `bin/console dal:validate` ebenfalls Fehler.

Zuerst den:

```auto
Data Abstraction Layer Validation
=================================

Checking for errors in entity definitions
=========================================

00:05:17 CRITICAL [console] Error thrown while running command "dal:validate". Message: "Unknown database type enum requested, Doctrine\DBAL\Platforms\MySQL80Platform may not support it." ["exception" => Doctrine\DBAL\Exception^ { …},"command" => "dal:validate","message" => "Unknown database type enum requested, Doctrine\DBAL\Platforms\MySQL80Platform may not support it."]

In AbstractPlatform.php line 452:
                                                                                                     
  Unknown database type enum requested, Doctrine\DBAL\Platforms\MySQL80Platform may not support it. 

```

über den ich zu diesem Beitrag gekommen bin. Und dann (eigentlich ohne etwas zu ändern) den:

```auto
Data Abstraction Layer Validation
=================================

Checking for errors in entity definitions
=========================================

00:15:10 CRITICAL [console] Error thrown while running command "dal:validate". Message: "Undefined constant Redgecko\Magnalister\Core\Content\Bundle\BundleCookieDefinition::ENTITY_NAME" ["exception" => Error { …},"command" => "dal:validate","message" => "Undefined constant Redgecko\Magnalister\Core\Content\Bundle\BundleCookieDefinition::ENTITY_NAME"]

In DefinitionValidator.php line 1028:
                                                                                                   
  Undefined constant Redgecko\Magnalister\Core\Content\Bundle\BundleCookieDefinition::ENTITY_NAME  

```

Ich musste es etwas anpassen damit es bei mir geklappt hat, mit der Version hat es bei mir in Shopware 6.6.6.1 funktioniert:

```auto
SELECT col.table_schema AS database_name,
       col.table_name,
       col.ordinal_position AS column_id,
       col.column_name,
       col.data_type,
       TRIM(LEADING 'enum' FROM col.column_type) AS enum_values
FROM information_schema.columns col
JOIN information_schema.tables tab 
  ON tab.table_schema = col.table_schema
 AND tab.table_name = col.table_name
 AND tab.table_type = 'BASE TABLE'
WHERE col.data_type IN ('enum')
  AND col.table_schema NOT IN ('information_schema', 'sys', 'performance_schema', 'mysql')
  -- and col.table_schema = 'database_name' -- Korrigierter Kommentar
ORDER BY col.table_schema,
         col.table_name,
         col.ordinal_position 
LIMIT 0, 25;

```

Das Problem lag am Magnalister Plugin in Version 3.2.96 und auch nach einem Update die aktuellste kompatible Version 3.3.06 wurde der gleiche Eintrag noch mit dem Befehl in phpmyadmin gefunden.

Nach dem ich das Magnalister Plugin deinstalliert habe, wurde ich nach dem selben Befehl zur Belohnung mit einer Liste von +400 Warnungen begrüßt:  
[https://codepen.io/great2gether/pen/WbvWJpm](https://codepen.io/great2gether/pen/WbvWJpm)

Sehr prickelnd 🙂
