# Umzug Shopware 6 - Datei Zugriffsrechte

**URL:** <https://forum.shopware.com/t/umzug-shopware-6-datei-zugriffsrechte/101486>\
**Category:** Shopware 6 (German)\
**Created:** [6. Oktober 2023 um 07:53 UTC](https://forum.shopware.com/t/umzug-shopware-6-datei-zugriffsrechte/101486 "2023-10-06T07:53:24Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![tony88](https://avatars.discourse-cdn.com/v4/letter/t/ebca7d/32.png) [@tony88](https://forum.shopware.com/u/tony88)\
**Post date:** [6. Oktober 2023 um 07:53 UTC](https://forum.shopware.com/t/umzug-shopware-6-datei-zugriffsrechte/101486/1 "2023-10-06T07:53:24Z")

</div>

Moin,

ich habe jetzt gefühlt alles mögliche im Forum und auf Google abgesucht und nichts zu diesem Thema gefunden. Einmal zu meiner Problematik: Ich möchte mein Shopware 6 System von meinem Privaten Testserver (IONOS/1und1) umziehen auf meinen Firmenserver. Mein Hauptproblem sind hier die „Datei Zugriffsrechte“.

Auf meinem IONOS Server hat mein System folgende Dateirechte:

- Ordner 705
- Dateien 666

Auf meinem Firmen Server bekomme ich dann ein 403 Permission Error. Also kurz gecheckt, welche Rechte korrekt sind. Also ändere ich Ordner zu 775 und Dateien zu 644. Dann funktioniert der Shop teilweise. Ich kann das Frontend aufrufen und das Backend. Wenn ich dann aber Änderungen vornehme wie zum Beispiel das Theme-Anpassungen mache, bekomme ich folgende Meldung:

-Failed to load resource: the server responded with a status of 500 (Internal Server Error)  
vendors-node.js?16965730962624918:2 PATCH [https://URL.de/api/\_action/theme/946ac841c24b43439c49e3c619a5a347/reset](https://URL.de/api/_action/theme/946ac841c24b43439c49e3c619a5a347/reset) 500 (Internal Server Error)

Wenn ich versuche mit einem Plugin (Custom CSS/JS) zu speichern kommt folgendes:

MELDUNG:  
Internal Server Error- Warning: chmod(): Operation not permitted

Console:  
-api/\_action/theme/946ac841c24b43439c49e3c619a5a347/reset:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)  
api/\_action/theme/946ac841c24b43439c49e3c619a5a347/reset:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)  
api/\_action/dne-customcssjs/compile:1 Failed to load resource: the server responded with a status of 500 (Internal Server Error)

Es scheint irgendein Problem mit den Rechten für die APIs zu sein. Aber ich bin eher ein Frontend Entwickler und weniger im Serverbereich unterwegs. Vielleicht hat ja jemand eine Idee. Über Input würde ich mich sehr freuen.

Danke für die Hilfe!

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [6. Oktober 2023 um 08:20 UTC](https://forum.shopware.com/t/umzug-shopware-6-datei-zugriffsrechte/101486/2 "2023-10-06T08:20:45Z")

</div>

Zumindest den Cache-Ordner würde ich noch kontrollieren, dass hier auch die Dateien 0775 haben.

---

<div class="post-metadata">

**Author:** ![tony88](https://avatars.discourse-cdn.com/v4/letter/t/ebca7d/32.png) [@tony88](https://forum.shopware.com/u/tony88)\
**Post date:** [6. Oktober 2023 um 09:24 UTC](https://forum.shopware.com/t/umzug-shopware-6-datei-zugriffsrechte/101486/3 "2023-10-06T09:24:56Z")

</div>

Die haben die Rechte 666. Aber das wird doch automatisch angelegt oder?

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [6. Oktober 2023 um 09:39 UTC](https://forum.shopware.com/t/umzug-shopware-6-datei-zugriffsrechte/101486/4 "2023-10-06T09:39:24Z")

</div>

Habe ich jetzt nicht ganz so auf dem Schirm, aber die Ordner haben 0777. Ich würde das alles durchgehen. Ist ja kein Problem, alles mal auf 0755 oder 0777 zu stellen. Da gehts ja nix kaputt. Vielleicht auch mal die Ordner unter /public/theme/ mit überrpüfen.

---

<div class="post-metadata">

**Author:** ![rene](https://avatars.discourse-cdn.com/v4/letter/r/7cd45c/32.png) [@rene](https://forum.shopware.com/u/rene)\
**Post date:** [7. Oktober 2023 um 04:45 UTC](https://forum.shopware.com/t/umzug-shopware-6-datei-zugriffsrechte/101486/5 "2023-10-07T04:45:10Z")

</div>

Hallo,

zu den Rechten sollte was in der Doku stehen. Sind die Ordner und Dateien dem richtigen Owner zugewisen? Das kann auch die Ursache sein.

Gruß ré

---

<div class="post-metadata">

**Author:** ![tony88](https://avatars.discourse-cdn.com/v4/letter/t/ebca7d/32.png) [@tony88](https://forum.shopware.com/u/tony88)\
**Post date:** [7. Oktober 2023 um 10:17 UTC](https://forum.shopware.com/t/umzug-shopware-6-datei-zugriffsrechte/101486/6 "2023-10-07T10:17:36Z")

</div>

Habe den Fehler gefunden. Es war ein Serverseitiger Fehler vorhanden bei meinem Anbieter. Ich habe die Dateirechte zwar angepasst und er hat sie bei mir auch übernommen aber in Wirklichkeit ist auf dem Server nichts passiert. Danke für euren Input!
