# Umstellung auf PHP 8 Fehler 500

**URL:** <https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295>\
**Category:** Shopware 5\
**Created:** [11. April 2023 um 18:57 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295 "2023-04-11T18:57:10Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![macca](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/macca/32/14195_2.png) [@macca](https://forum.shopware.com/u/macca)\
**Post date:** [11. April 2023 um 18:57 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/1 "2023-04-11T18:57:10Z")

</div>

Hallo Forum, wenn ich umstelle von PHP 7.x auf 8.x bekomme ich beim Laden des Plugin Manager oder beim senden einer Statusmail (siehe Screenshots) immer einen Fehler 500. Ich habe schon alle Plugins deaktiviert und der Fehler kommt weiterhin.  
Folgendes spuckt die .log aus…

```auto
mod_fcgid: stderr: PHP Fatal error: Declaration of Shopware_Plugins_Frontend_DreiscMailOutbox_Bootstrap::update() must be compatible with Shopware_Components_Plugin_Bootstrap::update($version) in /var/www/vhosts/xxx.netcup.net/httpdocs/engine/Shopware/Plugins/Community/Frontend/DreiscMailOutbox/Bootstrap.php on line 54, referer: https://xxx.de/backend/

```

Hat jemand eine Idee was ich noch tun kann?

 ![500_1](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/6/9/69808bcc0aae33d59264d82530e000a59b282774.jpeg)  
 ![500_2](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/6/0/6054cbdd4df0d670d94bb0678370056ecc2cddbd.jpeg)

Shopware 5.7.17

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [11. April 2023 um 19:07 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/2 "2023-04-11T19:07:30Z")

</div>

Hallo,

deaktiviere mal das Plugin „Dreischild MailOutbox“

Viele Grüße

---

<div class="post-metadata">

**Author:** ![macca](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/macca/32/14195_2.png) [@macca](https://forum.shopware.com/u/macca)\
**Post date:** [11. April 2023 um 19:15 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/3 "2023-04-11T19:15:09Z")

</div>

Diese Plugin finde ich bei mir nicht.  
Hab da was in der Datenbank gefunden…

 ![db](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/a/3/a3f250b63a8e85ae8bd35eb93ca053f001c9a106.jpeg)

Ist wohl das Plugin „Log des eMail-Ausgangs“, hat auch nichts gebracht. Wie gesagt, ich hatte schon alle Plugins deaktiviert.  
 ![mail](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/a/8/a8275fdec01718d7010164da4acaca96aaa39050.jpeg)

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [11. April 2023 um 19:33 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/4 "2023-04-11T19:33:54Z")

</div>

Das Plugin deaktivieren und den Cache leeren (im Notfall kurz zu PHP 7 zurück, damit dies klappt) und dann noch einmal versuchen.

---

<div class="post-metadata">

**Author:** ![macca](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/macca/32/14195_2.png) [@macca](https://forum.shopware.com/u/macca)\
**Post date:** [11. April 2023 um 19:36 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/5 "2023-04-11T19:36:09Z")

</div>

Ich musste das Plugin nicht nur deinstallieren sondern auch löschen, dann cache leeren und nun ist der Fehler weg.  
Kennt jemand ein ähnliches Plugin? Ich brauche das Plugin eigentlich um den Mailausgang zu loggen.

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [11. April 2023 um 19:41 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/6 "2023-04-11T19:41:39Z")

</div>

Ich würde einfach mal den Hersteller kontaktieren.

---

<div class="post-metadata">

**Author:** ![macca](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/macca/32/14195_2.png) [@macca](https://forum.shopware.com/u/macca)\
**Post date:** [11. April 2023 um 19:46 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/7 "2023-04-11T19:46:19Z")

</div>

> [@macca](#):
>
> Log des eMail-Ausgangs

Das Plugin wurde 2016das letzte mal aktualisiert, denke nicht das da noch was gemacht wird.  
Habe eine Alternative gefunden „E-Mail Archiv mit erneut senden Funktion“.

> **[E-Mail Ausgang Archiv mit Erneut Senden Funktion](https://store.shopware.com/esha683256150890/e-mail-ausgang-archiv-mit-erneut-senden-funktion.html)**
>
> E-Mail Ausgang Archiv mit Erneut Senden Funktion Haben Sie jetzt immer alle vom Shop versendeten E-Mails im Blick. Das Plugin E-Mail Ausgang…

---

<div class="post-metadata">

**Author:** ![Michael\_Telgmann](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/michael_telgmann/32/20289_2.png) [@Michael\_Telgmann](https://forum.shopware.com/u/Michael_Telgmann)\
**Post date:** [11. April 2023 um 19:51 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/8 "2023-04-11T19:51:36Z")

</div>

Hallo @macca

welche Shopware Version hast du denn im Einsatz? Vielleicht reicht dir ja die eingebaute Funktion, die es seit 5.6.0 gibt: [Shopware 5 - Einstellungen - E-Mails](https://docs.shopware.com/de/shopware-5-de/einstellungen/e-mails#e-mail-log)

Viele Grüße aus Schöppingen  
Michael Telgmann

---

<div class="post-metadata">

**Author:** ![macca](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/macca/32/14195_2.png) [@macca](https://forum.shopware.com/u/macca)\
**Post date:** [11. April 2023 um 19:57 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/9 "2023-04-11T19:57:49Z")

</div>

> [@macca](#):
>
> Shopware 5.7.17

Shopware 5.7.17  
Ich glaube da waren die Birthday-Gutscheine etc. nicht dabei, aber danke.

---

<div class="post-metadata">

**Author:** ![Max\_Shop](https://avatars.discourse-cdn.com/v4/letter/m/58f4c7/32.png) [@Max\_Shop](https://forum.shopware.com/u/Max_Shop)\
**Post date:** [30. Oktober 2023 um 10:31 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/10 "2023-10-30T10:31:46Z")

</div>

Bei zwei Plugins lag es eben daran, dass in Shopware\_Components\_Plugin\_Bootstrap::update($version) das $version neu eingefügt wurde und das Plugin noch Shopware\_Components\_Plugin\_Bootstrap::update() implementiert hatte. PHP hat das zuvor ignoriert.

Einfach $version an entsprechende Stelle eintragen, dann sollte das Plugin wieder funktionieren.

---

<div class="post-metadata">

**Author:** ![pfannen-joschi](https://avatars.discourse-cdn.com/v4/letter/p/c6cbf5/32.png) [@pfannen-joschi](https://forum.shopware.com/u/pfannen-joschi)\
**Post date:** [24. Januar 2024 um 16:50 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/11 "2024-01-24T16:50:54Z")

</div>

Hi @Max_Shop , Dank Deines Hinweises konnte ich meinen PlugIn Manager auch wieder zum Laufen bringen. Ich habe, wie beschrieben beim Funktionsaufruf die Variable $version mitgegeben.

Kann es sein, dass dann durch ein Update der Fehler wieder auftaucht?

Das wäre ja nicht so optimal.

---

<div class="post-metadata">

**Author:** ![Max\_Shop](https://avatars.discourse-cdn.com/v4/letter/m/58f4c7/32.png) [@Max\_Shop](https://forum.shopware.com/u/Max_Shop)\
**Post date:** [24. Januar 2024 um 17:14 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/12 "2024-01-24T17:14:22Z")

</div>

> [@pfannen-joschi](#):
>
> Kann es sein, dass dann durch ein Update der Fehler wieder auftaucht?

Wenn der Plugin-Hersteller sein Plugin mit einer PHP-8.x-Version testet, dann bekommt er den Fehler selbst angezeigt und würde ihn vermutlich beheben. Kurz, ich denke nicht, dass der Fehler wieder auftaucht.

Da Showare 5 keinen Support mehr durch Shopware erhält, wird sich da vermutlich aber auch nicht mehr viel bei den Plugin Herstellern tun.

---

<div class="post-metadata">

**Author:** ![pfannen-joschi](https://avatars.discourse-cdn.com/v4/letter/p/c6cbf5/32.png) [@pfannen-joschi](https://forum.shopware.com/u/pfannen-joschi)\
**Post date:** [27. Januar 2024 um 11:39 UTC](https://forum.shopware.com/t/umstellung-auf-php-8-fehler-500/99295/13 "2024-01-27T11:39:58Z")

</div>

Danke Dir. Dann hoffen wir mal das Beste 😉
