# Umstellung APP\_ENV von prod auf dev erzeugt 500er-Serverfehler

**URL:** <https://forum.shopware.com/t/umstellung-app-env-von-prod-auf-dev-erzeugt-500er-serverfehler/102491>\
**Category:** Administration\
**Created:** [12. Januar 2024 um 11:18 UTC](https://forum.shopware.com/t/umstellung-app-env-von-prod-auf-dev-erzeugt-500er-serverfehler/102491 "2024-01-12T11:18:48Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![shopmax](https://avatars.discourse-cdn.com/v4/letter/s/59ef9b/32.png) [@shopmax](https://forum.shopware.com/u/shopmax)\
**Post date:** [12. Januar 2024 um 11:18 UTC](https://forum.shopware.com/t/umstellung-app-env-von-prod-auf-dev-erzeugt-500er-serverfehler/102491/1 "2024-01-12T11:18:48Z")

</div>

Wenn ich in der .env den Eintrag APP\_ENV von prod auf dev, erzeugt der Server den nachfolgenden 500er Fehler. Der Hoster meint, dass es an Shopware liegen muss. Hat zufällig irgendjemand eine Idee von Euch.

# Warning: fileperms(): stat failed for /var/www/vhosts/shopdomain.de/shopdomain.de/var/cache/dev\_h68daf8d3c26cafd06d70360c8bcd38ad/ContainerAcnuAVc/proxy-classes.php

---

<div class="post-metadata">

**Author:** ![web-grips](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/web-grips/32/22792_2.png) [@web-grips](https://forum.shopware.com/u/web-grips)\
**Post date:** [12. Januar 2024 um 12:28 UTC](https://forum.shopware.com/t/umstellung-app-env-von-prod-auf-dev-erzeugt-500er-serverfehler/102491/2 "2024-01-12T12:28:10Z")

</div>

Scheint an den Zugriffsrechten auf die Dateien zu liegen.

---

<div class="post-metadata">

**Author:** ![Teddie](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/teddie/32/26013_2.png) [@Teddie](https://forum.shopware.com/u/Teddie)\
**Post date:** [16. Januar 2024 um 14:51 UTC](https://forum.shopware.com/t/umstellung-app-env-von-prod-auf-dev-erzeugt-500er-serverfehler/102491/3 "2024-01-16T14:51:49Z")

</div>

Lösche erst mal den cache/dev\_\* Ordner…

---

<div class="post-metadata">

**Author:** ![shopmax](https://avatars.discourse-cdn.com/v4/letter/s/59ef9b/32.png) [@shopmax](https://forum.shopware.com/u/shopmax)\
**Post date:** [18. Januar 2024 um 08:31 UTC](https://forum.shopware.com/t/umstellung-app-env-von-prod-auf-dev-erzeugt-500er-serverfehler/102491/4 "2024-01-18T08:31:27Z")

</div>

Hatte ich schon getestet, aber behebt das Problem leider nicht. Ich bin jetzt kurzfristig zu einem anderen Hoster gewechselt.

---

<div class="post-metadata">

**Author:** ![enerSpace](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/enerspace/32/13552_2.png) [@enerSpace](https://forum.shopware.com/u/enerSpace)\
**Post date:** [10. April 2024 um 10:40 UTC](https://forum.shopware.com/t/umstellung-app-env-von-prod-auf-dev-erzeugt-500er-serverfehler/102491/5 "2024-04-10T10:40:05Z")

</div>

Es ist zwar schon eine Weile her, seitdem der letzte Beitrag verfasst wurde, jedoch gab es bisher noch keine Lösung.

Das Problem wird durch die Einstellung `opcache.enable_file_override=1` ausgelöst und ist nicht auf einen Fehler seitens Shopware zurückzuführen. Shopware selbst rät auf ihrer Hilfe-Seite unter [Performance Tweaks | Shopware Documentation](https://developer.shopware.com/docs/guides/hosting/performance/performance-tweaks.html) zu diesen PHP Performance Einstellungen.

Um den Fehler zu beheben, sollte `opcache.enable_file_override` auf `0` gesetzt werden. Das aktivieren des Shopware Cluster mode soll das Problem ebenso beheben, da der Container nicht mehr gelöscht wird.

Danke geht an Shopware für diesen Tipp, den wir an der Stelle gerne weitergeben.

Viele Grüße, Rico von [enerspace.de](http://enerspace.de)

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [10. April 2024 um 13:06 UTC](https://forum.shopware.com/t/umstellung-app-env-von-prod-auf-dev-erzeugt-500er-serverfehler/102491/6 "2024-04-10T13:06:28Z")

</div>

> [@enerSpace](#):
>
> Shopware selbst rät auf ihrer Hilfe-Seite unter [Performance Tweaks | Shopware Documentation](https://developer.shopware.com/docs/guides/hosting/performance/performance-tweaks.html) zu diesen PHP Performance Einstellungen.

Interessant.

 ![2024.04.10-15_03_22](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/5/7/57d02c30b17e5ef6e2b89b889120d7260e3d5af3.png)

---

<div class="post-metadata">

**Author:** ![enerSpace](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/enerspace/32/13552_2.png) [@enerSpace](https://forum.shopware.com/u/enerSpace)\
**Post date:** [10. April 2024 um 13:41 UTC](https://forum.shopware.com/t/umstellung-app-env-von-prod-auf-dev-erzeugt-500er-serverfehler/102491/7 "2024-04-10T13:41:45Z")

</div>

Oder auch da. Es kommt halt auf die Umgebung an. Wir haben diese Einstellung global auf 0 gesetzt, da es wenig sinn macht, wenn deswegen Kunden zu einem anderen Hosting Anbieter wechseln würden 😉

VG Rico
