# Theme-Manager zeigt Fehler 500 - Internal Server Error?

**URL:** <https://forum.shopware.com/t/theme-manager-zeigt-fehler-500-internal-server-error/47530>\
**Category:** Plugins\
**Tags:** drittanbieter-plugin\
**Created:** [12. August 2017 um 15:14 UTC](https://forum.shopware.com/t/theme-manager-zeigt-fehler-500-internal-server-error/47530 "2017-08-12T15:14:46Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Senoner](https://avatars.discourse-cdn.com/v4/letter/s/85f322/32.png) [@Senoner](https://forum.shopware.com/u/Senoner)\
**Post date:** [12. August 2017 um 15:14 UTC](https://forum.shopware.com/t/theme-manager-zeigt-fehler-500-internal-server-error/47530/1 "2017-08-12T15:14:46Z")

</div>

Hallo!

ich habe vor kurzem die neuste Shopware Version 5.3 auf meinem 1&1 Managed Server installiert. Nach Anpassung der .htaccess lief der Shop einwandfrei.

Nach der Installation und Aktivierung eines gekauften Templates, erhalte ich derzeit jedoch einen Fehler 500 - Internal Server Error beim Aufruf des Template-Managers. Wird das Template im Pugin-Manager deaktiviert, funktioniert auch der Template-Manager wieder. Vielleicht hat von euch jemand eine Idee woher dieser Fehler kommt und wie es sich beheben lässt?

Verwendete Versionen:

PHP 7.0.21

Ioncube 10

&nbsp;

Viele Grüße

Manuel

---

<div class="post-metadata">

**Author:** ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)\
**Post date:** [12. August 2017 um 15:43 UTC](https://forum.shopware.com/t/theme-manager-zeigt-fehler-500-internal-server-error/47530/2 "2017-08-12T15:43:30Z")

</div>

Am besten Du fragst den Hersteller des Templates; ich hoffe es war nicht so teuer…

&nbsp;

Alternativ könntest Du selbst dich mit dem debuggen von Shopware beschäftigen, vorher vielleicht mal die Error-logs auslesen (Shopware und Server)

---

<div class="post-metadata">

**Author:** ![Senoner](https://avatars.discourse-cdn.com/v4/letter/s/85f322/32.png) [@Senoner](https://forum.shopware.com/u/Senoner)\
**Post date:** [12. August 2017 um 23:04 UTC](https://forum.shopware.com/t/theme-manager-zeigt-fehler-500-internal-server-error/47530/3 "2017-08-12T23:04:08Z")

</div>

Auslesen der Error-Logs des Servers gibt mir folgendes aus:

PHP Fatal error:&nbsp; Uncaught Error: Call to a member function getId() on null in /homepages/27/d192365444/htdocs/engine/Shopware/Components/Snippet/DatabaseHandler.php:138  
Stack trace:  
#0 /homepages/27/d192365444/htdocs/engine/Shopware/Components/Theme/Installer.php(287): Shopware\Components\Snippet\DatabaseHandler-\>loadToDatabase(’/homepages/27/d…’, false, ‚themes/magazine…‘)  
#1 /homepages/27/d192365444/htdocs/engine/Shopware/Components/Theme/Installer.php(206): Shopware\Components\Theme\Installer-\>synchronizeSnippets(Object(Shopware\Models\Shop\Template))  
#2 /homepages/27/d192365444/htdocs/engine/Shopware/Components/Theme/Installer.php(253): Shopware\Components\Theme\Installer-\>synchronizeThemeDirectories(Object(DirectoryIterator), Object(Shopware\Models\Plugin\Plugin))  
#3 /homepages/27/d192365444/htdocs/engine/Shopware/Components/Theme/Installer.php(144): Shopware\Components\Theme\Installer-\>synchronizePluginThemes()

&nbsp;

Was ich als Laie erkennen kann, muss es wohl tatsächlich ein Problem mit dem Template geben.

---

<div class="post-metadata">

**Author:** ![sumipc](https://avatars.discourse-cdn.com/v4/letter/s/ecb155/32.png) [@sumipc](https://forum.shopware.com/u/sumipc)\
**Post date:** [8. Mai 2018 um 01:57 UTC](https://forum.shopware.com/t/theme-manager-zeigt-fehler-500-internal-server-error/47530/4 "2018-05-08T01:57:14Z")

</div>

Habe es so gelöst das ich von PHP 7.0 auf PHP 5.6 umgestellt habe alles durchgeladen und von PHP 5.6 auf 7.0 zurück … Fehler weg.

---

<div class="post-metadata">

**Author:** ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)\
**Post date:** [8. Mai 2018 um 04:28 UTC](https://forum.shopware.com/t/theme-manager-zeigt-fehler-500-internal-server-error/47530/5 "2018-05-08T04:28:45Z")

</div>

Glaskugel: Der kommt wieder…
