# "The resource owner or authorization server denied the request" Fehler im Log

**URL:** <https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222>\
**Category:** Shopware 6 (German)\
**Created:** [4. April 2023 um 14:25 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222 "2023-04-04T14:25:23Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![hannes.pries-nf](https://avatars.discourse-cdn.com/v4/letter/h/dfb087/32.png) [@hannes.pries-nf](https://forum.shopware.com/u/hannes.pries-nf)\
**Post date:** [4. April 2023 um 14:25 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/1 "2023-04-04T14:25:23Z")

</div>

Hallo, seit ein paar Tagen ist extrem gehäuft dieser Fehler in den Logs zu finden.

```auto
[2023-04-04T14:22:14.299940+00:00] request.CRITICAL: Uncaught PHP Exception League\OAuth2\Server\Exception\OAuthServerException: "The resource owner or authorization server denied the request." at /home/xxxx/public_html/shopware6/vendor/league/oauth2-server/src/Exception/OAuthServerException.php line 243 {"exception":"[object] (League\\OAuth2\\Server\\Exception\\OAuthServerException(code: 9): The resource owner or authorization server denied the request. at /home/xxxx/public_html/shopware6/vendor/league/oauth2-server/src/Exception/OAuthServerException.php:243)\n[previous exception] [object] (Lcobucci\\JWT\\Token\\InvalidTokenStructure(code: 0): The JWT string must have two dots at /home/xxxx/public_html/shopware6/vendor/lcobucci/jwt/src/Token/InvalidTokenStructure.php:13)"} []

```

Es ist bei 2 Shops mit 6.4.18.1 und auch bei zwei Shops mit 6.4.20.0 zu beobachten. Da mehrere voneinander unabhängige Shops betroffen sind, wundert mich es etwas. Alle liefen vorher ohne Probleme und es wurden bis auf die Shopware-Updates keine Änderungen vorgenommen.

Ich konnte jetzt nicht wirklich eine Einschränkung der Funktion der Shops feststellen, aber allein die Anzahl der Fehler ist schon etwas nervig.

---

<div class="post-metadata">

**Author:** ![tomquenten](https://avatars.discourse-cdn.com/v4/letter/t/ea5d25/32.png) [@tomquenten](https://forum.shopware.com/u/tomquenten)\
**Post date:** [5. April 2023 um 12:38 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/2 "2023-04-05T12:38:00Z")

</div>

Das kann ich bestätigen! Mir ist das auch heute aufgefallen. Es sieht so aus, als ob alleine die Anzahl der Anfragen in einem Sciptlauf diesen Fehler verursacht. Wenn ich per Script (PHP) eine einzelne Anfrage stelle, klappt alles. Wenn ich, bei uns den gesamten Artikelstamm, an die Api übertrage, klappen die ersten x Anfragen und danach kommt der o.g. Fehler. Wir haben hier die 6.4.20.0

tomquenten

---

<div class="post-metadata">

**Author:** ![windes](https://avatars.discourse-cdn.com/v4/letter/w/ac91a4/32.png) [@windes](https://forum.shopware.com/u/windes)\
**Post date:** [5. April 2023 um 14:42 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/3 "2023-04-05T14:42:17Z")

</div>

Hallo die Meldungen hatte ich massenhaft, bei einem Kundenshop.  
Im Serverlog gab es diese Meldung:  
„POST [https://www.example.de/api/\_action/message-queue/consume](https://www.example.de/api/_action/message-queue/consume) HTTP/2.0“ 500 110 „[https://www.example.de/admin](https://www.example.de/admin)“ „Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/111.0“  
Nach dem ich das Plugin Shopware Store deaktiviert und aktiviert habe, ist Ruhe!

Frohe Ostern gewünscht!  
Steffen Winde

---

<div class="post-metadata">

**Author:** ![micha.hobert](https://avatars.discourse-cdn.com/v4/letter/m/e274bd/32.png) [@micha.hobert](https://forum.shopware.com/u/micha.hobert)\
**Post date:** [9. April 2023 um 10:59 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/4 "2023-04-09T10:59:23Z")

</div>

Same here, gibt es dazu Neuigkeiten?

---

<div class="post-metadata">

**Author:** ![hannes.pries-nf](https://avatars.discourse-cdn.com/v4/letter/h/dfb087/32.png) [@hannes.pries-nf](https://forum.shopware.com/u/hannes.pries-nf)\
**Post date:** [11. April 2023 um 07:37 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/5 "2023-04-11T07:37:59Z")

</div>

Ich habe einmal getestet das Store-Plugin zu deaktiveren. Aber das scheint keinen Effekt gehabt zu haben.

---

<div class="post-metadata">

**Author:** ![anelges](https://avatars.discourse-cdn.com/v4/letter/a/6a8cbe/32.png) [@anelges](https://forum.shopware.com/u/anelges)\
**Post date:** [14. April 2023 um 09:29 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/6 "2023-04-14T09:29:32Z")

</div>

Die gleichen Probleme treten auch bei unserem SW6-System auf: Version 6.4.20.0

---

<div class="post-metadata">

**Author:** ![Panasiam\_Clothing](https://avatars.discourse-cdn.com/v4/letter/p/ea5d25/32.png) [@Panasiam\_Clothing](https://forum.shopware.com/u/Panasiam_Clothing)\
**Post date:** [18. April 2023 um 14:29 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/7 "2023-04-18T14:29:42Z")

</div>

Wir haben auch das Problem, deaktivieren Shopware Store Plugin hat Abhilfe gebracht.

---

<div class="post-metadata">

**Author:** ![tomquenten](https://avatars.discourse-cdn.com/v4/letter/t/ea5d25/32.png) [@tomquenten](https://forum.shopware.com/u/tomquenten)\
**Post date:** [5. Mai 2023 um 15:12 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/8 "2023-05-05T15:12:39Z")

</div>

Also das deaktivieren des Shopware Store Plugin schaffte KEINE Abhilfe. Ich habe jetzt einen Anfragecounter mitlaufen lassen. Es können 861 Anfragen gestellt werden, ab der 862 Abfrage kommt der o.g. Fehler zurück. Auch habe ich TESTWEISE das Shopware 6 Sicherheits-Plugin deaktiviert - ohne Erfolg.

Gibt es sowas wie eine SessionTime pro Api Aufruf? Oder eine Begrenzung wie viele Api Anfragen pro Sekunde / Minute gestellt werden dürfen?

Noch jemand Ideen?

tomquenten

---

<div class="post-metadata">

**Author:** ![tomquenten](https://avatars.discourse-cdn.com/v4/letter/t/ea5d25/32.png) [@tomquenten](https://forum.shopware.com/u/tomquenten)\
**Post date:** [6. Mai 2023 um 16:13 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/9 "2023-05-06T16:13:47Z")

</div>

Heute konnte ich 1168 Anfragen stellen, ab der 1169 Anfrage kam wieder die Fehlermeldung…

`The resource owner or authorization server denied the request.`

Damit dürfte die Begrenzung pro Sekunde / Minute obsolet sein…denke ich.

Weitere Ideen?

tomquenten

---

<div class="post-metadata">

**Author:** ![cbm](https://avatars.discourse-cdn.com/v4/letter/c/a9a28c/32.png) [@cbm](https://forum.shopware.com/u/cbm)\
**Post date:** [9. Mai 2023 um 13:14 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/10 "2023-05-09T13:14:06Z")

</div>

Gibt es dazu schon ein Ticket?

---

<div class="post-metadata">

**Author:** ![tomquenten](https://avatars.discourse-cdn.com/v4/letter/t/ea5d25/32.png) [@tomquenten](https://forum.shopware.com/u/tomquenten)\
**Post date:** [10. Mai 2023 um 12:24 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/11 "2023-05-10T12:24:23Z")

</div>

Von mir nicht, ich weiß nicht wie das geht, habe ich noch nie gemacht.

---

<div class="post-metadata">

**Author:** ![ru.allenstein](https://avatars.discourse-cdn.com/v4/letter/r/8c91f0/32.png) [@ru.allenstein](https://forum.shopware.com/u/ru.allenstein)\
**Post date:** [17. Mai 2023 um 06:14 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/12 "2023-05-17T06:14:05Z")

</div>

Bei uns gibt es das gleiche Problem. Bei zu vielen ausgeführten API Requests wird der Fehler gefeuert.

---

<div class="post-metadata">

**Author:** ![zwei](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/zwei/32/12885_2.png) [@zwei](https://forum.shopware.com/u/zwei)\
**Post date:** [24. Mai 2023 um 15:30 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/13 "2023-05-24T15:30:08Z")

</div>

Habe das selbe Problem. Heute schon 9.200 Logeinträge.

Shopware: 6.4.19.0  
PHP: 8.0

---

<div class="post-metadata">

**Author:** ![markush777](https://avatars.discourse-cdn.com/v4/letter/m/a587f6/32.png) [@markush777](https://forum.shopware.com/u/markush777)\
**Post date:** [27. Mai 2023 um 18:35 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/14 "2023-05-27T18:35:23Z")

</div>

Wir haben dies auch. Gibt es Neues dazu bzw. befasst sich Shopware schon damit?  
@marco.steinhaeuser

---

<div class="post-metadata">

**Author:** ![marco.steinhaeuser](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/marco.steinhaeuser/32/14512_2.png) [@marco.steinhaeuser](https://forum.shopware.com/u/marco.steinhaeuser)\
**Post date:** [27. Mai 2023 um 19:52 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/15 "2023-05-27T19:52:20Z")

</div>

Shopware (Entwicklung) kann sich damit befassen, wenn es einen Bugreport dafür gibt. Wisst Ihr, wie das geht? Ansonsten kann ich das gern einmal beschreiben oder zeigen.

---

<div class="post-metadata">

**Author:** ![hannes.pries-nf](https://avatars.discourse-cdn.com/v4/letter/h/dfb087/32.png) [@hannes.pries-nf](https://forum.shopware.com/u/hannes.pries-nf)\
**Post date:** [1. Juni 2023 um 14:55 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/16 "2023-06-01T14:55:58Z")

</div>

Ich hab mir das heute nochmal angeguckt. Hier sind es gerade die Frosh-Tools, die im ausgeloggten Zustand, weiterhin Anfragen an die API senden (health-status) und dabei „Bearer false“ im Header haben. Wenn man also im ausgeloggten Zustand einfach weiterhin Abfragen gegen die API sendet und getBasicHeader() des Api-Service verwendet, ist es schon mal ein Weg diesen Fehler zu produzieren. „false“ ist eindeutig an nicht valider Token.

Ich beobachte aber noch weiter.

---

<div class="post-metadata">

**Author:** ![santana](https://avatars.discourse-cdn.com/v4/letter/s/5f9b8f/32.png) [@santana](https://forum.shopware.com/u/santana)\
**Post date:** [13. Juni 2023 um 09:48 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/17 "2023-06-13T09:48:53Z")

</div>

Moin, das Problem trifft bei ein unserem Kunden-Systeme jetzt auch. Das System bei uns ist allerdings noch in der entwicklung, aber auf einmal ist weder Frontend noch Backend erreichbar und die Log-Datei wirft folgender Fehler: “The resource owner or authorization server denied the request”  
Version 6.4.20 7 Php 8.0  
Hat jemand inwzischen einer Lösung sonst???  
Parallel habe ich ein Ticket über den Issue Träcker bei Shopware erstellt.  
Hier der Link um Fehler zu melden, falls jemand nochmal ein Ticket erstellen möchte: [https://issues.shopware.com/](https://issues.shopware.com/)

---

<div class="post-metadata">

**Author:** ![santana](https://avatars.discourse-cdn.com/v4/letter/s/5f9b8f/32.png) [@santana](https://forum.shopware.com/u/santana)\
**Post date:** [13. Juni 2023 um 10:13 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/18 "2023-06-13T10:13:51Z")

</div>

**Nachtrag** : Also falls es jemand hilft. In unserem Fall war die Lösung die PHP-Prozesse auf dem Server neu zu starten. Und der Shop ging wieder.

---

<div class="post-metadata">

**Author:** ![shyim](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/shyim/32/7681_2.png) [@shyim](https://forum.shopware.com/u/shyim)\
**Post date:** [20. Juni 2023 um 15:04 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/19 "2023-06-20T15:04:40Z")

</div>

Hey,

die Logs `The resource owner or authorization server denied the request` können ignoriert werden, das wird ausgelöst wenn jemand ohne Login die API aufruft.  
Ab \>=6.5 sollte diese Meldung auch nicht mehr in der Log erscheinen, weil sie ignoriert wird.

Das Anfragen zum Shop hängen bleiben, könnte an den Admin Watcher liegen. Dieser sollte am besten im [CLI modus laufen](https://developer.shopware.com/docs/guides/hosting/infrastructure/message-queue#cli-worker) und somit keine Web-Anfragen blockieren. Ansonsten haben wir den Admin-Worker für die nächste Version 6.5.3.0 verbessert, dass [dieser nur einmal parallel läuft.](https://github.com/shopware/platform/commit/f279758b4f7b7886b4070b2e0bd8ae5b89787ec0)

---

<div class="post-metadata">

**Author:** ![tomquenten](https://avatars.discourse-cdn.com/v4/letter/t/ea5d25/32.png) [@tomquenten](https://forum.shopware.com/u/tomquenten)\
**Post date:** [20. Juli 2023 um 10:25 UTC](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222/20 "2023-07-20T10:25:46Z")

</div>

Nachdem ich nun die 6.5.3 auf einem Testsystem installiert habe, dachte ich das Problem sei gelöst. Ich habe alle Produkte wieder mit meinem selbst geschriebenen PHP Script per Api in den Shop transportiert. Hat gut funktioniert. DESHALB dachte ich das Problem sei gelöst. Bei weiteren Versuchen, unter anderem den Bildupload, kam die Fehlermeldung dann doch wieder.

Mhhhhh, so eine Ka…e!

Ich mach es mal ganz kurz. Das Problem ist das der Token 10 Minuten gültig ist und danach erneuert werden muss. Das habe ich mit einem Zeitstempel im Script dann auch nachvollziehen können. Es sind exakt 10 Minuten, danach wird der Token abgewiesen.

Nun bin ich dran, meine API Klasse dahingehend anzupassen.

Eventuell hilft dies jemandem weiter.

Beste Grüße  
tomquenten

[Nächste Seite](https://forum.shopware.com/t/the-resource-owner-or-authorization-server-denied-the-request-fehler-im-log/99222.md?page=2)
