# SwagMediaS3: CDN Aktivierung in config.php \> Fatal error: Allowed memory size …

**URL:** <https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905>\
**Category:** Programmierung\
**Created:** [20. März 2018 um 19:59 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905 "2018-03-20T19:59:25Z")\
**Posts on this page:** 18\
**Page:** 1

<div class="post-metadata">

**Author:** ![dbb](https://avatars.discourse-cdn.com/v4/letter/d/e36b37/32.png) [@dbb](https://forum.shopware.com/u/dbb)\
**Post date:** [20. März 2018 um 19:59 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/1 "2018-03-20T19:59:25Z")

</div>

Hallo zusammen,

ich habe das SwagMediaS3 Plugin installiert und die config.php für den Amazon S3 CDN angepasst.

Obwohl ich die Speichergröße schon auf ein 1GB hochgeschraubt habe, kommt folgende Fehlermeldung:

```
Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 20480 bytes) in /Applications/MAMP/htdocs/www.domain.de/custom/plugins/SwagMediaS3/SwagMediaS3.php on line 67

```

Die Größe des Media-Ordners beträgt 62MB.

Hat jemand eine Idee warum immer noch die Fehlermeldung erscheint?

&nbsp;

Vielen Dank und beste Grüße  
Michael

---

<div class="post-metadata">

**Author:** ![dbb](https://avatars.discourse-cdn.com/v4/letter/d/e36b37/32.png) [@dbb](https://forum.shopware.com/u/dbb)\
**Post date:** [21. März 2018 um 07:51 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/2 "2018-03-21T07:51:51Z")

</div>

Guten Morgen,

noch ein kleiner Nachtrag zu meinem Problem…

Die Fehlermeldung erscheint bereits, wenn ich nur folgendes Snippet in die config.php einfüge, ohne das ich das SwagMediaS3 Plugin aktiviert habe:

```
  'cdn' => [
      'backend' => 's3',
      'adapters' => [
          's3' => [
              'type' => 's3',
              'mediaUrl' => 'YOUR_S3_OR_CLOUDFRONT_ENDPOINT',
              'key' => 'YOUR_AWS_KEY',
              'secret' => 'YOUR_AWS_SECRET',
              'region' => 'YOUR_S3_REGION',
              'bucket' => 'YOUR_S3_BUCKET_NAME',
              'prefix' => ''
          ]
      ]
  ]

```

Den Logs kann ich auch keine weitere Information entnehmen.  
Vielleicht ist noch hinzuzufügen, das ich mit einer Lokalen Mamp Installation arbeite.

&nbsp;

BGM

---

<div class="post-metadata">

**Author:** ![simkli](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/simkli/32/13124_2.png) [@simkli](https://forum.shopware.com/u/simkli)\
**Post date:** [21. März 2018 um 07:53 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/3 "2018-03-21T07:53:13Z")

</div>

Hi @dbb‍,

nur um sicher zu gehen: Sowas wie “YOUR\_AWS\_SECRET” hast du auch mit deinen Daten ausgefüllt oder?

Also statt&nbsp;YOUR\_AWS\_KEY deinen AWS-Schlüssel hinterlegt? 😉

Ansonsten: Ist bei dir unter Einstellungen \> System-Info alles grün?

Viele Grüße

---

<div class="post-metadata">

**Author:** ![dbb](https://avatars.discourse-cdn.com/v4/letter/d/e36b37/32.png) [@dbb](https://forum.shopware.com/u/dbb)\
**Post date:** [21. März 2018 um 07:58 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/4 "2018-03-21T07:58:31Z")

</div>

Guten Morgen Simkli,

in der System-Info ist alles grün und in der Config sind auch alle Daten korrekt hinterlegt.  
Die S3 Benutzerdaten haben ich via FTP mit einem erfolgreichen Connect geprüft.

BGM

---

<div class="post-metadata">

**Author:** ![simkli](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/simkli/32/13124_2.png) [@simkli](https://forum.shopware.com/u/simkli)\
**Post date:** [21. März 2018 um 08:19 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/5 "2018-03-21T08:19:04Z")

</div>

Hallo @dbb‍,

ich kann mir vorstellen, dass er beim ersten Aufruf eine Migration der Dateien durchführen würde, falls dies nicht geschehen ist. Das kann sehr Speicheraufwändig werden. Am besten nutzt du dafür die Kommandozeile wie in der Anleitung beschrieben.&nbsp;[MediaService](https://developers.shopware.com/developers-guide/shopware-5-media-service/#example:-migrating-all-media-files-to-amazon-s3)

In der Anleitung steht ja folgendes:

> You can now simply run this command to move all files from your local media file system to Amazon S3.
> 
> bin/console sw:media:migrate --from=local --to=s3

Hast du dieses Kommando ausgeführt?&nbsp;

Bei MAMP liegen die PHP-CLI Versionen unter&nbsp;/Applications/MAMP/bin/php/phpXXX/bin/php wobei XXX die Version sein sollte.  
Du kannst den Befehl also mit&nbsp;

```
/Applications/MAMP/bin/php/phpXXX/bin/php /PFAD/ZU/DEINER/SW/INSTALLATION/bin/console sw:media:migrate --from=local --to=s3 

```

ausführen.

Viele Grüße

---

<div class="post-metadata">

**Author:** ![dbb](https://avatars.discourse-cdn.com/v4/letter/d/e36b37/32.png) [@dbb](https://forum.shopware.com/u/dbb)\
**Post date:** [21. März 2018 um 08:24 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/6 "2018-03-21T08:24:10Z")

</div>

Hallo @simkli‍,

beim Aufruf über die Kommandozeile kommt leider auch die gleiche Fehlermeldung wie beim Aufruf der Seite über den Browser ☹

BGM

---

<div class="post-metadata">

**Author:** ![Thomas](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/thomas/32/8167_2.png) [@Thomas](https://forum.shopware.com/u/Thomas)\
**Post date:** [21. März 2018 um 11:45 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/7 "2018-03-21T11:45:56Z")

</div>

Welche Shopware Version setzt Du ein? Wenn ich mich richtig erinnere ist das Problem mit einem Update behoben worden.

---

<div class="post-metadata">

**Author:** ![dbb](https://avatars.discourse-cdn.com/v4/letter/d/e36b37/32.png) [@dbb](https://forum.shopware.com/u/dbb)\
**Post date:** [21. März 2018 um 12:10 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/8 "2018-03-21T12:10:26Z")

</div>

Hallo @Thomas‍,

die aktuelle Version 5.4.1. Leider sind in den Mamp PHP Logs auch keine weiteren Infos.

BGM

---

<div class="post-metadata">

**Author:** ![dbb](https://avatars.discourse-cdn.com/v4/letter/d/e36b37/32.png) [@dbb](https://forum.shopware.com/u/dbb)\
**Post date:** [21. März 2018 um 12:24 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/9 "2018-03-21T12:24:30Z")

</div>

Ich habe mir jetzt mal die Zeile 67 in der SwagMediaS3.php angschaut. Bei Aufruf den neuen Klasse wird der Fehler ausgelöst:

```
$client = new S3Client($clientConfig);

```

Kann es vielleicht an meiner PHP Version 7.0.27 oder vielleicht an einer Einstellung in der php.ini liegen?

BGM

---

<div class="post-metadata">

**Author:** ![dbb](https://avatars.discourse-cdn.com/v4/letter/d/e36b37/32.png) [@dbb](https://forum.shopware.com/u/dbb)\
**Post date:** [21. März 2018 um 12:56 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/10 "2018-03-21T12:56:23Z")

</div>

Ich habe gesehen das in dem SwagMediaS3 Plugin Verzeichnis noch eine composer.json mit einem Require liegt:

```
"require": {
  "league/flysystem-aws-s3-v3": "1.0.13"
}

```

Mit welchem Befehl kann ich das „flysystem-aws-s3-v3“ installieren lassen?

VGM

---

<div class="post-metadata">

**Author:** ![dbb](https://avatars.discourse-cdn.com/v4/letter/d/e36b37/32.png) [@dbb](https://forum.shopware.com/u/dbb)\
**Post date:** [21. März 2018 um 15:59 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/11 "2018-03-21T15:59:18Z")

</div>

Okay… nachdem ich custom/plugins/SwagMediaS3 \> copmposer update in der Konsole aufrufe, sind zwar alle dependencies installiert und es scheint auch alles soweit zu laufen, aber ich kann im Admin nicht mehr den Plugin Manager öffnen.

Kennt jemand von euch das Problem?

BGM

---

<div class="post-metadata">

**Author:** ![musikdiscount24](https://avatars.discourse-cdn.com/v4/letter/m/ac8455/32.png) [@musikdiscount24](https://forum.shopware.com/u/musikdiscount24)\
**Post date:** [23. Juli 2018 um 15:20 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/12 "2018-07-23T15:20:31Z")

</div>

> [@dbb schrieb:](https://forum.shopware.com/profile/23569/dbb "dbb")
> 
> Ich habe mir jetzt mal die Zeile 67 in der SwagMediaS3.php angschaut. Bei Aufruf den neuen Klasse wird der Fehler ausgelöst:
> 
> $client = new S3Client($clientConfig);
> 
> Kann es vielleicht an meiner PHP Version 7.0.27 oder vielleicht an einer Einstellung in der php.ini liegen?
> 
> BG

Das Problem habe ich auch. Gibt es dafür eine Lösung / eine Erklärung? Auch die Installation des AWS SDK für PHP brachte bei mir nur weitere Probleme mit sich.&nbsp;

---

<div class="post-metadata">

**Author:** ![musikdiscount24](https://avatars.discourse-cdn.com/v4/letter/m/ac8455/32.png) [@musikdiscount24](https://forum.shopware.com/u/musikdiscount24)\
**Post date:** [26. Juli 2018 um 14:06 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/13 "2018-07-26T14:06:36Z")

</div>

> [@musikdiscount24 schrieb:](https://forum.shopware.com/profile/4030/musikdiscount24 "musikdiscount24")
> 
> > [@dbb schrieb:](https://forum.shopware.com/profile/23569/dbb "dbb")
> > 
> > Ich habe mir jetzt mal die Zeile 67 in der SwagMediaS3.php angschaut. Bei Aufruf den neuen Klasse wird der Fehler ausgelöst:
> > 
> > $client = new S3Client($clientConfig);
> > 
> > Kann es vielleicht an meiner PHP Version 7.0.27 oder vielleicht an einer Einstellung in der php.ini liegen?
> > 
> > BG
> 
> Das Problem habe ich auch. Gibt es dafür eine Lösung / eine Erklärung? Auch die Installation des AWS SDK für PHP brachte bei mir nur weitere Probleme mit sich.&nbsp;

Update 26.07.2018:  
In den vorherigen Paketen war der Ordner vendor Teil der .zip-Datei. Das ist offenbar nicht der Fall. Dieser Ordner fehlt nun, kann allerdings mittels Composer erzeugt werden.

```
cd custom/plugins/SwagMediaS3

composer install

```

Bei mir gibt es dann allerdings ein neues Problem: nachdem der Ordner vendor angelegt wurde, bekomme ich im PluginManager einen Internal Server Error, ohne Einträge in den Server Log-Files. Wo das nun wieder herkommt versuche ich (wie vor mir schon dbb) grade rauszufinden, bin aber für jeden Hinweis dankbar!

&nbsp;

---

<div class="post-metadata">

**Author:** ![ronecker](https://avatars.discourse-cdn.com/v4/letter/r/d2c977/32.png) [@ronecker](https://forum.shopware.com/u/ronecker)\
**Post date:** [29. Juli 2018 um 19:33 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/14 "2018-07-29T19:33:57Z")

</div>

Jup,  
ist ein bestätigter Fehler, vermutlich gefällt die Guzzle version nicht, die installiert wird.  
Hab mal ein Issue&nbsp;drübern bei Github aufgemacht

[PHP Fatal error: Uncaught TypeError: Argument 3 passed to GuzzleHttp\Client::request() must be of the type array, string given · Issue #22 · shopwareLabs/SwagMediaS3 · GitHub](https://github.com/shopwareLabs/SwagMediaS3/issues/22)

---

<div class="post-metadata">

**Author:** ![ronecker](https://avatars.discourse-cdn.com/v4/letter/r/d2c977/32.png) [@ronecker](https://forum.shopware.com/u/ronecker)\
**Post date:** [30. Juli 2018 um 09:02 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/15 "2018-07-30T09:02:21Z")

</div>

OK Jungs,  
hier die Lösung. Vermutlich habt Ihr&nbsp;

`composer update`

ausgeführt, das führt zum Installieren der neusten Versionen und den beschriebenen Fehlern.&nbsp;  
Hier nun wie Ihr es zum Laufen bekommt

1. Plugin komplett deinstallieren.
2. Plugin “ver 2.0.0” neu in Shopware laden
3. auf der console dann vor dem&nbsp;  
`composer install`

die benötigte Guzzle Version installieren mit&nbsp;  
`composer require guzzlehttp/guzzle:5.3.1`

1. Nun könnt Ihr mit composer install alles sauber installieren.

2. je nach dem wie groß Eure Bildersammlung ist, kann es zu dem Speicherfehler kommen, dann einfach  
`bin/console sw:media:migrate --from=local --to=s3 --skip-scan`

ausführen und schon werden die Daten in den S3 Bucket verschoben.

Viel Spaß beim “nachbauen” :)&nbsp;

---

<div class="post-metadata">

**Author:** ![musikdiscount24](https://avatars.discourse-cdn.com/v4/letter/m/ac8455/32.png) [@musikdiscount24](https://forum.shopware.com/u/musikdiscount24)\
**Post date:** [30. Juli 2018 um 09:10 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/16 "2018-07-30T09:10:18Z")

</div>

Vielen herzlichen Dank!&nbsp; ![Smile](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/smile.png "Smile")&nbsp; ![Thumb-Up](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/thumb-up.png "Thumb-Up")

---

<div class="post-metadata">

**Author:** ![musikdiscount24](https://avatars.discourse-cdn.com/v4/letter/m/ac8455/32.png) [@musikdiscount24](https://forum.shopware.com/u/musikdiscount24)\
**Post date:** [26. Oktober 2018 um 13:11 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/17 "2018-10-26T13:11:39Z")

</div>

Wunderschönen guten Tag zusammen,

anknüpfend an die Problematik von vor drei Monaten würde ich gerne nachfragen, ob schon jemand den Schritt gewagt und auf 5.5.X geupdatet hat. In unserem Testsystem habe ich nun einfach mal ins Blaue hinein ein Update gemacht und erhalte Fehlermeldungen:

```
Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen.
The options "key", "prefix", "secret" do not exist. Defined options are: "bucket", "credentials", "mediaUrl", "region", "root", "type", "url", "version". in vendor/symfony/options-resolver/OptionsResolver.php on line 645
Stack trace: 
#0 engine/Shopware/Bundle/MediaBundle/Adapters/AwsS3v3Factory.php(75): Symfony\Component\OptionsResolver\OptionsResolver->resolve(Array) 
#1 engine/Shopware/Bundle/MediaBundle/Adapters/AwsS3v3Factory.php(40): Shopware\Bundle\MediaBundle\Adapters\AwsS3v3Factory->resolveS3Options(Array) 
#2 engine/Shopware/Bundle/MediaBundle/MediaServiceFactory.php(127): Shopware\Bundle\MediaBundle\Adapters\AwsS3v3Factory->create(Array) 
#3 engine/Shopware/Bundle/MediaBundle/MediaServiceFactory.php(83): Shopware\Bundle\MediaBundle\MediaServiceFactory->getAdapter(Array) 
#4 var/cache/production_201810171014/proxies/ShopwareProductionxxxxxxxxxProjectContainer.php(5146): Shopware\Bundle\MediaBundle\MediaServiceFactory->factory('s3') 
#5 vendor/symfony/dependency-injection/Container.php(306): ShopwareProductionxxxxxxxProjectContainer->getShopwareMedia_MediaServiceService() 
#6 engine/Shopware/Components/DependencyInjection/Container.php(211): Symfony\Component\DependencyInjection\Container->get('shopware_media....', 1) 
#7 engine/Shopware/Components/DependencyInjection/Container.php(143): Shopware\Components\DependencyInjection\Container->doLoad('shopware_media....', 1) 
#8 engine/Library/Enlight/Controller/Action.php(414): Shopware\Components\DependencyInjection\Container->get('shopware_media....') 
#9 engine/Shopware/Controllers/Backend/MediaManager.php(206): Enlight_Controller_Action->get('shopware_media....') 
#10 engine/Library/Enlight/Controller/Action.php(193): Shopware_Controllers_Backend_MediaManager->getAlbumMediaAction() 
#11 engine/Library/Enlight/Controller/Dispatcher/Default.php(548): Enlight_Controller_Action->dispatch('getAlbumMediaAc...') 
#12 engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) 
#13 engine/Shopware/Kernel.php(202): Enlight_Controller_Front->dispatch() 
#14 vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(102): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) 
#15 vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true) 
#16 engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) 
#17 vendor/symfony/http-kernel/HttpCache/HttpCache.php(238): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) 
#18 engine/Shopware/Components/HttpCache/AppCache.php(105): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) 
#19 shopware.php(122): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) 
#20 {main}

```

Meine Vorgehensweise wie folgt:

1. Deaktivieren und Deinstallation aller Plugins, die nicht updatesicher waren - allem voran das S3 Plugin
2. Update von 5.4.6 auf Shopware 5.5.2
3. S3 Plugin per Pluginmanager installiert
4. per FTP den Inhalt des Pluginordners hochgeladen (ergo nicht wie oben beschrieben neu via Console installiert)
5. S3 Plugin aktiviert
6. Config-Datei wie vorher mit den S3-Zugangsdaten etc. gefüllt und auf dem Server gespeichert
7. Caches (auch production\_xxx) gelöscht

Sobald ich einen Artikel öffne, das Theme neu kompoliere oder in den Medienmanager gehe, kommt die Fehlermeldung.

```
The options "key", "prefix", "secret" do not exist. Defined options are: "bucket", "credentials", "mediaUrl", "region", "root", "type", "url", "version". in vendor/symfony/options-resolver/OptionsResolver.php on line 645

```

Dieser Teil sagt ja bereits schon einiges aus. Die Frage ist nun, ob das einfach zu beheben ist, oder ob das Plugin an sich ein Update oder…

Vielleicht hat sich damit auch schon jemand auseinander gesetzt und könnte hier seine Erfahrungen teilen.

Viele Grüße

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [26. Oktober 2018 um 15:09 UTC](https://forum.shopware.com/t/swagmedias3-cdn-aktivierung-in-config-php-fatal-error-allowed-memory-size/51905/18 "2018-10-26T15:09:51Z")

</div>

[https://forum.shopware.com/discussion/comment/231219/#Comment\_231219](https://forum.shopware.com/discussion/comment/231219/#Comment_231219)
