# SQLSTATE\[42000\]: Syntax error or access violation: 1064

**URL:** https://forum.shopware.com/t/sqlstate-42000-syntax-error-or-access-violation-1064/31565
**Category:** Installation/Einstieg
**Tags:** resolved-topics
**Created:** [21. Oktober 2015 um 18:47 UTC](https://forum.shopware.com/t/sqlstate-42000-syntax-error-or-access-violation-1064/31565 "2015-10-21T18:47:22Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![scanner](https://avatars.discourse-cdn.com/v4/letter/s/3ec8ea/32.png) [@scanner](https://forum.shopware.com/u/scanner)
#### Post date: [21. Oktober 2015 um 18:47 UTC](https://forum.shopware.com/t/sqlstate-42000-syntax-error-or-access-violation-1064/31565/1 "2015-10-21T18:47:22Z")

</div>

Hi(lfe) bei der Installation von Shopware 5.1 bekommen wir den folgenden Datenbankfehler beim DB-Import: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‚il‘, 1, @locale\_en\_GB, ‚debit/bank\_code‘, ‚Bank code‘, ‚2015-10-12 13:52:35‘, ‚2‘ at line 1 Vom Hoster weiß ich: Es ist ein RedHat-Linux Server zunächst mit MariaDB. MySQL wurde nun auch schon getestet: der gleiche Fehler. Eine lokale Installation auf MAMP läuft bei mir durch. Jemand eine Idee, was an dem Server zu fummeln ist, dass die Installation durchläuft? Danke schonmal, Andreas

---

<div class="post-metadata">

### Author: ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)
#### Post date: [21. Oktober 2015 um 20:08 UTC](https://forum.shopware.com/t/sqlstate-42000-syntax-error-or-access-violation-1064/31565/2 "2015-10-21T20:08:11Z")

</div>

Hallo, evtl. der selbe Fehler: [installation-einstieg-f99/fehler-im-frontend-nach-shopware-5-0-4-installation-t31495.html?hilit=mariaDB#p138121](http://forum.shopware.com/installation-einstieg-f99/fehler-im-frontend-nach-shopware-5-0-4-installation-t31495.html?hilit=mariaDB#p138121)

---

<div class="post-metadata">

### Author: ![Trax](https://avatars.discourse-cdn.com/v4/letter/t/e19b73/32.png) [@Trax](https://forum.shopware.com/u/Trax)
#### Post date: [23. Oktober 2015 um 09:59 UTC](https://forum.shopware.com/t/sqlstate-42000-syntax-error-or-access-violation-1064/31565/3 "2015-10-23T09:59:12Z")

</div>

Hallo Andreas (scanner), hast Du eine Lösung gefunden? Ich wollte Shopware mal ausprobieren und bekomme bei der Installation ganz genau die gleiche Fehlermeldung (allerdings auf einer MySQL-Datenbank). Viele Grüße Mark

---

<div class="post-metadata">

### Author: ![scanner](https://avatars.discourse-cdn.com/v4/letter/s/3ec8ea/32.png) [@scanner](https://forum.shopware.com/u/scanner)
#### Post date: [23. Oktober 2015 um 11:04 UTC](https://forum.shopware.com/t/sqlstate-42000-syntax-error-or-access-violation-1064/31565/4 "2015-10-23T11:04:09Z")

</div>

Der IT’ler hat den kompletten Linuxserver noch einmal neu aufgesetzt. Jetzt läuft es, auch mit der MariaDB (5.5), php5.5 Er hat k.A. was da war… MySQL hatten wir auch probiert. 3 Tage rumdoktern :o( Tscha… Gruß, Andreas Alles wäre nicht so schwer, wenn es etwas leichter wär’.
