# SQL Import Fehler - pickware\_shipping\_carrier kann nicht erzeugt werden

**URL:** <https://forum.shopware.com/t/sql-import-fehler-pickware-shipping-carrier-kann-nicht-erzeugt-werden/103939>\
**Category:** Shopware 6 (German)\
**Created:** [6. Mai 2024 um 21:51 UTC](https://forum.shopware.com/t/sql-import-fehler-pickware-shipping-carrier-kann-nicht-erzeugt-werden/103939 "2024-05-06T21:51:00Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![PromoID](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/promoid/32/14015_2.png) [@PromoID](https://forum.shopware.com/u/PromoID)\
**Post date:** [6. Mai 2024 um 21:51 UTC](https://forum.shopware.com/t/sql-import-fehler-pickware-shipping-carrier-kann-nicht-erzeugt-werden/103939/1 "2024-05-06T21:51:01Z")

</div>

Hallo zusammen,

wir wollten eine Kopie von einem Shop erstellen (selber Server, selbe Datenbankkonfiguration).  
Jetzt bekommen wir beim Import der SQL Datei folgende Fehlermeldung:

```auto
--
-- Constraints der Tabelle `pickware_shipping_carrier`
--
ALTER TABLE `pickware_shipping_carrier`
  ADD CONSTRAINT `pickware_shipping_carrier.fk.return_label_mail_template` FOREIGN KEY (`return_label_mail_template_type_technical_name`) REFERENCES `mail_template_type` (`technical_name`) ON DELETE SET NULL ON UPDATE CASCADE
MySQL meldet:Dokumentation

#1005 - Kann Tabelle `COPYOF023`.`pickware_shipping_carrier` nicht erzeugen (Fehler: 150 "Foreign key constraint is incorrectly formed") (Details…)

```

was dazu führt das man keine Versandetiketten mehr erstellen kann:

`Beim Starten des Vorgangs ist ein Fehler aufgetreten: An exception occurred while executing a query: SQLSTATE[HY000]: General error: 1267 Illegal mix of collations (utf8mb4_general_ci,IMPLICIT) and (utf8mb4_unicode_ci,IMPLICIT) for operation '='`

Hat jemand eine Idee oder Lösung dazu? 🙂

---

<div class="post-metadata">

**Author:** ![hth](https://avatars.discourse-cdn.com/v4/letter/h/b77776/32.png) [@hth](https://forum.shopware.com/u/hth)\
**Post date:** [7. Mai 2024 um 06:48 UTC](https://forum.shopware.com/t/sql-import-fehler-pickware-shipping-carrier-kann-nicht-erzeugt-werden/103939/2 "2024-05-07T06:48:34Z")

</div>

Für die Fehlermeldung bei „Alter“ schau mit SHOW ENGINE INNODB STATUS nach dem Foreign Key Error , dort steht wahrscheinlich eine Ursache.

Bei der Erzeugung der Versandetiketten ist der Fehler eigentlich eindeutig: du verwendest verschiedene collation (Zeichensätze) in den Tabellen. Das sollte immer sein: utf8mb4\_unicode\_ci  
Setz diese bei den betroffenen Tabellen neu und bei der DB als Default.

---

<div class="post-metadata">

**Author:** ![PromoID](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/promoid/32/14015_2.png) [@PromoID](https://forum.shopware.com/u/PromoID)\
**Post date:** [7. Mai 2024 um 11:11 UTC](https://forum.shopware.com/t/sql-import-fehler-pickware-shipping-carrier-kann-nicht-erzeugt-werden/103939/3 "2024-05-07T11:11:55Z")

</div>

Danke für deine Antwort. SHOW ENGINE INNODB STATUS hatte ich anscheinend über phpMyAdmin keine Berechtigung 😕

Das war jetzt eine schwere Geburt. Durch das Ändern der Zeichensätze über phpMyAdmin hatten wir keinen Erfolg.

Die Lösung war etwas aufwändiger: Einfach mal eine neue Datenbank erstellt, utf8mb4\_unicode\_ci als Standard gesetzt, eine Kombination aus dem alten .sql Backup und neuem .sql Back zusammengewürfelt - jetzt klappt alles wieder 🙂

Alte und neue Backup mussten halt zusammengewürfelt werden, da der Fehler erst nach dem WE aufgefallen ist und über das WE noch Bestellungen und Änderungen an der Seite durchgeführt wurden 🙂

Scheint auch alles jetzt soweit zu funktionieren 🙂
