# SQL Fehler bei update

**URL:** <https://forum.shopware.com/t/sql-fehler-bei-update/38369>\
**Category:** Programmierung\
**Created:** [19. Juli 2016 um 15:20 UTC](https://forum.shopware.com/t/sql-fehler-bei-update/38369 "2016-07-19T15:20:06Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![wimpernshop](https://avatars.discourse-cdn.com/v4/letter/w/e8c25b/32.png) [@wimpernshop](https://forum.shopware.com/u/wimpernshop)\
**Post date:** [19. Juli 2016 um 15:20 UTC](https://forum.shopware.com/t/sql-fehler-bei-update/38369/1 "2016-07-19T15:20:06Z")

</div>

Hallo liebe Leute,&nbsp;

Leider ging bei unserem Update von 5.1.6 auf 5.2.x einiges schief. &nbsp;Er bringt mir mehrere Tabellen, &nbsp;die schon bereits vorhanden sind. &nbsp;Die sind ja kein Problem, da sie leer sind, &nbsp;werden die einfsch gelöscht, und beim nächsten updaterun wieder eingefügt. &nbsp;Aber leider hänge ich bei folgenden Fehler. &nbsp;Ich verstehe , &nbsp;dass ihm die Spalte plugin\_id fehlt. &nbsp;Aber in welcher Tabelle? &nbsp;Jemand ein Tipp? &nbsp;

**Error**

Received the following error message:  
Could not apply migration (Migrations\_Migration708). Error: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‚plugin\_id‘ in ‚field list‘&nbsp;

Please try to fix this error and restart the update.

**Response**

{„valid“:false,„errorMsg“:"Could not apply migration (Migrations\_Migration708). Error: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‚plugin\_id‘ in ‚field list‘ "}

&nbsp;

Danke für eure Bemühungen&nbsp;

---

<div class="post-metadata">

**Author:** ![jandings](https://avatars.discourse-cdn.com/v4/letter/j/77aa72/32.png) [@jandings](https://forum.shopware.com/u/jandings)\
**Post date:** [2. August 2016 um 08:09 UTC](https://forum.shopware.com/t/sql-fehler-bei-update/38369/2 "2016-08-02T08:09:45Z")

</div>

Hallo,

ich habe exakt das gleiche Problem, auch von 5.1.6 (bei dieser Version hänge ich jetzt noch fest). Habe sogar die 5.1.6 DB völlig neu aufgebaut (durch eine leere 5.1.6 DB einer Neuinstallation), aber spätestens bei dem Fehler UNKNOWN COLUMN PLUGIN\_ID (siehe &nbsp;vorheriger Post)&nbsp;ist jetzt Schluss. Ich habe auch keine weiteres Errorlog gefunden, als die Meldung im Updater. Ohne Info, welche Tabelle überhaupt gemeint ist, geht’s jetzt nicht weiter.

Hat niemand einen Tipp, welche Tabelle gemeint sein könnte, indem PLUGIN\_ID fehlt?

Mehr, als die 5.1.6 DB komplett neu aufzubauen kann ich nun wirklich nicht mehr machen. Ich kann auch nicht auf alte Backups zurückgreifen, denn die DB-Struktur scheint schon länger durch ein schlechtes Shopware Update vermurkst zu sein und auf sehr alte Backups kann ich wegen des alten Datenbestands nicht zurückgreifen.&nbsp;

Wenn ich das Problem also nicht gelöst bekomme, heißt das, Ende mit Shopware - für mich. Das wäre sehr ärgerlich.

Grüße

---

<div class="post-metadata">

**Author:** ![t2oh4e](https://avatars.discourse-cdn.com/v4/letter/t/a5b964/32.png) [@t2oh4e](https://forum.shopware.com/u/t2oh4e)\
**Post date:** [2. August 2016 um 08:17 UTC](https://forum.shopware.com/t/sql-fehler-bei-update/38369/3 "2016-08-02T08:17:41Z")

</div>

Die Migration 708 fügt an dieser Stelle eine Konfiguration ein:&nbsp;[shopware/708-attribute-administration.php at 5.2 · shopware/shopware · GitHub](https://github.com/shopware/shopware/blob/5.2/_sql/migrations/708-attribute-administration.php#L109)

Ich vermute mal, dass der Fehler daher kommt. Allerdings sollte das Feld etwas weiter oben in der gleichen Migration angelegt werden, bzw die ganze Tabelle mit diesem Feld.

Gab es diese Tabelle bei euch schon vorher? Eigentlich gibt es die erst ab 5.2

---

<div class="post-metadata">

**Author:** ![jandings](https://avatars.discourse-cdn.com/v4/letter/j/77aa72/32.png) [@jandings](https://forum.shopware.com/u/jandings)\
**Post date:** [3. August 2016 um 07:56 UTC](https://forum.shopware.com/t/sql-fehler-bei-update/38369/4 "2016-08-03T07:56:06Z")

</div>

Hallo,&nbsp;

danke an t2oh4e und wimpernshop, tatsächlich ist der Tipp Gold wert, bei den Update-Fehlern des Autoupdaters darauf zu achten, welche Nummer hinter “Migration” steht. Es handelt sich bei dieser Nummer dann um ein ziemlich kurzes Skript, welches zu finden ist unter&nbsp;

/files/update/update-assets/migrations

Diese Skripte kann man dann ansehen (oder auch sogar patchen, sie sind wirklich sehr kompakt) und somit den Fehlern näher auf die Spur kommen.&nbsp;

Letztlich ist die Vorgehendweise bei Datenbankproblemen während des Updates so, dass man ein paralleles Fenster mit myPHPadmin aufhat, um die fehlenden oder zuviel vorhandenen DB-Einträge dann händisch zu bearbeiten. Das Update startet man dann im Updatefenster neu, indem man einfach die im Browser stehende URL (die jetzt noch den Update-Fehler anzeigt) um das letzte Wort kürzt (dann endet die URL mit sowas wie “/dbmigration” oder ähnlich, weiß ich grad nicht mehr genau) und neu sendet. Der Updater wiederholt dann nur den letzten Schritt und macht ab dort weiter.

Trotzdem bin ich am Ende der DB Migration, nach dem Aufräumen, dann auf einen Fehler gelaufen, der mir sagte, dass die Attribute Models nicht mehr in Ordnung wären. Eine Reparatur war zu diesem Zeitpunkt nach dem eigentlich sehr guten Hilfe-Artikel&nbsp;[http://community.shopware.com/Shopware-Updates-Debuggen-von-Fehlern-und-FAQ\_detail\_1378.html](http://community.shopware.com/Shopware-Updates-Debuggen-von-Fehlern-und-FAQ_detail_1378.html) nur noch möglich, in dem man auf die Konsole zugreift (denn Backend ist ja gesperrt). Konsolenzugriff habe ich aber nicht.&nbsp;

Ich konnte das Problem dann lösen, indem ich ein Rollback gemacht habe und von vorne angefangen habe:

1. Erst Sicherheitskopie der kompletten DB und der Dateien
2. Alle Caches über das Backend löschen. Alle!
3. myPHP Admin für die Datenbank öffnen
4. Die Foreign-Key-Reparatur anwenden, siehe Artikel&nbsp;[http://community.shopware.com/Foreign-Keys-reparieren\_detail\_954.html](http://community.shopware.com/Foreign-Keys-reparieren_detail_954.html)
5. Nochmal alle Caches löschen
6. Das Auto-Update starten (bei mir wurden Plugins DHL und Backend-Bestellungen als nicht kompatibel gemerkt - aber wie lange soll man denn da warten? Also ignoriert).
7. Bei jedem auftretenden Fehler im Updater parallel den Fehler in myPHPadmin behoben (Hinweise ggfs noch aus den Migration-Skripten [siehe mein Text weiter oben] nutzen).
8. Updater DB-Migration neu starten (Einfach URL im Browser um den letzten Begriff kürzen und Enter)

So habe ich es schließlich nach viel Schweiß geschafft, sauber auf 5.2.3 zu kommen. Läuft alles problemlos jetzt.&nbsp;

Ich vermute übrigend, der Fehler in meiner DB hat sich irgendwann mal eingeschlichen, weil ich ein Rollback/Restore gemacht habe, indem ich ein Backup per Import in eine neuere Version gespielt habe. Die beiden Versionen wurden somit gemerget. Ich hätte vorher natürlich die alte DB LÖSCHEN müssen. Wann das genau war, weiß ich nicht mehr. Egal, jetzt ist der Fehler behoben.

&nbsp;
