# Sporadische Fehler im Blog-Modul

**URL:** <https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586>\
**Category:** Shopware 3.5\
**Tags:** general\
**Created:** [2. November 2012 um 20:47 UTC](https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586 "2012-11-02T20:47:13Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![TomBOX](https://avatars.discourse-cdn.com/v4/letter/t/f19dbf/32.png) [@TomBOX](https://forum.shopware.com/u/TomBOX)\
**Post date:** [2. November 2012 um 20:47 UTC](https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586/1 "2012-11-02T20:47:13Z")

</div>

Hallo, seit dem Update auf die Version 4.0.4 RC erhalten wir ab und zu - bislang kein Muster erkennbar - folgende Fehlermeldung, die den ganzen Shop lahmlegt: Fatal error: Cannot redeclare Shopware\Models\Attribute\Blog::$blog in /serverpfad\_zum\_kunden/installationsverzeichnis/engine/Shopware/Models/Attribute/Blog.php on line 132 Dieser Fehler lässt sich derzeit nur so lösen, dass ich im FTP im Ordner /engine/Shopware/Models/Attribute die Datei Blog.php lösche. Bei irgend einer Gelegenheit wird sie wieder erstellt. Das Komische ist, wir nutzen das Blog-Modul gar nicht. Dennoch erhalten wir jenen Fehler. Was kann das wohl sein?

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [3. November 2012 um 01:55 UTC](https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586/2 "2012-11-03T01:55:31Z")

</div>

Hallo, das sieht nach einem Problem in der Datenbank aus. Exportiere mal nur die Tabelle s\_blog\_attributes und prüfe, wie viele foreign keys gesetzt sind. Die Meldung besagt, dass mehrere vorhanden sind - es darf aber nur einer vorhanden sein… Es geht um diesen Befehl, der im Export nur einmal vorkommen darf: ALTER TABLE `s_blog_attributes` ADD CONSTRAINT `s_blog_attributes_ibfk_1` FOREIGN KEY (`blog_id`) REFERENCES `s_blog` (`id`) ON DELETE CASCADE ON UPDATE NO ACTION;

---

<div class="post-metadata">

**Author:** ![TomBOX](https://avatars.discourse-cdn.com/v4/letter/t/f19dbf/32.png) [@TomBOX](https://forum.shopware.com/u/TomBOX)\
**Post date:** [5. November 2012 um 08:35 UTC](https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586/3 "2012-11-05T08:35:37Z")

</div>

Guten Morgen Sebastian, [quote=„Sebastian Klöpper“]Hallo, das sieht nach einem Problem in der Datenbank aus. Exportiere mal nur die Tabelle s\_blog\_attributes und prüfe, wie viele foreign keys gesetzt sind. Die Meldung besagt, dass mehrere vorhanden sind - es darf aber nur einer vorhanden sein… Es geht um diesen Befehl, der im Export nur einmal vorkommen darf: ALTER TABLE `s_blog_attributes` ADD CONSTRAINT `s_blog_attributes_ibfk_1` FOREIGN KEY (`blog_id`) REFERENCES `s_blog` (`id`) ON DELETE CASCADE ON UPDATE NO ACTION;[/quote] vielen Dank für die nächtliche Antwort. Um diese Zeit hatte ich das gar nicht erwartet. :thumbup: Mein SQL-Argument sieht so aus: ` ALTER TABLE `s_blog_attributes` ADD CONSTRAINT `s_blog_attributes_ibfk_3` FOREIGN KEY (`blog_id`) REFERENCES `s_blog` (`id`) ON DELETE CASCADE ON UPDATE NO ACTION, ADD CONSTRAINT `s_blog_attributes_ibfk_1` FOREIGN KEY (`blog_id`) REFERENCES `s_blog` (`id`) ON DELETE CASCADE ON UPDATE NO ACTION, ADD CONSTRAINT `s_blog_attributes_ibfk_2` FOREIGN KEY (`blog_id`) REFERENCES `s_blog` (`id`) ON DELETE CASCADE ON UPDATE NO ACTION; ` Das sind dann also drei, statt nur eins. Und was mache ich jetzt?

---

<div class="post-metadata">

**Author:** ![TomBOX](https://avatars.discourse-cdn.com/v4/letter/t/f19dbf/32.png) [@TomBOX](https://forum.shopware.com/u/TomBOX)\
**Post date:** [7. November 2012 um 16:18 UTC](https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586/4 "2012-11-07T16:18:23Z")

</div>

Also ich hätte wirklich nichts dagegen, wenn jetzt eine Antwort auf mein letztes Posting erschiene. 😉

---

<div class="post-metadata">

**Author:** ![Benjamin\_Cremer](https://avatars.discourse-cdn.com/v4/letter/b/a8b319/32.png) [@Benjamin\_Cremer](https://forum.shopware.com/u/Benjamin_Cremer)\
**Post date:** [7. November 2012 um 17:05 UTC](https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586/5 "2012-11-07T17:05:49Z")

</div>

Hallo, die überflüssigen Fremdschlüssel kannst du folgendermaßen löschen: ` ALTER TABLE s\_blog\_attributes DROP FOREIGN KEY s\_blog\_attributes\_ibfk\_2; ALTER TABLE s\_blog\_attributes DROP FOREIGN KEY s\_blog\_attributes\_ibfk\_3; ` Viele Grüße Benjamin Cremer :shopware:

---

<div class="post-metadata">

**Author:** ![TomBOX](https://avatars.discourse-cdn.com/v4/letter/t/f19dbf/32.png) [@TomBOX](https://forum.shopware.com/u/TomBOX)\
**Post date:** [8. November 2012 um 11:42 UTC](https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586/6 "2012-11-08T11:42:11Z")

</div>

Hallo, [quote=„Benjamin Cremer“]Hallo, die überflüssigen Fremdschlüssel kannst du folgendermaßen löschen: ` ALTER TABLE s\_blog\_attributes DROP FOREIGN KEY s\_blog\_attributes\_ibfk\_2; ALTER TABLE s\_blog\_attributes DROP FOREIGN KEY s\_blog\_attributes\_ibfk\_3; ` Viele Grüße Benjamin Cremer :shopware:[/quote] den Befehl habe ich ausgeführt und zur Prüfung die Tabelle nochmals exportiert. Die beiden überflüssigen Einträge sind fort. Zum Testen habe ich nun die originale Blog.php (aus dem 4.0.4.-Release) wieder eingestellt. Und es klappt wieder nicht: dieselbe Fehlermeldung wie oben schon erwähnt. Ich habe auch noch einmal in der Datenbank nachgesehen, die zusätzlichen Einträge in der Tabelle s\_blog\_attributes gibt es nicht mehr, auch nicht erneut. Der Fehler besteht jedoch noch immer. Was nun?

---

<div class="post-metadata">

**Author:** ![Marcel\_S](https://avatars.discourse-cdn.com/v4/letter/m/cc9497/32.png) [@Marcel\_S](https://forum.shopware.com/u/Marcel_S)\
**Post date:** [8. November 2012 um 11:47 UTC](https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586/7 "2012-11-08T11:47:20Z")

</div>

Hi, hast du schon auf die finale 4.0.4 upgedatet ? Hier sollte dein Problem gelöst sein. Grüße, Marcel

---

<div class="post-metadata">

**Author:** ![TomBOX](https://avatars.discourse-cdn.com/v4/letter/t/f19dbf/32.png) [@TomBOX](https://forum.shopware.com/u/TomBOX)\
**Post date:** [8. November 2012 um 13:25 UTC](https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586/8 "2012-11-08T13:25:04Z")

</div>

[quote=„Marcel S“]Hi, hast du schon auf die finale 4.0.4 upgedatet ? Hier sollte dein Problem gelöst sein. Grüße, Marcel[/quote] Huch!? Ich wusste gar nicht, dass die 4.0.4. jetzt final ist. Muss ich gleich mal nachholen… ich melde mich wieder.

---

<div class="post-metadata">

**Author:** ![TomBOX](https://avatars.discourse-cdn.com/v4/letter/t/f19dbf/32.png) [@TomBOX](https://forum.shopware.com/u/TomBOX)\
**Post date:** [8. November 2012 um 15:32 UTC](https://forum.shopware.com/t/sporadische-fehler-im-blog-modul/9586/9 "2012-11-08T15:32:33Z")

</div>

Okay… erste Tests ergeben keine Fehler. Sieht schonmal gut aus. \*hoff\*
