# Sofort. Plugin | Fehler beim Checkout - ERROR 500

**URL:** <https://forum.shopware.com/t/sofort-plugin-fehler-beim-checkout-error-500/54163>\
**Category:** Plugins\
**Tags:** drittanbieter-plugin\
**Created:** [19. Juli 2018 um 08:03 UTC](https://forum.shopware.com/t/sofort-plugin-fehler-beim-checkout-error-500/54163 "2018-07-19T08:03:24Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![jnzmm](https://avatars.discourse-cdn.com/v4/letter/j/ba8739/32.png) [@jnzmm](https://forum.shopware.com/u/jnzmm)\
**Post date:** [19. Juli 2018 um 08:03 UTC](https://forum.shopware.com/t/sofort-plugin-fehler-beim-checkout-error-500/54163/1 "2018-07-19T08:03:24Z")

</div>

**Bestellung mit „Sofort.“-Plugin nicht möglich**

Plugin ist wie in deren Anleitung beschrieben eingerichtet und mit „Sofort.“-Projekt verbunden.  
Beim Checkout mit ausgewählter Bezahlmethode, bekomme ich direkt nach dem Klick auf „Zahlungspflichtig bestellen“, vom Browser einen ERROR 500 angezeigt.

&nbsp;

**Sofort-Plugin Support**

Sagt es handle sich um einen Fehler auf meinem Server. Verzeichnis- und Dateiberechtigungen sind seiner Meinung nach schuld. Ich solle nach der Lösung Googeln.

&nbsp;

**Webhoster Support**

Sagt, dass mit den Rechten alles in Ordnung ist und diese so Standard sind. Er kann nicht nachvollziehen warum der Plugin-Hersteller solch einen Rat gegeben hat.

&nbsp;

**Was kann ich tun?**

Ich will ungern die Standard(!) Shopware Verzeichnisrechte abändern nur damit ein Plugin funktioniert. Es muss eine andere Möglichkeit geben.  
Hat jemand das selbe Problem bzw. weiß an welcher Schraube ich noch drehen muss?

&nbsp;

**Systeminfo**

Shopware: 5.4.5  
Sofort-Plugin: 1.0.0&nbsp;[Sofort. für Shopware 5.2.13 und höher | Shopware Community Store](https://store.shopware.com/sofor62224950330f/sofort.-fuer-shopware-5.2.13-und-hoeher.html)  
php:&nbsp;7.1.9 FPM

---

<div class="post-metadata">

**Author:** ![PStadtfeld](https://avatars.discourse-cdn.com/v4/letter/p/3bc359/32.png) [@PStadtfeld](https://forum.shopware.com/u/PStadtfeld)\
**Post date:** [19. Juli 2018 um 08:12 UTC](https://forum.shopware.com/t/sofort-plugin-fehler-beim-checkout-error-500/54163/2 "2018-07-19T08:12:33Z")

</div>

Ich sage es ja nur ungern, aber die häufigsten Ursachen für Error 500 liegen wirklich bei Server/Konfiguration.

Hier ist eine kleine Seite darüber inkl. Ursachenabschnitt und möglichen Ansätzen: [https://hosting.1und1.de/digitalguide/hosting/hosting-technik/http-error-500-tipps-tricks-zur-problemloesung/](https://hosting.1und1.de/digitalguide/hosting/hosting-technik/http-error-500-tipps-tricks-zur-problemloesung/)

Ist zwar leider keine wirkliche Problemlösung, aber vielleicht hilft die richtige Richtung schonmal.

ggf. die Berechtigung doch nochmal prüfen, bei den Plugins meist 0775, schauen ob alle Skripte der gleichen Gruppe/ dem gleichen User zugeordnet sind und sich kein Root eingeschlichen hat…

---

<div class="post-metadata">

**Author:** ![jnzmm](https://avatars.discourse-cdn.com/v4/letter/j/ba8739/32.png) [@jnzmm](https://forum.shopware.com/u/jnzmm)\
**Post date:** [19. Juli 2018 um 08:37 UTC](https://forum.shopware.com/t/sofort-plugin-fehler-beim-checkout-error-500/54163/3 "2018-07-19T08:37:34Z")

</div>

Wie im Artikel beschrieben sind bei mir alle Ordner mit **755** und Dateien mit **644** Berechtigung versehen. Also wie im Standard.

Ich verstehe nun auch nicht ob das nur den _custom/plugins/SofortPay_ Ordner betreffen würde oder mehr…

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [19. Juli 2018 um 08:53 UTC](https://forum.shopware.com/t/sofort-plugin-fehler-beim-checkout-error-500/54163/4 "2018-07-19T08:53:02Z")

</div>

Der Fehler wird im PHP Errorlog des Shops zu finden sein. Ohne die Fehlermeldung kann man nur vermuten. Du kannst die auch im Frontend ausgeben lassen:&nbsp;[https://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen\_detail\_1880.html#Frontend\_Error\_Reporter](https://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html#Frontend_Error_Reporter)

&nbsp;

Also einmal die Fehlerausgabe aktivieren und das Problem nachstellen, dann Fehler hier posten.

---

<div class="post-metadata">

**Author:** ![jnzmm](https://avatars.discourse-cdn.com/v4/letter/j/ba8739/32.png) [@jnzmm](https://forum.shopware.com/u/jnzmm)\
**Post date:** [19. Juli 2018 um 09:17 UTC](https://forum.shopware.com/t/sofort-plugin-fehler-beim-checkout-error-500/54163/5 "2018-07-19T09:17:39Z")

</div>

Bei aktiviertem Error Reporting bekomme ich folgenden Fehler ausgegeben:

```
Fatal error: Uncaught ArgumentCountError: Too few arguments to function SofortPay\Components\Logger\SofortLogger::__construct(), 0 passed in /html/shopware/var/cache/production_201806180817/proxies/ShopwareProductionc8c10722c670a94ee19e025c321b260594c0d166ProjectContainer.php on line 3402 and at least 1 expected in /html/shopware/custom/plugins/SofortPay/Components/Logger/SofortLogger.php:27 Stack trace: #0 /html/shopware/var/cache/production_201806180817/proxies/ShopwareProductionc8c10722c670a94ee19e025c321b260594c0d166ProjectContainer.php(3402): SofortPay\Components\Logger\SofortLogger->__construct() #1 /html/shopware/vendor/symfony/dependency-injection/Container.php(297): ShopwareProductionc8c10722c670a94ee19e025c321b260594c0d166ProjectContainer->getSofortPay_SofortLoggerService() #2 /html/shopware/engine/Shopware/Components/DependencyInjection/Container.php(211): Symfony\Component\DependencyInjection\Container->get('sofort_pay.sofo...', 1) #3 /html/shopware/engine/Shopware/Components/DependencyInjection/Container.php( in /html/shopware/custom/plugins/SofortPay/Components/Logger/SofortLogger.php on line 27

```

&nbsp;

**Server Logs oder Shopware Logs sind leer bzw. enthalten nichts in Richtung Sofort.**

---

<div class="post-metadata">

**Author:** ![jnzmm](https://avatars.discourse-cdn.com/v4/letter/j/ba8739/32.png) [@jnzmm](https://forum.shopware.com/u/jnzmm)\
**Post date:** [20. Juli 2018 um 15:23 UTC](https://forum.shopware.com/t/sofort-plugin-fehler-beim-checkout-error-500/54163/6 "2018-07-20T15:23:49Z")

</div>

**Das Plugin ist nicht mit PHP&nbsp;7.1 kompatibel!**

PHP Version auf 7.0 stellen, löst das Problem.

&nbsp;

Schade, dass der Sofort-Support beim betrachten meiner Systeminfos nicht selbst dahinter gekommen ist.

---

<div class="post-metadata">

**Author:** ![malzfons](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@malzfons](https://forum.shopware.com/u/malzfons)\
**Post date:** [20. Juli 2018 um 18:36 UTC](https://forum.shopware.com/t/sofort-plugin-fehler-beim-checkout-error-500/54163/7 "2018-07-20T18:36:27Z")

</div>

Vielleicht weiß der sofort Support gar nicht dass deren Plugin verschlüsselt im Store ist. Unverschlüsselt würde es mit php 7.1 wohl laufen.
