# Shopware Fehler Reporter &quot;unable to write file...&quot;

**URL:** https://forum.shopware.com/t/shopware-fehler-reporter-quot-unable-to-write-file-quot/21405
**Category:** Shopware 3.5
**Tags:** general
**Created:** [18. Juli 2014 um 12:54 UTC](https://forum.shopware.com/t/shopware-fehler-reporter-quot-unable-to-write-file-quot/21405 "2014-07-18T12:54:17Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![leopard](https://avatars.discourse-cdn.com/v4/letter/l/ee7513/32.png) [@leopard](https://forum.shopware.com/u/leopard)
#### Post date: [18. Juli 2014 um 12:54 UTC](https://forum.shopware.com/t/shopware-fehler-reporter-quot-unable-to-write-file-quot/21405/1 "2014-07-18T12:54:17Z")

</div>

Hallo, ich bekomme folgende Fehlermeldung nach dem Login ins Backend. Kann mir jemand weiterhelfen? Fehlerinformationen: Fehlerbeschreibung: [code]

## Ups! Ein Fehler ist aufgetreten!

Die nachfolgenden Hinweise sollten Ihnen weiterhelfen.

unable to write file /var/www/web1/html/cache/templates/backend\_de\_DE\_401c7/c0/a2/ff/wrt53c821c4b04543.76679568 in Smarty/sysplugins/smarty\_internal\_write\_file.php on line 48

### Stack trace:

```
#0 Smarty/sysplugins/smarty\_internal\_template.php(201): Smarty\_Internal\_Write\_File::writeFile('/var/www/web1/h...', '<?php /* Smarty...', Object(Enlight_Template_Manager))
#1 Smarty/sysplugins/smarty_internal_templatebase.php(155): Smarty_Internal_Template->compileTemplateSource() #2 Smarty/sysplugins/smarty\_internal\_template.php(286): Smarty\_Internal\_TemplateBase-\>fetch(NULL, NULL, NULL, NULL, false, false, true) #3 cache/templates/backend\_de\_DE\_401c7/f3/1d/a6/f31da60a168a4cf7eba2fc8ab23ac63ab8249a82.snippet.payment\_methods.js.php(94): Smarty\_Internal\_Template-\>getSubTemplate('backend/custome...', NULL, 'backend\_de\_DE\_4...', NULL, NULL, Array, 0) #4 Smarty/sysplugins/smarty\_internal\_templatebase.php(180): content\_53c821c1ac5384\_99265985(Object(Enlight\_Template\_Default)) #5 Enlight/View/Default.php(273): Smarty\_Internal\_TemplateBase-\>fetch() #6 Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(212): Enlight\_View\_Default-\>render(Object(Enlight\_Template\_Default)) #7 Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(238): Enlight\_Controller\_Plugins\_ViewRenderer\_Bootstrap-\>renderTemplate(Object(Enlight\_Template\_Default)) #8 Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight\_Controller\_Plugins\_ViewRenderer\_Bootstrap-\>render() #9 [internal function]: Enlight\_Controller\_Plugins\_ViewRenderer\_Bootstrap-\>onPostDispatch(Object(Enlight\_Controller\_ActionEventArgs)) #10 Enlight/Event/Handler/Default.php(91): call\_user\_func(Array, Object(Enlight\_Controller\_ActionEventArgs)) #11 Enlight/Event/EventManager.php(211): Enlight\_Event\_Handler\_Default-\>execute(Object(Enlight\_Controller\_ActionEventArgs)) #12 Enlight/Controller/Action.php(202): Enlight\_Event\_EventManager-\>notify('Enlight\_Control...', Object(Enlight\_Controller\_ActionEventArgs)) #13 Enlight/Controller/Dispatcher/Default.php(528): Enlight\_Controller\_Action-\>dispatch('loadAction') #14 Enlight/Controller/Front.php(228): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #15 Shopware/Kernel.php(141): Enlight\_Controller\_Front-\>dispatch() #16 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(473): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #17 Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #18 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(244): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #19 Shopware/Components/HttpCache/AppCache.php(102): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #20 shopware.php(91): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #21 {main}

```

[/code]

---

<div class="post-metadata">

### Author: ![Dennis\_Wahl](https://avatars.discourse-cdn.com/v4/letter/d/838e76/32.png) [@Dennis\_Wahl](https://forum.shopware.com/u/Dennis_Wahl)
#### Post date: [18. Juli 2014 um 13:03 UTC](https://forum.shopware.com/t/shopware-fehler-reporter-quot-unable-to-write-file-quot/21405/2 "2014-07-18T13:03:24Z")

</div>

Hi, hier kann in /cache/templates/ nicht geschrieben werden. Eine Mögliche Ursache ist das die Rechte des Ordners nicht stimmen, es könnte auch sein dass es unterschiedliche Besitzer gibt dies solltest du einmal überprüfen. Gruß Dennis

---

<div class="post-metadata">

### Author: ![leopard](https://avatars.discourse-cdn.com/v4/letter/l/ee7513/32.png) [@leopard](https://forum.shopware.com/u/leopard)
#### Post date: [18. Juli 2014 um 13:09 UTC](https://forum.shopware.com/t/shopware-fehler-reporter-quot-unable-to-write-file-quot/21405/3 "2014-07-18T13:09:44Z")

</div>

Der Ordner /cache/templates/ hat die Rechte 755. Was genau meinst du mit unterschiedliche Besitzer und wo kann ich das überprüfen?

---

<div class="post-metadata">

### Author: ![mkl1525](https://avatars.discourse-cdn.com/v4/letter/m/c2a13f/32.png) [@mkl1525](https://forum.shopware.com/u/mkl1525)
#### Post date: [18. Juli 2014 um 13:59 UTC](https://forum.shopware.com/t/shopware-fehler-reporter-quot-unable-to-write-file-quot/21405/4 "2014-07-18T13:59:39Z")

</div>

Wenn du per FTP auf deinen Account zugreifst, zeigen die meisten FTP-Programme bei der Dateiliste in einer separaten Spalte wem die Datei bzw. das Verzeichnis gehört. Im Allgemeinen sollte das der User sein, unter dem der Webserver läuft (meist www oder www-data). Weitere Vermutung: dein Plattenplatz ist nicht zufällig voll? Gruß Mario

---

<div class="post-metadata">

### Author: ![leopard](https://avatars.discourse-cdn.com/v4/letter/l/ee7513/32.png) [@leopard](https://forum.shopware.com/u/leopard)
#### Post date: [18. Juli 2014 um 19:06 UTC](https://forum.shopware.com/t/shopware-fehler-reporter-quot-unable-to-write-file-quot/21405/5 "2014-07-18T19:06:58Z")

</div>

Hier ein Screenshot vom FTP. Bei “Eigentümer” steht überall “1000”. Am Speicherplatz sollte es nicht liegen. Habe 35GB frei. Ich seh das Problem auch zum ersten mal. Mein Backend funktioniert soweit auch. Nur eben jedesmal wenn das Browser-Fenster neu geladen wird, taucht das Fenster “Shopware Fehler Reporter” auf, wo ich unten auf “Reload-Modul” klicken kann (ohne Wirkung) oder auf “Abbrechen”.

---

<div class="post-metadata">

### Author: ![mkl1525](https://avatars.discourse-cdn.com/v4/letter/m/c2a13f/32.png) [@mkl1525](https://forum.shopware.com/u/mkl1525)
#### Post date: [18. Juli 2014 um 19:35 UTC](https://forum.shopware.com/t/shopware-fehler-reporter-quot-unable-to-write-file-quot/21405/6 "2014-07-18T19:35:56Z")

</div>

Probier einfach mal, ob du alle Dateien unterhalb von templates zu löschen, funktioniert das? Ist dann der Fehler weg?

---

<div class="post-metadata">

### Author: ![leopard](https://avatars.discourse-cdn.com/v4/letter/l/ee7513/32.png) [@leopard](https://forum.shopware.com/u/leopard)
#### Post date: [18. Juli 2014 um 20:02 UTC](https://forum.shopware.com/t/shopware-fehler-reporter-quot-unable-to-write-file-quot/21405/7 "2014-07-18T20:02:39Z")

</div>

Habe alles löschen können. Als Eigentümer steht dort nun “web1”, so heißt mein Server auch tatsächlich (also ein gutes Zeichen). Die Fehlermeldung im Backend scheint nun auch weg zu sein! Danke :thumbup:
