# shopware.event\_subscriber in service.xml verursacht HTTP ERROR 500

**URL:** https://forum.shopware.com/t/shopware-event-subscriber-in-service-xml-verursacht-http-error-500/46861
**Category:** Programmierung
**Created:** [12. Juli 2017 um 10:17 UTC](https://forum.shopware.com/t/shopware-event-subscriber-in-service-xml-verursacht-http-error-500/46861 "2017-07-12T10:17:19Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![dwaidmann](https://avatars.discourse-cdn.com/v4/letter/d/45deac/32.png) [@dwaidmann](https://forum.shopware.com/u/dwaidmann)
#### Post date: [12. Juli 2017 um 10:17 UTC](https://forum.shopware.com/t/shopware-event-subscriber-in-service-xml-verursacht-http-error-500/46861/1 "2017-07-12T10:17:19Z")

</div>

Hallo Shopware-Community,

wir haben die Shopware-Version 5.2.26 installiert. Dabei&nbsp;testen wir gerade das&nbsp;seit der Version 5.2 enthaltene, neue Plugin-System. Beim Einfügen eines **_Event subsribers_** laut dieser Anleitung [https://developers.shopware.com/developers-guide/plugin-system/#event-subscriber](https://developers.shopware.com/developers-guide/plugin-system/#event-subscriber) lässt sich weder das Frontend, noch das Backend aufrufen. Es erscheint ein HTTP ERROR 500. Wir haben festgestellt, dass der Fehler durch die Zeile

in der Datei _Resources/services.xml_ verursacht wird. Hat jemand das selbe Problem auch schon gehabt, bzw. weiß jemand, wodurch dieser Fehler verursacht wird?

Viele Grüße

Daniel

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;

---

<div class="post-metadata">

### Author: ![Thomas](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/thomas/32/8167_2.png) [@Thomas](https://forum.shopware.com/u/Thomas)
#### Post date: [12. Juli 2017 um 10:30 UTC](https://forum.shopware.com/t/shopware-event-subscriber-in-service-xml-verursacht-http-error-500/46861/2 "2017-07-12T10:30:32Z")

</div>

Hallo Daniel,

kannst Du einmal ein minimalistisches Plugin hier posten was diesen Fehler beinhaltet?

---

<div class="post-metadata">

### Author: ![dwaidmann](https://avatars.discourse-cdn.com/v4/letter/d/45deac/32.png) [@dwaidmann](https://forum.shopware.com/u/dwaidmann)
#### Post date: [12. Juli 2017 um 10:40 UTC](https://forum.shopware.com/t/shopware-event-subscriber-in-service-xml-verursacht-http-error-500/46861/3 "2017-07-12T10:40:03Z")

</div>

Hallo Thomas, da hat sich ein kleiner Fehler in meinem Beitrag eingeschlichen. Der XML-Code wurde ignoriert. Hab ihn jetzt als Codeschnipsel eingefügt. Ich werde dann ein anschauliches Beispiel erstellen und hier im Laufe des Tages posten. Gruß Daniel

---

<div class="post-metadata">

### Author: ![dwaidmann](https://avatars.discourse-cdn.com/v4/letter/d/45deac/32.png) [@dwaidmann](https://forum.shopware.com/u/dwaidmann)
#### Post date: [12. Juli 2017 um 12:19 UTC](https://forum.shopware.com/t/shopware-event-subscriber-in-service-xml-verursacht-http-error-500/46861/4 "2017-07-12T12:19:16Z")

</div>

Hat sich erledigt. Der Pfad war nicht so angelegt wie in dem definierten Namespace des Event Subscribers. Trotzdem Danke für deine angebotene Hilfe, Thomas.
