# Shopware auf ubuntu

**URL:** <https://forum.shopware.com/t/shopware-auf-ubuntu/50154>\
**Category:** Installation/Einstieg\
**Created:** [25. Dezember 2017 um 22:09 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154 "2017-12-25T22:09:11Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![feflered](https://avatars.discourse-cdn.com/v4/letter/f/f07891/32.png) [@feflered](https://forum.shopware.com/u/feflered)\
**Post date:** [25. Dezember 2017 um 22:09 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/1 "2017-12-25T22:09:11Z")

</div>

Installation von shopware startet nicht.

BeimStartversuch über shell &nbsp;kommt folgende Meldung.

&nbsp;

service apache2 restart  
&nbsp;\* Restarting web server apache2 &nbsp; &nbsp; &nbsp; &nbsp;  
[OK]  
php -v  
PHP 7.0.26-2+ubuntu14.04.1+deb.sury.org+2 (cli) (built: Dec &nbsp;7 2017 20:34:48) ( NTS )  
Copyright © 1997-2017 The PHP Group  
Zend Engine v3.0.0, Copyright © 1998-2017 Zend Technologies  
&nbsp; &nbsp; with Zend OPcache v7.0.26-2+ubuntu14.04.1+deb.sury.org+2, Copyright © 1999-2017, by Zend Technologies  
cd /var/www/html/shopware  
php recovery/install/index.php  
PHP Fatal error: &nbsp;Uncaught Error: Call to undefined function Shopware\Recovery\Common\Service\mb\_strlen() in /var/www/html/shopware/recovery/common/src/Service/UniqueIdGenerator.php:72  
Stack trace:  
#0 /var/www/html/shopware/recovery/common/src/Service/UniqueIdGenerator.php(56): Shopware\Recovery\Common\Service\UniqueIdGenerator-\>generateUniqueId()  
#1 /var/www/html/shopware/recovery/install/src/ContainerProvider.php(216): Shopware\Recovery\Common\Service\UniqueIdGenerator-\>getUniqueId()  
#2 /var/www/html/shopware/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install{closure}(Object(Pimple\Container))  
#3 /var/www/html/shopware/recovery/install/src/Command/InstallCommand.php(101): Pimple\Container-\>offsetGet(‘shopware.notify’)  
#4 /var/www/html/shopware/recovery/common/vendor/symfony/console/Symfony/Component/Console/Command/Command.php(257): Shopware\Recovery\Install\Command\InstallCommand-\>execute(Object(Symfony\Component\Console\Input\ArgvInput in /var/www/html/shopware/recovery/common/src/Service/UniqueIdGenerator.php on line 72

Fatal error: Uncaught Error: Call to undefined function Shopware\Recovery\Common\Service\mb\_strlen() in /var/www/html/shopware/recovery/common/src/Service/UniqueIdGenerator.php:72  
Stack trace:  
#0 /var/www/html/shopware/recovery/common/src/Service/UniqueIdGenerator.php(56): Shopware\Recovery\Common\Service\UniqueIdGenerator-\>generateUniqueId()  
#1 /var/www/html/shopware/recovery/install/src/ContainerProvider.php(216): Shopware\Recovery\Common\Service\UniqueIdGenerator-\>getUniqueId()  
#2 /var/www/html/shopware/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install{closure}(Object(Pimple\Container))  
#3 /var/www/html/shopware/recovery/install/src/Command/InstallCommand.php(101): Pimple\Container-\>offsetGet(‘shopware.notify’)  
#4 /var/www/html/shopware/recovery/common/vendor/symfony/console/Symfony/Component/Console/Command/Command.php(257): Shopware\Recovery\Install\Command\InstallCommand-\>execute(Object(Symfony\Component\Console\Input\ArgvInput in /var/www/html/shopware/recovery/common/src/Service/UniqueIdGenerator.php on line 72

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [25. Dezember 2017 um 22:23 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/2 "2017-12-25T22:23:23Z")

</div>

Hast du alle benötigten PHP-Extensions installiert? Z.B. php mbstring?

---

<div class="post-metadata">

**Author:** ![feflered](https://avatars.discourse-cdn.com/v4/letter/f/f07891/32.png) [@feflered](https://forum.shopware.com/u/feflered)\
**Post date:** [25. Dezember 2017 um 22:26 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/3 "2017-12-25T22:26:30Z")

</div>

Wahrscheinlich nicht.

Wo gibt es eine Liste aller benötigen PHP- extensions?

---

<div class="post-metadata">

**Author:** ![feflered](https://avatars.discourse-cdn.com/v4/letter/f/f07891/32.png) [@feflered](https://forum.shopware.com/u/feflered)\
**Post date:** [25. Dezember 2017 um 22:51 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/4 "2017-12-25T22:51:41Z")

</div>

Der Aufruf über Webbrowser unter meinserver/shopware liefert Fehler 500.WordPress auf dem selben Server läuft ohne Probleme.

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [25. Dezember 2017 um 23:27 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/5 "2017-12-25T23:27:44Z")

</div>

beim Aufruf der Installation im Browser müsste es eine checkliste geben mit den Extensions.

---

<div class="post-metadata">

**Author:** ![feflered](https://avatars.discourse-cdn.com/v4/letter/f/f07891/32.png) [@feflered](https://forum.shopware.com/u/feflered)\
**Post date:** [25. Dezember 2017 um 23:52 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/6 "2017-12-25T23:52:44Z")

</div>

Die Installation im Browser startet nicht.

Es kommt Fehler 500 (Server angeblich falsch konfiguriert.

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [26. Dezember 2017 um 08:23 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/7 "2017-12-26T08:23:30Z")

</div>

Im DocumentRoot oder ein darüber ist meist ein Ordner mit requests.log und error.log . Der gibt dir den Fehler an.

---

<div class="post-metadata">

**Author:** ![feflered](https://avatars.discourse-cdn.com/v4/letter/f/f07891/32.png) [@feflered](https://forum.shopware.com/u/feflered)\
**Post date:** [26. Dezember 2017 um 15:56 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/8 "2017-12-26T15:56:27Z")

</div>

Error.log sagt dass .htaccess nicht erlaubt ist.

---

<div class="post-metadata">

**Author:** ![feflered](https://avatars.discourse-cdn.com/v4/letter/f/f07891/32.png) [@feflered](https://forum.shopware.com/u/feflered)\
**Post date:** [26. Dezember 2017 um 16:16 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/9 "2017-12-26T16:16:47Z")

</div>

Habe die Rechte für .htaccess erteilt.Jetzt will die Installation nicht starten weil php5.5.9 erkannt wird. Habe jedoch ein Update auf php7 bereits durchgeführt.

Unter /etc gibt es jedoch ein Verzeichnis PHP5 und ein PHP/7.0.

---

<div class="post-metadata">

**Author:** ![NextMike](https://avatars.discourse-cdn.com/v4/letter/n/838e76/32.png) [@NextMike](https://forum.shopware.com/u/NextMike)\
**Post date:** [26. Dezember 2017 um 17:07 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/10 "2017-12-26T17:07:21Z")

</div>

> **[Shopware Dokumentation](https://docs.shopware.com/de)**

---

<div class="post-metadata">

**Author:** ![feflered](https://avatars.discourse-cdn.com/v4/letter/f/f07891/32.png) [@feflered](https://forum.shopware.com/u/feflered)\
**Post date:** [26. Dezember 2017 um 17:08 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/11 "2017-12-26T17:08:16Z")

</div>

Update auf PHP7 war erfolgreich.

Jetzt möchte shopware aber&nbsp;nicht mehr.

**Fatal error** : Uncaught Error: Call to undefined function Shopware\Recovery\Common\HttpClient\curl\_init() in /var/www/html/shopware/recovery/common/src/HttpClient/CurlClient.php:102 Stack trace: #0 /var/www/html/shopware/recovery/common/src/HttpClient/CurlClient.php(62): Shopware\Recovery\Common\HttpClient\CurlClient-\>call(‚[https://api.sho](https://api.sho)…‘, ‚POST‘, Array, ‚{"additionalDat…‘) #1 /var/www/html/shopware/recovery/common/src/Service/Notification.php(73): Shopware\Recovery\Common\HttpClient\CurlClient-\>post(‚[https://api.sho](https://api.sho)…‘, ‚{"additionalDat…‘) #2 /var/www/html/shopware/recovery/install/src/app.php(206): Shopware\Recovery\Common\Service\Notification-\>doTrackEvent(‚Installer start…‘) #3 [internal function]: {closure}() #4 /var/www/html/shopware/recovery/common/vendor/slim/slim/Slim/Route.php(462): call\_user\_func\_array(Object(Closure), Array) #5 /var/www/html/shopware/recovery/common/vendor/slim/slim/Slim/Slim.php(1326): Slim\Route-\>dispatch() #6 /var/www/html/shopware/recovery/common/vendor/slim/slim/Slim/Middleware/ in **/var/www/html/shopware/recovery/common/src/HttpClient/CurlClient.php** on line **102**

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [26. Dezember 2017 um 19:02 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/12 "2017-12-26T19:02:10Z")

</div>

sieht aus, als ob dir noch php-curl fehlt.

&nbsp;

[https://developers.shopware.com/sysadmins-guide/system-requirements/#required-php-extensions:](https://developers.shopware.com/sysadmins-guide/system-requirements/#required-php-extensions:)

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [28. Dezember 2017 um 09:14 UTC](https://forum.shopware.com/t/shopware-auf-ubuntu/50154/13 "2017-12-28T09:14:33Z")

</div>

```
 apt-get install php7.0-curl service apache2 restart

```

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)
