# Shopware 6 Sicherheits-Plugin. Update auf Version 2.0.2: Internal Server Error

**URL:** <https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718>\
**Category:** Programmierung\
**Created:** [27. Januar 2024 um 20:46 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718 "2024-01-27T20:46:50Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![Lago](https://avatars.discourse-cdn.com/v4/letter/l/e56c9b/32.png) [@Lago](https://forum.shopware.com/u/Lago)\
**Post date:** [27. Januar 2024 um 20:46 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/1 "2024-01-27T20:46:50Z")

</div>

Hallo zusammen,

hat noch jemand das gleiche Problem? Es geht um Shopware 6 Sicherheits-Plugin. Update auf Version 2.0.2 bringt Fehlermeldung „Internal Server Error“:

=========================

Attempted to load class „UpdateHtaccess“ from namespace „Swag\Security\Components“. Did you forget a „use“ statement for „Shopware\Core\Framework\Update\Services\UpdateHtaccess“?

=========================

Hätte ich allen gehabt, dann würde vielleicht nicht fragen, aber es sind drei verschiedene Shop mit dem gleichen Ergebnis. Es handelt sich scheinbar um einen Fehler in der Programmierung. Die Fehlermeldung besagt, das anscheinend eine Klasse nicht geladen werden kann „UpdateHtaccess“. Hier kann die Ursache sein, dass eine bestimmte Datei vergessen wurde einzubinden (use), welche die Klasse entweder erstellt oder in dieser angelegt ist.

Ich freue mich auf eine Antwort.

Mit besten Grüßen  
Lago

---

<div class="post-metadata">

**Author:** ![Benjamin\_Hummel](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/benjamin_hummel/32/25953_2.png) [@Benjamin\_Hummel](https://forum.shopware.com/u/Benjamin_Hummel)\
**Post date:** [28. Januar 2024 um 17:13 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/2 "2024-01-28T17:13:59Z")

</div>

Moin Lago,

vielleicht wieder ein Problem mit dem OPCache? Alle drei Shops mit OPAchea vielleicht und dort liegen noch Reste einer alten Version? Setzt den OPCache mal mit deinem Hoster zurück.

VG Benjamin

---

<div class="post-metadata">

**Author:** ![hanfmuffel](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/hanfmuffel/32/21204_2.png) [@hanfmuffel](https://forum.shopware.com/u/hanfmuffel)\
**Post date:** [28. Januar 2024 um 17:14 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/3 "2024-01-28T17:14:45Z")

</div>

danke für den hinweis. werde auch erstmal eine updatepause einlegen. da ist irgendwie gerade der wurm drin.

---

<div class="post-metadata">

**Author:** ![Lago](https://avatars.discourse-cdn.com/v4/letter/l/e56c9b/32.png) [@Lago](https://forum.shopware.com/u/Lago)\
**Post date:** [28. Januar 2024 um 20:24 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/4 "2024-01-28T20:24:53Z")

</div>

Hallo Benjamin,

Danke für die schnelle Antwort. 🙂

Ja, ich habe auch schon so gedacht und habe All Inkl bereits angeschrieben. MAl schauen was die sagen. Aber die erste Vermutung ist wie gesagt, dass eine bestimmte Datei vergessen wurde einzubinden (use), welche die Klasse entweder erstellt oder in dieser angelegt ist.

Ich melde mich sobald ich Antwort von All Inkl kriege. 😉

Mit besten Grüßen  
Lago

---

<div class="post-metadata">

**Author:** ![Lago](https://avatars.discourse-cdn.com/v4/letter/l/e56c9b/32.png) [@Lago](https://forum.shopware.com/u/Lago)\
**Post date:** [29. Januar 2024 um 13:47 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/5 "2024-01-29T13:47:07Z")

</div>

Hallo zusammen,

OPCache gelöscht, Cache geleert und aufgewärmt, Update gestartet, gleiche Fehlermeldung erhalten. D.h. es liegt doch nicht an OPCache…

Mit besten Grüßen  
Lago

---

<div class="post-metadata">

**Author:** ![eckert](https://avatars.discourse-cdn.com/v4/letter/e/dc4da7/32.png) [@eckert](https://forum.shopware.com/u/eckert)\
**Post date:** [29. Januar 2024 um 14:43 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/6 "2024-01-29T14:43:07Z")

</div>

Hab das Problem auch, hab das update mal liegen lassen.

---

<div class="post-metadata">

**Author:** ![Lago](https://avatars.discourse-cdn.com/v4/letter/l/e56c9b/32.png) [@Lago](https://forum.shopware.com/u/Lago)\
**Post date:** [29. Januar 2024 um 15:07 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/7 "2024-01-29T15:07:40Z")

</div>

Vielen Dank für die Meldung!

Also, dann sind doch mehrere betroffen. Ich tippe jetzt auf eine Datei, die beim letzten oder aktuellem Update fehlerhaft war/ist. 🙂

---

<div class="post-metadata">

**Author:** ![MarcSch](https://avatars.discourse-cdn.com/v4/letter/m/a87d85/32.png) [@MarcSch](https://forum.shopware.com/u/MarcSch)\
**Post date:** [30. Januar 2024 um 06:30 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/8 "2024-01-30T06:30:03Z")

</div>

Habe ebenfalls die gleiche Fehlermeldung. Hosting auch bei all-inkl …

Edit: Das Update von Shopware 6.5.7.2 auf 6.5.8.2 hat am Problem auch nichts geändert. Kann das Sicherheitsplugin nicht mehr installieren.

```auto
Attempted to load class "UpdateHtaccess" from namespace "Swag\Security\Components". Did you forget a "use" statement for "Shopware\Core\Framework\Update\Services\UpdateHtaccess"?

```

---

<div class="post-metadata">

**Author:** ![sven666](https://avatars.discourse-cdn.com/v4/letter/s/bc8723/32.png) [@sven666](https://forum.shopware.com/u/sven666)\
**Post date:** [30. Januar 2024 um 13:55 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/9 "2024-01-30T13:55:26Z")

</div>

Schliesse mich an, wir sind bei DF auf 6.5.7.3, gleicher Fehler…

---

<div class="post-metadata">

**Author:** ![jonas-sfx](https://avatars.discourse-cdn.com/v4/letter/j/a9a28c/32.png) [@jonas-sfx](https://forum.shopware.com/u/jonas-sfx)\
**Post date:** [30. Januar 2024 um 16:25 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/10 "2024-01-30T16:25:42Z")

</div>

Ist das Security-Plugin nicht einfach der Plan B, wenn ich Lücken nicht mehr per Update patchen kann, weil hier entweder keins mehr rauskommt, oder ich aus irgendwelchen Gründen damit noch warten muss.

Ich frag, weil dann für die neuste Core-Version und die, die noch gepatcht werden/wurden ja niemand einfach mal prophylaktisch ein Security-Plugin installieren muss.

Wenn ich mein Security-Plugin dann genau so schlecht mit Updates versorge wie den Core, hab ich evtl. so gar nichts dabei gewonnen. Oder?

---

<div class="post-metadata">

**Author:** ![Lago](https://avatars.discourse-cdn.com/v4/letter/l/e56c9b/32.png) [@Lago](https://forum.shopware.com/u/Lago)\
**Post date:** [15. Februar 2024 um 11:22 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/11 "2024-02-15T11:22:00Z")

</div>

Hallo zusammen,

Nachtrag. Jetzt ist auch Plugin „Shopware Store“ betroffen. Wenn man den aktualisieren will dann wird alles zerschossen… Und das sind alles eigene Plugins von Shopware… Von anderen Anbietern läuft alles wie es sein muss. 🙂

Mit besten Grüßen  
Lago

---

<div class="post-metadata">

**Author:** ![intex](https://avatars.discourse-cdn.com/v4/letter/i/e36b37/32.png) [@intex](https://forum.shopware.com/u/intex)\
**Post date:** [25. Februar 2024 um 12:18 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/12 "2024-02-25T12:18:09Z")

</div>

Kann ebenfalls nicht updaten

---

<div class="post-metadata">

**Author:** ![Benjamin\_Hummel](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/benjamin_hummel/32/25953_2.png) [@Benjamin\_Hummel](https://forum.shopware.com/u/Benjamin_Hummel)\
**Post date:** [25. Februar 2024 um 20:00 UTC](https://forum.shopware.com/t/shopware-6-sicherheits-plugin-update-auf-version-2-0-2-internal-server-error/102718/13 "2024-02-25T20:00:03Z")

</div>

Nabend,

OPcache schon als Ursache ausgeschlossen?

> **[How To Clear PHP’s Opcache](https://ma.ttias.be/how-to-clear-php-opcache/)**
>
> PHP can be configured to store precompiled bytecode in shared memory, called Opcache. It prevents the loading and parsing of PHP scripts on every request. This guide will tell you how to flush that bytecode Opcache, should you need it.

Determine your PHP method

Anwendung auf eigene Gefahr und nur mit entsprechendem Wissen/Backup bitte 🙂. Ansonsten Hoster ansprechen.

VG Benjamin
