# Shopware 6 lokale Installation

**URL:** <https://forum.shopware.com/t/shopware-6-lokale-installation/59674>\
**Category:** Installation / Einstieg\
**Created:** [23. Mai 2019 um 10:04 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674 "2019-05-23T10:04:09Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![Larineso](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@Larineso](https://forum.shopware.com/u/Larineso)\
**Post date:** [23. Mai 2019 um 10:04 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/1 "2019-05-23T10:04:09Z")

</div>

Hallo,

leider scheitern meine Versuche Shopware 6 lokal zu installieren. Schon beim Befehl&nbsp;

```
git clone git@github.com:shopware/development.git

```

bekomme ich die eine Fehlermeldung:&nbsp;

Cloning into ‘development’…

[git@github.com](mailto:git@github.com): Permission denied (publickey).

fatal: Could not read from remote repository.

&nbsp;

Gibt es keine einfache Möglichkeit wie bei der normalen Shopware 5 Installation?

Also einfach die Datei entpacken, in das FTP-Verzeichnis und installieren?

&nbsp;

Liebe Grüße

---

<div class="post-metadata">

**Author:** ![wontfix](https://avatars.discourse-cdn.com/v4/letter/w/b19c9b/32.png) [@wontfix](https://forum.shopware.com/u/wontfix)\
**Post date:** [23. Mai 2019 um 10:17 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/2 "2019-05-23T10:17:21Z")

</div>

git “protocol” braucht ne ssh schlüssel. wenn du keine hast, benutze https protocol:

```
git clone https://github.com/shopware/development.git

```

ps. hab eben die docker methode probiert, funktioniert wunderbar. und wow, shopware war sehr fleisig, veeeery niiiice!

---

<div class="post-metadata">

**Author:** ![DenKon26](https://avatars.discourse-cdn.com/v4/letter/d/5e9695/32.png) [@DenKon26](https://forum.shopware.com/u/DenKon26)\
**Post date:** [23. Mai 2019 um 10:32 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/3 "2019-05-23T10:32:26Z")

</div>

Ich kriege beim Ausführen des Befehls

```
./psh.phar docker:start

```

folgenden Fehler:

```
Starting Execution of 'docker:start' ('C:\Workspace\konoppa\shopware6\development/dev-ops/docker/actions/start.sh')

PHP Fatal error: Uncaught Symfony\Component\Process\Exception\ProcessFailedException: The command "id -u" failed.

Exit Code: 1(General error)

Working directory: C:\Workspace\konoppa\shopware6\development

Output:
================

Error Output:
================
 in phar://C:/Workspace/konoppa/shopware6/development/psh.phar/vendor/symfony/process/Process.php:232
Stack trace:
#0 phar://C:/Workspace/konoppa/shopware6/development/psh.phar/src/ScriptRuntime/ProcessValueProvider.php(27): Symfony\Component\Process\Process->mustRun()
#1 phar://C:/Workspace/konoppa/shopware6/development/psh.phar/src/ScriptRuntime/TemplateEngine.php(51): Shopware\Psh\ScriptRuntime\ProcessValueProvider->getValue()
#2 phar://C:/Workspace/konoppa/shopware6/development/psh.phar/src/ScriptRuntime/TemplateEngine.php(26): Shopware\Psh\ScriptRuntime\TemplateEngine->getValue(' __USER_ID__', Array)
#3 phar://C:/Workspace/konoppa/shopware6/development/psh.phar/src/ScriptRuntime/ProcessExecutor.php(214): Shopware\Psh\ScriptRuntime\TemplateEngine->render('#overri in phar://C:/Workspace/konoppa/shopware6/development/psh.phar/vendor/symfony/process/Process.php on line 232

Fatal error: Uncaught Symfony\Component\Process\Exception\ProcessFailedException: The command "id -u" failed.

Exit Code: 1(General error)

Working directory: C:\Workspace\konoppa\shopware6\development

```

Jemand eine Idee?

---

<div class="post-metadata">

**Author:** ![wontfix](https://avatars.discourse-cdn.com/v4/letter/w/b19c9b/32.png) [@wontfix](https://forum.shopware.com/u/wontfix)\
**Post date:** [23. Mai 2019 um 10:38 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/4 "2019-05-23T10:38:55Z")

</div>

hat dein host system denn befehl `id`?

```
> id -u
1000

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![DenKon26](https://avatars.discourse-cdn.com/v4/letter/d/5e9695/32.png) [@DenKon26](https://forum.shopware.com/u/DenKon26)\
**Post date:** [23. Mai 2019 um 10:42 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/5 "2019-05-23T10:42:47Z")

</div>

> [@wontfix schrieb:](https://forum.shopware.com/profile/21043/wontfix "wontfix")
> 
> hat dein host system denn befehl `id`?
> 
> > id -u  
> > 1000
> 
> &nbsp;
> 
> &nbsp;

Ich erhalte:

&nbsp;

```
id -u
1055091

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![wontfix](https://avatars.discourse-cdn.com/v4/letter/w/b19c9b/32.png) [@wontfix](https://forum.shopware.com/u/wontfix)\
**Post date:** [23. Mai 2019 um 10:44 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/6 "2019-05-23T10:44:35Z")

</div>

> Working directory: C:\Workspace\konoppa\shopware6\development

hmm, bist du auf ms-windows?

wenn ja, weiss nicht ob das unterstütz wird…

leider sagt der fehler nicht was genau nicht geklappt hat…

---

<div class="post-metadata">

**Author:** ![DenKon26](https://avatars.discourse-cdn.com/v4/letter/d/5e9695/32.png) [@DenKon26](https://forum.shopware.com/u/DenKon26)\
**Post date:** [23. Mai 2019 um 10:47 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/7 "2019-05-23T10:47:28Z")

</div>

Ja aktuell Windows 10.

&nbsp;

Macht offenbar Probleme ☹

---

<div class="post-metadata">

**Author:** ![wontfix](https://avatars.discourse-cdn.com/v4/letter/w/b19c9b/32.png) [@wontfix](https://forum.shopware.com/u/wontfix)\
**Post date:** [23. Mai 2019 um 10:51 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/8 "2019-05-23T10:51:20Z")

</div>

vielleicht WSL probieren?  
[Install Windows Subsystem for Linux (WSL) on Windows 10 | Microsoft Docs](https://docs.microsoft.com/en-us/windows/wsl/install-win10)

ich hab meine test in ms-windows 7 mit archlinux in vagrant gemacht. und in archlinux dann deren docker image geladen. vm inception!

---

<div class="post-metadata">

**Author:** ![DenKon26](https://avatars.discourse-cdn.com/v4/letter/d/5e9695/32.png) [@DenKon26](https://forum.shopware.com/u/DenKon26)\
**Post date:** [23. Mai 2019 um 11:05 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/9 "2019-05-23T11:05:24Z")

</div>

werde ich später mal ausprobieren. ich gebe Bescheid! Danke!

---

<div class="post-metadata">

**Author:** ![Larineso](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@Larineso](https://forum.shopware.com/u/Larineso)\
**Post date:** [23. Mai 2019 um 11:35 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/10 "2019-05-23T11:35:26Z")

</div>

> [@wontfix schrieb:](https://forum.shopware.com/profile/21043/wontfix "wontfix")
> 
> git „protocol“ braucht ne ssh schlüssel. wenn du keine hast, benutze https protocol:
> 
> git clone [GitHub - shopware/development](https://github.com/shopware/development.git)
> 
> ps. hab eben die docker methode probiert, funktioniert wunderbar. und wow, shopware war sehr fleisig, veeeery niiiice!

Das hat funktioniert, vielen Dank!

Dem kann ich nur zustimmen, Shopware 6 ist ein Traum.

---

<div class="post-metadata">

**Author:** ![Larineso](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@Larineso](https://forum.shopware.com/u/Larineso)\
**Post date:** [23. Mai 2019 um 12:17 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/11 "2019-05-23T12:17:47Z")

</div>

Bei mir läuft Shopware 6 über Docker und funktioniert ohne Fehler. Allerdings habe ich Ladezeiten von 1-2 Minuten. Gibt es eine Möglichkeit das zu ändern oder ist mein Macbook zu langsam? Habe das 12" Macbook, das bekanntlich nicht sonderlich schnell ist.&nbsp;

---

<div class="post-metadata">

**Author:** ![Whynot](https://avatars.discourse-cdn.com/v4/letter/w/c77e96/32.png) [@Whynot](https://forum.shopware.com/u/Whynot)\
**Post date:** [23. Mai 2019 um 16:33 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/12 "2019-05-23T16:33:03Z")

</div>

Hallo zusammen,

ich habe eine Lokale Installation ohne Docker probiert und hänge am Befehl:&nbsp;&nbsp;./psh.phar install

Schritt 3 bemängelt die Zugriffsdaten für die MySQL Datenbank.

Er scheint sich diese Daten aus der .env (symfony 4) zu ziehen. Wenn ich diese Datei allerdings anpasse und den oben genannten Befehl ausführe, kommt der Fehler erneut und die .env wurde zurück gesetzt? Wo muss ich die Zugriffsdaten für die MySQL pflegen?

VG

&nbsp;

---

<div class="post-metadata">

**Author:** ![Patrick\_Stahl](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/patrick_stahl/32/7679_2.png) [@Patrick\_Stahl](https://forum.shopware.com/u/Patrick_Stahl)\
**Post date:** [23. Mai 2019 um 17:22 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/13 "2019-05-23T17:22:29Z")

</div>

Moin @Whynot‍,

hast du bei dir mal&nbsp;\_[bin/setup](https://docs.shopware.com/en/shopware-platform-dev-en/getting-started/installation-guide#setting-up-shopware)&nbsp;\_im Shopware Development Verzeichnis ausgeführt?  
Das müsste dich dann nach den Credentials fragen und in einer Datei namens `psh.yaml.override` hinterlegen, wenn ich mich richtig erinnere.

Gruß,  
Patrick&nbsp; ![Shopware](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/86c57fbace799dd4eb1f1b8a2d3bdc1733f0aea1.png "Shopware")

---

<div class="post-metadata">

**Author:** ![Whynot](https://avatars.discourse-cdn.com/v4/letter/w/c77e96/32.png) [@Whynot](https://forum.shopware.com/u/Whynot)\
**Post date:** [24. Mai 2019 um 06:23 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/14 "2019-05-24T06:23:38Z")

</div>

> [@Patrick Stahl schrieb:](https://forum.shopware.com/profile/1869/Patrick%20Stahl "Patrick%20Stahl")
> 
> Moin @Whynot‍,
> 
> hast du bei dir mal&nbsp;\_[bin/setup](https://docs.shopware.com/en/shopware-platform-dev-en/getting-started/installation-guide#setting-up-shopware)&nbsp;\_im Shopware Development Verzeichnis ausgeführt?  
> Das müsste dich dann nach den Credentials fragen und in einer Datei namens `psh.yaml.override` hinterlegen, wenn ich mich richtig erinnere.
> 
> Gruß,  
> Patrick&nbsp; ![Shopware](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/86c57fbace799dd4eb1f1b8a2d3bdc1733f0aea1.png "Shopware")

Hi,

hatte den Fehler dann gefunden - aber korrekt - falsche Datei durchgeführt.

---

<div class="post-metadata">

**Author:** ![Whynot](https://avatars.discourse-cdn.com/v4/letter/w/c77e96/32.png) [@Whynot](https://forum.shopware.com/u/Whynot)\
**Post date:** [24. Mai 2019 um 06:25 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/15 "2019-05-24T06:25:18Z")

</div>

Hallo,

ich hänge inzwischen an einem anderen Problem.

Beim Aufruf des Frontends oder dem Adminbereich kommt ein 500er Error:

```
Key path "file:///home/vagrant/web/xxx/config/jwt/public.pem" does not exist or is not readable

```

Hat hier jemand eine Idee?

VG

Christian

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [24. Mai 2019 um 06:34 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/16 "2019-05-24T06:34:27Z")

</div>

Das ist ein Problem mit den Schreib-/Leserechten. Die Datei darf nur für den Webserver/PHP lesbar sein. Am besten die Besitzrechte der Dabei überprüfen und dann die korrekten Zugriffsrechte (readable) setzen. 0777 ist zu offen und macht Probleme.&nbsp;

Hat wenig mit Shopware zu tun, sondern mehr mit den Besitzrechten unter UNIX. Bei Vagrant weiß ich allerdings nicht, ob es da einen eigenen User gibt, oder ob die einzelnen Prozesse auch unterschiedliche User haben (bspw. Apache, PHP, …).

---

<div class="post-metadata">

**Author:** ![DenKon26](https://avatars.discourse-cdn.com/v4/letter/d/5e9695/32.png) [@DenKon26](https://forum.shopware.com/u/DenKon26)\
**Post date:** [24. Mai 2019 um 06:36 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/17 "2019-05-24T06:36:00Z")

</div>

Ich kriege es leider nach wie vor nicht zum laufen. Habe es jetzt in einer Vagrant Maschine geklont und dort Docker installiert.

beim Befehl

```
./psh.phar install

```

Bricht die Installation nach den Datenbank Operationen ab mit folgendem Error:

```
 Unable to save binary /app/platform/src/Administration/Resources/administration/node_modules/node-sass/vendor/linux-x64-67 : { Error: EACCES: permission denied, mkdir '/app/platform/src/Administration/Resources/administration/node_modules/node-sass/vendor'
            at Object.mkdirSync (fs.js:773:3)
            at sync (/app/platform/src/Administration/Resources/administration/node_modules/mkdirp/index.js:71:13)
            at Function.sync (/app/platform/src/Administration/Resources/administration/node_modules/mkdirp/index.js:77:24)
            at checkAndDownloadBinary (/app/platform/src/Administration/Resources/administration/node_modules/node-sass/scripts/install.js:114:11)
            at Object. (/app/platform/src/Administration/Resources/administration/node_modules/node-sass/scripts/install.js:157:1)
            at Module._compile (internal/modules/cjs/loader.js:816:30)
            at Object.Module._extensions..js (internal/modules/cjs/loader.js:827:10)
            at Module.load (internal/modules/cjs/loader.js:685:32)
            at Function.Module._load (internal/modules/cjs/loader.js:620:12)
            at Function.Module.runMain (internal/modules/cjs/loader.js:877:12)
          errno: -13,
          syscall: 'mkdir',
          code: 'EACCES',
          path:
           '/app/platform/src/Administration/Resources/administration/node_modules/node-sass/vendor' }
        
        > node-sass@4.12.0 postinstall /app/vendor/shopware/platform/src/Administration/Resources/administration/node_modules/node-sass
        > node scripts/build.js
        
        Building: /usr/bin/node /app/platform/src/Administration/Resources/administration/node_modules/node-gyp/bin/node-gyp.js rebuild --verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library=
        gyp info it worked if it ends with ok
        gyp verb cli [ '/usr/bin/node',
        gyp verb cli '/app/platform/src/Administration/Resources/administration/node_modules/node-gyp/bin/node-gyp.js',
        gyp verb cli 'rebuild',
        gyp verb cli '--verbose',
        gyp verb cli '--libsass_ext=',
        gyp verb cli '--libsass_cflags=',
        gyp verb cli '--libsass_ldflags=',
        gyp verb cli '--libsass_library=' ]
        gyp info using node-gyp@3.8.0
        gyp info using node@11.15.0 | linux | x64
        gyp verb command rebuild []
        gyp verb command clean []
        gyp verb clean removing "build" directory
        gyp verb command configure []
        gyp verb check python checking for Python executable "python2" in the PATH
        gyp verb `which` succeeded python2 /usr/bin/python2
        gyp verb check python version `/usr/bin/python2 -c "import sys; print "2.7.13
        gyp verb check python version .%s.%s" % sys.version_info[:3];"` returned: %j
        gyp verb get node dir no --target version specified, falling back to host node version: 11.15.0
        gyp verb command install ['11.15.0']
        gyp verb install input version string "11.15.0"
        gyp verb install installing version: 11.15.0
        gyp verb install --ensure was passed, so won't reinstall if already installed
        gyp WARN EACCES user "undefined" does not have permission to access the dev dir "/root/.node-gyp/11.15.0"
        gyp WARN EACCES attempting to reinstall using temporary dev dir "/app/vendor/shopware/platform/src/Administration/Resources/administration/node_modules/node-sass/.node-gyp"
        gyp verb command install ['--node_gyp_internal_noretry', '11.15.0']
        gyp verb install input version string "11.15.0"
        gyp verb install installing version: 11.15.0
        gyp verb install --ensure was passed, so won't reinstall if already installed
        gyp verb install version not already installed, continuing with install 11.15.0
        gyp verb ensuring nodedir is created /app/vendor/shopware/platform/src/Administration/Resources/administration/node_modules/node-sass/.node-gyp/11.15.0
        gyp WARN install got an error, rolling back install
        gyp verb command remove ['11.15.0']
        gyp verb remove using node-gyp dir: /app/vendor/shopware/platform/src/Administration/Resources/administration/node_modules/node-sass/.node-gyp
        gyp verb remove removing target version: 11.15.0
        gyp verb remove removing development files for version: 11.15.0
        gyp WARN install got an error, rolling back install
        gyp verb command remove ['11.15.0']
        gyp verb remove using node-gyp dir: /app/vendor/shopware/platform/src/Administration/Resources/administration/node_modules/node-sass/.node-gyp
        gyp verb remove removing target version: 11.15.0
        gyp verb remove removing development files for version: 11.15.0
        gyp ERR! configure error 
        gyp ERR! stack Error: EACCES: permission denied, mkdir '/app/vendor/shopware/platform/src/Administration/Resources/administration/node_modules/node-sass/.node-gyp'
        gyp ERR! System Linux 4.4.0-87-generic
        gyp ERR! command "/usr/bin/node" "/app/platform/src/Administration/Resources/administration/node_modules/node-gyp/bin/node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
        gyp ERR! cwd /app/platform/src/Administration/Resources/administration/node_modules/node-sass
        gyp ERR! node -v v11.15.0
        gyp ERR! node-gyp -v v3.8.0
        gyp ERR! not ok 
        Build failed with error code: 1
        npm ERR! code ELIFECYCLE
        npm ERR! errno 1
        npm ERR! node-sass@4.12.0 postinstall: `node scripts/build.js`
        npm ERR! Exit status 1
        npm ERR! 
        npm ERR! Failed at the node-sass@4.12.0 postinstall script.
        npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
        
        npm ERR! A complete log of this run can be found in:
        npm ERR! /.npm/_logs/2019-05-24T06_31_12_130Z-debug.log
        
Execution aborted, a subcommand failed!

```

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [24. Mai 2019 um 06:39 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/18 "2019-05-24T06:39:04Z")

</div>

> [@DenKon26 schrieb:](https://forum.shopware.com/profile/21548/DenKon26 "DenKon26")
> 
> Ich kriege es leider nach wie vor nicht zum laufen. Habe es jetzt in einer Vagrant Maschine geklont und dort Docker installiert.
> 
> beim Befehl
> 
> ./psh.phar install
> 
> Bricht die Installation nach den Datenbank Operationen ab mit folgendem Error:
> 
> Unable to save binary /app/platform/src/Administration/Resources/administration/node\_modules/node-sass/vendor/linux-x64-67 : { Error: EACCES: permission denied, mkdir ‚/app/platform/src/Administration/Resources/administration/node\_modules/node-sass/vendor‘  
> at Object.mkdirSync (fs.js:773:3)  
> at sync (/app/platform/src/Administration/Resources/administration/node\_modules/mkdirp/index.js:71:13)  
> at Function.sync (/app/platform/src/Administration/Resources/administration/node\_modules/mkdirp/index.js:77:24)  
> at checkAndDownloadBinary (/app/platform/src/Administration/Resources/administration/node\_modules/node-sass/scripts/install.js:114:11)  
> at Object. (/app/platform/src/Administration/Resources/administration/node\_modules/node-sass/scripts/install.js:157:1)  
> at Module.\_compile (internal/modules/cjs/loader.js:816:30)  
> at Object.Module.\_extensions…js (internal/modules/cjs/loader.js:827:10)  
> at Module.load (internal/modules/cjs/loader.js:685:32)  
> at Function.Module.\_load (internal/modules/cjs/loader.js:620:12)  
> at Function.Module.runMain (internal/modules/cjs/loader.js:877:12)  
> errno: -13,  
> syscall: ‚mkdir‘,  
> code: ‚EACCES‘,  
> path:  
> ‚/app/platform/src/Administration/Resources/administration/node\_modules/node-sass/vendor‘ }
> 
> > node-sass@4.12.0 postinstall /app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass  
> > node scripts/build.js
> 
> Building: /usr/bin/node /app/platform/src/Administration/Resources/administration/node\_modules/node-gyp/bin/node-gyp.js rebuild --verbose --libsass\_ext= --libsass\_cflags= --libsass\_ldflags= --libsass\_library=  
> gyp info it worked if it ends with ok  
> gyp verb cli [ ‚/usr/bin/node‘,  
> gyp verb cli ‚/app/platform/src/Administration/Resources/administration/node\_modules/node-gyp/bin/node-gyp.js‘,  
> gyp verb cli ‚rebuild‘,  
> gyp verb cli ‚–verbose‘,  
> gyp verb cli ‚–libsass\_ext=‘,  
> gyp verb cli ‚–libsass\_cflags=‘,  
> gyp verb cli ‚–libsass\_ldflags=‘,  
> gyp verb cli ‚–libsass\_library=‘ ]  
> gyp info using node-gyp@3.8.0  
> gyp info using node@11.15.0 | linux | x64  
> gyp verb command rebuild   
> gyp verb command clean   
> gyp verb clean removing „build“ directory  
> gyp verb command configure   
> gyp verb check python checking for Python executable „python2“ in the PATH  
> gyp verb `which` succeeded python2 /usr/bin/python2  
> gyp verb check python version `/usr/bin/python2 -c "import sys; print "2.7.13 gyp verb check python version .%s.%s" % sys.version_info[:3];"` returned: %j  
> gyp verb get node dir no --target version specified, falling back to host node version: 11.15.0  
> gyp verb command install [‚11.15.0‘]  
> gyp verb install input version string „11.15.0“  
> gyp verb install installing version: 11.15.0  
> gyp verb install --ensure was passed, so won’t reinstall if already installed  
> gyp WARN EACCES user „undefined“ does not have permission to access the dev dir „/root/.node-gyp/11.15.0“  
> gyp WARN EACCES attempting to reinstall using temporary dev dir „/app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass/.node-gyp“  
> gyp verb command install [‚–node\_gyp\_internal\_noretry‘, ‚11.15.0‘]  
> gyp verb install input version string „11.15.0“  
> gyp verb install installing version: 11.15.0  
> gyp verb install --ensure was passed, so won’t reinstall if already installed  
> gyp verb install version not already installed, continuing with install 11.15.0  
> gyp verb ensuring nodedir is created /app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass/.node-gyp/11.15.0  
> gyp WARN install got an error, rolling back install  
> gyp verb command remove [‚11.15.0‘]  
> gyp verb remove using node-gyp dir: /app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass/.node-gyp  
> gyp verb remove removing target version: 11.15.0  
> gyp verb remove removing development files for version: 11.15.0  
> gyp WARN install got an error, rolling back install  
> gyp verb command remove [‚11.15.0‘]  
> gyp verb remove using node-gyp dir: /app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass/.node-gyp  
> gyp verb remove removing target version: 11.15.0  
> gyp verb remove removing development files for version: 11.15.0  
> gyp ERR! configure error  
> gyp ERR! stack Error: EACCES: permission denied, mkdir ‚/app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass/.node-gyp‘  
> gyp ERR! System Linux 4.4.0-87-generic  
> gyp ERR! command „/usr/bin/node“ „/app/platform/src/Administration/Resources/administration/node\_modules/node-gyp/bin/node-gyp.js“ „rebuild“ „–verbose“ „–libsass\_ext=“ „–libsass\_cflags=“ „–libsass\_ldflags=“ „–libsass\_library=“  
> gyp ERR! cwd /app/platform/src/Administration/Resources/administration/node\_modules/node-sass  
> gyp ERR! node -v v11.15.0  
> gyp ERR! node-gyp -v v3.8.0  
> gyp ERR! not ok  
> Build failed with error code: 1  
> npm ERR! code ELIFECYCLE  
> npm ERR! errno 1  
> npm ERR! node-sass@4.12.0 postinstall: `node scripts/build.js`  
> npm ERR! Exit status 1  
> npm ERR!  
> npm ERR! Failed at the node-sass@4.12.0 postinstall script.  
> npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
> 
> npm ERR! A complete log of this run can be found in:  
> npm ERR! /.npm/\_logs/2019-05-24T06\_31\_12\_130Z-debug.log
> 
> Execution aborted, a subcommand failed!
> 
> &nbsp;
> 
> &nbsp;

Komplett anderes Problem. Du haste NodeJS 12 - das läuft damit nicht. Du müsstest ein Downgrade auf 11 machen, dann tritt der Fehler auch nicht auf.&nbsp;

---

<div class="post-metadata">

**Author:** ![Larineso](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@Larineso](https://forum.shopware.com/u/Larineso)\
**Post date:** [24. Mai 2019 um 06:45 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/19 "2019-05-24T06:45:32Z")

</div>

> [@Larineso schrieb:](https://forum.shopware.com/profile/29313/Larineso "Larineso")
> 
> Bei mir läuft Shopware 6 über Docker und funktioniert ohne Fehler. Allerdings habe ich Ladezeiten von 1-2 Minuten. Gibt es eine Möglichkeit das zu ändern oder ist mein Macbook zu langsam? Habe das 12" Macbook, das bekanntlich nicht sonderlich schnell ist.&nbsp;

Hat jemand eine Idee woran das liegt?

---

<div class="post-metadata">

**Author:** ![DenKon26](https://avatars.discourse-cdn.com/v4/letter/d/5e9695/32.png) [@DenKon26](https://forum.shopware.com/u/DenKon26)\
**Post date:** [24. Mai 2019 um 06:49 UTC](https://forum.shopware.com/t/shopware-6-lokale-installation/59674/20 "2019-05-24T06:49:05Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> > [@DenKon26 schrieb:](https://forum.shopware.com/profile/21548/DenKon26 "DenKon26")
> > 
> > Ich kriege es leider nach wie vor nicht zum laufen. Habe es jetzt in einer Vagrant Maschine geklont und dort Docker installiert.
> > 
> > beim Befehl
> > 
> > ./psh.phar install
> > 
> > Bricht die Installation nach den Datenbank Operationen ab mit folgendem Error:
> > 
> > Unable to save binary /app/platform/src/Administration/Resources/administration/node\_modules/node-sass/vendor/linux-x64-67 : { Error: EACCES: permission denied, mkdir ‚/app/platform/src/Administration/Resources/administration/node\_modules/node-sass/vendor‘  
> > at Object.mkdirSync (fs.js:773:3)  
> > at sync (/app/platform/src/Administration/Resources/administration/node\_modules/mkdirp/index.js:71:13)  
> > at Function.sync (/app/platform/src/Administration/Resources/administration/node\_modules/mkdirp/index.js:77:24)  
> > at checkAndDownloadBinary (/app/platform/src/Administration/Resources/administration/node\_modules/node-sass/scripts/install.js:114:11)  
> > at Object. (/app/platform/src/Administration/Resources/administration/node\_modules/node-sass/scripts/install.js:157:1)  
> > at Module.\_compile (internal/modules/cjs/loader.js:816:30)  
> > at Object.Module.\_extensions…js (internal/modules/cjs/loader.js:827:10)  
> > at Module.load (internal/modules/cjs/loader.js:685:32)  
> > at Function.Module.\_load (internal/modules/cjs/loader.js:620:12)  
> > at Function.Module.runMain (internal/modules/cjs/loader.js:877:12)  
> > errno: -13,  
> > syscall: ‚mkdir‘,  
> > code: ‚EACCES‘,  
> > path:  
> > ‚/app/platform/src/Administration/Resources/administration/node\_modules/node-sass/vendor‘ }
> > 
> > > node-sass@4.12.0 postinstall /app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass  
> > > node scripts/build.js
> > 
> > Building: /usr/bin/node /app/platform/src/Administration/Resources/administration/node\_modules/node-gyp/bin/node-gyp.js rebuild --verbose --libsass\_ext= --libsass\_cflags= --libsass\_ldflags= --libsass\_library=  
> > gyp info it worked if it ends with ok  
> > gyp verb cli [ ‚/usr/bin/node‘,  
> > gyp verb cli ‚/app/platform/src/Administration/Resources/administration/node\_modules/node-gyp/bin/node-gyp.js‘,  
> > gyp verb cli ‚rebuild‘,  
> > gyp verb cli ‚–verbose‘,  
> > gyp verb cli ‚–libsass\_ext=‘,  
> > gyp verb cli ‚–libsass\_cflags=‘,  
> > gyp verb cli ‚–libsass\_ldflags=‘,  
> > gyp verb cli ‚–libsass\_library=‘ ]  
> > gyp info using node-gyp@3.8.0  
> > gyp info using node@11.15.0 | linux | x64  
> > gyp verb command rebuild   
> > gyp verb command clean   
> > gyp verb clean removing „build“ directory  
> > gyp verb command configure   
> > gyp verb check python checking for Python executable „python2“ in the PATH  
> > gyp verb `which` succeeded python2 /usr/bin/python2  
> > gyp verb check python version `/usr/bin/python2 -c "import sys; print "2.7.13 gyp verb check python version .%s.%s" % sys.version_info[:3];"` returned: %j  
> > gyp verb get node dir no --target version specified, falling back to host node version: 11.15.0  
> > gyp verb command install [‚11.15.0‘]  
> > gyp verb install input version string „11.15.0“  
> > gyp verb install installing version: 11.15.0  
> > gyp verb install --ensure was passed, so won’t reinstall if already installed  
> > gyp WARN EACCES user „undefined“ does not have permission to access the dev dir „/root/.node-gyp/11.15.0“  
> > gyp WARN EACCES attempting to reinstall using temporary dev dir „/app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass/.node-gyp“  
> > gyp verb command install [‚–node\_gyp\_internal\_noretry‘, ‚11.15.0‘]  
> > gyp verb install input version string „11.15.0“  
> > gyp verb install installing version: 11.15.0  
> > gyp verb install --ensure was passed, so won’t reinstall if already installed  
> > gyp verb install version not already installed, continuing with install 11.15.0  
> > gyp verb ensuring nodedir is created /app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass/.node-gyp/11.15.0  
> > gyp WARN install got an error, rolling back install  
> > gyp verb command remove [‚11.15.0‘]  
> > gyp verb remove using node-gyp dir: /app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass/.node-gyp  
> > gyp verb remove removing target version: 11.15.0  
> > gyp verb remove removing development files for version: 11.15.0  
> > gyp WARN install got an error, rolling back install  
> > gyp verb command remove [‚11.15.0‘]  
> > gyp verb remove using node-gyp dir: /app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass/.node-gyp  
> > gyp verb remove removing target version: 11.15.0  
> > gyp verb remove removing development files for version: 11.15.0  
> > gyp ERR! configure error  
> > gyp ERR! stack Error: EACCES: permission denied, mkdir ‚/app/vendor/shopware/platform/src/Administration/Resources/administration/node\_modules/node-sass/.node-gyp‘  
> > gyp ERR! System Linux 4.4.0-87-generic  
> > gyp ERR! command „/usr/bin/node“ „/app/platform/src/Administration/Resources/administration/node\_modules/node-gyp/bin/node-gyp.js“ „rebuild“ „–verbose“ „–libsass\_ext=“ „–libsass\_cflags=“ „–libsass\_ldflags=“ „–libsass\_library=“  
> > gyp ERR! cwd /app/platform/src/Administration/Resources/administration/node\_modules/node-sass  
> > gyp ERR! node -v v11.15.0  
> > gyp ERR! node-gyp -v v3.8.0  
> > gyp ERR! not ok  
> > Build failed with error code: 1  
> > npm ERR! code ELIFECYCLE  
> > npm ERR! errno 1  
> > npm ERR! node-sass@4.12.0 postinstall: `node scripts/build.js`  
> > npm ERR! Exit status 1  
> > npm ERR!  
> > npm ERR! Failed at the node-sass@4.12.0 postinstall script.  
> > npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
> > 
> > npm ERR! A complete log of this run can be found in:  
> > npm ERR! /.npm/\_logs/2019-05-24T06\_31\_12\_130Z-debug.log
> > 
> > Execution aborted, a subcommand failed!
> > 
> > &nbsp;
> > 
> > &nbsp;
> 
> Komplett anderes Problem. Du haste NodeJS 12 - das läuft damit nicht. Du müsstest ein Downgrade auf 11 machen, dann tritt der Fehler auch nicht auf.&nbsp;

im Docker COntainer sagt er mir aber mit node -v dass ich version 11.15.0 habe?!

```
> node -v
v11.15.0

```

&nbsp;

[Nächste Seite](https://forum.shopware.com/t/shopware-6-lokale-installation/59674.md?page=2)
