# Shopware 6 Domain-Mapping-Fehler nach Systemkopie: URLs werden nicht mit Sales Channel gematcht

**URL:** <https://forum.shopware.com/t/shopware-6-domain-mapping-fehler-nach-systemkopie-urls-werden-nicht-mit-sales-channel-gematcht/107900>\
**Category:** Shopware 6 (German)\
**Created:** [16. September 2025 um 10:54 UTC](https://forum.shopware.com/t/shopware-6-domain-mapping-fehler-nach-systemkopie-urls-werden-nicht-mit-sales-channel-gematcht/107900 "2025-09-16T10:54:44Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![riddermark](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@riddermark](https://forum.shopware.com/u/riddermark)\
**Post date:** [16. September 2025 um 10:54 UTC](https://forum.shopware.com/t/shopware-6-domain-mapping-fehler-nach-systemkopie-urls-werden-nicht-mit-sales-channel-gematcht/107900/1 "2025-09-16T10:54:44Z")

</div>

Hallo zusammen,

ich kämpfe mit einem hartnäckigen Problem auf einer Shopware 6 Staging-Instanz auf einem gemanagten Netcup-Server mit Plesk. Nach einer 1:1 Systemkopie (Shop + Datenbank) zeigt Shopware die Fehlermeldung „Shopware Domain Mapping Misconfiguration“ für `https://staging.promoshirt.ch`. Das Kernproblem ist, dass Shopware die URL nicht mit dem aktiven Sales Channel verknüpfen kann, obwohl sie exakt so in der `sales_channel_domain`-Tabelle eingetragen ist. In Production (`https://promoshirt.ch`) tritt das Problem nicht auf, obwohl der gleiche Netcup-Proxy davor läuft. Die Datenbankverbindung, APP\_URL etc., habe ich nach der Systemkopie natürlich angepasst im .env.local der Staging Instanz.

### Setup-Details

- **Shopware-Version** : 6.6.10.4

- **Server** : Gemanagter Netcup-Server mit Plesk, NGINX als Reverse-Proxy vor Apache, kein Cloudflare.

- **PHP-Version** : 8.3

- **Fehlermeldung** :

### Datenbank-Details (`sales_channel_domain`)

Die Sales Channel Domain habe ich direkt nach der Systemkopie angepasst auf [https://staging.promoshirt.ch](https://staging.promoshirt.ch/). Geht man auf die Seite, kopiert die URL aus der Browser Bar, und sucht danach auf der Website, sieht man auch direkt, dass der Sales Channel wirklich vorhanden ist.

### Beobachtungen

- **Production vs. Staging** : Production (`https://promoshirt.ch`) lädt problemlos, im genau gleichen Setup.

- **Temporärer Erfolg** : Nach einer neuen Systemkopie und manueller Änderung der URL im Admin (`https://staging.promoshirt.ch`) funktionierte die Seite kurz, aber nach einem Reload kam die Fehlermeldung zurück. Das könnte aber auch mit Browser Caching zusammenhängen.

- **Cache** : Mehrfach geleert (`bin/console cache:clear`, `var/cache/*` gelöscht).

Habt ihr Tipps, um das Matching-Problem zu debuggen (z. B. spezifische Shopware-Logs oder CLI-Befehle), oder Ideen, woran das liegen kann, wenn alle offensichtlichen Fehlerquellen bereits ausgeschlossen wurden?

Vielen Dank im Voraus!  
Riddermark

---

<div class="post-metadata">

**Author:** ![riddermark](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@riddermark](https://forum.shopware.com/u/riddermark)\
**Post date:** [16. September 2025 um 12:50 UTC](https://forum.shopware.com/t/shopware-6-domain-mapping-fehler-nach-systemkopie-urls-werden-nicht-mit-sales-channel-gematcht/107900/2 "2025-09-16T12:50:14Z")

</div>

Update: Der Fehler hat sich nach einem harmlosen Plugin-Update über das Admin Backend, das rein gar nichts mit Domains oder Sales Channels zu tun hat (Frosh Tools) in Luft aufgelöst.

Eine Aktion wie Plugin Update stösst anscheinend systemintern etwas an, was den entscheidenden Reset gibt, bzw. die Erkennung der vor Ewigkeiten bereits angepassten Sales Channel Domain ermöglicht. Danke Shopware….
