# Shopware 6 development version installation error.

**URL:** <https://forum.shopware.com/t/shopware-6-development-version-installation-error/62576>\
**Category:** Installation / Getting Started (EN)\
**Created:** [24. Oktober 2019 um 07:08 UTC](https://forum.shopware.com/t/shopware-6-development-version-installation-error/62576 "2019-10-24T07:08:09Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![abinjohnedamana](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/abinjohnedamana/32/17378_2.png) [@abinjohnedamana](https://forum.shopware.com/u/abinjohnedamana)\
**Post date:** [24. Oktober 2019 um 07:08 UTC](https://forum.shopware.com/t/shopware-6-development-version-installation-error/62576/1 "2019-10-24T07:08:09Z")

</div>

Hi

I am trying to install shopware6 on ubuntu. I got the following error when I am trying to install using the command&nbsp;./psh.phar install

"ERROR 2059 (HY000)Authentication plugin ‘caching\_sha2\_password’ cannot be loaded: /usr/lib/x86\_64-linux-gnu/mariadb18/plugin/caching\_sha2\_password.so:  
cannot open shared object file: No such file or directory

Execution aborted, a subcommand failed!"

I am using&nbsp;

ubuntu 19.04

Php 7.2&nbsp;

Mysql 5.7.27

I have tried this&nbsp;

ALTER USER root@localhost IDENTIFIED WITH mysql\_native\_password BY ‘password’;

But not working.

Anyone can help me?

---

<div class="post-metadata">

**Author:** ![abinjohnedamana](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/abinjohnedamana/32/17378_2.png) [@abinjohnedamana](https://forum.shopware.com/u/abinjohnedamana)\
**Post date:** [31. Oktober 2019 um 11:53 UTC](https://forum.shopware.com/t/shopware-6-development-version-installation-error/62576/2 "2019-10-31T11:53:20Z")

</div>

Please follow the following instructions in order to complete the developer version installation

1. You can skip the ‘caching\_sha2\_password’ issue by using MySQL 5.7.28 image in docker file (Mysql 8 is the cause of this error)

&nbsp; &nbsp;dev-ops/docker/containers/mysql/Dockerfile FROM mysql:8 -\> FROM mysql:5.7.28

1. docker commands should run without sudo command

&nbsp; &nbsp;check&nbsp;  
&nbsp; &nbsp;“docker info” - If you got an error related to permission please run the following command

&nbsp; &nbsp;“sudo chmod 666 /var/run/docker.sock” - Then check again “docker info”

&nbsp; &nbsp;if it is ok please follow the installation.

1. You need to set the permissions of the folders. (Installation will stop many times with permission issue message)

2. Set permissions and continue the installation

3. At last, it will be installed 🙂

---

<div class="post-metadata">

**Author:** ![abinjohnedamana](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/abinjohnedamana/32/17378_2.png) [@abinjohnedamana](https://forum.shopware.com/u/abinjohnedamana)\
**Post date:** [5. März 2020 um 13:23 UTC](https://forum.shopware.com/t/shopware-6-development-version-installation-error/62576/3 "2020-03-05T13:23:34Z")

</div>

Mysql 8 error can be solved by adding “command: --default-authentication-plugin=mysql\_native\_password” in&nbsp;docker-compose.yml in root folder.

app\_mysql:  
build: dev-ops/docker/containers/mysql  
environment:  
MYSQL\_ROOT\_PASSWORD: root  
MYSQL\_USER: app  
MYSQL\_PASSWORD: app  
command: --default-authentication-plugin=mysql\_native\_password
