# Shopware 6.5 Schriftart Inter-roman

**URL:** <https://forum.shopware.com/t/shopware-6-5-schriftart-inter-roman/101420>\
**Category:** Shopware 6 (German)\
**Created:** [28. September 2023 um 12:59 UTC](https://forum.shopware.com/t/shopware-6-5-schriftart-inter-roman/101420 "2023-09-28T12:59:04Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![AndreasBielmeier](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@AndreasBielmeier](https://forum.shopware.com/u/AndreasBielmeier)\
**Post date:** [28. September 2023 um 12:59 UTC](https://forum.shopware.com/t/shopware-6-5-schriftart-inter-roman/101420/1 "2023-09-28T12:59:04Z")

</div>

Ich habe eine frische Shopware-Installation mit Shopware Version 6.5.5.2 durchgeführt. Im Shop-Frontend sehe ich über die Chrome DevTools folgenden Fehler bei Laden der Schriftart „Inter-roman“:  
500 Internal Server Error  
z.B.: [https://tourishop.avs.de/stage6/public/theme/018adb5a3b677195b1b77d24aaaa7a98/assets/font/Inter-roman.latin.var.woff2](https://tourishop.avs.de/stage6/public/theme/018adb5a3b677195b1b77d24aaaa7a98/assets/font/Inter-roman.latin.var.woff2)

Was heißt das konkret?  
Was ist die Schrift „Inter-roman“, die war in Shopware 6.4 noch nicht da.

Durch den Fehler wird die Schrift auch nicht korrekt angezeigt im Browser.

---

<div class="post-metadata">

**Author:** ![PromoID](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/promoid/32/14015_2.png) [@PromoID](https://forum.shopware.com/u/PromoID)\
**Post date:** [28. September 2023 um 13:31 UTC](https://forum.shopware.com/t/shopware-6-5-schriftart-inter-roman/101420/2 "2023-09-28T13:31:14Z")

</div>

Es wird versucht die Datei zu laden, diese existiert nicht bzw. ist nicht erreichbar.  
Die Schrift kann durch alle möglichen Themes, Plugins usw. eingebunden werden.  
Ich sehe bei dir z.B. direkt das --bs-body-font-family: Inter, sans-serif; über die all.css geladen wird.  
Schau mal im Theme nach ^^

Ggf. musst du die Schrift herunterladen und einbinden (s. [google webfonts helper](https://gwfh.mranftl.com/fonts/inter?subsets=latin))

---

<div class="post-metadata">

**Author:** ![AndreasBielmeier](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@AndreasBielmeier](https://forum.shopware.com/u/AndreasBielmeier)\
**Post date:** [28. September 2023 um 14:01 UTC](https://forum.shopware.com/t/shopware-6-5-schriftart-inter-roman/101420/3 "2023-09-28T14:01:03Z")

</div>

Das ist eine frische, neue Installation von Shopware 6.5 ohne irgendwelche Anpassungen von mir. Heißt der Fehler ist im Theme von Shopware vorhanden.

Hab grad gesehen, dass es im Shopware Issue Tracker bereits einen Vorgang gibt:

> **[Shopware Issuetracker](https://issues.shopware.com/issues/NEXT-29293)**
>
> Shopware Issuetracker

Leider ist dieser seit 2,5 Monaten offen…

Zusätzlich finde ich im Apache-Log diesen Fehler, denke der hängt damit zusammen:  
Syntax error in type map, no ‚:‘ in /var/www/shopware/tourishop/stage6/public/theme/018adb5a3b677195b1b77d  
24aaaa7a98/assets/font/Inter-roman.latin.var.woff2 for header wof2

---

<div class="post-metadata">

**Author:** ![PromoID](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/promoid/32/14015_2.png) [@PromoID](https://forum.shopware.com/u/PromoID)\
**Post date:** [28. September 2023 um 14:17 UTC](https://forum.shopware.com/t/shopware-6-5-schriftart-inter-roman/101420/4 "2023-09-28T14:17:35Z")

</div>

Mag sein das es ein Installationsfehler ist ^^ Aber sollte sich das Problem nicht lösen wenn du die Schriftart runterlädst und in den vorgesehenen Ordner legst?

---

<div class="post-metadata">

**Author:** ![AndreasBielmeier](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@AndreasBielmeier](https://forum.shopware.com/u/AndreasBielmeier)\
**Post date:** [28. September 2023 um 14:21 UTC](https://forum.shopware.com/t/shopware-6-5-schriftart-inter-roman/101420/5 "2023-09-28T14:21:05Z")

</div>

Der Font liegt in dem Ordner, das ist nicht das Problem.

Ich habe die Lösung gefunden:

> <https://github.com/rsms/inter/issues/334>
>
> \*\*Describe the bug\*\*
> 
> Well, "bug"... It is more of an incompatibility.
> 
> On s…ome webhosts, the Inter font files with the text ".var." in the file name are not loaded. The browser console shows a status code "500 Internal Server Error" for these files.
> 
> \*\*To Reproduce\*\*
> 
> It simply depends on your webhost; whether or not it uses type maps for content negotiation. For me the problem occurred while preparing a switch to a different webhost. All of a sudden the Inter variable font files could no longer be loaded. The server error log shows messages like "AH00681: Syntax error in type map, no ':' in \<path to the file name\>" 
> 
> This is caused by the Apache type-map handler. When it finds a text ".var." in a file name, treats that file as a type map - which is obviously not the case, resulting in an error.
> 
> I found that the same problem was reported for the WordPress TwentyTwenty theme, that includes the Inter variable font, (see \[https://github.com/WordPress/twentytwenty/pull/827\](https://github.com/WordPress/twentytwenty/pull/827)), back in October 2019. WP (@carolinan) decided to address this by renaming the font-files.
> 
> Although there are other 'solutions', like adding a directive "RemoveHandler .var" in your .htaccess file, I think it would be best if the variable font files in this repository would be renamed.
> 
> Best regards,
> Henk

> <https://serverfault.com/questions/159152/apache-treating-files-with-var-in-their-names-as-type-maps>

Apache interpretiert das Font-File falsch und daher tritt der Fehler auf.

Ich habe in der Apache Config den Eintrag „RemoveHandler .var“ auf das Shopware Verzeichnis angewandt, jetzt geht es.

---

<div class="post-metadata">

**Author:** ![web-grips](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/web-grips/32/22792_2.png) [@web-grips](https://forum.shopware.com/u/web-grips)\
**Post date:** [9. Februar 2024 um 10:26 UTC](https://forum.shopware.com/t/shopware-6-5-schriftart-inter-roman/101420/6 "2024-02-09T10:26:40Z")

</div>

alternativ geht es auch über die .htaccess im public Verzeichnis mit folgendem Eintrag:

RemoveHandler type-map .var
