# Shopware 6.5.3 Administration - Fehlermeldung wenn Gutschrift in eine Bestellung hinzugefügt

**URL:** <https://forum.shopware.com/t/shopware-6-5-3-administration-fehlermeldung-wenn-gutschrift-in-eine-bestellung-hinzugefuegt/101365>\
**Category:** Administration\
**Tags:** administration\
**Created:** [25. September 2023 um 09:59 UTC](https://forum.shopware.com/t/shopware-6-5-3-administration-fehlermeldung-wenn-gutschrift-in-eine-bestellung-hinzugefuegt/101365 "2023-09-25T09:59:19Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![shopxline](https://avatars.discourse-cdn.com/v4/letter/s/90ced4/32.png) [@shopxline](https://forum.shopware.com/u/shopxline)\
**Post date:** [25. September 2023 um 09:59 UTC](https://forum.shopware.com/t/shopware-6-5-3-administration-fehlermeldung-wenn-gutschrift-in-eine-bestellung-hinzugefuegt/101365/1 "2023-09-25T09:59:19Z")

</div>

Hallo zusammen,

Wenn ich über die Administration versuche, eine Bestellung mit einer manuellen Gutschrift-Position zu bearbeiten, bekomme ich eine Fehlermeldung „Bei der Preisberechnung ist ein Fehler aufgetreten“ (siehe Screenshot unten). Die Gutschrift wird auch nicht angelegt.

Die Browser-Console wirft einen Fehler 500 bzw. 405 (GET Method not allowed) bei der abgerufene URL _[https://shop-domain.com/api/\_action/order/{order-id}/recalculate](https://shop-domain.com/api/_action/order/%7Border-id%7D/recalculate)_

Angeblich wird die Neuberechnung der Bestellung über die API verweigert.  
Was könnte das Problem verursachen? Hat jemand schon das Problem gehabt?

Für Eure Hilfe wäre ich sehr dankbar.  
VG  
Cédric

 ![manuelle-gutschrift-fehlermeldung](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/f/a/fa87cf83b243e450b6e7b28bef26b7b04c0e69eb.jpeg)

---

<div class="post-metadata">

**Author:** ![shopxline](https://avatars.discourse-cdn.com/v4/letter/s/90ced4/32.png) [@shopxline](https://forum.shopware.com/u/shopxline)\
**Post date:** [28. September 2023 um 07:46 UTC](https://forum.shopware.com/t/shopware-6-5-3-administration-fehlermeldung-wenn-gutschrift-in-eine-bestellung-hinzugefuegt/101365/2 "2023-09-28T07:46:12Z")

</div>

Bin ich wirklich der Einzige mit diesem Fehler?

Ich habe noch den Fehler über den Symfony-Profiler gescant.

Es wird ein **Warming: Undefined Array Key mit einem Produkt-ID** ausgegeben. (siehe Screenshot)  
In der Datenbank sind die Bestellpositionen und -items mit dem passenden Product-ID bzw. Identifier eingetragen.

Was könnte einen solchen Fehler provozieren? Hat es evtl. mit MySQL 8 zu tun?

Danke vorab für Eure Hilfe.  
VG  
Cédric

 ![screenshots-2](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/d/e/de6d4e78e22c1080e9f313c43753d3ebee1f37af.jpeg)

---

<div class="post-metadata">

**Author:** ![aboutbodycare](https://avatars.discourse-cdn.com/v4/letter/a/87869e/32.png) [@aboutbodycare](https://forum.shopware.com/u/aboutbodycare)\
**Post date:** [28. Dezember 2023 um 17:13 UTC](https://forum.shopware.com/t/shopware-6-5-3-administration-fehlermeldung-wenn-gutschrift-in-eine-bestellung-hinzugefuegt/101365/3 "2023-12-28T17:13:39Z")

</div>

Gab es hier schon eine Lösung? Ich habe dasselbe Problem

---

<div class="post-metadata">

**Author:** ![shopxline](https://avatars.discourse-cdn.com/v4/letter/s/90ced4/32.png) [@shopxline](https://forum.shopware.com/u/shopxline)\
**Post date:** [3. Januar 2024 um 12:22 UTC](https://forum.shopware.com/t/shopware-6-5-3-administration-fehlermeldung-wenn-gutschrift-in-eine-bestellung-hinzugefuegt/101365/4 "2024-01-03T12:22:31Z")

</div>

Hallo,

Eigentlich dies passierte bei uns, sobald wir versuchten, ein Abverkauf-Produkt **mit einem Lagerbestand = 0** gutzuschreiben. Sobald das Abverkauf-Produkt wieder aufgestockt wird (z.B. nach einer Retoure), kann das Produkt wieder gutgeschrieben werden und der Fehler kommt nicht mehr.

Ich hoffe, dass dies hilft.  
VG  
Cédric
