# Shopware 6.4.0.0 Update Fehler

**URL:** <https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386>\
**Category:** Shopware 6 (German)\
**Created:** [4. Mai 2021 um 16:08 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386 "2021-05-04T16:08:27Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![AMSPO24online](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/amspo24online/32/7865_2.png) [@AMSPO24online](https://forum.shopware.com/u/AMSPO24online)\
**Post date:** [4. Mai 2021 um 16:08 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/1 "2021-05-04T16:08:27Z")

</div>

Update von 6.3.5.4 auf 6.4.0.0

Update läuft nicht durch und bleibt in der Datenbank beim Schritt 2 stehen.

Alle Plugins wurden deaktiviert!

Fehler:

Error  
Received the following error message:  
An exception occurred while executing ‚ALTER TABLE `cms_slot` ADD CONSTRAINT `fk.cms_slot.cms_block_id` FOREIGN KEY (`cms_block_id`, `cms_block_version_id`) REFERENCES `cms_block` (`id`, `version_id`) ON DELETE CASCADE ON UPDATE CASCADE‘: SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`dbs306431`.`#sql-93c_6a3b0c3`, CONSTRAINT `fk.cms_slot.cms_block_id` FOREIGN KEY (`cms_block_id`, `cms_block_version_id`) REFERENCES `cms_block` (`id`, `version_id`) ON DELETE CASCADE ON UPDA)

Please try to fix this error and restart the update.  
Response  
{„valid“:false,„errorMsg“:„An exception occurred while executing ‚ALTER TABLE `cms_slot` ADD CONSTRAINT `fk.cms_slot.cms_block_id` FOREIGN KEY (`cms_block_id`, `cms_block_version_id`) REFERENCES `cms_block` (`id`, `version_id`) ON DELETE CASCADE ON UPDATE CASCADE‘:\n\nSQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`dbs306431`.`#sql-93c_6a3b0c3`, CONSTRAINT `fk.cms_slot.cms_block_id` FOREIGN KEY (`cms_block_id`, `cms_block_version_id`) REFERENCES `cms_block` (`id`, `version_id`) ON DELETE CASCADE ON UPDA)“}  
2 / 3 Datenbank-Update wird durchgeführt…

Mit freundlichen Grüßen  
Rainer Amend

---

<div class="post-metadata">

**Author:** ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)\
**Post date:** [4. Mai 2021 um 16:30 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/2 "2021-05-04T16:30:57Z")

</div>

Willkommen im Club

> [@Shopware 6.4.0 Update Error](https://forum.shopware.com/t/shopware-6-4-0-update-error/87365):
>
> Hallo Zusammen, wir haben bei unserem SW6 Demoshop (6.3.5.1) alle Plugins deaktiviert und ein Update geamcht und erhalten foglende Fehlermeldung: Error Received the following error message: An exception occurred while executing ‚ALTER TABLE cms\_page\_translation ADD CONSTRAINT fk.cms\_page\_translation.cms\_page\_id FOREIGN KEY (cms\_page\_id, cms\_page\_version\_id) REFERENCES cms\_page (id, version\_id) ON DELETE CASCADE ON UPDATE CASCADE‘: SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot …

---

<div class="post-metadata">

**Author:** ![lenniep](https://avatars.discourse-cdn.com/v4/letter/l/3ec8ea/32.png) [@lenniep](https://forum.shopware.com/u/lenniep)\
**Post date:** [6. Mai 2021 um 11:57 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/3 "2021-05-06T11:57:56Z")

</div>

Habe leider genau den gleichen Fehler mit den CMS Blocks.

Hat hier jemand eine Lösung gefunden? Ich weiss nicht, ob der oben verlinkte Beitrag die gleiche Ursache hat (cms\_page\_translation).

---

<div class="post-metadata">

**Author:** ![AMSPO24online](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/amspo24online/32/7865_2.png) [@AMSPO24online](https://forum.shopware.com/u/AMSPO24online)\
**Post date:** [6. Mai 2021 um 13:49 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/4 "2021-05-06T13:49:24Z")

</div>

Ich habe noch keine Lösung gefunden. Ich bin zurück auf die V 6.3.5.4.

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [6. Mai 2021 um 14:09 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/5 "2021-05-06T14:09:07Z")

</div>

Die Kollegen schauen sich das schon an, solange würde ich empfehlen auf der 6.3.x zu bleiben. Wir haben wohl einen Dump bekommen und schauen jetzt, was die Ursache ist.

---

<div class="post-metadata">

**Author:** ![AMSPO24online](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/amspo24online/32/7865_2.png) [@AMSPO24online](https://forum.shopware.com/u/AMSPO24online)\
**Post date:** [8. Mai 2021 um 12:42 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/6 "2021-05-08T12:42:34Z")

</div>

Weiß man schon was den Fehler verursacht und wann eine Lösung in Sicht sein wird?

---

<div class="post-metadata">

**Author:** ![archery-analytics](https://avatars.discourse-cdn.com/v4/letter/a/f04885/32.png) [@archery-analytics](https://forum.shopware.com/u/archery-analytics)\
**Post date:** [10. Mai 2021 um 11:58 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/7 "2021-05-10T11:58:34Z")

</div>

Gleiches Problem hier. Es handelt sich bei uns um eine MariaDB v10.4.  
Nach dem Fehler kann man nicht mehr auf SW 6.3.x zurück weil die DB kaputt ist. (Nur über Backup/Snapshot)

---

<div class="post-metadata">

**Author:** ![jfranke](https://avatars.discourse-cdn.com/v4/letter/j/a5b964/32.png) [@jfranke](https://forum.shopware.com/u/jfranke)\
**Post date:** [10. Mai 2021 um 12:32 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/8 "2021-05-10T12:32:06Z")

</div>

Moin zusammen,

ich habe auch Probleme mit der 6.4. Version.  
In meinem Fall, wird das Logo nicht angezeigt obwohl das „Demo Logo“ Bild im Backend eingestellt ist und ich den Block: „layout\_header\_logo“ vom „parent“ nutze.

Dazu werden manche Links von einige Pages nicht abgerufen und bekomme die Fehlermeldung " Parameter „Parameter id missing“ is missing.", obwohl ich die ID auch verwende.

```
<a data-toggle="modal" 
   class="footer-vat ml-3" 
   href="{{ path('frontend.cms.page',{ id: shopware.config.core.basicInformation.revocationPage }) }}"
   data-url="{{ path('frontend.cms.page',{ id: shopware.config.core.basicInformation.privacyPage }) }}">
        Datenschutzerklärung
</a>

```

Bei der 6.3 hat es problemlos funktioniert.

Das hat bestimmt rigendwas mit der DB zu tun, oder?

---

<div class="post-metadata">

**Author:** ![Moorleiche](https://avatars.discourse-cdn.com/v4/letter/m/6f9a4e/32.png) [@Moorleiche](https://forum.shopware.com/u/Moorleiche)\
**Post date:** [10. Mai 2021 um 13:36 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/9 "2021-05-10T13:36:04Z")

</div>

> [@jfranke](#):
>
> `shopware.config.core.basicInformation.privacyPage`

ist jetzt

config(‚core.basicInformation.privacyPage‘)

---

<div class="post-metadata">

**Author:** ![jfranke](https://avatars.discourse-cdn.com/v4/letter/j/a5b964/32.png) [@jfranke](https://forum.shopware.com/u/jfranke)\
**Post date:** [10. Mai 2021 um 13:44 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/11 "2021-05-10T13:44:03Z")

</div>

Top! Funktioniert wie Butter 🙂

Danke für den Hinweis. Ich habe es auch beim Changelog gesehen. Trotzdem habe nicht so richtig verstande, wie man das dann anwendet. Jetzt liegt das Problem beim Logo noch.

---

<div class="post-metadata">

**Author:** ![blueroger](https://avatars.discourse-cdn.com/v4/letter/b/df788c/32.png) [@blueroger](https://forum.shopware.com/u/blueroger)\
**Post date:** [12. Mai 2021 um 08:31 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/12 "2021-05-12T08:31:28Z")

</div>

Hallo zusammen,

ich habe das gleich Problem mit meinem Testshop. Die Aktualisierung bleibt hängen. Wie kann ich die Aktualisierung rückgängig machen bzw. aus dem Wartungsmodus raus kommen?

Danke und Gruß

---

<div class="post-metadata">

**Author:** ![AMSPO24online](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/amspo24online/32/7865_2.png) [@AMSPO24online](https://forum.shopware.com/u/AMSPO24online)\
**Post date:** [12. Mai 2021 um 13:55 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/13 "2021-05-12T13:55:02Z")

</div>

Kann man es jetzt wagen dass Update 6.4.0.0 einzuspielen oder sollte man noch warten?

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [12. Mai 2021 um 14:03 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/14 "2021-05-12T14:03:56Z")

</div>

Nur mal so als Rückinfo: Ich habe das Update 6.4 eingespielt und nicht ein Fehler ist passiert.

---

<div class="post-metadata">

**Author:** ![archery-analytics](https://avatars.discourse-cdn.com/v4/letter/a/f04885/32.png) [@archery-analytics](https://forum.shopware.com/u/archery-analytics)\
**Post date:** [13. Mai 2021 um 11:44 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/15 "2021-05-13T11:44:00Z")

</div>

Mit MariaDB? Welche Version?

---

<div class="post-metadata">

**Author:** ![Moorleiche](https://avatars.discourse-cdn.com/v4/letter/m/6f9a4e/32.png) [@Moorleiche](https://forum.shopware.com/u/Moorleiche)\
**Post date:** [13. Mai 2021 um 11:49 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/16 "2021-05-13T11:49:11Z")

</div>

Also selbst ich als erfahrener Shopware Anwender habe mächtig schiss bei jedem Update 😁👍 aber umso schöner wenn es mal funktioniert!

---

<div class="post-metadata">

**Author:** ![AMSPO24online](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/amspo24online/32/7865_2.png) [@AMSPO24online](https://forum.shopware.com/u/AMSPO24online)\
**Post date:** [13. Mai 2021 um 16:32 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/17 "2021-05-13T16:32:11Z")

</div>

> [@archery-analytics](#):
>
> Mit MariaDB? Welche Version?

Ich nutze: MySQL 5.7 | \* Versionsinformationen: 4.9.7

---

<div class="post-metadata">

**Author:** ![archery-analytics](https://avatars.discourse-cdn.com/v4/letter/a/f04885/32.png) [@archery-analytics](https://forum.shopware.com/u/archery-analytics)\
**Post date:** [13. Mai 2021 um 17:20 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/18 "2021-05-13T17:20:00Z")

</div>

Hmm Ich dachte das Problem tritt nur bei der MariaDB auf?

---

<div class="post-metadata">

**Author:** ![AMSPO24online](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/amspo24online/32/7865_2.png) [@AMSPO24online](https://forum.shopware.com/u/AMSPO24online)\
**Post date:** [13. Mai 2021 um 20:58 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/19 "2021-05-13T20:58:25Z")

</div>

Ich habe es nochmal versucht, die Shopware 6.4.0.0 das Update einzulesen, wieder ohne Erfolg. Der Fehler kommt in der Datenbank vor und tritt innerhalb des 2. Schrittes auf.

Hm, da wird man wohl mit der Version 6.3.5.4 leben müssen.

Der Fehler:

## Datenbank-Update durchführen

## Error

Received the following error message:  
Tables with multi column primary keys not supported

Please try to fix this error and restart the update.

### Response

{„valid“:false,„errorMsg“:„Tables with multi column primary keys not supported“}

---

<div class="post-metadata">

**Author:** ![schindler-tk](https://avatars.discourse-cdn.com/v4/letter/s/c4cdca/32.png) [@schindler-tk](https://forum.shopware.com/u/schindler-tk)\
**Post date:** [13. Mai 2021 um 21:35 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/20 "2021-05-13T21:35:37Z")

</div>

Der Fehler tritt im 2. Schritt bei der DB Migration auf (Tabelle 192).

Ich hatte auf dem selben Server noch eine Testumgebung mit der 6.3.5.2 drauf. Diese hab ich problemlos auf die 6.4. updaten können. Hab dann den ganzen Inhalt gepackt, Datenbankzuordnung auf meine andere Domain gemacht, Inhalte „drüben“ ausgepackt und sh. da…es läuft.

Hab dann in der Konfiguration die entsprechenden Änderungen vorgenommen und jetzt funzt alles.

Für mich stellt sich die Frage warum in der selben Serverumgebung und trotz neu erstellter Domain die Installation auf der einen klappt und auf der anderen nicht.

---

<div class="post-metadata">

**Author:** ![tomtomtom](https://avatars.discourse-cdn.com/v4/letter/t/a88e57/32.png) [@tomtomtom](https://forum.shopware.com/u/tomtomtom)\
**Post date:** [14. Mai 2021 um 11:04 UTC](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386/21 "2021-05-14T11:04:08Z")

</div>

Received the following error message:

An exception occurred while executing ‚ALTER TABLE `cms_page_translation` ADD CONSTRAINT `fk.cms_page_translation.cms_page_id` FOREIGN KEY (`cms_page_id`, `cms_page_version_id`) REFERENCES `cms_page` (`id`, `version_id`) ON DELETE CASCADE ON UPDATE CASCADE‘: SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`usr_pxxxxx_1`.`#sql-2b0_aae70aa`, CONSTRAINT `fk.cms_page_translation.cms_page_id` FOREIGN KEY (`cms_page_id`, `cms_page_version_id`) REFERENCES `cms_page` (`id`, `version_id`) ON DELETE CAS)

[Nächste Seite](https://forum.shopware.com/t/shopware-6-4-0-0-update-fehler/87386.md?page=2)
