# Shopware 5 Responsive Theme bringt 500 Internal Server Error

**URL:** <https://forum.shopware.com/t/shopware-5-responsive-theme-bringt-500-internal-server-error/27816>\
**Category:** Administration\
**Created:** [1. Juni 2015 um 14:53 UTC](https://forum.shopware.com/t/shopware-5-responsive-theme-bringt-500-internal-server-error/27816 "2015-06-01T14:53:40Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![edge](https://avatars.discourse-cdn.com/v4/letter/e/0ea827/32.png) [@edge](https://forum.shopware.com/u/edge)\
**Post date:** [1. Juni 2015 um 14:53 UTC](https://forum.shopware.com/t/shopware-5-responsive-theme-bringt-500-internal-server-error/27816/1 "2015-06-01T14:53:40Z")

</div>

Ich habe die Version 5.0.1 frisch und clean neu aufgesetzt. Alle PHP Einstellungen und Berechtigungen sollten sind korrekt (PHP 5.6.9 / FastCGI / [http://nettostore.ch/phpinfo.php](http://nettostore.ch/phpinfo.php)). Die Aktivierung des Responsive Themes bringt einen 500 Fehler mit folgendem Eintrag in der error\_log: `[Mon Jun 01 14:26:22 2015] [warn] [client 84.183.249.23] (104)Connection reset by peer: mod\_fcgid: error reading data from server [Mon Jun 01 14:26:22 2015] [error] [client 84.183.249.23] Premature end of script headers: shopware.php` Hab hier schon nachgeforscht und die Timeouts in der fcgid.conf erhöht, das führt aber zu einem 502 Bad Gateway. Emotion Theme und ein selbst gekauftes (Dashone) funktionieren. Allerdings habe ich hier Probleme mit den Produktbilder, die falsch oder gar nicht dargestellt werden. Zunächst möchte ich die Ursache für den FastCGI-Fehler in der shopware.php finden und bräuchte da mal eure Hilfe.

---

<div class="post-metadata">

**Author:** ![Heiner\_Lohaus](https://avatars.discourse-cdn.com/v4/letter/h/b5a626/32.png) [@Heiner\_Lohaus](https://forum.shopware.com/u/Heiner_Lohaus)\
**Post date:** [1. Juni 2015 um 15:49 UTC](https://forum.shopware.com/t/shopware-5-responsive-theme-bringt-500-internal-server-error/27816/2 "2015-06-01T15:49:24Z")

</div>

Hi, schaue mal in den Error.log von “PHP”. Wenn keins vorhanden, solltest du es aktiveren. Der Fcgi-Server verschluckt nämlich die Fehlermeldung und ohne die Fehlermeldung kann dir wahrscheinlich keiner helfen. Heiner

---

<div class="post-metadata">

**Author:** ![edge](https://avatars.discourse-cdn.com/v4/letter/e/0ea827/32.png) [@edge](https://forum.shopware.com/u/edge)\
**Post date:** [1. Juni 2015 um 21:57 UTC](https://forum.shopware.com/t/shopware-5-responsive-theme-bringt-500-internal-server-error/27816/3 "2015-06-01T21:57:40Z")

</div>

komme da nicht so richtig weiter, error\_log ist ja das PHP-Log, zumindest vom VHost (Plesk). Das serverweite PHP Log spuckt noch aus: `[Mon Jun 01 21:47:41 2015] [error] mod\_fcgid: process /var/www/cgi-bin/cgi\_wrapper/cgi\_wrapper(20080) exit(communication error), get unexpected signal 11` Mehr Infos finde ich nicht. Wo könnte ich noch schauen? System ist Centos 6.6 mit Plesk 12. Error Reporting ist auf E-ALL (siehe [http://nettostore.ch/phpinfo.php](http://nettostore.ch/phpinfo.php)). LG Jürgen

---

<div class="post-metadata">

**Author:** ![Heiner\_Lohaus](https://avatars.discourse-cdn.com/v4/letter/h/b5a626/32.png) [@Heiner\_Lohaus](https://forum.shopware.com/u/Heiner_Lohaus)\
**Post date:** [2. Juni 2015 um 08:19 UTC](https://forum.shopware.com/t/shopware-5-responsive-theme-bringt-500-internal-server-error/27816/4 "2015-06-02T08:19:06Z")

</div>

Hi, den PHP-Error.log kannst du über die php.ini aktiveren. Beispiel: error\_log = /var/log/php.log Der Error-Log landet dann in der Datei “/var/log/php.log”. Heiner

---

<div class="post-metadata">

**Author:** ![edge](https://avatars.discourse-cdn.com/v4/letter/e/0ea827/32.png) [@edge](https://forum.shopware.com/u/edge)\
**Post date:** [4. Juni 2015 um 15:05 UTC](https://forum.shopware.com/t/shopware-5-responsive-theme-bringt-500-internal-server-error/27816/5 "2015-06-04T15:05:00Z")

</div>

das sind schon die richtigen Error-Logs, das Reporting funktioniert. `[Thu Jun 04 15:01:29 2015] [warn] [client 79.241.212.241] (104)Connection reset by peer: mod\_fcgid: error reading data from FastCGI server [Thu Jun 04 15:01:29 2015] [error] [client 79.241.212.241] Premature end of script headers: shopware.php [Thu Jun 04 15:01:32 2015] [error] mod\_fcgid: process /var/www/cgi-bin/cgi\_wrapper/cgi\_wrapper(5727) exit(communication error), get unexpected signal 11 ` Das ist alles was ich an Infos finde. suexec\_log spuckt noch aus: ` [2015-06-04 14:58:19]: uid: (10025/swissft) gid: (503/503) cmd: cgi\_wrapper` Es scheint, ich bin nicht der einzige mit dem Problem, und es deutet in Richtung Probleme mit FastCGI Konfiguration / Plesk: [http://forum.odin.com/threads/error-104 … er.331521/](http://forum.odin.com/threads/error-104-connection-reset-by-peer-mod%5C_fcgid-error-reading-data-from-fastcgi-server.331521/)

---

<div class="post-metadata">

**Author:** ![baudy](https://avatars.discourse-cdn.com/v4/letter/b/a4c791/32.png) [@baudy](https://forum.shopware.com/u/baudy)\
**Post date:** [2. August 2015 um 12:16 UTC](https://forum.shopware.com/t/shopware-5-responsive-theme-bringt-500-internal-server-error/27816/6 "2015-08-02T12:16:23Z")

</div>

Wir haben das selbe problem. Gibt es hier schon einen Lösungsansatz?

---

<div class="post-metadata">

**Author:** ![italia-lifestyle](https://avatars.discourse-cdn.com/v4/letter/i/50afbb/32.png) [@italia-lifestyle](https://forum.shopware.com/u/italia-lifestyle)\
**Post date:** [13. August 2015 um 01:43 UTC](https://forum.shopware.com/t/shopware-5-responsive-theme-bringt-500-internal-server-error/27816/7 "2015-08-13T01:43:44Z")

</div>

Hallo, wir hatten das gleiche Problem. Ich habe es wie folgt gelöst: In der Beschreibung vom Dashone sind die Größen der Bilder anders gefordert wie Shopware diese voreingestellt hat. Darin lag das Problem bei uns! Wir haben dann die Bildgröße wie von Herrn Piero ([shop-templates.com](http://shop-templates.com)) genannt verändert, und siehe da, alles war ok. Nach dem eintragen der richtigen Größe den Durchlauf starten und schwups alles ok. Gruß Didi

P.S.: Kurzer Nachtrag für alle:[Thumbs / Artikelbilder werden nicht richtig dargestellt : Support | shop-templates.com](https://shop-templates.freshdesk.com/support/solutions/articles/5000628996-thumbs-artikelbilder-werden-nicht-richtig-dargestellt-)
