# Shopware 4 - Installer - Fehler bei Datenbank importieren

**URL:** <https://forum.shopware.com/t/shopware-4-installer-fehler-bei-datenbank-importieren/8182>\
**Category:** Shopware 3.5\
**Tags:** general\
**Created:** [28. August 2012 um 17:10 UTC](https://forum.shopware.com/t/shopware-4-installer-fehler-bei-datenbank-importieren/8182 "2012-08-28T17:10:01Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![\_Deleted\_User11](https://avatars.discourse-cdn.com/v4/letter/_/ed655f/32.png) [@\_Deleted\_User11](https://forum.shopware.com/u/_Deleted_User11)\
**Post date:** [28. August 2012 um 17:10 UTC](https://forum.shopware.com/t/shopware-4-installer-fehler-bei-datenbank-importieren/8182/1 "2012-08-28T17:10:01Z")

</div>

The user and all related content has been deleted.

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [28. August 2012 um 17:27 UTC](https://forum.shopware.com/t/shopware-4-installer-fehler-bei-datenbank-importieren/8182/2 "2012-08-28T17:27:50Z")

</div>

Hey, hast du genauere Informationen wie dein MySQL-Server konfiguriert ist? Das Problem können wir so nicht reproduzieren. Kannst du den Datenbank-Dump (liegt unter /install/assets/sql/sw4\_clean.sql) ggf. manuell über PHPMyadmin importieren und Step 4 im Installer dann überspringen (Skip Database Import)?

---

<div class="post-metadata">

**Author:** ![\_Deleted\_User11](https://avatars.discourse-cdn.com/v4/letter/_/ed655f/32.png) [@\_Deleted\_User11](https://forum.shopware.com/u/_Deleted_User11)\
**Post date:** [28. August 2012 um 17:36 UTC](https://forum.shopware.com/t/shopware-4-installer-fehler-bei-datenbank-importieren/8182/3 "2012-08-28T17:36:05Z")

</div>

The user and all related content has been deleted.

---

<div class="post-metadata">

**Author:** ![ovi](https://avatars.discourse-cdn.com/v4/letter/o/3ab097/32.png) [@ovi](https://forum.shopware.com/u/ovi)\
**Post date:** [28. August 2012 um 19:26 UTC](https://forum.shopware.com/t/shopware-4-installer-fehler-bei-datenbank-importieren/8182/4 "2012-08-28T19:26:03Z")

</div>

Kann mehrere Ursachen haben, das einfachste wäre, wenn InnoDB einfach abgeschaltet ist, und der Fehler dadurch zu Stande kommt, dass MyISAM einfach nur 1000 bytes verarbeiten kann. Ob InnoDB aktiviert ist, kannst du mit diesem SQL Statement herausfinden: `SHOW VARIABLES LIKE 'have\_innodb';` Falls doch, dann liegt es einfach daran, dass die maximale Schlüssellänge eingeschränkt wurde.

---

<div class="post-metadata">

**Author:** ![\_Deleted\_User11](https://avatars.discourse-cdn.com/v4/letter/_/ed655f/32.png) [@\_Deleted\_User11](https://forum.shopware.com/u/_Deleted_User11)\
**Post date:** [29. August 2012 um 11:11 UTC](https://forum.shopware.com/t/shopware-4-installer-fehler-bei-datenbank-importieren/8182/5 "2012-08-29T11:11:27Z")

</div>

The user and all related content has been deleted.

---

<div class="post-metadata">

**Author:** ![ovi](https://avatars.discourse-cdn.com/v4/letter/o/3ab097/32.png) [@ovi](https://forum.shopware.com/u/ovi)\
**Post date:** [29. August 2012 um 11:12 UTC](https://forum.shopware.com/t/shopware-4-installer-fehler-bei-datenbank-importieren/8182/6 "2012-08-29T11:12:05Z")

</div>

Kein Problem 🙂
