# Shop will im Produktivmodus nicht laufen

**URL:** <https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913>\
**Category:** Installation/Einstieg\
**Created:** [5. Februar 2018 um 08:56 UTC](https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913 "2018-02-05T08:56:04Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![hentschke](https://avatars.discourse-cdn.com/v4/letter/h/b487fb/32.png) [@hentschke](https://forum.shopware.com/u/hentschke)\
**Post date:** [5. Februar 2018 um 08:56 UTC](https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913/1 "2018-02-05T08:56:04Z")

</div>

Hallo,

ich habe letzte Woche meinen shop auf  
[https://hentschke-keramik.de](https://hentschke-keramik.de)  
live geschaltet.  
Es läuft nicht extrem langsam aber ich würde trotzdem gerne den HTTP Cache aktivieren. (Produktivmodus)

* * *

Wenn ich den cache aktiviere dann läuft der shop gar nicht mehr.

Ohne cache:  
[https://hentschke-keramik.de/transfer/cacheoff.jpg](https://hentschke-keramik.de/transfer/cacheoff.jpg)

Mit cache:  
[https://hentschke-keramik.de/transfer/cacheon.jpg](https://hentschke-keramik.de/transfer/cacheon.jpg)

* * *

Shopware 5.3.7

* * *

Server: 8 GB RAM (PHP auf 4 GB RAM “begrenzt”), 200 GB SSD  
Das sollte kein Problem sein.

PHP OPcache ist aktiviert und funktioniert, sollte aber eigentlich den HTTP cache nicht berühren, da das eine Funktion des plugins ist.

* * *

Backend -\> Einstellungen -\> Cache  
Das Setting für “Shop im Produktivmodus verwenden” wird definitiv angenommen und gespeichert.

* * *

Cronjobs:  
ClearHttpCache ist _nicht_ doppelt vorhanden, auch keine Fehlermeldungen bei der Aktivierung / Neuinstallation des HTTP Cache plugins.

* * *

config.php:&nbsp; Keine Einträge ausser den benötigten DB infos.  
Da der shop läuft müssen die Einträge richtig sein.

* * *

HTTP Cache Plugin:  
\shopware\engine\Shopware\Plugins\Default\Core\HttpCache\Bootstrap.php  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ‘install’ =\> true,  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ‘enable’ =\> true,  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; ‘update’ =\> true,

Alles testweise aktiviert und das plugin so komplett neu installiert… falls da eine alte Version drin gewesen sein sollte.

* * *

Sämtliche auffindbaren caches (auch in Untermenüs) geleert und Theme oft neu kompiliert.

* * *

Cache aufwärmen lässt sich ausführen aber ändert nichts am Ergebnis.  
_Sollte_ auch egal sein, da der cache sich sowieso automatisch aufbauen/erneuern muss.

* * *

Sorry aber mir gehen die Ideen aus…

&nbsp;

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [5. Februar 2018 um 09:10 UTC](https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913/2 "2018-02-05T09:10:17Z")

</div>

Gibt es Fehlermeldungen im Error-Log der Website oder in den Shopware-Logs?

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![hentschke](https://avatars.discourse-cdn.com/v4/letter/h/b487fb/32.png) [@hentschke](https://forum.shopware.com/u/hentschke)\
**Post date:** [5. Februar 2018 um 09:28 UTC](https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913/3 "2018-02-05T09:28:46Z")

</div>

Nein, keine Fehler von Shopware,&nbsp; nur ein “Der Produktivmodus wurde erfolgreich aktiviert”.

Im Serverlog sehe ich nur Fehler die fonts betreffen (auch im Bearbeitungsmodus, wo die Anzeige funktioniert…)  
[Mon Feb 05 10:16:53.493817 2018] [core:info] [pid 10063:tid 139782262527744] [client 193.16.193.251:16000] AH00128: File does not exist: /usr/www/users/hentscs/shopware/themes/Frontend/Responsive/frontend/\_public/src/fonts/open-sans-fontface/Bold/OpenSans-Bold.ttf, referer: [https://www.hentschke-keramik.de/cat/index/sCategory/58](https://www.hentschke-keramik.de/cat/index/sCategory/58)

Wenn ich irgendeine Fehlermeldung _hätte_ wäre das ja schon ein Fortschritt. =)

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [5. Februar 2018 um 09:34 UTC](https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913/4 "2018-02-05T09:34:37Z")

</div>

Hast Du die Möglichkeit, verschiedene PHP-Versionen zu probieren?

Kannst Du mit den Entwickler-Tools von Chrome oder Firefox (F12 drücken, um sie zu öffnen) irgendwelche Fehler erkennen?

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![hentschke](https://avatars.discourse-cdn.com/v4/letter/h/b487fb/32.png) [@hentschke](https://forum.shopware.com/u/hentschke)\
**Post date:** [5. Februar 2018 um 10:05 UTC](https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913/5 "2018-02-05T10:05:03Z")

</div>

Oha!

Blocked loading mixed active content “[http://community.shopware.com/templates/0/de/media/fonts/scc.woff?tyxaom”](http://community.shopware.com/templates/0/de/media/fonts/scc.woff?tyxaom%E2%80%9D)[Learn More]  
[www.hentschke-keramik.de](http://www.hentschke-keramik.de)

Blocked loading mixed active content “[http://fonts.gstatic.com/s/opensans/v15/cJZKeOuBrn4kERxqtaUH3VtXRa8TVwTICgirnJhmVJw.woff2”](http://fonts.gstatic.com/s/opensans/v15/cJZKeOuBrn4kERxqtaUH3VtXRa8TVwTICgirnJhmVJw.woff2%E2%80%9D)[Learn More]  
[www.hentschke-keramik.de](http://www.hentschke-keramik.de)

Blocked loading mixed active content “[http://fonts.gstatic.com/s/opensans/v15/MTP\_ySUJH\_bn48VBG8sNSugdm0LZdjqr5-oayXSOefg.woff2”](http://fonts.gstatic.com/s/opensans/v15/MTP_ySUJH_bn48VBG8sNSugdm0LZdjqr5-oayXSOefg.woff2%E2%80%9D)[Learn More]

&nbsp;

Failed to load resource: the server responded with a status of 404 (Not Found)&nbsp; OpenSans-Regular.ttf

Failed to load resource: the server responded with a status of 404 (Not Found) OpenSans-Regular.woff

[www.hentschke-keramik.de/](http://www.hentschke-keramik.de/) Failed to load resource: the server responded with a status of 500 (Internal Server Error)

Da wirds schon wärmer!  
Sieht so aus als würden die cached pages “http:” links generieren und der “mixed content” blockiert dann.  
Ohne cache werden diese fonts definitiv als “https:” referenziert.

Nur wie erkläre ich das dem cache plugin? LOL

---

<div class="post-metadata">

**Author:** ![chwzr](https://avatars.discourse-cdn.com/v4/letter/c/8c91f0/32.png) [@chwzr](https://forum.shopware.com/u/chwzr)\
**Post date:** [5. Februar 2018 um 10:40 UTC](https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913/6 "2018-02-05T10:40:28Z")

</div>

Du musst in den Einstellungen auf Grundeinstellungen --\> Shopeinstellungen --\> Shops&nbsp; —\>&nbsp; deinen Shop bearbeiten (Stift symbol) und dann rechts in der Leiste SSL aktivieren.

Dann nurnoch den Cache leeren URLS (STRG + ALT + X). Dannach sollten alle URLs über https laufen.

Falls möglich konfiguriere deinen Server so dass http automatisch auf https umgeleitet wird. (Google sollte helfen).

Natürlich muss auf deinem Server dazu auch ein Zertifikat installiert und SSL konfiguriert sein. Solltest du keine möglichkeit haben gibt es eine gute Alternative:

Server normal auf http laufen lassen und domain bei Cloudflare registrieren ( kostenlos reicht aus ) … dort kann man in den Crypto einstellungen SSL auf Flexible stellen, und eine Page Rule erstellen die den Traffic auf https umleitet. Deine Seite wird dann vom Cloudflare Proxy mit einem von Cloudflare generiertem Zertifikat ausgeliefert. Intern fragt der Cloudflare Proxy deinen Server aber über http ab. Die Sopware einstellungen müssen natürlich trotzdem auf SSL umgestellt werden.

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![hentschke](https://avatars.discourse-cdn.com/v4/letter/h/b487fb/32.png) [@hentschke](https://forum.shopware.com/u/hentschke)\
**Post date:** [5. Februar 2018 um 11:14 UTC](https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913/7 "2018-02-05T11:14:47Z")

</div>

Danke aber der Shop ist schon auf SSL umgestellt,  
Server/Domain hat ein SSL Zertifikat,  
.htaccess leitet schon automatisch alle http requests auf https um.

Das läuft alles schon eine Woche so.  
Nachdem ich jetzt die fehlenden .woff fonts nachinstalliert hatte habe ich auch keine Browserfehler mehr.

Wonach ich jetzt noch suche ist…&nbsp; der Grund warum es trotzdem nicht funktioniert. Weder in Chrome noch in Firefox.  
Ich habe 0 Serverfehler, 0 Shopware-Fehler, 0 Browserfehler…

und einen leeren Shop sobald ich den Cache einschalte: [https://hentschke-keramik.de/transfer/cacheon.jpg](https://hentschke-keramik.de/transfer/cacheon.jpg)

Als nächstes ist .htaccess dran.  
Kann immer sein dass bei einem der regex Filter irgendwas zuviel geblockt oder umgeleitet wird.  
Das wird ein Spass.

---

<div class="post-metadata">

**Author:** ![hentschke](https://avatars.discourse-cdn.com/v4/letter/h/b487fb/32.png) [@hentschke](https://forum.shopware.com/u/hentschke)\
**Post date:** [6. Februar 2018 um 06:47 UTC](https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913/8 "2018-02-06T06:47:25Z")

</div>

Hmm. Scheint es auch nicht zu sein.  
Wenn irgendetwas nicht auffindbar wäre dann würde ich ja auch den redirect/404 im server log finden.

---

<div class="post-metadata">

**Author:** ![chwzr](https://avatars.discourse-cdn.com/v4/letter/c/8c91f0/32.png) [@chwzr](https://forum.shopware.com/u/chwzr)\
**Post date:** [6. Februar 2018 um 08:31 UTC](https://forum.shopware.com/t/shop-will-im-produktivmodus-nicht-laufen/50913/9 "2018-02-06T08:31:12Z")

</div>

Failed to load resource: the server responded with a status of 500 (Internal Server Error)

Der Fehler sollte allerdings im log sein.&nbsp;
