# Resource license not found failure

**URL:** <https://forum.shopware.com/t/resource-license-not-found-failure/37609>\
**Category:** Administration\
**Created:** [21. Juni 2016 um 16:09 UTC](https://forum.shopware.com/t/resource-license-not-found-failure/37609 "2016-06-21T16:09:24Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![s\_oliver](https://avatars.discourse-cdn.com/v4/letter/s/5daacb/32.png) [@s\_oliver](https://forum.shopware.com/u/s_oliver)\
**Post date:** [21. Juni 2016 um 16:09 UTC](https://forum.shopware.com/t/resource-license-not-found-failure/37609/1 "2016-06-21T16:09:24Z")

</div>

**httpdocs/engine/Shopware/Components/DependencyInjection/Container.php** on line **192**  
503 Service Unavailable

Bekomme ich nach dem&nbsp;klicken auf neuinstallation vom Lizenz-Manager. Was kann ich hier jetzt machen??

---

<div class="post-metadata">

**Author:** ![tschersich](https://avatars.discourse-cdn.com/v4/letter/t/a9adbd/32.png) [@tschersich](https://forum.shopware.com/u/tschersich)\
**Post date:** [23. Juni 2016 um 13:48 UTC](https://forum.shopware.com/t/resource-license-not-found-failure/37609/2 "2016-06-23T13:48:33Z")

</div>

Hast Du es gelöst?

Ich habe bei einem Shop genau das selbe Problem, allerdings beim Update des License Managers auf 1.2.0

Bitte um Hilfe!

&nbsp;

Oops! An error has occurred!

The following notes should help you.

Resource “license” not found failure in Shopware/Components/DependencyInjection/Container.php on line 192

Stack trace:

```
 #0 Enlight/Plugin/Bootstrap.php(116): Shopware\Components\DependencyInjection\Container-\>get('license') #1 Shopware/Plugins/Community/Backend/SwagDigitalPublishing/Bootstrap.php(373): Enlight\_Plugin\_Bootstrap-\>get() #2 Shopware/Plugins/Community/Backend/SwagDigitalPublishing/Bootstrap.php(312): Shopware\_Plugins\_Backend\_SwagDigitalPublishing\_Bootstrap-\>checkLicenseCore() #3 Shopware/Plugins/Community/Backend/SwagDigitalPublishing/Bootstrap.php(148): Shopware\_Plugins\_Backend\_SwagDigitalPublishing\_Bootstrap-\>checkLicense() #4 Enlight/Event/Handler/Plugin.php(149): Shopware\_Plugins\_Backend\_SwagDigitalPublishing\_Bootstrap-\>registerSubscriber(Object(Enlight\_Controller\_ActionEventArgs)) #5 Enlight/Event/EventManager.php(213): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Controller\_ActionEventArgs)) #6 Enlight/Controller/Action.php(137): Enlight\_Event\_EventManager-\>notify('Enlight\_Control...', Object(Enlight\_Controller\_ActionEventArgs)) #7 Enlight/Controller/Dispatcher/Default.php(523): Enlight\_Controller\_Action-\>dispatch('indexAction') #8 Enlight/Controller/Front.php(226): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #9 Shopware/Kernel.php(153): Enlight\_Controller\_Front-\>dispatch() #10 vendor/symfony/http-kernel/HttpCache/HttpCache.php(492): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #11 Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #12 vendor/symfony/http-kernel/HttpCache/HttpCache.php(263): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #13 Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #14 shopware.php(101): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #15 {main}
```

---

<div class="post-metadata">

**Author:** ![tschersich](https://avatars.discourse-cdn.com/v4/letter/t/a9adbd/32.png) [@tschersich](https://forum.shopware.com/u/tschersich)\
**Post date:** [23. Juni 2016 um 14:24 UTC](https://forum.shopware.com/t/resource-license-not-found-failure/37609/3 "2016-06-23T14:24:53Z")

</div>

Lösung bei mir:

Digital Publishing aus dem Plugins Ordner schieben, dann geht das Backend wieder.

Lizenmanager war nach dem Update inaktiv (nicht zm ersten mal bei einem Plugin-Update), also aktivieren

Digital Publishing Ordner wieder zurück schieben und die verknüpften Einkaufswelten löschen und neu anlegen, weil irgendeine Zuordnung verloren geht.

Blöd!

---

<div class="post-metadata">

**Author:** ![s\_oliver](https://avatars.discourse-cdn.com/v4/letter/s/5daacb/32.png) [@s\_oliver](https://forum.shopware.com/u/s_oliver)\
**Post date:** [24. Juni 2016 um 14:13 UTC](https://forum.shopware.com/t/resource-license-not-found-failure/37609/4 "2016-06-24T14:13:10Z")

</div>

Ganz so einfach war es dann auch nicht, aber Danke für den Schubser in die richtige Richtung.

SwagFuzzy musste auch noch rausgenommen werden, das das Backend wieder funktioniert hat.

Viele Grüße

---

<div class="post-metadata">

**Author:** ![kossi\_lpc](https://avatars.discourse-cdn.com/v4/letter/k/a4c791/32.png) [@kossi\_lpc](https://forum.shopware.com/u/kossi_lpc)\
**Post date:** [6. Oktober 2017 um 07:51 UTC](https://forum.shopware.com/t/resource-license-not-found-failure/37609/5 "2017-10-06T07:51:45Z")

</div>

Shopware version 5.1.3&nbsp;

Datum 2017-10-06

Falls das Problem noch besteht bzw. für andere die genau auf dieses Problem stossen. Die Lösung ist ganz ein einfach.

1. Nach dem Plugin in der Datenbank suchen.&nbsp;

[SELECT](http://localhost/phpmyadmin/url.php?url=https://dev.mysql.com/doc/refman/5.5/en/select.html)&nbsp;\*&nbsp;FROM&nbsp;`s_core_plugins`&nbsp;WHERE&nbsp;label=’’;

1. Den Eintrag ‚active‘ von den betroffenen Modul auf 0 setzen.
