# Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitI

**URL:** <https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224>\
**Category:** Allgemein\
**Created:** [21. August 2016 um 07:51 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224 "2016-08-21T07:51:42Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ichkannesnicht](https://avatars.discourse-cdn.com/v4/letter/i/c2a13f/32.png) [@Ichkannesnicht](https://forum.shopware.com/u/Ichkannesnicht)\
**Post date:** [21. August 2016 um 07:51 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/1 "2016-08-21T07:51:42Z")

</div>

Hallo,

Domain auf Server A, SW auf sever B. Nach dem auslösen der Seite www.sa\_sa\_sa\_sa.de kommt front zu sehen alles funktioniert nur sobald man etwas anklickt kommt

Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace

Wie bekomme ich das fertig ?

Auf den SW Server kann ich folgende Einstellungen verändern.

display\_errors:

magic\_quotes\_gpc:

register\_globals:

safe\_mode:

oPcache:

Encodery PHP

ionCube:

phpShield:

Zend Optimizer/Zend Guard:

Dies Optionen kann ich direkt am Server an / aus einstellen&nbsp;?!

Hab mal probiert aber ohne Erfolg

Kann jemand Helfen ?

&nbsp;

---

<div class="post-metadata">

**Author:** ![NextMike](https://avatars.discourse-cdn.com/v4/letter/n/838e76/32.png) [@NextMike](https://forum.shopware.com/u/NextMike)\
**Post date:** [21. August 2016 um 09:03 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/2 "2016-08-21T09:03:54Z")

</div>

Hast Du in Shopware den Host korrekt eingetragen?

Wann erfolgte die DNS Umstellung?

---

<div class="post-metadata">

**Author:** ![Ichkannesnicht](https://avatars.discourse-cdn.com/v4/letter/i/c2a13f/32.png) [@Ichkannesnicht](https://forum.shopware.com/u/Ichkannesnicht)\
**Post date:** [21. August 2016 um 09:12 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/3 "2016-08-21T09:12:43Z")

</div>

> [@NextMike schrieb:](https://forum.shopware.com/profile/19433/NextMike "NextMike")
> 
> Hast Du in Shopware den Host korrekt eingetragen?
> 
> **Denke Schon die Gleiche Adresse wir die Domain&nbsp;**
> 
> Wann erfolgte die DNS Umstellung?
> 
> **So Ca. vor 30 Stunden**

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [21. August 2016 um 10:28 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/4 "2016-08-21T10:28:21Z")

</div>

Kann es sein, daß Du im Shopware-Backend als Domain [www.domain.de](http://www.domain.de) eingetragen hast, Deinen Webserver aber so konfiguriert hast, daß er auf [domain.de](http://domain.de) (ohne www) umschreibt (oder umgekehrt)? Gleiches wäre auch mit http vs. https denkbar (Du hast Shopware so konfiguriert, daß der Zugriff immer über https erfolgen soll, aber Dein Webserver ist so konfiguriert, daß er auf http umschreibt).

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![Ichkannesnicht](https://avatars.discourse-cdn.com/v4/letter/i/c2a13f/32.png) [@Ichkannesnicht](https://forum.shopware.com/u/Ichkannesnicht)\
**Post date:** [21. August 2016 um 10:41 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/5 "2016-08-21T10:41:27Z")

</div>

Ok, danke erstmal habe jetzt alles auf ohne WWW geschaltet es war tatsächlich etwas nicht richtig ,jetzt wollen wir mal abwarten.

Also alles ohne WWW.

&nbsp;

---

<div class="post-metadata">

**Author:** ![Ichkannesnicht](https://avatars.discourse-cdn.com/v4/letter/i/c2a13f/32.png) [@Ichkannesnicht](https://forum.shopware.com/u/Ichkannesnicht)\
**Post date:** [21. August 2016 um 17:10 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/6 "2016-08-21T17:10:48Z")

</div>

So jetzt habe ich abgewartet leider ohne Erfolg.

Mit https habe ich nichts gemacht alles nur http

???

---

<div class="post-metadata">

**Author:** ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)\
**Post date:** [22. August 2016 um 05:37 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/7 "2016-08-22T05:37:22Z")

</div>

Also scheint Dein Problem wie im anderen Thread geschrieben doch nicht gelöst zu sein!? 🙂  
Lies nochmal den anderen Thread, dort sind ja etliche Lösungsmöglichkeiten gelistet.

---

<div class="post-metadata">

**Author:** ![Ichkannesnicht](https://avatars.discourse-cdn.com/v4/letter/i/c2a13f/32.png) [@Ichkannesnicht](https://forum.shopware.com/u/Ichkannesnicht)\
**Post date:** [22. August 2016 um 05:58 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/8 "2016-08-22T05:58:51Z")

</div>

Hallo,

Probleme teilweise gelöst. 🙂

Es lag an der Seite des Servers wo die SW liegt. Es war so eingestellt das die Zuweisung der Domain auf ganzen Hauptverzeichnis geleitet war, habe das auf die Zuweisung auf entsprechende Verzeichnisse geändert und es funktioniert.

Es lag also nicht an WWW vor den Domains.

Aber es sind jetzt noch zwei Fehler die ich bearbeiten muss.

A) Nach Eingabe der Adresse mit WWW davor oder ohne kommt https:// also als unsichere Seite.

Nach der Eingabe das ich doch die Seite besuchen möchte kommt funktioniert alles wunderbar.

Doch für den Kunden ist das nicht akzeptabel !!! Da muss ich noch etwas Arbeiten dran.

B) Wenn ich auf ein Artikel gehe und dann auf „Frage zum Artikel?“ kann ich das Formular ausfüllen doch nach dem ich auf senden klicke kommt UPS! Es ist ein Fehler… alle andere Formulare die ich versenden Möchte funktionieren.

Viellicht hat vor ab jemand einen kleinen Tipp ?!

Danke

---

<div class="post-metadata">

**Author:** ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)\
**Post date:** [22. August 2016 um 10:34 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/9 "2016-08-22T10:34:38Z")

</div>

Du hast nach wie vor ein Problem in Deiner vHost Config. Requests auf http sollten auf https umgeleitet werden, zum Beispiel mit folgendem mod\_rewrite:

```
        ServerName www.domain.at:80
        ServerAlias www.domain.at ww.domain.at apobag.at

        RewriteEngine On
        RewriteRule ^/?(.*) https://www.domain.at/$1 [R,L]

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [23. August 2016 um 17:03 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/10 "2016-08-23T17:03:00Z")

</div>

> [@Ichkannesnicht schrieb:](https://forum.shopware.com/profile/24364/Ichkannesnicht "Ichkannesnicht")
> 
> &nbsp;
> 
> A) Nach Eingabe der Adresse mit WWW davor oder ohne kommt https:// also als unsichere Seite.
> 
> Nach der Eingabe das ich doch die Seite besuchen möchte kommt funktioniert alles wunderbar.
> 
> Doch für den Kunden ist das nicht akzeptabel !!! Da muss ich noch etwas Arbeiten dran.

Du benötigst ein „richtiges“ SSL-Zertifikat (z.B. von Comodo, GeoTrust, Thawte, Globalsign, etc.). Momentan scheinst Du nur ein selbstsigniertes SSL-Zertifikat zu nutzen (oder es ist abgelaufen).

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)\
**Post date:** [23. August 2016 um 17:13 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/11 "2016-08-23T17:13:35Z")

</div>

Wobei ein selbstsigniertes Zertifikat kein Grund für einen Redirect ist…  
Du kannst auch eines von [letsencrypt.org](http://letsencrypt.org) nehmen - die sind kostenlos und mit dem Dienst für Linux auch sehr bequem.

---

<div class="post-metadata">

**Author:** ![Ichkannesnicht](https://avatars.discourse-cdn.com/v4/letter/i/c2a13f/32.png) [@Ichkannesnicht](https://forum.shopware.com/u/Ichkannesnicht)\
**Post date:** [2. September 2016 um 06:38 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/12 "2016-09-02T06:38:02Z")

</div>

Hallo, habe eine Frage in der Programmierung gestellt aber da bekomme ich keine Antwort da versuche ich hier.

ok der Shop habe ich auf die Beine Gestellt und es funktioniert das Problem ist das er im Front sehr langsam ist.

Habe jetzt gelesen das die “optimizer\_search\_depth” Einstellung ca. 25% das ganze beschleunigt.

Ok, jezt habe ich geschaut und tat sächlich die ist bei mir auf 62 jetzt will ich die auf 0 setzen doch es geht nicht.

Ich logge mich in der Mysql ein setze alles so wie es soll doch der wert bleibt immer auf 62.

Ich vermute das diese Einstellung irgendwo in einem Script von SW zu ändern ist, oder ?!

der Hoster sagt, das er den Wert nicht ändern kann das es für alle Nutzer seines services wäre und ich soll ein extra serve mieten wo ich alles für mich einstellen kann.

Doch durch ändereung eines Scripts sollte das auch gehen?

Und wenn dann wo ???

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [2. September 2016 um 15:53 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/13 "2016-09-02T15:53:03Z")

</div>

optimizer\_search\_depth ist eine MySQL-Variable: [MySQL :: MySQL 5.6 Reference Manual :: 5.1.7 Server System Variables](https://dev.mysql.com/doc/refman/5.6/en/server-system-variables.html#sysvar_optimizer_search_depth)

Wenn Du Deinen eigenen Server oder VServer hast, dann kannst Du die Einstellung selber ändern (z.B. in /etc/mysql/my.cnf auf Debian/Ubuntu); wenn Du ein Shared Hosting hast, dann hast Du wahrscheinlich Pech gehabt, weil Dein Hoster das kaum für Dich ändern wird (denn die Änderunge beträfe automatisch auch alle anderen Benutzer auf dem Server).

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![Ichkannesnicht](https://avatars.discourse-cdn.com/v4/letter/i/c2a13f/32.png) [@Ichkannesnicht](https://forum.shopware.com/u/Ichkannesnicht)\
**Post date:** [2. September 2016 um 17:01 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/14 "2016-09-02T17:01:39Z")

</div>

Danke , genau das segten die mir auch ☹

Danke

---

<div class="post-metadata">

**Author:** ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)\
**Post date:** [2. September 2016 um 19:38 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/15 "2016-09-02T19:38:30Z")

</div>

Wie kommst Du zu dem Schluss, dass dieser Parameter die Performance-Issues begründet? Es gibt ungefähr 500 Parameter, die die Performance beeinflussen können - das ist nur einer davon…

---

<div class="post-metadata">

**Author:** ![Ichkannesnicht](https://avatars.discourse-cdn.com/v4/letter/i/c2a13f/32.png) [@Ichkannesnicht](https://forum.shopware.com/u/Ichkannesnicht)\
**Post date:** [2. September 2016 um 20:12 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/16 "2016-09-02T20:12:16Z")

</div>

Ja, da der Shop nach aufrufen im Frontet erst mal paar sekunden brucht bis er normal läuft suchte ich nach eine geschwiendigkeit optimierung,

Da habe ich die Hinweise auf&nbsp;optimizer\_search\_depth und wollte mal damit anfangen ?!

&nbsp;

---

<div class="post-metadata">

**Author:** ![DerNils](https://avatars.discourse-cdn.com/v4/letter/d/f14d63/32.png) [@DerNils](https://forum.shopware.com/u/DerNils)\
**Post date:** [3. September 2016 um 15:41 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/17 "2016-09-03T15:41:52Z")

</div>

Kann es sein, dass Dein Shop noch im Bearbeitungsmodus ist? Schau mal auf der ersten Seite des&nbsp;Moduls&nbsp;Cache/Performance

---

<div class="post-metadata">

**Author:** ![Ichkannesnicht](https://avatars.discourse-cdn.com/v4/letter/i/c2a13f/32.png) [@Ichkannesnicht](https://forum.shopware.com/u/Ichkannesnicht)\
**Post date:** [3. September 2016 um 19:22 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/18 "2016-09-03T19:22:01Z")

</div>

Hallo,

ne ist alles ok, Produktivmodus ist Aktiv hin und her geschaltet kein Unterschied.

&nbsp;

---

<div class="post-metadata">

**Author:** ![DerNils](https://avatars.discourse-cdn.com/v4/letter/d/f14d63/32.png) [@DerNils](https://forum.shopware.com/u/DerNils)\
**Post date:** [4. September 2016 um 11:17 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/19 "2016-09-04T11:17:38Z")

</div>

HTTP-Cache aufgewärmt?&nbsp;

---

<div class="post-metadata">

**Author:** ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)\
**Post date:** [5. September 2016 um 05:26 UTC](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224/20 "2016-09-05T05:26:46Z")

</div>

Ein Tipp: Analysiere zuerst den Perfomance-Bottleneck bevor Du an irgendwelchen Parametern schraubst ohne zu wissen&nbsp;was Du genau tust und ob (in diesem Fall) überhaupt die Datenbank das Problem darstellt. So zerstörst Du mehr als es nützt - abgesehen davon, dass es reine Zeitverschwendung ist im Dunkeln um sich zu schlagen.

[Nächste Seite](https://forum.shopware.com/t/request-exceeded-the-limit-of-10-internal-redirects-due-to-probable-configuration-error-use-limiti/39224.md?page=2)
