# Product Stream - 500 Internal Server Error

**URL:** https://forum.shopware.com/t/product-stream-500-internal-server-error/49739
**Category:** Allgemein
**Created:** [28. November 2017 um 06:06 UTC](https://forum.shopware.com/t/product-stream-500-internal-server-error/49739 "2017-11-28T06:06:41Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![robitronic](https://avatars.discourse-cdn.com/v4/letter/r/958977/32.png) [@robitronic](https://forum.shopware.com/u/robitronic)
#### Post date: [28. November 2017 um 06:06 UTC](https://forum.shopware.com/t/product-stream-500-internal-server-error/49739/1 "2017-11-28T06:06:41Z")

</div>

Wenn ich bei Product Stream auf Vorschau aktualiseren Klicke bekomme ich einen 500- Internal Server Error.

Hatte jemand schon ein ähnliches Problem mit den Product streams ?  
Nach einer Neuinstallation hat es funktioniert - nur nach einiger Zeit ging es nicht mehr.

Kann eigentlich nicht an der Installation liegen - sondern an der Datenbank oder Plugins&nbsp; - obwohl selbst beim deaktiveren aller Plugins funktioniert es nicht.

&nbsp;

---

<div class="post-metadata">

### Author: ![robitronic](https://avatars.discourse-cdn.com/v4/letter/r/958977/32.png) [@robitronic](https://forum.shopware.com/u/robitronic)
#### Post date: [29. November 2017 um 15:12 UTC](https://forum.shopware.com/t/product-stream-500-internal-server-error/49739/2 "2017-11-29T15:12:19Z")

</div>

Als Nachtrag hier noch die Fehlermeldung:

**Fatal error** : Uncaught Error: Call to a member function getId() on null in /srv/www/shop.robitronic.com/engine/Shopware/Components/DependencyInjection/Bridge/Session.php:90

Stack trace:

#0 /srv/www/shop.robitronic.com/var/cache/production\_201710241020/proxies/ShopwareProductionb5143f7edbd05e81bc932689767a44413e1aa021ProjectContainer.php(1138): Shopware\Components\DependencyInjection\Bridge\Session-\>createSession(Object(ShopwareProductionb5143f7edbd05e81bc932689767a44413e1aa021ProjectContainer), Object(Shopware\Components\Session\PdoSessionHandler))

#1 /srv/www/shop.robitronic.com/vendor/symfony/dependency-injection/Container.php(304): ShopwareProductionb5143f7edbd05e81bc932689767a44413e1aa021ProjectContainer-\>getSessionService()

#2 /srv/www/shop.robitronic.com/engine/Shopware/Components/DependencyInjection/Container.php(217): Symfony\Component\DependencyInjection\Container-\>get(‘session’, 1)

#3 /srv/www/shop.robitronic.com/engine/Shopware/Components/DependencyInjection/Container.php(146): Shopware\Components\DependencyInje in **/srv/www/shop.robitronic.com/engine/Shopware/Components/DependencyInjection/Bridge/Session.php** on line **90**

&nbsp;

---

<div class="post-metadata">

### Author: ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)
#### Post date: [30. November 2017 um 12:10 UTC](https://forum.shopware.com/t/product-stream-500-internal-server-error/49739/3 "2017-11-30T12:10:04Z")

</div>

Hast Du mal den Shopware-Cache geleert?

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

### Author: ![robitronic](https://avatars.discourse-cdn.com/v4/letter/r/958977/32.png) [@robitronic](https://forum.shopware.com/u/robitronic)
#### Post date: [30. November 2017 um 12:37 UTC](https://forum.shopware.com/t/product-stream-500-internal-server-error/49739/4 "2017-11-30T12:37:53Z")

</div>

Danke für die Antwort - wir haben den Cache sowohl mittles Backend Funktion alsauch das Verzeichnis geleert.  
Nach einer kompletten Neuinstallation ging es auch wieder einige Zeit - und leider nicht nachvollziebar warum und wann - tritt das Problem wieder auf.

---

<div class="post-metadata">

### Author: ![bquarta](https://avatars.discourse-cdn.com/v4/letter/b/4af34b/32.png) [@bquarta](https://forum.shopware.com/u/bquarta)
#### Post date: [18. April 2018 um 14:29 UTC](https://forum.shopware.com/t/product-stream-500-internal-server-error/49739/5 "2018-04-18T14:29:30Z")

</div>

Auch wenn das hier schon 5 Monate her ist, möchte ich das Thema mal pushen, da ich das selbe Problem habe.

Bei mir wird der Fehler offenkundig durch den folgenden Aufruf produziert:  
[DOMAIN]/widgets/emotion/productStreamArticleSlider/streamId/1/productBoxLayout/slider?start=0&limit=10

Jetzt gibt es bei dem Product-Box-Layout ja noch andere Möglichkeiten. Wenn ich den Link direkt aufrufe lande ich auf dem 500er-Fehler. Ändere ich hingegen den Link wie folgt ab:&nbsp;/widgets/emotion/productStreamArticleSlider/streamId/1/productBoxLayout/ **emotion**?start=0&limit=10

… dann findet er den Stream und gibt mir auch etwas aus.

Wirklich gelöst habe ich es aber noch nicht bekommen. Vielleicht hilft das ja aber irgendwem weiter und er möchte seine Erleuchtung hier mit allen teilen 😃

Shopware-Version ist übrigens die aktuelle 5.4.2

UPDATE:  
Ich konnte mittlerweile den “Bösewicht” ausfindig machen. In meinem Fall habe ich in einem Plugin ein Template-Override gehabt und zwar in der Datei&nbsp;

```
 frontend/listing/product-box/product-actions.tpl 

```

Das ganze führt wohl dazu, dass die Abfolgen der Events nicht mehr stimmen… genau verstanden habe ich es leider noch nicht, aber wenn ich den Override herausnehme, dann ist wieder alles in Ordnung mit der Funktionalität des Streams.

Vielleicht hilft das jemandem 🙂
