# Probleme mit Backend und SSL / Varnish Cache

**URL:** https://forum.shopware.com/t/probleme-mit-backend-und-ssl-varnish-cache/42074
**Category:** Administration
**Created:** [9. Dezember 2016 um 08:29 UTC](https://forum.shopware.com/t/probleme-mit-backend-und-ssl-varnish-cache/42074 "2016-12-09T08:29:06Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![marek\_pudelko](https://avatars.discourse-cdn.com/v4/letter/m/db5fbb/32.png) [@marek\_pudelko](https://forum.shopware.com/u/marek_pudelko)
#### Post date: [9. Dezember 2016 um 08:29 UTC](https://forum.shopware.com/t/probleme-mit-backend-und-ssl-varnish-cache/42074/1 "2016-12-09T08:29:06Z")

</div>

Hallo zusammen,  
ich stehe gerade vor einem unlösebaren Problem. Unser Shop wird in der Amazon Cloud betrieben. Vorgeschaltet ist eine Varnish Cache Instanz.  
Sowohl Shop als auch Backend laufen unter HTTPS.  
Als Option ist “SSL überall verwenden” aktiv. Unter “HTTP-Cache” ist bei “Alternative Proxy URL”, “[http://xx.xx.xx.xx](http://xx.xx.xx.xx)” eingetragen

Jedoch häufen sich diese Fehlermeldungen, wie unten angegeben. Außerdem gibt es auch in regelmäßigen Abständen Session Fehler.  
Die IP Adresse, die Shopware versucht zu erreichen ist die Varnish Instanz.  
Weiß jemand Rat, wo ich da ansetzen könnte?

```
Message:	
Unable to Connect to ssl://xx.xx.xx.xx:443. Error #111: Connection refused
Time:	
2016-12-09T09:00:20.252006+0100
Channel:	
core
Context:	
{
    "exception": {
        "class": "Zend_Http_Client_Adapter_Exception",
        "message": "Unable to Connect to ssl://xx.xx.xx.xx:443. Error #111: Connection refused",
        "code": 0,
        "file": "/srv/path/engine/Library/Zend/Http/Client/Adapter/Socket.php:235",
        "trace": [
            "/srv/path/engine/Library/Zend/Http/Client.php:1059",
            "/srv/path/engine/Shopware/Plugins/Default/Core/HttpCache/Bootstrap.php:1046",
            "/srv/path/engine/Shopware/Plugins/Default/Core/HttpCache/Bootstrap.php:1009",
            "/srv/path/engine/Shopware/Plugins/Default/Core/HttpCache/Bootstrap.php:926",
            "/srv/path/vendor/doctrine/common/lib/Doctrine/Common/EventManager.php:59",
            "/srv/path/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php:3325",
            "/srv/path/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php:427",
            "/srv/path/vendor/doctrine/orm/lib/Doctrine/ORM/EntityManager.php:356",
            "/srv/path/engine/Shopware/Components/Api/Resource/Resource.php:260",
            "/srv/path/engine/Shopware/Components/Api/Resource/Article.php:620",
            "/srv/path/engine/Shopware/Components/Api/Resource/Resource.php:521",
            "/srv/path/engine/Shopware/Plugins/Community/Backend/MaxoutCSVImporter/Components/Articles.php:0",
            "/srv/path/engine/Shopware/Plugins/Community/Backend/MaxoutCSVImporter/Bootstrap.php:215",
            "/srv/path/engine/Library/Enlight/Event/Handler/Plugin.php:149",
            "/srv/path/engine/Library/Enlight/Event/EventManager.php:251",
            "/srv/path/engine/Library/Enlight/Components/Cron/Manager.php:260",
            "/srv/path/engine/Shopware/Plugins/Default/Core/Cron/Cron.php:52",
            "/srv/path/engine/Library/Enlight/Controller/Action.php:159",
            "/srv/path/engine/Library/Enlight/Controller/Dispatcher/Default.php:523",
            "/srv/path/engine/Library/Enlight/Controller/Front.php:223",
            "/srv/path/engine/Shopware/Kernel.php:178",
            "/srv/path/shopware.php:113"
        ]
    }
}
request:	
{
    "uri": "/backend/cron",
    "method": null,
    "query": {
        "module": "backend",
        "controller": "cron",
        "action": "index"
    },
    "post": []
}
shop:	
No shop data available
session:	
No session data available

```

&nbsp;

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [9. Dezember 2016 um 11:31 UTC](https://forum.shopware.com/t/probleme-mit-backend-und-ssl-varnish-cache/42074/2 "2016-12-09T11:31:14Z")

</div>

Die Proxy-URL hast du auch wie in der Doku erwähnt in der config.php gepflegt?

[https://developers.shopware.com/sysadmins-guide/varnish-setup/#shopware-configuration](https://developers.shopware.com/sysadmins-guide/varnish-setup/#shopware-configuration)

&nbsp;
