# Probleme bei der Installation woran kann das liegen was kann ich tun ?

**URL:** <https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753>\
**Category:** Installation/Einstieg\
**Created:** [22. August 2017 um 21:38 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753 "2017-08-22T21:38:52Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dennis3090](https://avatars.discourse-cdn.com/v4/letter/d/ac8455/32.png) [@Dennis3090](https://forum.shopware.com/u/Dennis3090)\
**Post date:** [22. August 2017 um 21:38 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/1 "2017-08-22T21:38:52Z")

</div>

**Probleme bei der Installation woran kann das liegen was kann ich tun ?**

**Der Fehler Code ist 1 zu 1 kopiert:**

&nbsp;

Slim Application Error

The application could not run because of the following error:

Details

**Type:** ErrorException

**Code:** 2

**Message:** file\_put\_contents(C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs/recovery/install/data/uniqueid.txt): failed to open stream: Permission denied

**File:** C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\common\src\Service\UniqueIdGenerator.php

**Line:** 85

Trace

```
 &nbsp;

```

#0 [internal function]: Slim\Slim::handleErrors(2, ‘file\_put\_conten…’, ‘C:\Inetpub\vhos…’, 85, Array)  
#1 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\common\src\Service\UniqueIdGenerator.php(85): file\_put\_contents(‘C:\Inetpub\vhos…’, ‘bbpvDUESt1Vpabv…’)  
#2 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\common\src\Service\UniqueIdGenerator.php(58): Shopware\Recovery\Common\Service\UniqueIdGenerator-\>saveUniqueId(‘bbpvDUESt1Vpabv…’)  
#3 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\install\src\ContainerProvider.php(216): Shopware\Recovery\Common\Service\UniqueIdGenerator-\>getUniqueId()  
#4 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\common\vendor\pimple\pimple\src\Pimple\Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install{closure}(Object(Pimple\Container))  
#5 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\install\src\app.php(206): Pimple\Container-\>offsetGet(‘shopware.notify’)  
#6 [internal function]: {closure}()  
#7 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\common\vendor\slim\slim\Slim\Route.php(462): call\_user\_func\_array(Object(Closure), Array)  
#8 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\common\vendor\slim\slim\Slim\Slim.php(1326): Slim\Route-\>dispatch()  
#9 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\common\vendor\slim\slim\Slim\Middleware\Flash.php(85): Slim\Slim-\>call()  
#10 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\common\vendor\slim\slim\Slim\Middleware\MethodOverride.php(92): Slim\Middleware\Flash-\>call()  
#11 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\common\vendor\slim\slim\Slim\Middleware\PrettyExceptions.php(67): Slim\Middleware\MethodOverride-\>call()  
#12 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\common\vendor\slim\slim\Slim\Slim.php(1271): Slim\Middleware\PrettyExceptions-\>call()  
#13 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\recovery\install\index.php(75): Slim\Slim-\>run()  
#14 {main}

&nbsp;

Ihr könnt euch das ganze wenn ihr wollt auch gerne live anschauen: [http://vps1341053.fastwebserver.de/recovery/install/Index.php](http://vps1341053.fastwebserver.de/recovery/install/Index.php)

&nbsp;

Falls jemand eine Idee hat oder eine Lösung wäre für jede Art von Hilfe dankbar.

&nbsp;

Mit freundlichen Grüßen,

&nbsp;

Dennis

---

<div class="post-metadata">

**Author:** ![sschreier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sschreier/32/23296_2.png) [@sschreier](https://forum.shopware.com/u/sschreier)\
**Post date:** [22. August 2017 um 21:51 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/2 "2017-08-22T21:51:18Z")

</div>

Hallo,

der Fehler steht doch aber deutlich da: „Permission denied“. Das heißt, deine Verzeichnisse und Dateien haben nicht die erforderlichen Rechte (Schreiben, Lesen, Ausführen). Am besten gibst du allen Verzeichnissen und Dateien das Recht „777“, dann dürfte es funktionieren.

Beste Grüße

Sebastian

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [22. August 2017 um 22:34 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/3 "2017-08-22T22:34:40Z")

</div>

Ich würde Dir raten, auf ein Linux-Hosting zu wechseln. Dort sollten dann für Dateien die Rechte 644 und für Ordner 755 reichen.

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![Dennis3090](https://avatars.discourse-cdn.com/v4/letter/d/ac8455/32.png) [@Dennis3090](https://forum.shopware.com/u/Dennis3090)\
**Post date:** [24. August 2017 um 17:24 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/4 "2017-08-24T17:24:12Z")

</div>

Erstmal danke für die Antworten. Ich habe es jetzt soweit geschafft die Installation vorran zu treiben jedoch beim Finish sage ich mal tritt nun folgender Fehler auf mit dem ich leider nicht viel anfangen kann.

&nbsp;

Slim Application Error

The application could not run because of the following error:

Details

**Type:** ErrorException

**Code:** 2

**Message:** is\_file(): File name is longer than the maximum allowed path length on this platform (260): C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\var\cache\production\_201708081547\general\shopware–14706311e738d389e9866a785322e031Shopware\shopware–Models\shopware–201708081547\shopware—internal-metadatas—14706311e738d389e9866a785322e031Shopware\_Models\_201708081547\_771b61f40420ee0af1fa5d37775278e5

**File:** C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\engine\Library\Zend\Cache\Backend\File.php

**Line:** 982

Trace

```
 &nbsp;

```

#0 [internal function]: Slim\Slim::handleErrors(2, ‚is\_file(): File…‘, ‚C:\Inetpub\vhos…‘, 982, Array)  
#1 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\engine\Library\Zend\Cache\Backend\File.php(982): is\_file(‚C:\Inetpub\vhos…‘)  
#2 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\engine\Library\Zend\Cache\Backend\File.php(569): Zend\_Cache\_Backend\_File-\>\_fileGetContents(‚C:\Inetpub\vhos…‘)  
#3 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\engine\Library\Zend\Cache\Backend\File.php(502): Zend\_Cache\_Backend\_File-\>\_loadMetadatas(‚14706311e738d38…‘)  
#4 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\engine\Library\Zend\Cache\Backend\File.php(963): Zend\_Cache\_Backend\_File-\>\_getMetadatas(‚14706311e738d38…‘)  
#5 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\engine\Library\Zend\Cache\Backend\File.php(197): Zend\_Cache\_Backend\_File-\>\_test(‚14706311e738d38…‘, false)  
#6 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\engine\Library\Zend\Cache\Core.php(306): Zend\_Cache\_Backend\_File-\>load(‚14706311e738d38…‘, false)  
#7 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\engine\Shopware\Components\Model\Cache.php(78): Zend\_Cache\_Core-\>load(‚Shopware\_Models…‘)  
#8 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\vendor\doctrine\cache\lib\Doctrine\Common\Cache\CacheProvider.php(212): Shopware\Components\Model\Cache-\>doFetch(‚DoctrineNamespa…‘)  
#9 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\vendor\doctrine\cache\lib\Doctrine\Common\Cache\CacheProvider.php(165): Doctrine\Common\Cache\CacheProvider-\>getNamespaceVersion()  
#10 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\engine\Shopware\Components\Model\ModelManager.php(193): Doctrine\Common\Cache\CacheProvider-\>deleteAll()  
#11 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\engine\Shopware\Components\Model\ModelManager.php(180): Shopware\Components\Model\ModelManager-\>regenerateAttributeProxies(Array)  
#12 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\install\src\ContainerProvider.php(125): Shopware\Components\Model\ModelManager-\>generateAttributeModels()  
#13 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\common\vendor\pimple\pimple\src\Pimple\Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install{closure}(Object(Pimple\Container))  
#14 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\install\src\ContainerProvider.php(131): Pimple\Container-\>offsetGet(‚shopware.contai…‘)  
#15 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\common\vendor\pimple\pimple\src\Pimple\Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install{closure}(Object(Pimple\Container))  
#16 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\install\src\ContainerProvider.php(146): Pimple\Container-\>offsetGet(‚shopware.theme\_…‘)  
#17 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\common\vendor\pimple\pimple\src\Pimple\Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install{closure}(Object(Pimple\Container))  
#18 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\install\src\app.php(497): Pimple\Container-\>offsetGet(‚theme.service‘)  
#19 [internal function]: {closure}()  
#20 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\common\vendor\slim\slim\Slim\Route.php(462): call\_user\_func\_array(Object(Closure), Array)  
#21 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\common\vendor\slim\slim\Slim\Slim.php(1326): Slim\Route-\>dispatch()  
#22 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\common\vendor\slim\slim\Slim\Middleware\Flash.php(85): Slim\Slim-\>call()  
#23 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\common\vendor\slim\slim\Slim\Middleware\MethodOverride.php(92): Slim\Middleware\Flash-\>call()  
#24 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\common\vendor\slim\slim\Slim\Middleware\PrettyExceptions.php(67): Slim\Middleware\MethodOverride-\>call()  
#25 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\common\vendor\slim\slim\Slim\Slim.php(1271): Slim\Middleware\PrettyExceptions-\>call()  
#26 C:\Inetpub\vhosts\[vps1341053.fastwebserver.de](http://vps1341053.fastwebserver.de)\httpdocs\shop\recovery\install\index.php(75): Slim\Slim-\>run()  
#27 {main}

&nbsp;

Zu der Geschichte mit Linux ? Wieso Linux gibt es da irgendwelche Vorteile ?

&nbsp;

Mit freundlichen Grüßen,

&nbsp;

Dennis

---

<div class="post-metadata">

**Author:** ![svenhab](https://avatars.discourse-cdn.com/v4/letter/s/35a633/32.png) [@svenhab](https://forum.shopware.com/u/svenhab)\
**Post date:** [25. August 2017 um 06:16 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/5 "2017-08-25T06:16:07Z")

</div>

Ich habe genau das selbe Problem und keine Ahnung weshalb.

&nbsp;

Weiß jemand wo das Problem liegt?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [25. August 2017 um 06:32 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/6 "2017-08-25T06:32:32Z")

</div>

Ist das ein Windows System? Shopware ist generell nicht für den Betrieb auf Windows-Systemen geeignet. Die Fehlermeldung sagt erstmal nur, dass die Länge des Cache-Pfades auf dem System zu lang ist.&nbsp;

---

<div class="post-metadata">

**Author:** ![M\_Heying](https://avatars.discourse-cdn.com/v4/letter/m/c89c15/32.png) [@M\_Heying](https://forum.shopware.com/u/M_Heying)\
**Post date:** [25. August 2017 um 09:21 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/7 "2017-08-25T09:21:42Z")

</div>

> [@svenhab schrieb:](https://forum.shopware.com/profile/27111/svenhab "svenhab")
> 
> Ich habe genau das selbe Problem und keine Ahnung weshalb.
> 
> &nbsp;
> 
> Weiß jemand wo das Problem liegt?

Ja, wie Moritz schon schrieb am Betriebssystem, weitere Infos findest du [hier](https://msdn.microsoft.com/en-us/library/aa365247(VS.85).aspx#maxpath)

---

<div class="post-metadata">

**Author:** ![Dennis3090](https://avatars.discourse-cdn.com/v4/letter/d/ac8455/32.png) [@Dennis3090](https://forum.shopware.com/u/Dennis3090)\
**Post date:** [25. August 2017 um 14:26 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/8 "2017-08-25T14:26:11Z")

</div>

Okay habe jetzt den Server von Windows auf Linux umgestellt. Jetzt kann ich die installation erfolgreich abschließen jedoch sehe ich nix wenn ich meine Seite aufrufe.

Wenn ich auf die „Admin Seite“ gehe dann habe ich eine leere hellblaue Seite und wenn ich auf die eigentliche Shop Seite gehe so bleibt diese einfach nur Weiß.

&nbsp;

Wer sich davon selbst überzeugen möchte findet den Link zu meiner Website hier:

&nbsp;

[KLICK](http://www.aquaristik-shop.com)

&nbsp;

Falls jemand eine Idee oder Lösung hat würde mich freuen.

&nbsp;

Lg. Dennis

&nbsp;

---

<div class="post-metadata">

**Author:** ![AndreHerking](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/andreherking/32/7839_2.png) [@AndreHerking](https://forum.shopware.com/u/AndreHerking)\
**Post date:** [25. August 2017 um 14:46 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/9 "2017-08-25T14:46:27Z")

</div>

Hey Dennis,

scheinbar fehlen ganze Komponenten - am Besten führst du einen kompletten Reinstall durch. Es empfiehlt sich das ZIP Archiv erst auf dem Server zu entpacken, um Dateiverluste während der Übertragung zu vermeiden. An der jetztigen Installation lässt sich nicht weiter rum doktern.

LG Andre

---

<div class="post-metadata">

**Author:** ![Dennis3090](https://avatars.discourse-cdn.com/v4/letter/d/ac8455/32.png) [@Dennis3090](https://forum.shopware.com/u/Dennis3090)\
**Post date:** [25. August 2017 um 16:17 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/10 "2017-08-25T16:17:08Z")

</div>

Okay danke ist ja krass das bei der Übertragung solche Dateilücken entstehen.

&nbsp;

Dann lade ich mal eben schnell das zip file hoch und entpacke es vorort.

&nbsp;

Lg.

---

<div class="post-metadata">

**Author:** ![Dennis3090](https://avatars.discourse-cdn.com/v4/letter/d/ac8455/32.png) [@Dennis3090](https://forum.shopware.com/u/Dennis3090)\
**Post date:** [25. August 2017 um 23:20 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/11 "2017-08-25T23:20:47Z")

</div>

Jetzt habe ich die zip dateil drauf gepackt und vorort entpackt und jetzt will die installation net mehr starten das ist ja zum verrückt werden irgendwas ist immer.

Aktuell spuckt es wieder folgenden Fehler aus:

&nbsp;

Slim Application Error

The application could not run because of the following error:

Details

**Type:** ErrorException

**Code:** 2

**Message:** file\_put\_contents(/var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/install/data/uniqueid.txt): failed to open stream: Permission denied

**File:** /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/src/Service/UniqueIdGenerator.php

**Line:** 85

Trace

```
 &nbsp;

```

#0 [internal function]: Slim\Slim::handleErrors(2, ‘file\_put\_conten…’, ‘/var/www/vhosts…’, 85, Array)  
#1 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/src/Service/UniqueIdGenerator.php(85): file\_put\_contents(’/var/www/vhosts…’, ‘Hdxs53HoWy9Xvc5…’)  
#2 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/src/Service/UniqueIdGenerator.php(58): Shopware\Recovery\Common\Service\UniqueIdGenerator-\>saveUniqueId(‘Hdxs53HoWy9Xvc5…’)  
#3 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/install/src/ContainerProvider.php(216): Shopware\Recovery\Common\Service\UniqueIdGenerator-\>getUniqueId()  
#4 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install{closure}(Object(Pimple\Container))  
#5 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/install/src/app.php(206): Pimple\Container-\>offsetGet(‘shopware.notify’)  
#6 [internal function]: {closure}()  
#7 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Route.php(462): call\_user\_func\_array(Object(Closure), Array)  
#8 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Slim.php(1326): Slim\Route-\>dispatch()  
#9 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim-\>call()  
#10 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash-\>call()  
#11 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Middleware/PrettyExceptions.php(67): Slim\Middleware\MethodOverride-\>call()  
#12 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Slim.php(1271): Slim\Middleware\PrettyExceptions-\>call()  
#13 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/install/index.php(75): Slim\Slim-\>run()  
#14 {main}

&nbsp;

Ich hoffe wenn diese ganzen Probleme erstmal gelöst sind das Shopware dann das hält was es verspricht 😃

&nbsp;

Lg.

---

<div class="post-metadata">

**Author:** ![Dennis3090](https://avatars.discourse-cdn.com/v4/letter/d/ac8455/32.png) [@Dennis3090](https://forum.shopware.com/u/Dennis3090)\
**Post date:** [26. August 2017 um 13:14 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/12 "2017-08-26T13:14:53Z")

</div>

Also ich muss sagen ich weiß nicht mehr weiter kaum löst man ein Problem tun sich 10 andere auf ich denke ich schenke mir das mit Shopware das wird nix. Das kostet mich nur Zeit, Geld und Nerven. Am Anfang wo ich die Datein ausgepackt hochgeladen hatte hat wenigstens die installation funktioniert wobei auch nicht zu 100% weil daten beim hochladen verloren gegangen sind und jetzt wenn ich das zip archive hochlade auspacke und dann die installation starten möchte klappt einfach nix.

&nbsp;

Falls noch jemand eine Idee oder eine Lösung hat kann er mir diese ja gerne mitteilen.

&nbsp;

Slim Application Error

The application could not run because of the following error:

Details

**Type:** ErrorException

**Code:** 2

**Message:** file\_put\_contents(/var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/install/data/uniqueid.txt): failed to open stream: Permission denied

**File:** /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/src/Service/UniqueIdGenerator.php

**Line:** 85

Trace

```
 &nbsp;

```

#0 [internal function]: Slim\Slim::handleErrors(2, ‘file\_put\_conten…’, ‘/var/www/vhosts…’, 85, Array)  
#1 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/src/Service/UniqueIdGenerator.php(85): file\_put\_contents(’/var/www/vhosts…’, ‘YdhsNykrI6ENBXT…’)  
#2 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/src/Service/UniqueIdGenerator.php(58): Shopware\Recovery\Common\Service\UniqueIdGenerator-\>saveUniqueId(‘YdhsNykrI6ENBXT…’)  
#3 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/install/src/ContainerProvider.php(216): Shopware\Recovery\Common\Service\UniqueIdGenerator-\>getUniqueId()  
#4 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install{closure}(Object(Pimple\Container))  
#5 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/install/src/app.php(206): Pimple\Container-\>offsetGet(‘shopware.notify’)  
#6 [internal function]: {closure}()  
#7 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Route.php(462): call\_user\_func\_array(Object(Closure), Array)  
#8 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Slim.php(1326): Slim\Route-\>dispatch()  
#9 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim-\>call()  
#10 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash-\>call()  
#11 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Middleware/PrettyExceptions.php(67): Slim\Middleware\MethodOverride-\>call()  
#12 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/common/vendor/slim/slim/Slim/Slim.php(1271): Slim\Middleware\PrettyExceptions-\>call()  
#13 /var/www/vhosts/aquaristik-shop.com/httpdocs/recovery/install/index.php(75): Slim\Slim-\>run()  
#14 {main}

&nbsp;

Die Alternative ist ein Shop Baukasten wo man mit dem Hosting nix am Hut hat den diese ganzen Probleme gehen mir langsam aber sicher auf den Keks.

&nbsp;

Danke an alle die bisher geholfen haben oder eventuell noch helfen werden.

&nbsp;

Mit freundlichen Grüßen,

&nbsp;

Dennis

---

<div class="post-metadata">

**Author:** ![simkli](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/simkli/32/13124_2.png) [@simkli](https://forum.shopware.com/u/simkli)\
**Post date:** [26. August 2017 um 14:43 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/13 "2017-08-26T14:43:14Z")

</div>

Du kannst dir auch ein zertifiziertes Shopware-Hosting holen:&nbsp;[https://de.shopware.com/Partner/list/type/hosting/](https://de.shopware.com/Partner/list/type/hosting/) . Da wird speziell darauf geachtet, dass es mit Shopware keine Probleme gibt. Das spart dir sicher viele Nerven und Zeit 😉

Ansonsten hast du ein Berechtigungsproblem: Shopware kann die Dateien nicht ändern. Du musst Shopware die richtigen Rechte geben.&nbsp;

Viele Grüße

---

<div class="post-metadata">

**Author:** ![Dennis3090](https://avatars.discourse-cdn.com/v4/letter/d/ac8455/32.png) [@Dennis3090](https://forum.shopware.com/u/Dennis3090)\
**Post date:** [26. August 2017 um 16:20 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/14 "2017-08-26T16:20:48Z")

</div>

Danke 😃 dann versuche ich mal mein Glück mit den Rechten. Ja das stimmt Zeit und Nerven würde es sparen aber dafür wollen solche Hoster im Schnitt 30€/Monat + 25€ Einrichtungsgebühr (Einmalig) da probiere ich lieber noch 6 Wochen mit der installation rum bevor ich 30€ für einen normalen Webspace pro Monat bezahle.

&nbsp;

&nbsp;

Lg.

---

<div class="post-metadata">

**Author:** ![Dennis3090](https://avatars.discourse-cdn.com/v4/letter/d/ac8455/32.png) [@Dennis3090](https://forum.shopware.com/u/Dennis3090)\
**Post date:** [27. August 2017 um 12:11 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/15 "2017-08-27T12:11:53Z")

</div>

Puh also ich verstehe es ums verrecken nicht. Alle System Vorraussetzungen sind erfüllt das Rechte Problem ist gelöst ich habe die Zip datei hochgeladen entpackt und die installation laut dem was da steht “erfolgreich” durchgeführt und dennoch bekomme ich wenn ich auf das backend gehe oder auf den Shop an sich ein blanko Seite.

Ich meine das kann es doch net sein oder ? ich meine das ist eigentlich keine komplexe sache aber trotsdem funktioniert einfach nichts. Als Betriebssystem nutze ich Debian 8 auf meinem vServer habe Plesk zur verwaltung von Webspace & Domain am start und weiß langsam einfach nicht mehr weiter.

&nbsp;

Fall noch irgendwer eine Idee haben sollte ich bin für jede Art der Hilfe mehr als dankbar.

&nbsp;

Lg. Dennis

---

<div class="post-metadata">

**Author:** ![Murmeltier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/murmeltier/32/16126_2.png) [@Murmeltier](https://forum.shopware.com/u/Murmeltier)\
**Post date:** [28. August 2017 um 10:25 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/16 "2017-08-28T10:25:10Z")

</div>

> **[Shopware Dokumentation](https://docs.shopware.com/de)**

Wirklich alles davon erfüllt?

---

<div class="post-metadata">

**Author:** ![Murmeltier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/murmeltier/32/16126_2.png) [@Murmeltier](https://forum.shopware.com/u/Murmeltier)\
**Post date:** [28. August 2017 um 10:32 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/17 "2017-08-28T10:32:08Z")

</div>

> [@Dennis3090 schrieb:](https://forum.shopware.com/profile/27100/Dennis3090 "Dennis3090")
> 
> Danke ![:D](https://dub1.discourse-cdn.com/flex013/resources/emoji/lol.png ":D") dann versuche ich mal mein Glück mit den Rechten. Ja das stimmt Zeit und Nerven würde es sparen aber dafür wollen solche Hoster im Schnitt 30€/Monat + 25€ Einrichtungsgebühr (Einmalig) da probiere ich lieber noch 6 Wochen mit der installation rum bevor ich 30€ für einen normalen Webspace pro Monat bezahle.

Leg Dir einfach mal ein vernünftiges Webpaket bei All-Inkl zu! Kostet - mit&nbsp;9,95 €/Monat - jetzt echt nicht die Welt. Zudem sind die ersten 3 Monate im Moment sogar gratis:

> **[Webhosting Tarif ALL-INKL PREMIUM - ALL-INKL.COM](https://all-inkl.com/webhosting/premium/)**
>
> Webhosting für Neukunden 3 Monate kostenlos! Tarif ALL-INKL PREMIUM mit 10 Domains, 250 GB Webspace, 50 x MySQL, keine Einrichtungsgebühr, monatlich kündbar!

---

<div class="post-metadata">

**Author:** ![Dennis3090](https://avatars.discourse-cdn.com/v4/letter/d/ac8455/32.png) [@Dennis3090](https://forum.shopware.com/u/Dennis3090)\
**Post date:** [28. August 2017 um 13:32 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/18 "2017-08-28T13:32:29Z")

</div>

@Murmeltier‍&nbsp; Ja auf der Checkliste die beim Installieren dargestellt wird war alles auf Grün deshalb verstehe ich es ja einfach nicht wo da das Problem ist. Mal angenommen ich miete das Webpaket was soll das für ein Unterschied machen ? bei einem vServer bin ich eigentlich ja noch uneingeschränkter als bei einem billigen Webspace wo 150 Mann auf einem Root Server liegen und jeder nur einen kleinen Teil davon abbekommt und man da null Rechte hat um das System zu gestalten wie man es gerne hätte ?

&nbsp;

Lg.

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![Murmeltier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/murmeltier/32/16126_2.png) [@Murmeltier](https://forum.shopware.com/u/Murmeltier)\
**Post date:** [28. August 2017 um 13:56 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/19 "2017-08-28T13:56:19Z")

</div>

Klar, da hast Du sicherlich nicht ganz unrecht, aber momentan kriegst Du es ja auf Deinem Server auch nicht zum Laufen… und das, obwohl Du da ja mit niemandem den Platz dort teilen musst! 😉

Dein Fontend geht überhaupt nicht und im Backend hast Du folgende Fehlermeldung:

```
Error: Ext.Loader is not enabled, so dependencies cannot be resolved dynamically. Missing required class: Shopware.container.Viewport

```

Zudem hast Du zwei 503 Errors:

```
/backend/base?file=bootstrap&201708221512

```

Von daher würde ich mal schauen, ob der Fehler nicht sogar an Deiner Serverkonfiguration liegt!?

&nbsp;

---

<div class="post-metadata">

**Author:** ![Murmeltier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/murmeltier/32/16126_2.png) [@Murmeltier](https://forum.shopware.com/u/Murmeltier)\
**Post date:** [28. August 2017 um 14:02 UTC](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753/20 "2017-08-28T14:02:29Z")

</div>

BTW: Wie lädst Du denn die Daten auf den Server? Binär oder ASCII?

[Nächste Seite](https://forum.shopware.com/t/probleme-bei-der-installation-woran-kann-das-liegen-was-kann-ich-tun/47753.md?page=2)
