# Problem mit 1und1 - Internal Server Error - Fehlercode 500

**URL:** https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971
**Category:** Installation/Einstieg
**Created:** [24. Oktober 2018 um 20:33 UTC](https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971 "2018-10-24T20:33:27Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![gebe](https://avatars.discourse-cdn.com/v4/letter/g/e9a140/32.png) [@gebe](https://forum.shopware.com/u/gebe)
#### Post date: [24. Oktober 2018 um 20:33 UTC](https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971/1 "2018-10-24T20:33:27Z")

</div>

Hallo zusammen,

ich hab bereits nach einiger Recherche hier im Forum meinen Fehler eingrenzen können und hab auch schon verschiedene Lösungswege versucht. Leider zeigt alles bei mir keine Wirkung.

Fehlerbeschreibung:

> Nach entpacken der .zip funktioniert die automatische Weiterleitung zur Installation nicht. Man landet auf einer leeren Seite (laut 1&1 ist die Adresse vergeben aber noch keine Webseite vorhanden.)
> 
> /recovery/install funktioniert nicht. Es erscheint eine leere Seite. (aber: /recovery/install/index.php ruft die Installation auf)
> 
> Nach der Installation (erfolgreich) Button zum Backend führt auf eine leere Seite.
> 
> /backend fürht auf eine leere Seite.
> 
> Menüpunkte im Frontend führen auf eine leere Seite.

Daher versuch ich es mit einem neuen Thema.

Mein Hoster ist 1und1. Es ist anscheinend bekannt, dass bei diesem Hoster die Installation und der Zugriff auf das Backend nicht reibungslos funktionieren. In ettlichen Diskussionen und Posts kommen die meisten zu dem Schluss, dass eine Umbenennung der .hcacess Datei im Verzeichnis ./recovery/install und eine Änderung in der .htacess Datei im Stammverzeichnis die Lösung ist.

Siehe z.B. folgende Links:

> [https://forum.shopware.com/discussion/56148/help-nach-installation-und-aufruf-des-backend-erscheint-fehler-500/p1](https://forum.shopware.com/discussion/56148/help-nach-installation-und-aufruf-des-backend-erscheint-fehler-500/p1)
> 
> [HELP ! bei der Erstinstallation Fehler: 500 Internal Server Error error - #9 von ALA - Installation/Einstieg - Shopware Community Forum](https://forum.shopware.com/discussion/comment/232323/#Comment%5C_232323)
> 
> [https://it-fvb.de/shopware-5-x-auf-11-installieren-internal-server-error-500-fehler-beheben.html](https://it-fvb.de/shopware-5-x-auf-11-installieren-internal-server-error-500-fehler-beheben.html)

&nbsp;Diese Änderung hat bei mir aber bisher nichts geholfen.

Nach einer erneuten Installation ist mir in Schritt 2 der Installation „Systemvorraussetzungen“ aufgefallen, dass er zwar sagt „Alles OK, weiter“ aber wenn man die Systemvorraussetzungen aufklappt fehlt offenbar etwas.

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/b/bfe46dccee4216f7485826092a5ec3362fa4a7c5.png)

und auch

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/6/65e2a8ee8bf46893eee438309e1f54bd97895843.png)

Ich weiss das in dieser&nbsp;.htaccess Datei am anfang das Rewrite auf „On“ gesetzt wird. Kann man diesen Fehler daher irgnorieren? Wenn nein - wie kann ich es aktivieren?

Zum zweiten Bild hab ich überhaupt kein Ahnung warum der Speicher auf -1 ist.

&nbsp;

PS: Frontend geht, phpinfo() geht

Ich wäre euch sehr dankbar falls jemand einen weiteren Tipp hat der mich zu einer Lösung führt.

Liebe Grüße

---

<div class="post-metadata">

### Author: ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)
#### Post date: [24. Oktober 2018 um 21:10 UTC](https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971/2 "2018-10-24T21:10:26Z")

</div>

Das memory\_limit solltest du über die php.ini einstellen können.

---

<div class="post-metadata">

### Author: ![HeroBoarding](https://avatars.discourse-cdn.com/v4/letter/h/c5a1d2/32.png) [@HeroBoarding](https://forum.shopware.com/u/HeroBoarding)
#### Post date: [24. Oktober 2018 um 22:09 UTC](https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971/3 "2018-10-24T22:09:33Z")

</div>

Hallo, ich habe beide Probleme gelöst, es war etwas knifflig bei mir läuft es aber jetzt, ich habe gerade keinen Laptop aber schreibe mir morgen mal eine PN, dann antworte ich dir mit den Lösungen&nbsp;

---

<div class="post-metadata">

### Author: ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)
#### Post date: [24. Oktober 2018 um 22:20 UTC](https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971/4 "2018-10-24T22:20:44Z")

</div>

Bzgl. der .htaccess kann ich sonst auch gerne helfen, das sollte kein großes Problem sein.

---

<div class="post-metadata">

### Author: ![HeroBoarding](https://avatars.discourse-cdn.com/v4/letter/h/c5a1d2/32.png) [@HeroBoarding](https://forum.shopware.com/u/HeroBoarding)
#### Post date: [25. Oktober 2018 um 20:01 UTC](https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971/5 "2018-10-25T20:01:16Z")

</div>

Also ich habe folgendes gemacht, bei der Installation kam bei mir auch der Fehler, dann habe ich folgende beschriebe Schritte gemacht:

&nbsp;

> **[Shopware 5.x auf 1&1 installieren - Internal Server Error 500 Fehler beheben](https://it-fvb.de/shopware-5-x-auf-11-installieren-internal-server-error-500-fehler-beheben.html)**
>
> Aus aktuellem Anlass heute eine kurze Anleitung, wie man eine aktuelle Shopware-Installation auf einem 1und1-Webhosting-Paket (z. B. UNLIMITED PRO) zum Laufen bekommt. Normalerweise ist es ganz simpel. Man legt bei 1und1 eine Domain oder Subdomain...

&nbsp;

Danach hatte ich auch das Problem mit den Server Einstellungen und das geht wie gesagt über die php.ini Datei.&nbsp;

Ich habe die Datei erstellt und in mein Hauptverzeichnis vom Server hoch geladen mit Cyberduck.&nbsp;

[https://hosting.1und1.de/hilfe/hosting/php-fuer-web-projekt-verwenden/php-einstellungen-ueber-phpini-aendern/](https://hosting.1und1.de/hilfe/hosting/php-fuer-web-projekt-verwenden/php-einstellungen-ueber-phpini-aendern/)

Danach hast du aber das Problem, dass bei 1und1 die Einstellungen nicht für alle Ordner übernommen wird. Sprich jetzt muss in allen Ordnern, in denen eine php Datei ist, die ini Datei, du kannst dir ja vorstellen wie kompliziert das ist 😉 vor allem wenn du etwas neues Installierst, muss du die Datei wieder rein legen.&nbsp;

Dazu habe ich folgende Anleitung gefunden:

> **[PHP-Einstellungen für alle Unterverzeichnisse übernehmen - IONOS Hilfe](https://www.ionos.de/hilfe/hosting/php-fuer-web-projekt-verwenden/php-einstellungen-fuer-alle-unterverzeichnisse-uebernehmen/)**
>
> Wir zeigen Ihnen, wie Sie Ihre Einstellungen über eine php.ini auch für Unterverzeichnisse übernehmen.

Hilfreich fand ich auch&nbsp;

> **[How to FIND and EDIT PHP.ini file using SSH.](https://www.youtube.com/watch?v=dplIHZhPVgY)**
>
> How to FIND and EDIT PHP.ini file using SSH. This is a easy way to find PHP.ini to make changes, so WordPress, Drupal or other programs/CMS can run smoothly....

&nbsp;

&nbsp;

&nbsp;

&nbsp;

&nbsp;

---

<div class="post-metadata">

### Author: ![gebe](https://avatars.discourse-cdn.com/v4/letter/g/e9a140/32.png) [@gebe](https://forum.shopware.com/u/gebe)
#### Post date: [26. Oktober 2018 um 15:20 UTC](https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971/6 "2018-10-26T15:20:13Z")

</div>

Hab das Problem bereits gelöst.

Ich hab meinen Shop unter ./Shop/&nbsp;

D.h. ich musste statt „RewriteBase /“ „RewriteBase /Shop/“ in die .htaccess Datei einfürgen.

&nbsp;

War letztendlich recht einfach wenn mans weiss 😃

&nbsp;

Trotzdem danke für eure Hilfe!

&nbsp;

Liebe Grüße

---

<div class="post-metadata">

### Author: ![HeroBoarding](https://avatars.discourse-cdn.com/v4/letter/h/c5a1d2/32.png) [@HeroBoarding](https://forum.shopware.com/u/HeroBoarding)
#### Post date: [26. Oktober 2018 um 15:44 UTC](https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971/7 "2018-10-26T15:44:54Z")

</div>

Und das Memory Limit konntest du auch anpassen?&nbsp;

---

<div class="post-metadata">

### Author: ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)
#### Post date: [27. Oktober 2018 um 13:03 UTC](https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971/8 "2018-10-27T13:03:07Z")

</div>

Denke schon, ich hatte ihm diesbezüglich eine Anleitung geschickt. Bei dir läuft jetzt auch alles?

---

<div class="post-metadata">

### Author: ![gebe](https://avatars.discourse-cdn.com/v4/letter/g/e9a140/32.png) [@gebe](https://forum.shopware.com/u/gebe)
#### Post date: [27. Oktober 2018 um 18:21 UTC](https://forum.shopware.com/t/problem-mit-1und1-internal-server-error-fehlercode-500/55971/9 "2018-10-27T18:21:00Z")

</div>

> [@HeroBoarding schrieb:](https://forum.shopware.com/profile/30104/HeroBoarding "HeroBoarding")
> 
> MeinUnd das Memory Limit konntest du auch anpassen?&nbsp;

Mein Memory Limit schein von 1und1 auf „bis zu 512 MB“ gesetzt zu sein. Warum das von dem Installer nicht erkannt wird ka. Jedenfalls macht das keine Probleme.
